54 lines
2.4 KiB
Diff
54 lines
2.4 KiB
Diff
diff -up elfutils-0.131/libelf/Makefile.am.gcc43~ elfutils-0.131/libelf/Makefile.am
|
|
--- elfutils-0.131/libelf/Makefile.am.gcc43~ 2007-10-04 17:10:42.000000000 +0000
|
|
+++ elfutils-0.131/libelf/Makefile.am 2007-11-24 14:05:43.000000000 +0000
|
|
@@ -33,7 +33,7 @@ endif
|
|
if BUILD_STATIC
|
|
AM_CFLAGS += -fpic
|
|
endif
|
|
-AM_CFLAGS += -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 -std=gnu99 \
|
|
+AM_CFLAGS += -Wall -Wshadow -Werror -Wno-unused -Wextra -Wformat=2 -std=gnu99 \
|
|
$($(*F)_CFLAGS)
|
|
INCLUDES = -I$(srcdir) -I$(top_srcdir)/lib -I..
|
|
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
|
diff -up elfutils-0.131/libelf/Makefile.in.gcc43~ elfutils-0.131/libelf/Makefile.in
|
|
--- elfutils-0.131/libelf/Makefile.in.gcc43~ 2007-11-24 14:06:15.000000000 +0000
|
|
+++ elfutils-0.131/libelf/Makefile.in 2007-11-24 14:06:27.000000000 +0000
|
|
@@ -252,11 +251,11 @@ target_alias = @target_alias@
|
|
top_builddir = @top_builddir@
|
|
top_srcdir = @top_srcdir@
|
|
@MUDFLAP_FALSE@AM_CFLAGS = $(am__append_1) -Wall -Wshadow -Werror \
|
|
-@MUDFLAP_FALSE@ -Wunused -Wextra -Wformat=2 -std=gnu99 \
|
|
+@MUDFLAP_FALSE@ -Wno-unused -Wextra -Wformat=2 -std=gnu99 \
|
|
@MUDFLAP_FALSE@ $($(*F)_CFLAGS)
|
|
@MUDFLAP_TRUE@AM_CFLAGS = -fmudflap $(am__append_1) -Wall -Wshadow \
|
|
-@MUDFLAP_TRUE@ -Werror -Wunused -Wextra -Wformat=2 -std=gnu99 \
|
|
-@MUDFLAP_TRUE@ $($(*F)_CFLAGS)
|
|
+@MUDFLAP_TRUE@ -Werror -Wno-unused -Wextra -Wformat=2 \
|
|
+@MUDFLAP_TRUE@ -std=gnu99 $($(*F)_CFLAGS)
|
|
INCLUDES = -I$(srcdir) -I$(top_srcdir)/lib -I..
|
|
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
|
COMPILE.os = $(filter-out -fprofile-arcs, $(filter-out -ftest-coverage, \
|
|
diff -up elfutils-0.131/src/ld.h.gcc43~ elfutils-0.131/src/ld.h
|
|
--- elfutils-0.131/src/ld.h.gcc43~ 2007-06-05 23:23:47.000000000 +0000
|
|
+++ elfutils-0.131/src/ld.h 2007-11-24 14:05:43.000000000 +0000
|
|
@@ -1087,19 +1087,5 @@ extern bool dynamically_linked_p (void);
|
|
|
|
/* Checked whether the symbol is undefined and referenced from a DSO. */
|
|
extern bool linked_from_dso_p (struct scninfo *scninfo, size_t symidx);
|
|
-extern inline bool
|
|
-linked_from_dso_p (struct scninfo *scninfo, size_t symidx)
|
|
-{
|
|
- struct usedfiles *file = scninfo->fileinfo;
|
|
-
|
|
- /* If this symbol is not undefined in this file it cannot come from
|
|
- a DSO. */
|
|
- if (symidx < file->nlocalsymbols)
|
|
- return false;
|
|
-
|
|
- struct symbol *sym = file->symref[symidx];
|
|
-
|
|
- return sym->defined && sym->in_dso;
|
|
-}
|
|
|
|
#endif /* ld.h */
|