ed/ed-0.5-makefile_lns.patch

21 lines
998 B
Diff

--- ed-0.5/Makefile.in 2006-11-16 21:33:09.000000000 +0100
+++ ed-0.5/Makefile.in.lns 2007-06-04 20:16:02.000000000 +0200
@@ -48,7 +48,7 @@
if test ! -d $(DESTDIR)$(bindir) ; then $(INSTALL) -d $(DESTDIR)$(bindir) ; fi
$(INSTALL_PROGRAM) ./$(progname) $(DESTDIR)$(bindir)/$(progname)
-rm -f $(DESTDIR)$(bindir)/r$(progname)
- cd $(DESTDIR)$(bindir) ; ln $(progname) r$(progname)
+ cd $(DESTDIR)$(bindir) ; ln -s $(progname) r$(progname)
install-info :
if test ! -d $(DESTDIR)$(infodir) ; then $(INSTALL) -d $(DESTDIR)$(infodir) ; fi
@@ -59,7 +59,7 @@
if test ! -d $(DESTDIR)$(mandir)/man1 ; then $(INSTALL) -d $(DESTDIR)$(mandir)/man1 ; fi
$(INSTALL_DATA) $(VPATH)/doc/$(progname).1 $(DESTDIR)$(mandir)/man1/$(progname).1
-rm -f $(DESTDIR)$(mandir)/man1/r$(progname).1
- cd $(DESTDIR)$(mandir)/man1 ; ln $(progname).1 r$(progname).1
+ cd $(DESTDIR)$(mandir)/man1 ; ln -s $(progname).1 r$(progname).1
install-strip : all
$(MAKE) INSTALL_PROGRAM='$(INSTALL_PROGRAM) -s' install