76 lines
2.4 KiB
RPMSpec
76 lines
2.4 KiB
RPMSpec
%define pkgver %(echo %version | cut -d. -f3 | tr _ -)
|
|
%define majver %(echo %version | cut -d. -f1-2)
|
|
Name: eclipse-java
|
|
Version: 4.24.2022_06
|
|
Release: 1mamba
|
|
Summary: Highly extensible IDE for Java developers
|
|
Group: Graphical Desktop/Applications/Development
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.eclipse.org/
|
|
Source: https://ftp.halifax.rwth-aachen.de/eclipse/technology/epp/downloads/release/%{pkgver}/R/eclipse-java-%{pkgver}-R-linux-gtk-x86_64.tar.gz
|
|
#Source: https://www.eclipse.org/downloads/download.php?mirror_id=1045&file=/technology/epp/downloads/release/%{pkgver}/R/eclipse-java-%{pkgver}-R-linux-gtk-x86_64.tar.gz
|
|
Source1: eclipse.desktop
|
|
License: Eclipse Public License
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
Requires: java-runtime
|
|
|
|
%description
|
|
Highly extensible IDE for Java developers.
|
|
|
|
%debug_package
|
|
|
|
%global __requires_exclude_from ^%{_libdir}/eclipse/.*$
|
|
%global __provides_exclude_from ^%{_libdir}/eclipse/.*$
|
|
|
|
%prep
|
|
%setup -q -c %{name}-%{version} -D -T
|
|
|
|
%build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
install -d %{buildroot}%{_libdir}
|
|
cp -r eclipse %{buildroot}%{_libdir}/eclipse
|
|
|
|
install -d %{buildroot}%{_bindir}
|
|
ln -s ../%{_lib}/eclipse/eclipse %{buildroot}%{_bindir}/eclipse
|
|
|
|
install -Dm0644 %{SOURCE1} %{buildroot}%{_datadir}/applications/eclipse.desktop
|
|
|
|
for i in 16 22 24 32 48 64 128 256 512 1024 ; do
|
|
install -Dm0644 eclipse/plugins/org.eclipse.platform_%{majver}*/eclipse$i.png \
|
|
%{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/eclipse.png
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/eclipse
|
|
%dir %{_libdir}/eclipse
|
|
%{_libdir}/eclipse/.eclipseproduct
|
|
%{_libdir}/eclipse/artifacts.xml
|
|
%{_libdir}/eclipse/icon.xpm
|
|
%dir %{_libdir}/eclipse/configuration
|
|
%{_libdir}/eclipse/configuration/*
|
|
%{_libdir}/eclipse/eclipse
|
|
%{_libdir}/eclipse/eclipse.ini
|
|
%dir %{_libdir}/eclipse/features
|
|
%{_libdir}/eclipse/features/*
|
|
%dir %{_libdir}/eclipse/p2
|
|
%{_libdir}/eclipse/p2/*
|
|
%dir %{_libdir}/eclipse/readme
|
|
%{_libdir}/eclipse/readme/*
|
|
%dir %{_libdir}/eclipse/plugins
|
|
%{_libdir}/eclipse/plugins/*
|
|
%{_datadir}/applications/eclipse.desktop
|
|
%{_datadir}/icons/hicolor/*/apps/eclipse.png
|
|
|
|
%changelog
|
|
* Thu Sep 08 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 4.24.2022_06R-1mamba
|
|
- package created using the webbuild interface
|