automatic rebuild by autodist [release 2.3.3-2mamba;Sat Aug 31 2013]
This commit is contained in:
parent
083b42153a
commit
05c33d18c3
@ -1,2 +1,5 @@
|
||||
# eagle-usb
|
||||
|
||||
This is an enhanced version of the Linux driver for DSL modems based on the Analog chipset Eagle 8051. The Sagem F@st 800 modem as well as USRobotics DSL modems are based on this chipset.
|
||||
Depending on your setup/isp, you might also need ppp and/or a dhcp client.
|
||||
|
||||
|
15
eagle-usb-2.3.3-kernel_headers.patch
Normal file
15
eagle-usb-2.3.3-kernel_headers.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -ru eagle-usb-2.3.3.orig/driver/eu_types.h eagle-usb-2.3.3/driver/eu_types.h
|
||||
--- eagle-usb-2.3.3.orig/driver/eu_types.h 2005-05-20 15:36:21.000000000 +0200
|
||||
+++ eagle-usb-2.3.3/driver/eu_types.h 2008-11-20 18:06:22.000000000 +0100
|
||||
@@ -26,7 +26,7 @@
|
||||
#define __EU_TYPES_H__
|
||||
|
||||
#include <linux/if_ether.h>
|
||||
-#include <asm/bitops.h>
|
||||
+//#include <asm/bitops.h>
|
||||
#include <linux/types.h>
|
||||
|
||||
/**
|
||||
Only in eagle-usb-2.3.3.orig/driver/firmware: buildDSP
|
||||
Only in eagle-usb-2.3.3.orig/driver/firmware: dsp_code_isdn.bin
|
||||
Only in eagle-usb-2.3.3.orig/driver/firmware: dsp_code_pots.bin
|
12
eagle-usb-2.3.3-kernel_test.patch
Normal file
12
eagle-usb-2.3.3-kernel_test.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru eagle-usb-2.3.3.orig/configure eagle-usb-2.3.3/configure
|
||||
--- eagle-usb-2.3.3.orig/configure 2006-03-01 01:18:33.000000000 +0100
|
||||
+++ eagle-usb-2.3.3/configure 2008-11-09 21:52:14.000000000 +0100
|
||||
@@ -5779,7 +5779,7 @@
|
||||
echo $ECHO_N "checking for kernel version... $ECHO_C" >&6
|
||||
cat <<EOF > conftest.c
|
||||
#include <stdio.h>
|
||||
-#include "$KERNELSRC/include/linux/version.h"
|
||||
+#include "$KERNELSRC/include/linux/utsrelease.h"
|
||||
|
||||
int
|
||||
main()
|
74
eagle-usb.spec
Normal file
74
eagle-usb.spec
Normal file
@ -0,0 +1,74 @@
|
||||
Name: eagle-usb
|
||||
Version: 2.3.3
|
||||
Release: 2mamba
|
||||
Summary: Utilities for Eagle driven usb modem
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.eagle-usb.org
|
||||
Source: http://baud123.free.fr/eagle-usb/eagle-usb-2.3/%{name}-%{version}.tar.bz2
|
||||
Patch0: %{name}-2.3.3-kernel_test.patch
|
||||
Patch1: %{name}-2.3.3-kernel_headers.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
This is an enhanced version of the Linux driver for DSL modems based on the Analog chipset Eagle 8051. The Sagem F@st 800 modem as well as USRobotics DSL modems are based on this chipset.
|
||||
Depending on your setup/isp, you might also need ppp and/or a dhcp client.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
# disable kernel driver build
|
||||
sed -i "s|all: driver|all:|" driver/Makefile-2.6 driver/Makefile-2.4
|
||||
sed -i "s|\(install: .*\) installdriver|\1|" driver/Makefile-2.6 driver/Makefile-2.4
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
install -d %{buildroot}%{_mandir}
|
||||
make -C doc install MANDIR=%{buildroot}%{_mandir}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc ChangeLog LICENSE README
|
||||
%{_sysconfdir}/hotplug/usb/eagle-usb
|
||||
%{_sysconfdir}/init.d/eagle-usb
|
||||
%{_sysconfdir}/sysconfig/network-scripts/net_cnx_down
|
||||
%{_sysconfdir}/sysconfig/network-scripts/net_cnx_pg
|
||||
%{_sysconfdir}/sysconfig/network-scripts/net_cnx_up
|
||||
%dir %{_sysconfdir}/eagle-usb
|
||||
%{_sysconfdir}/eagle-usb/*
|
||||
%{_sbindir}/*
|
||||
%{_datadir}/eagle-usb/lang/*
|
||||
%{_datadir}/eagle-usb/dsp/*.bin
|
||||
%{_mandir}/man8/*
|
||||
|
||||
%changelog
|
||||
* Sat Aug 31 2013 Automatic Build System <autodist@mambasoft.it> 2.3.3-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Sun Nov 09 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.3-1mamba
|
||||
- update to 2.3.3
|
||||
|
||||
* Wed May 18 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.1-3qilnx
|
||||
- added firmware and other user tools
|
||||
|
||||
* Tue May 17 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.1-2qilnx
|
||||
- added man pages
|
||||
|
||||
* Thu Apr 28 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.1-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user