rebuilt with ImageMagick 6.8.8.6 [release 0.7.1-2mamba;Fri Feb 28 2014]

This commit is contained in:
Silvan Calarco 2024-01-05 22:00:36 +01:00
parent 0708581f9d
commit 3e312c2afe
3 changed files with 120 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# dvdauthor # dvdauthor
dvdauthor is a program that will generate a DVD movie from a valid mpeg2 stream that should play when you put it in a DVD player.

View File

@ -0,0 +1,22 @@
--- dvdauthor-0.7.0.orig/src/spuunmux.c
+++ dvdauthor-0.7.0/src/spuunmux.c
@@ -38,6 +38,7 @@
#include <netinet/in.h>
+#include <zlib.h>
#include <png.h>
#include "rgb.h"
@@ -610,7 +611,11 @@
png_destroy_write_struct(&png_ptr, (png_infopp)NULL);
return -1;
} /*if*/
+#if PNG_LIBPNG_VER_MAJOR >= 1 && PNG_LIBPNG_VER_MINOR >= 4
+ if (setjmp(png_jmpbuf(png_ptr)))
+#else
if (setjmp(png_ptr->jmpbuf))
+#endif
{
png_destroy_write_struct(&png_ptr, &info_ptr);
fclose(fp);

96
dvdauthor.spec Normal file
View File

@ -0,0 +1,96 @@
Name: dvdauthor
Version: 0.7.1
Release: 2mamba
Summary: Set of tools to author a DVD
Group: Applications/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://dvdauthor.sf.net/
Source: http://downloads.sourceforge.net/project/dvdauthor/dvdauthor/%{version}/dvdauthor-%{version}.tar.gz
Patch0: dvdauthor-0.7.0-libpng-1.5.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libbzip2-devel
BuildRequires: libdvdread-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libfribidi-devel
BuildRequires: libMagick-devel
BuildRequires: libpng-devel
BuildRequires: libxml2-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
dvdauthor is a program that will generate a DVD movie from a valid mpeg2 stream that should play when you put it in a DVD player.
%prep
%setup -q -n dvdauthor
#%patch0 -p1
%build
%configure
%make
%install
[ %{buildroot} != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ %{buildroot} != / ] && rm -rf "%{buildroot}"
%files
%defattr(-, root, root, 0755)
%{_bindir}/*
%dir %{_datadir}/dvdauthor
%{_datadir}/dvdauthor/*
%{_mandir}/*
#%doc COPYING README TODO
%changelog
* Fri Feb 28 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.1-2mamba
- rebuilt with ImageMagick 6.8.8.6
* Sun Jan 20 2013 Automatic Build System <autodist@mambasoft.it> 0.7.1-1mamba
- automatic version update by autodist
* Sat Dec 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.0-3mamba
- rebuilt with ImageMagick 6.8.0.10
* Tue Dec 11 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.0-2mamba
- rebuilt with ImageMagick 6.8.0.8
* Sat Jun 25 2011 Automatic Build System <autodist@mambasoft.it> 0.7.0-1mamba
- automatic update by autodist
* Fri Jul 09 2010 Automatic Build System <autodist@mambasoft.it> 0.6.18-2mamba
- automatic rebuild by autodist
* Tue Jun 22 2010 Automatic Build System <autodist@mambasoft.it> 0.6.18-1mamba
- update to 0.6.18
* Thu Jan 14 2010 Automatic Build System <autodist@mambasoft.it> 0.6.14-4mamba
- automatic rebuild by autodist
* Tue Feb 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.14-3mamba
- automatic rebuild by autodist
* Tue Jun 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.14-2mamba
- rebuilt against ImageMagick 6.4.1
* Mon May 26 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.14-1mamba
- update to 0.6.14
* Mon Jan 02 2006 Davide Madrisan <davide.madrisan@qilinux.it> 0.6.11-2qilnx
- rebuilt
- own %{_datadir}/dvdauthor
- added some missing build requirements
* Wed Apr 13 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.6.11-1qilnx
- new version
* Tue Sep 14 2004 Matteo Bernasconi <voyagernm@virgilio.it> 0.6.10-1qilnx
- first build