automatic version update by autodist [release 1.7.1-1mamba;Sat Sep 21 2024]
This commit is contained in:
parent
e54cce1fc6
commit
f00d7efd55
@ -1,18 +0,0 @@
|
||||
diff --git a/setup.py b/setup.py
|
||||
index e82a832..da01efd 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -49,11 +49,8 @@ class build_py(_build_py):
|
||||
|
||||
setup(
|
||||
name='libfdt',
|
||||
- use_scm_version={
|
||||
- "root": srcdir,
|
||||
- },
|
||||
cmdclass = {'build_py' : build_py},
|
||||
- setup_requires = ['setuptools_scm'],
|
||||
+ version="@VERSION@",
|
||||
author='Simon Glass',
|
||||
author_email='sjg@chromium.org',
|
||||
description='Python binding for libfdt',
|
||||
|
11
dtc.spec
11
dtc.spec
@ -1,5 +1,5 @@
|
||||
Name: dtc
|
||||
Version: 1.7.0
|
||||
Version: 1.7.1
|
||||
Release: 1mamba
|
||||
Summary: Device Tree Compiler
|
||||
Group: System/Kernel and Hardware
|
||||
@ -8,11 +8,10 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/dgibson/dtc
|
||||
Source: https://github.com/dgibson/dtc.git/v%{version}/dtc-%{version}.tar.bz2
|
||||
Patch0: dtc-1.7.0-python-scm.patch
|
||||
License: BSD, GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libpython3-devel
|
||||
BuildRequires: libpython311-devel
|
||||
BuildRequires: libyaml-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: meson
|
||||
@ -50,7 +49,6 @@ This package contains shared libraries for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch 0 -p1 -b .python-scm
|
||||
sed -i "s/@VERSION@/%{version}/" setup.py
|
||||
|
||||
%build
|
||||
@ -64,8 +62,6 @@ sed -i "s/@VERSION@/%{version}/" setup.py
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n libfdt -p /sbin/ldconfig
|
||||
%postun -n libfdt -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
@ -101,5 +97,8 @@ sed -i "s/@VERSION@/%{version}/" setup.py
|
||||
%doc README.license README.md TODO
|
||||
|
||||
%changelog
|
||||
* Sat Sep 21 2024 Automatic Build System <autodist@openmamba.org> 1.7.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Aug 26 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.0-1mamba
|
||||
- package created using the webbuild interface
|
||||
|
Loading…
Reference in New Issue
Block a user