patch and install installdbgsymbols.sh script; add requirements for gdb preamble.py script [release 5.26.5-2mamba;Tue Jan 10 2023]
This commit is contained in:
parent
c1c0fbc89d
commit
0f07ecb531
37
drkonqi-5.26.5-installdbgsymbols.patch
Normal file
37
drkonqi-5.26.5-installdbgsymbols.patch
Normal file
@ -0,0 +1,37 @@
|
||||
diff --git a/src/doc/examples/installdbgsymbols_fedora.sh b/src/doc/examples/installdbgsymbols_fedora.sh
|
||||
index 4a1254a..7ac3f91 100644
|
||||
--- a/src/doc/examples/installdbgsymbols_fedora.sh
|
||||
+++ b/src/doc/examples/installdbgsymbols_fedora.sh
|
||||
@@ -27,12 +27,12 @@ run_in_terminal()
|
||||
mkfifo $fifo
|
||||
|
||||
# start terminal
|
||||
- konsole -e sh -c "echo \$\$ > $fifo; $1; exit_status=\$?; sleep 1; rm $fifo; echo \$exit_status > $fifo" &
|
||||
+ konsole -e sh -c "echo \$\$ > $fifo; set -x ; $1; exit_status=\$?; sleep 10; rm $fifo; echo \$exit_status > $fifo" &
|
||||
|
||||
# wait for it to finish
|
||||
local pid=`cat $fifo`
|
||||
while [ "$?" = "0" ]; do
|
||||
- sleep 1
|
||||
+ sleep 10
|
||||
kill -0 $pid 2>/dev/null
|
||||
done
|
||||
|
||||
@@ -65,7 +65,7 @@ check_dep()
|
||||
fi
|
||||
}
|
||||
|
||||
-check_dep debuginfo-install
|
||||
+# check_dep debuginfo-install
|
||||
check_dep konsole
|
||||
|
||||
# start searching for packages
|
||||
@@ -80,7 +80,7 @@ done
|
||||
# filter out duplicates
|
||||
packages=`echo "$packages" | tr " " "\n" | sort | uniq | tr "\n" " "`
|
||||
|
||||
-run_in_terminal "su -c \"debuginfo-install $packages\""
|
||||
+run_in_terminal "pkexec dnf debuginfo-install $packages"
|
||||
|
||||
if [ "$?" = "1" ]; then
|
||||
exit 3
|
11
drkonqi-5.26.5-qdbus-qt5.patch
Normal file
11
drkonqi-5.26.5-qdbus-qt5.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- drkonqi-5.26.5/src/data/gdb/preamble.py.orig 2023-01-10 19:14:55.100846553 +0100
|
||||
+++ drkonqi-5.26.5/src/data/gdb/preamble.py 2023-01-10 19:15:05.211772163 +0100
|
||||
@@ -403,7 +403,7 @@
|
||||
if not distro_build_id:
|
||||
distro_build_id = distro.os_release_attr('variant_id')
|
||||
|
||||
- print(get_stdout(['qdbus', '--system', 'org.freedesktop.systemd1', '/org/freedesktop/systemd1', 'org.freedesktop.systemd1.Manager.Virtualization']))
|
||||
+ print(get_stdout(['qdbus-qt5', '--system', 'org.freedesktop.systemd1', '/org/freedesktop/systemd1', 'org.freedesktop.systemd1.Manager.Virtualization']))
|
||||
sentry_event = { # https://develop.sentry.dev/sdk/event-payloads/
|
||||
"debug_meta": { # https://develop.sentry.dev/sdk/event-payloads/debugmeta/
|
||||
"images": SentryImages().to_list()
|
18
drkonqi.spec
18
drkonqi.spec
@ -2,7 +2,7 @@
|
||||
|
||||
Name: drkonqi
|
||||
Version: 5.26.5
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: KDE Plasma 5 crash handler
|
||||
Group: Graphical Desktop/Applications/Environment
|
||||
Vendor: openmamba
|
||||
@ -10,6 +10,8 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://kde.org/
|
||||
Source: https://download.kde.org/stable/plasma/%{plasmaver}/drkonqi-%{version}.tar.xz
|
||||
Patch0: drkonqi-5.26.5-installdbgsymbols.patch
|
||||
Patch1: drkonqi-5.26.5-qdbus-qt5.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -40,6 +42,10 @@ BuildRequires: qt5-qtdeclarative-devel
|
||||
BuildRequires: cmake
|
||||
BuildRequires: rpm-macros-kde5
|
||||
BuildRequires: extra-cmake-modules
|
||||
Requires: gdb
|
||||
Requires: python-distro-py3
|
||||
Requires: python-psutil-py3
|
||||
Requires: qt5-qttools
|
||||
|
||||
%description
|
||||
KDE Plasma 5 crash handler.
|
||||
@ -48,6 +54,8 @@ KDE Plasma 5 crash handler.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .installdbgsymbols
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%cmake_kde5 -d build
|
||||
@ -57,6 +65,10 @@ KDE Plasma 5 crash handler.
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
# installdbgsymbols script
|
||||
install -p -D -m755 src/doc/examples/installdbgsymbols_fedora.sh \
|
||||
%{buildroot}%{_bindir}/installdbgsymbols.sh
|
||||
|
||||
%find_lang %{name}5_qt --with-qt --all-name || touch %{name}5_qt.lang
|
||||
|
||||
%clean
|
||||
@ -65,6 +77,7 @@ KDE Plasma 5 crash handler.
|
||||
%files -f %{name}5_qt.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/drkonqi-coredump-gui
|
||||
%{_bindir}/installdbgsymbols.sh
|
||||
%{_datadir}/applications/org.kde.drkonqi.desktop
|
||||
%{_datadir}/applications/org.kde.drkonqi.coredump.gui.desktop
|
||||
%{_unitdir}/drkonqi-coredump-processor@.service
|
||||
@ -88,6 +101,9 @@ KDE Plasma 5 crash handler.
|
||||
%doc LICENSES
|
||||
|
||||
%changelog
|
||||
* Tue Jan 10 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 5.26.5-2mamba
|
||||
- patch and install installdbgsymbols.sh script; add requirements for gdb preamble.py script
|
||||
|
||||
* Wed Jan 04 2023 Automatic Build System <autodist@mambasoft.it> 5.26.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user