fix installed includes directory [release 1.1.3-2mamba;Fri Jul 15 2022]

This commit is contained in:
Silvan Calarco 2024-01-05 21:57:22 +01:00
parent bbaf4c4e95
commit 4d9df8f80c
3 changed files with 73 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# dragonbox
Reference implementation of Dragonbox in C++.

View File

@ -0,0 +1,11 @@
--- dragonbox-1.1.3/CMakeLists.txt.orig 2022-07-15 18:43:37.403238584 +0200
+++ dragonbox-1.1.3/CMakeLists.txt 2022-07-15 18:43:48.436169740 +0200
@@ -58,7 +58,7 @@
On)
set(dragonbox_directory "dragonbox-${PROJECT_VERSION}")
-set(dragonbox_include_directory "${CMAKE_INSTALL_INCLUDEDIR}/${dragonbox_directory}")
+set(dragonbox_include_directory "${CMAKE_INSTALL_INCLUDEDIR}")
set(dragonbox_install_targets "dragonbox")
if (DRAGONBOX_INSTALL_TO_CHARS)

60
dragonbox.spec Normal file
View File

@ -0,0 +1,60 @@
Name: dragonbox
Version: 1.1.3
Release: 2mamba
Summary: Reference implementation of Dragonbox in C++
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/jk-jeon/dragonbox
Source: https://github.com/jk-jeon/dragonbox.git/%{version}/dragonbox-%{version}.tar.bz2
Patch0: dragonbox-1.1.3-fix-include-directory.patch
License: Apache License 2.0, Boost Software License
## AUTOBUILDREQ-BEGIN
## AUTOBUILDREQ-END
BuildRequires: cmake
%description
Reference implementation of Dragonbox in C++.
%package devel
Group: Development/Libraries
Summary: Development files for %{name}
%description devel
Reference implementation of Dragonbox in C++.
This package contains header files for developing applications that use %{name}.
#% debug_package
%prep
%setup -q
%patch0 -p1
%build
%cmake -d build
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files devel
%defattr(-,root,root)
%dir %{_includedir}/dragonbox
%{_includedir}/dragonbox/*.h
%dir %{_libdir}/cmake/dragonbox-%{version}
%{_libdir}/cmake/dragonbox-%{version}/dragonbox*.cmake
%{_libdir}/libdragonbox_to_chars.a
%doc README.md
%changelog
* Fri Jul 15 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.3-2mamba
- fix installed includes directory
* Wed Jul 13 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.3-1mamba
- package created using the webbuild interface