backport patches to fix systemd 255 support [release 059-4mamba;Tue Dec 12 2023]
This commit is contained in:
parent
a17362e23d
commit
dcba693ab7
@ -0,0 +1,34 @@
|
||||
From 805728cabf81ddef6a550b95d08f1f6e00e0cf8b Mon Sep 17 00:00:00 2001
|
||||
From: Antonio Alvarez Feijoo <antonio.feijoo@suse.com>
|
||||
Date: Tue, 26 Sep 2023 08:12:23 +0200
|
||||
Subject: [PATCH] fix(systemd-pcrphase): rename systemd-pcrphase binary to
|
||||
systemd-pcrextend
|
||||
|
||||
The `systemd-pcrphase` binary has been renamed to `systemd-pcrextend` since
|
||||
https://github.com/systemd/systemd/commit/32295fa0
|
||||
---
|
||||
modules.d/01systemd-pcrphase/module-setup.sh | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/modules.d/01systemd-pcrphase/module-setup.sh b/modules.d/01systemd-pcrphase/module-setup.sh
|
||||
index 3dbb4974ef..b9817e6405 100755
|
||||
--- a/modules.d/01systemd-pcrphase/module-setup.sh
|
||||
+++ b/modules.d/01systemd-pcrphase/module-setup.sh
|
||||
@@ -6,7 +6,7 @@
|
||||
check() {
|
||||
|
||||
# If the binary(s) requirements are not fulfilled the module can't be installed.
|
||||
- require_binaries "$systemdutildir"/systemd-pcrphase || return 1
|
||||
+ require_binaries "$systemdutildir"/systemd-pcrextend || return 1
|
||||
|
||||
# Return 255 to only include the module, if another module requires it.
|
||||
return 255
|
||||
@@ -27,7 +27,7 @@ depends() {
|
||||
install() {
|
||||
|
||||
inst_multiple -o \
|
||||
- "$systemdutildir"/systemd-pcrphase \
|
||||
+ "$systemdutildir"/systemd-pcrextend \
|
||||
"$systemdsystemunitdir"/systemd-pcrphase.service \
|
||||
"$systemdsystemunitdir/systemd-pcrphase.service.d/*.conf" \
|
||||
"$systemdsystemunitdir"/systemd-pcrphase-sysinit.service \
|
26
dracut-059-systemd-executor-systemd-255.patch
Normal file
26
dracut-059-systemd-executor-systemd-255.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From bee1c4824a8cd47ce6c01892a548bdc07b1fa678 Mon Sep 17 00:00:00 2001
|
||||
From: Frantisek Sumsal <frantisek@sumsal.cz>
|
||||
Date: Sat, 14 Oct 2023 23:45:57 +0200
|
||||
Subject: [PATCH] feat(systemd): install systemd-executor
|
||||
|
||||
In [0] systemd gained a new binary - systemd-executor - that's used to
|
||||
spawn processes forked off systemd. Let's copy it into the initrd if
|
||||
it's available.
|
||||
|
||||
[0] https://github.com/systemd/systemd/pull/27890
|
||||
---
|
||||
modules.d/00systemd/module-setup.sh | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/modules.d/00systemd/module-setup.sh b/modules.d/00systemd/module-setup.sh
|
||||
index 554c25a08..9a13a1dbb 100755
|
||||
--- a/modules.d/00systemd/module-setup.sh
|
||||
+++ b/modules.d/00systemd/module-setup.sh
|
||||
@@ -34,6 +34,7 @@ install() {
|
||||
"$systemdutildir"/systemd \
|
||||
"$systemdutildir"/systemd-coredump \
|
||||
"$systemdutildir"/systemd-cgroups-agent \
|
||||
+ "$systemdutildir"/systemd-executor \
|
||||
"$systemdutildir"/systemd-shutdown \
|
||||
"$systemdutildir"/systemd-reply-password \
|
||||
"$systemdutildir"/systemd-fsck \
|
26
dracut-059-systemd-hibernate-resume-systemd-255.patch
Normal file
26
dracut-059-systemd-hibernate-resume-systemd-255.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From a2fe89116db4b286fbf515f26bd1773b5e6ee8ad Mon Sep 17 00:00:00 2001
|
||||
From: Antonio Alvarez Feijoo <antonio.feijoo@suse.com>
|
||||
Date: Tue, 26 Sep 2023 09:43:37 +0200
|
||||
Subject: [PATCH] fix(resume): add new systemd-hibernate-resume.service
|
||||
|
||||
Since https://github.com/systemd/systemd/commit/a628d933, the generator only
|
||||
does the initial validation of the system info and then enables the new
|
||||
`systemd-hibernate-resume.service`.
|
||||
|
||||
Fixes #2513
|
||||
---
|
||||
modules.d/95resume/module-setup.sh | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/modules.d/95resume/module-setup.sh b/modules.d/95resume/module-setup.sh
|
||||
index d255103366..9204f9cb73 100755
|
||||
--- a/modules.d/95resume/module-setup.sh
|
||||
+++ b/modules.d/95resume/module-setup.sh
|
||||
@@ -44,6 +44,7 @@ install() {
|
||||
if dracut_module_included "systemd" && [[ -x $dracutsysrootdir$systemdutildir/systemd-hibernate-resume ]]; then
|
||||
inst_multiple -o \
|
||||
"$systemdutildir"/system-generators/systemd-hibernate-resume-generator \
|
||||
+ "$systemdsystemunitdir"/systemd-hibernate-resume.service \
|
||||
"$systemdsystemunitdir"/systemd-hibernate-resume@.service \
|
||||
"$systemdutildir"/systemd-hibernate-resume
|
||||
return 0
|
16
dracut.spec
16
dracut.spec
@ -1,6 +1,6 @@
|
||||
Name: dracut
|
||||
Version: 059
|
||||
Release: 3mamba
|
||||
Release: 4mamba
|
||||
Summary: Generic, modular initramfs generation tool that can be used across various distributions
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
@ -29,6 +29,9 @@ Patch25: dracut-055-bluetooth-lib64-fix.patch
|
||||
Patch26: dracut-057-i18n-fix-adding-keymaps-includes.patch
|
||||
Patch27: dracut-057-upstream-add_required_includes_for_keymaps.patch
|
||||
Patch28: dracut-057-upstream-dont_fail_if_FONT_has_the_file_extension.patch
|
||||
Patch29: dracut-059-fix-systemd-pcrphase-rename-systemd-pcrphase-binary.patch
|
||||
Patch30: dracut-059-systemd-hibernate-resume-systemd-255.patch
|
||||
Patch31: dracut-059-systemd-executor-systemd-255.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -88,6 +91,7 @@ Requires: /sbin/reboot
|
||||
Requires: /sbin/poweroff
|
||||
Requires: /sbin/halt
|
||||
Requires(post): filesystem >= 2.3-10mamba
|
||||
Requires(post): systemd >= 2:255
|
||||
Provides: mkinitramfs
|
||||
Obsoletes: mkinitramfs < 054
|
||||
Obsoletes: ifenslave <= 1.1.0
|
||||
@ -114,13 +118,16 @@ This package conatins extra optional modules for dracut.
|
||||
#%patch6 -p1
|
||||
#%patch8 -p1
|
||||
#%patch10 -p1
|
||||
%patch21 -p1
|
||||
%patch 21 -p1
|
||||
%ifarch x86_64 aarch64
|
||||
%patch25 -p1
|
||||
%patch 25 -p1
|
||||
%endif
|
||||
#%patch26 -p1
|
||||
#%patch27 -p1 -b .upstream-add_required_includes_for_keymaps
|
||||
#%patch28 -p1 -b .upstream-dont_fail_if_FONT_has_the_file_extension
|
||||
%patch 29 -p1 -b .fix-systemd-pcrphase-rename-systemd-pcrphase-binary
|
||||
%patch 30 -p1 -b .systemd-hibernate-resume-systemd-255
|
||||
%patch 31 -p1 -b .systemd-executor-systemd-255
|
||||
|
||||
#chmod +x modules.d/99squash-live/*
|
||||
|
||||
@ -443,6 +450,9 @@ fi
|
||||
#%doc NEWS README README.generic README.kernel README.modules TODO
|
||||
|
||||
%changelog
|
||||
* Tue Dec 12 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 059-4mamba
|
||||
- backport patches to fix systemd 255 support
|
||||
|
||||
* Sun Oct 29 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 059-3mamba
|
||||
- rebuilt to make sure /usr/sbin/dracut symlink is removed on all archs
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user