update to 101 [release 101-1mamba;Mon Apr 29 2024]
This commit is contained in:
parent
2bf77fb551
commit
d58bd9eea3
@ -1,34 +0,0 @@
|
|||||||
From 805728cabf81ddef6a550b95d08f1f6e00e0cf8b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Antonio Alvarez Feijoo <antonio.feijoo@suse.com>
|
|
||||||
Date: Tue, 26 Sep 2023 08:12:23 +0200
|
|
||||||
Subject: [PATCH] fix(systemd-pcrphase): rename systemd-pcrphase binary to
|
|
||||||
systemd-pcrextend
|
|
||||||
|
|
||||||
The `systemd-pcrphase` binary has been renamed to `systemd-pcrextend` since
|
|
||||||
https://github.com/systemd/systemd/commit/32295fa0
|
|
||||||
---
|
|
||||||
modules.d/01systemd-pcrphase/module-setup.sh | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/modules.d/01systemd-pcrphase/module-setup.sh b/modules.d/01systemd-pcrphase/module-setup.sh
|
|
||||||
index 3dbb4974ef..b9817e6405 100755
|
|
||||||
--- a/modules.d/01systemd-pcrphase/module-setup.sh
|
|
||||||
+++ b/modules.d/01systemd-pcrphase/module-setup.sh
|
|
||||||
@@ -6,7 +6,7 @@
|
|
||||||
check() {
|
|
||||||
|
|
||||||
# If the binary(s) requirements are not fulfilled the module can't be installed.
|
|
||||||
- require_binaries "$systemdutildir"/systemd-pcrphase || return 1
|
|
||||||
+ require_binaries "$systemdutildir"/systemd-pcrextend || return 1
|
|
||||||
|
|
||||||
# Return 255 to only include the module, if another module requires it.
|
|
||||||
return 255
|
|
||||||
@@ -27,7 +27,7 @@ depends() {
|
|
||||||
install() {
|
|
||||||
|
|
||||||
inst_multiple -o \
|
|
||||||
- "$systemdutildir"/systemd-pcrphase \
|
|
||||||
+ "$systemdutildir"/systemd-pcrextend \
|
|
||||||
"$systemdsystemunitdir"/systemd-pcrphase.service \
|
|
||||||
"$systemdsystemunitdir/systemd-pcrphase.service.d/*.conf" \
|
|
||||||
"$systemdsystemunitdir"/systemd-pcrphase-sysinit.service \
|
|
@ -1,26 +0,0 @@
|
|||||||
From bee1c4824a8cd47ce6c01892a548bdc07b1fa678 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Frantisek Sumsal <frantisek@sumsal.cz>
|
|
||||||
Date: Sat, 14 Oct 2023 23:45:57 +0200
|
|
||||||
Subject: [PATCH] feat(systemd): install systemd-executor
|
|
||||||
|
|
||||||
In [0] systemd gained a new binary - systemd-executor - that's used to
|
|
||||||
spawn processes forked off systemd. Let's copy it into the initrd if
|
|
||||||
it's available.
|
|
||||||
|
|
||||||
[0] https://github.com/systemd/systemd/pull/27890
|
|
||||||
---
|
|
||||||
modules.d/00systemd/module-setup.sh | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/modules.d/00systemd/module-setup.sh b/modules.d/00systemd/module-setup.sh
|
|
||||||
index 554c25a08..9a13a1dbb 100755
|
|
||||||
--- a/modules.d/00systemd/module-setup.sh
|
|
||||||
+++ b/modules.d/00systemd/module-setup.sh
|
|
||||||
@@ -34,6 +34,7 @@ install() {
|
|
||||||
"$systemdutildir"/systemd \
|
|
||||||
"$systemdutildir"/systemd-coredump \
|
|
||||||
"$systemdutildir"/systemd-cgroups-agent \
|
|
||||||
+ "$systemdutildir"/systemd-executor \
|
|
||||||
"$systemdutildir"/systemd-shutdown \
|
|
||||||
"$systemdutildir"/systemd-reply-password \
|
|
||||||
"$systemdutildir"/systemd-fsck \
|
|
@ -1,26 +0,0 @@
|
|||||||
From a2fe89116db4b286fbf515f26bd1773b5e6ee8ad Mon Sep 17 00:00:00 2001
|
|
||||||
From: Antonio Alvarez Feijoo <antonio.feijoo@suse.com>
|
|
||||||
Date: Tue, 26 Sep 2023 09:43:37 +0200
|
|
||||||
Subject: [PATCH] fix(resume): add new systemd-hibernate-resume.service
|
|
||||||
|
|
||||||
Since https://github.com/systemd/systemd/commit/a628d933, the generator only
|
|
||||||
does the initial validation of the system info and then enables the new
|
|
||||||
`systemd-hibernate-resume.service`.
|
|
||||||
|
|
||||||
Fixes #2513
|
|
||||||
---
|
|
||||||
modules.d/95resume/module-setup.sh | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/modules.d/95resume/module-setup.sh b/modules.d/95resume/module-setup.sh
|
|
||||||
index d255103366..9204f9cb73 100755
|
|
||||||
--- a/modules.d/95resume/module-setup.sh
|
|
||||||
+++ b/modules.d/95resume/module-setup.sh
|
|
||||||
@@ -44,6 +44,7 @@ install() {
|
|
||||||
if dracut_module_included "systemd" && [[ -x $dracutsysrootdir$systemdutildir/systemd-hibernate-resume ]]; then
|
|
||||||
inst_multiple -o \
|
|
||||||
"$systemdutildir"/system-generators/systemd-hibernate-resume-generator \
|
|
||||||
+ "$systemdsystemunitdir"/systemd-hibernate-resume.service \
|
|
||||||
"$systemdsystemunitdir"/systemd-hibernate-resume@.service \
|
|
||||||
"$systemdutildir"/systemd-hibernate-resume
|
|
||||||
return 0
|
|
@ -1,88 +0,0 @@
|
|||||||
From bddffedae038ceca263a904e40513a6e92f1b558 Mon Sep 17 00:00:00 2001
|
|
||||||
From: David Cassany <dcassany@suse.com>
|
|
||||||
Date: Fri, 22 Sep 2023 16:28:48 +0200
|
|
||||||
Subject: [PATCH] fix(overlayfs): split overlayfs mount in two steps
|
|
||||||
|
|
||||||
This commit splits the creation of required overlayfs underlaying
|
|
||||||
directories and the actual overlayfs mount. This way it is still
|
|
||||||
possible to mount the overlayfs with the generated sysroot.mount that
|
|
||||||
dmsquash-live creates.
|
|
||||||
|
|
||||||
The overlayfs tree is created in a pre-mount hook so it is executed
|
|
||||||
before sysroot.mount is started. Otherwise sysroot.mount starts and
|
|
||||||
fails before mount hooks are executed.
|
|
||||||
|
|
||||||
Signed-off-by: David Cassany <dcassany@suse.com>
|
|
||||||
---
|
|
||||||
modules.d/90overlayfs/module-setup.sh | 1 +
|
|
||||||
modules.d/90overlayfs/mount-overlayfs.sh | 13 -------------
|
|
||||||
modules.d/90overlayfs/prepare-overlayfs.sh | 21 +++++++++++++++++++++
|
|
||||||
3 files changed, 22 insertions(+), 13 deletions(-)
|
|
||||||
create mode 100755 modules.d/90overlayfs/prepare-overlayfs.sh
|
|
||||||
|
|
||||||
diff --git a/modules.d/90overlayfs/module-setup.sh b/modules.d/90overlayfs/module-setup.sh
|
|
||||||
index 27aa7cfa58..893e2dc366 100755
|
|
||||||
--- a/modules.d/90overlayfs/module-setup.sh
|
|
||||||
+++ b/modules.d/90overlayfs/module-setup.sh
|
|
||||||
@@ -15,4 +15,5 @@ installkernel() {
|
|
||||||
|
|
||||||
install() {
|
|
||||||
inst_hook mount 01 "$moddir/mount-overlayfs.sh"
|
|
||||||
+ inst_hook pre-mount 01 "$moddir/prepare-overlayfs.sh"
|
|
||||||
}
|
|
||||||
diff --git a/modules.d/90overlayfs/mount-overlayfs.sh b/modules.d/90overlayfs/mount-overlayfs.sh
|
|
||||||
index 7e2da1a804..e1d23fb443 100755
|
|
||||||
--- a/modules.d/90overlayfs/mount-overlayfs.sh
|
|
||||||
+++ b/modules.d/90overlayfs/mount-overlayfs.sh
|
|
||||||
@@ -3,24 +3,11 @@
|
|
||||||
type getarg > /dev/null 2>&1 || . /lib/dracut-lib.sh
|
|
||||||
|
|
||||||
getargbool 0 rd.live.overlay.overlayfs && overlayfs="yes"
|
|
||||||
-getargbool 0 rd.live.overlay.reset -d -y reset_overlay && reset_overlay="yes"
|
|
||||||
getargbool 0 rd.live.overlay.readonly -d -y readonly_overlay && readonly_overlay="--readonly" || readonly_overlay=""
|
|
||||||
|
|
||||||
ROOTFLAGS="$(getarg rootflags)"
|
|
||||||
|
|
||||||
if [ -n "$overlayfs" ]; then
|
|
||||||
- if ! [ -e /run/rootfsbase ]; then
|
|
||||||
- mkdir -m 0755 -p /run/rootfsbase
|
|
||||||
- mount --bind "$NEWROOT" /run/rootfsbase
|
|
||||||
- fi
|
|
||||||
-
|
|
||||||
- mkdir -m 0755 -p /run/overlayfs
|
|
||||||
- mkdir -m 0755 -p /run/ovlwork
|
|
||||||
- if [ -n "$reset_overlay" ] && [ -h /run/overlayfs ]; then
|
|
||||||
- ovlfsdir=$(readlink /run/overlayfs)
|
|
||||||
- info "Resetting the OverlayFS overlay directory."
|
|
||||||
- rm -r -- "${ovlfsdir:?}"/* "${ovlfsdir:?}"/.* > /dev/null 2>&1
|
|
||||||
- fi
|
|
||||||
if [ -n "$readonly_overlay" ] && [ -h /run/overlayfs-r ]; then
|
|
||||||
ovlfs=lowerdir=/run/overlayfs-r:/run/rootfsbase
|
|
||||||
else
|
|
||||||
diff --git a/modules.d/90overlayfs/prepare-overlayfs.sh b/modules.d/90overlayfs/prepare-overlayfs.sh
|
|
||||||
new file mode 100755
|
|
||||||
index 0000000000..87bcc19634
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/modules.d/90overlayfs/prepare-overlayfs.sh
|
|
||||||
@@ -0,0 +1,21 @@
|
|
||||||
+#!/bin/sh
|
|
||||||
+
|
|
||||||
+type getarg > /dev/null 2>&1 || . /lib/dracut-lib.sh
|
|
||||||
+
|
|
||||||
+getargbool 0 rd.live.overlay.overlayfs && overlayfs="yes"
|
|
||||||
+getargbool 0 rd.live.overlay.reset -d -y reset_overlay && reset_overlay="yes"
|
|
||||||
+
|
|
||||||
+if [ -n "$overlayfs" ]; then
|
|
||||||
+ if ! [ -e /run/rootfsbase ]; then
|
|
||||||
+ mkdir -m 0755 -p /run/rootfsbase
|
|
||||||
+ mount --bind "$NEWROOT" /run/rootfsbase
|
|
||||||
+ fi
|
|
||||||
+
|
|
||||||
+ mkdir -m 0755 -p /run/overlayfs
|
|
||||||
+ mkdir -m 0755 -p /run/ovlwork
|
|
||||||
+ if [ -n "$reset_overlay" ] && [ -h /run/overlayfs ]; then
|
|
||||||
+ ovlfsdir=$(readlink /run/overlayfs)
|
|
||||||
+ info "Resetting the OverlayFS overlay directory."
|
|
||||||
+ rm -r -- "${ovlfsdir:?}"/* "${ovlfsdir:?}"/.* > /dev/null 2>&1
|
|
||||||
+ fi
|
|
||||||
+fi
|
|
25
dracut.spec
25
dracut.spec
@ -1,21 +1,17 @@
|
|||||||
Name: dracut
|
Name: dracut
|
||||||
Version: 059
|
Version: 101
|
||||||
Release: 6mamba
|
Release: 1mamba
|
||||||
Summary: Generic, modular initramfs generation tool that can be used across various distributions
|
Summary: Generic, modular initramfs generation tool that can be used across various distributions
|
||||||
Group: System/Kernel and Hardware
|
Group: System/Kernel and Hardware
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://sourceforge.net/projects/dracut/
|
URL: https://github.com/dracut-ng/dracut-ng/wiki
|
||||||
Source: https://github.com/dracutdevs/dracut.git/%{version}/dracut-%{version}.tar.bz2
|
Source: https://github.com/dracut-ng/dracut-ng.git/%{version}/dracut-ng-%{version}.tar.bz2
|
||||||
Source1: dracut-openmamba.conf
|
Source1: dracut-openmamba.conf
|
||||||
Source2: dracut-openmamba.png
|
Source2: dracut-openmamba.png
|
||||||
Patch21: dracut-040-dmsetup_fix_path.patch
|
Patch21: dracut-040-dmsetup_fix_path.patch
|
||||||
Patch25: dracut-055-bluetooth-lib64-fix.patch
|
Patch25: dracut-055-bluetooth-lib64-fix.patch
|
||||||
Patch29: dracut-059-fix-systemd-pcrphase-rename-systemd-pcrphase-binary.patch
|
|
||||||
Patch30: dracut-059-systemd-hibernate-resume-systemd-255.patch
|
|
||||||
Patch31: dracut-059-systemd-executor-systemd-255.patch
|
|
||||||
Patch32: dracut-059-upstream-overlayfs-split-mount.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -96,15 +92,11 @@ Dracut is a generic, modular initramfs generation tool that can be used across v
|
|||||||
This package conatins extra optional modules for dracut.
|
This package conatins extra optional modules for dracut.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n dracut-ng-%{version}
|
||||||
%patch 21 -p1
|
%patch 21 -p1
|
||||||
%ifarch x86_64 aarch64
|
%ifarch x86_64 aarch64
|
||||||
%patch 25 -p1
|
%patch 25 -p1
|
||||||
%endif
|
%endif
|
||||||
%patch 29 -p1 -b .fix-systemd-pcrphase-rename-systemd-pcrphase-binary
|
|
||||||
%patch 30 -p1 -b .systemd-hibernate-resume-systemd-255
|
|
||||||
%patch 31 -p1 -b .systemd-executor-systemd-255
|
|
||||||
%patch 32 -p1 -b .upstream-overlayfs-split-mount
|
|
||||||
|
|
||||||
#chmod +x modules.d/99squash-live/*
|
#chmod +x modules.d/99squash-live/*
|
||||||
|
|
||||||
@ -206,6 +198,8 @@ fi
|
|||||||
%{_prefix}/lib/dracut/modules.d/35network-manager/*
|
%{_prefix}/lib/dracut/modules.d/35network-manager/*
|
||||||
%dir %{_prefix}/lib/dracut/modules.d/40network
|
%dir %{_prefix}/lib/dracut/modules.d/40network
|
||||||
%{_prefix}/lib/dracut/modules.d/40network/*
|
%{_prefix}/lib/dracut/modules.d/40network/*
|
||||||
|
%dir %{_prefix}/lib/dracut/modules.d/45net-lib
|
||||||
|
%{_prefix}/lib/dracut/modules.d/45net-lib/*
|
||||||
%dir %{_prefix}/lib/dracut/modules.d/45url-lib
|
%dir %{_prefix}/lib/dracut/modules.d/45url-lib
|
||||||
%{_prefix}/lib/dracut/modules.d/45url-lib/*
|
%{_prefix}/lib/dracut/modules.d/45url-lib/*
|
||||||
%dir %{_prefix}/lib/dracut/modules.d/50drm
|
%dir %{_prefix}/lib/dracut/modules.d/50drm
|
||||||
@ -392,8 +386,6 @@ fi
|
|||||||
%{_prefix}/lib/dracut/modules.d/05busybox/module-setup.sh
|
%{_prefix}/lib/dracut/modules.d/05busybox/module-setup.sh
|
||||||
%dir %{_prefix}/lib/dracut/modules.d/06dbus-broker
|
%dir %{_prefix}/lib/dracut/modules.d/06dbus-broker
|
||||||
%{_prefix}/lib/dracut/modules.d/06dbus-broker/*
|
%{_prefix}/lib/dracut/modules.d/06dbus-broker/*
|
||||||
%dir %{_prefix}/lib/dracut/modules.d/35network-wicked
|
|
||||||
%{_prefix}/lib/dracut/modules.d/35network-wicked/*
|
|
||||||
%dir %{_prefix}/lib/dracut/modules.d/35connman/
|
%dir %{_prefix}/lib/dracut/modules.d/35connman/
|
||||||
%{_prefix}/lib/dracut/modules.d/35connman/*
|
%{_prefix}/lib/dracut/modules.d/35connman/*
|
||||||
%dir %{_prefix}/lib/dracut/modules.d/45ifcfg
|
%dir %{_prefix}/lib/dracut/modules.d/45ifcfg
|
||||||
@ -411,6 +403,9 @@ fi
|
|||||||
#%doc NEWS README README.generic README.kernel README.modules TODO
|
#%doc NEWS README README.generic README.kernel README.modules TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 29 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 101-1mamba
|
||||||
|
- update to 101
|
||||||
|
|
||||||
* Sun Mar 17 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 059-6mamba
|
* Sun Mar 17 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 059-6mamba
|
||||||
- overlayfs: upstream patch to fix missing /run/overlayfs dir message at boot
|
- overlayfs: upstream patch to fix missing /run/overlayfs dir message at boot
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user