added patch to fix error loading autofs4 and ipv6 modules [release 040-4mamba;Sat Jan 10 2015]
This commit is contained in:
parent
2ae5feb70a
commit
1f93028a94
@ -1,18 +0,0 @@
|
|||||||
Solo in dracut-007: dracut.8
|
|
||||||
Solo in dracut-007: dracut-catimages.8
|
|
||||||
Solo in dracut-007: dracut.conf.5
|
|
||||||
Solo in dracut-007: dracut-gencmdline.8
|
|
||||||
Solo in dracut-007: dracut.kernel.7
|
|
||||||
diff -ru dracut-007.orig//modules.d/90dmsquash-live/dmsquash-liveiso-genrules.sh dracut-007/modules.d/90dmsquash-live/dmsquash-liveiso-genrules.sh
|
|
||||||
--- dracut-007.orig//modules.d/90dmsquash-live/dmsquash-liveiso-genrules.sh 2010-08-09 16:13:51.000000000 +0200
|
|
||||||
+++ dracut-007/modules.d/90dmsquash-live/dmsquash-liveiso-genrules.sh 2010-10-22 22:11:42.265423182 +0200
|
|
||||||
@@ -1,5 +1,9 @@
|
|
||||||
if [ "${root%%:*}" = "liveiso" ]; then
|
|
||||||
+ DEVLABEL=${root#liveiso:/}
|
|
||||||
+ DEVLABEL=${DEVLABEL/\/`basename ${DEVLABEL}`}
|
|
||||||
{
|
|
||||||
+ printf 'ENV{ID_FS_LABEL}=="%s", RUN+="/bin/mkdir /%s", RUN+="/bin/mount /dev/%%k /%s"\n' \
|
|
||||||
+ ${DEVLABEL} ${DEVLABEL} ${DEVLABEL}
|
|
||||||
printf 'KERNEL=="loop0", RUN+="/sbin/initqueue --settled --onetime --unique /sbin/dmsquash-live-root `/sbin/losetup -f --show %s`"\n' \
|
|
||||||
${root#liveiso:}
|
|
||||||
} >> /etc/udev/rules.d/99-liveiso-mount.rules
|
|
@ -1,26 +0,0 @@
|
|||||||
diff -ru dracut-007.orig//modules.d/50plymouth/installkernel dracut-007/modules.d/50plymouth/installkernel
|
|
||||||
--- dracut-007.orig//modules.d/50plymouth/installkernel 2010-08-09 16:13:51.000000000 +0200
|
|
||||||
+++ dracut-007/modules.d/50plymouth/installkernel 2010-09-18 21:36:22.048443676 +0200
|
|
||||||
@@ -3,3 +3,9 @@
|
|
||||||
for modname in $(find "$srcmods/kernel/drivers/gpu/drm" -name '*.ko' 2>/dev/null); do
|
|
||||||
grep -q drm_crtc_init $modname && instmods $modname
|
|
||||||
done
|
|
||||||
+# Include uvesafb
|
|
||||||
+[ -e /sbin/v86d ] && {
|
|
||||||
+ instmods uvesafb
|
|
||||||
+ inst /sbin/v86d
|
|
||||||
+ inst /sbin/testvbe
|
|
||||||
+}
|
|
||||||
diff -ru dracut-007.orig//modules.d/50plymouth/plymouth-pretrigger.sh dracut-007/modules.d/50plymouth/plymouth-pretrigger.sh
|
|
||||||
--- dracut-007.orig//modules.d/50plymouth/plymouth-pretrigger.sh 2010-08-09 16:13:51.000000000 +0200
|
|
||||||
+++ dracut-007/modules.d/50plymouth/plymouth-pretrigger.sh 2010-09-18 21:12:37.753313417 +0200
|
|
||||||
@@ -8,6 +8,9 @@
|
|
||||||
udevadm trigger --subsystem-match=graphics --subsystem-match=drm --subsystem-match=tty >/dev/null 2>&1
|
|
||||||
|
|
||||||
udevadm settle --timeout=30 2>&1 | vinfo
|
|
||||||
+
|
|
||||||
+ [ ! -c /dev/fb0 -a -e /sbin/v86d ] && modprobe uvesafb
|
|
||||||
+
|
|
||||||
[ -c /dev/zero ] || mknod -m 0666 /dev/zero c 1 5
|
|
||||||
[ -c /dev/tty0 ] || mknod -m 0620 /dev/tty0 c 4 0
|
|
||||||
[ -e /dev/systty ] || ln -s tty0 /dev/systty
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -Nru dracut-010.orig//dracut-functions dracut-010/dracut-functions
|
|
||||||
--- dracut-010.orig//dracut-functions 2011-03-31 19:50:31.000000000 +0200
|
|
||||||
+++ dracut-010/dracut-functions 2011-06-02 20:20:35.858288574 +0200
|
|
||||||
@@ -190,6 +190,7 @@
|
|
||||||
# but you cannot create the logical volume without the volume group.
|
|
||||||
# And the volume group might be bigger than the devices the LV needs.
|
|
||||||
check_vol_slaves() {
|
|
||||||
+ [ -d /dev/mapper ] && \
|
|
||||||
for i in /dev/mapper/*; do
|
|
||||||
lv=$(get_numeric_dev $i)
|
|
||||||
if [[ $lv = $2 ]]; then
|
|
@ -1,27 +0,0 @@
|
|||||||
From 76353076c081ac51647214c5ce910aba027b25db Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?utf8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
|
|
||||||
Date: Sat, 2 Apr 2011 00:45:44 +0200
|
|
||||||
Subject: [PATCH] dracut: don't fail on empty /etc/ld.so.conf.d/
|
|
||||||
|
|
||||||
---
|
|
||||||
dracut | 4 +++-
|
|
||||||
1 files changed, 3 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/dracut b/dracut
|
|
||||||
index c6605bb..15a5ee5 100755
|
|
||||||
--- a/dracut
|
|
||||||
+++ b/dracut
|
|
||||||
@@ -524,7 +524,9 @@ done
|
|
||||||
unset item
|
|
||||||
|
|
||||||
# make sure that library links are correct and up to date
|
|
||||||
-dracut_install /etc/ld.so.conf /etc/ld.so.conf.d/*
|
|
||||||
+for f in /etc/ld.so.conf /etc/ld.so.conf.d/*; do
|
|
||||||
+ [[ -e $f ]] && dracut_install "$f"
|
|
||||||
+done
|
|
||||||
if ! ldconfig -r "$initdir"; then
|
|
||||||
if [[ $UID = 0 ]]; then
|
|
||||||
derror "ldconfig exited ungracefully"
|
|
||||||
--
|
|
||||||
1.7.4.4
|
|
||||||
|
|
@ -1,26 +0,0 @@
|
|||||||
From d63fdc1198cd13ed68e7f08acd7ca164c9f35262 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Harald Hoyer <harald@redhat.com>
|
|
||||||
Date: Tue, 20 Sep 2011 10:10:29 +0200
|
|
||||||
Subject: [PATCH] 99base/init: mount securityfs with source "securityfs"
|
|
||||||
instead of dest
|
|
||||||
|
|
||||||
---
|
|
||||||
modules.d/99base/init | 2 +-
|
|
||||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/modules.d/99base/init b/modules.d/99base/init
|
|
||||||
index 4f59818..fa808ca 100755
|
|
||||||
--- a/modules.d/99base/init
|
|
||||||
+++ b/modules.d/99base/init
|
|
||||||
@@ -89,7 +89,7 @@ RD_DEBUG=""
|
|
||||||
SECURITYFSDIR="/sys/kernel/security"
|
|
||||||
export SECURITYFSDIR
|
|
||||||
if ! ismounted "${SECURITYFSDIR}"; then
|
|
||||||
- mount -t securityfs -o nosuid,noexec,nodev ${SECURITYFSDIR} ${SECURITYFSDIR} >/dev/null 2>&1
|
|
||||||
+ mount -t securityfs -o nosuid,noexec,nodev securityfs ${SECURITYFSDIR} >/dev/null 2>&1
|
|
||||||
fi
|
|
||||||
|
|
||||||
if [ -x /lib/systemd/systemd-timestamp ]; then
|
|
||||||
--
|
|
||||||
1.7.6.2
|
|
||||||
|
|
@ -1,45 +0,0 @@
|
|||||||
From 2e7b6616814a3706f0c15bc20c7c8303463bcba0 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Harald Hoyer <harald@redhat.com>
|
|
||||||
Date: Fri, 20 Jan 2012 12:06:41 +0100
|
|
||||||
Subject: [PATCH] 90kernel-modules/module-setup.sh: install modules.order
|
|
||||||
|
|
||||||
Also install modules.order and all modules.builtin*
|
|
||||||
---
|
|
||||||
modules.d/90kernel-modules/module-setup.sh | 11 ++++++-----
|
|
||||||
1 files changed, 6 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/modules.d/90kernel-modules/module-setup.sh b/modules.d/90kernel-modules/module-setup.sh
|
|
||||||
index 257b3bc..7888428 100755
|
|
||||||
--- a/modules.d/90kernel-modules/module-setup.sh
|
|
||||||
+++ b/modules.d/90kernel-modules/module-setup.sh
|
|
||||||
@@ -68,7 +68,7 @@ installkernel() {
|
|
||||||
}
|
|
||||||
|
|
||||||
install() {
|
|
||||||
- local _f
|
|
||||||
+ local _f i
|
|
||||||
[ -f /etc/modprobe.conf ] && dracut_install /etc/modprobe.conf
|
|
||||||
for i in $(find -L /etc/modprobe.d/ -maxdepth 1 -type f -name '*.conf'); do
|
|
||||||
inst_simple "$i"
|
|
||||||
@@ -76,13 +76,14 @@ install() {
|
|
||||||
inst_hook cmdline 01 "$moddir/parse-kernel.sh"
|
|
||||||
inst_simple "$moddir/insmodpost.sh" /sbin/insmodpost.sh
|
|
||||||
|
|
||||||
- local f
|
|
||||||
-
|
|
||||||
for _f in modules.builtin.bin modules.builtin; do
|
|
||||||
- [[ $srcmods/$_f ]] && inst_simple "$srcmods/$_f" "/lib/modules/$kernel/$_f" \
|
|
||||||
- && break
|
|
||||||
+ [[ $srcmods/$_f ]] && break
|
|
||||||
done || {
|
|
||||||
dfatal "No modules.builtin.bin and modules.builtin found!"
|
|
||||||
return 1
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+ for _f in modules.builtin.bin modules.builtin modules.order; do
|
|
||||||
+ [[ $srcmods/$_f ]] && inst_simple "$srcmods/$_f" "/lib/modules/$kernel/$_f"
|
|
||||||
+ done
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.7.6.5
|
|
||||||
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -Nru dracut-020.orig/modules.d/50plymouth/module-setup.sh dracut-020/modules.d/50plymouth/module-setup.sh
|
|
||||||
--- dracut-020.orig/modules.d/50plymouth/module-setup.sh 2012-06-29 12:54:38.000000000 +0200
|
|
||||||
+++ dracut-020/modules.d/50plymouth/module-setup.sh 2012-07-01 13:02:10.613450256 +0200
|
|
||||||
@@ -65,7 +65,6 @@
|
|
||||||
|
|
||||||
install() {
|
|
||||||
if grep -q nash /usr/libexec/plymouth/plymouth-populate-initrd \
|
|
||||||
- || ! grep -q PLYMOUTH_POPULATE_SOURCE_FUNCTIONS /usr/libexec/plymouth/plymouth-populate-initrd \
|
|
||||||
|| [ ! -x /usr/libexec/plymouth/plymouth-populate-initrd ]; then
|
|
||||||
. "$moddir"/plymouth-populate-initrd.sh
|
|
||||||
else
|
|
@ -1,40 +0,0 @@
|
|||||||
--- a/lsinitrd.sh
|
|
||||||
+++ b/lsinitrd.sh
|
|
||||||
@@ -54,23 +54,23 @@ if [[ "$1" ]]; then
|
|
||||||
usage
|
|
||||||
exit 1
|
|
||||||
fi
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
-[[ -f /etc/machine-id ]] && read MACHINE_ID < /etc/machine-id
|
|
||||||
-
|
|
||||||
-if [[ $MACHINE_ID ]] && ( [[ -d /boot/${MACHINE_ID} ]] || [[ -L /boot/${MACHINE_ID} ]] ); then
|
|
||||||
- image="/boot/${MACHINE_ID}/${KERNEL_VERSION}/initrd"
|
|
||||||
else
|
|
||||||
- image="/boot/initramfs-${KERNEL_VERSION}.img}"
|
|
||||||
-fi
|
|
||||||
+ [[ -f /etc/machine-id ]] && read MACHINE_ID < /etc/machine-id
|
|
||||||
|
|
||||||
-if ! [[ -f "$image" ]]; then
|
|
||||||
- {
|
|
||||||
+ if [[ $MACHINE_ID ]] && ( [[ -d /boot/${MACHINE_ID} ]] || [[ -L /boot/${MACHINE_ID} ]] ); then
|
|
||||||
+ image="/boot/${MACHINE_ID}/${KERNEL_VERSION}/initrd"
|
|
||||||
+ else
|
|
||||||
+ image="/boot/initramfs-${KERNEL_VERSION}.img"
|
|
||||||
+ fi
|
|
||||||
+
|
|
||||||
+ if ! [[ -f "$image" ]]; then
|
|
||||||
+ {
|
|
||||||
echo "No <initramfs file> specified and the default image '$image' cannot be accessed!"
|
|
||||||
echo
|
|
||||||
- } >&2
|
|
||||||
- usage
|
|
||||||
- exit 1
|
|
||||||
+ } >&2
|
|
||||||
+ usage
|
|
||||||
+ exit 1
|
|
||||||
+ fi
|
|
||||||
fi
|
|
||||||
|
|
||||||
CAT=zcat
|
|
||||||
|
|
@ -1,14 +0,0 @@
|
|||||||
diff -Nru dracut-027.orig/dracut-functions.sh dracut-027/dracut-functions.sh
|
|
||||||
--- dracut-027.orig/dracut-functions.sh 2013-03-26 16:55:03.000000000 +0100
|
|
||||||
+++ dracut-027/dracut-functions.sh 2013-04-04 15:23:14.500724486 +0200
|
|
||||||
@@ -83,10 +83,6 @@
|
|
||||||
|
|
||||||
srcmods="/lib/modules/$kernel/"
|
|
||||||
[[ $drivers_dir ]] && {
|
|
||||||
- if vercmp $(modprobe --version | cut -d' ' -f3) lt 3.7; then
|
|
||||||
- dfatal 'To use --kmoddir option module-init-tools >= 3.7 is required.'
|
|
||||||
- exit 1
|
|
||||||
- fi
|
|
||||||
srcmods="$drivers_dir"
|
|
||||||
}
|
|
||||||
export srcmods
|
|
11
dracut-040-fix-autofs4-ipv6-modules.patch
Normal file
11
dracut-040-fix-autofs4-ipv6-modules.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- dracut-040/modules.d/98systemd/module-setup.sh.orig 2015-01-10 00:28:56.552983678 +0100
|
||||||
|
+++ dracut-040/modules.d/98systemd/module-setup.sh 2015-01-10 00:29:53.702055474 +0100
|
||||||
|
@@ -18,7 +18,7 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
installkernel() {
|
||||||
|
- instmods autofs4 ipv6
|
||||||
|
+ hostonly='' instmods autofs4 ipv6
|
||||||
|
instmods -s efivarfs
|
||||||
|
}
|
||||||
|
|
25
dracut.spec
25
dracut.spec
@ -1,6 +1,6 @@
|
|||||||
Name: dracut
|
Name: dracut
|
||||||
Version: 040
|
Version: 040
|
||||||
Release: 3mamba
|
Release: 4mamba
|
||||||
Summary: Generic, modular initramfs generation tool that can be used across various distributions
|
Summary: Generic, modular initramfs generation tool that can be used across various distributions
|
||||||
Group: System/Kernel and Hardware
|
Group: System/Kernel and Hardware
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -11,24 +11,16 @@ Source: ftp://ftp.kernel.org/pub/linux/utils/boot/dracut/dracut-%{version
|
|||||||
Source1: dracut-openmamba.conf
|
Source1: dracut-openmamba.conf
|
||||||
Source2: dracut-openmamba.png
|
Source2: dracut-openmamba.png
|
||||||
Patch0: %{name}-020-openmamba_logo_release.patch
|
Patch0: %{name}-020-openmamba_logo_release.patch
|
||||||
Patch2: %{name}-007-install_uvesafb.patch
|
|
||||||
Patch3: %{name}-007-dmsquash-liveiso-extramount.patch
|
|
||||||
Patch4: %{name}-010-devmapper_silent.patch
|
|
||||||
Patch5: %{name}-037-squash-overlayfs-live-openmamba.patch
|
Patch5: %{name}-037-squash-overlayfs-live-openmamba.patch
|
||||||
Patch6: %{name}-037-mkinitrd-hostonly.patch
|
Patch6: %{name}-037-mkinitrd-hostonly.patch
|
||||||
Patch7: %{name}-010-ld.so.conf.d-fix.patch
|
|
||||||
Patch8: %{name}-037-fix_devpts_gid.patch
|
Patch8: %{name}-037-fix_devpts_gid.patch
|
||||||
Patch9: %{name}-013-mount_securityfs_with_source_securityfs_instead_of_dest.patch
|
|
||||||
Patch10: %{name}-037-i18n_install_locale-archive.patch
|
Patch10: %{name}-037-i18n_install_locale-archive.patch
|
||||||
Patch11: %{name}-014-also_install_modules.order_and_all_modules.builtin.patch
|
|
||||||
Patch12: %{name}-020-plymouth-0.8.5.1.patch
|
|
||||||
Patch13: dracut-026-lsinitrd.patch
|
|
||||||
Patch14: dracut-027-kmod.patch
|
|
||||||
Patch15: dracut-027-find-systemdutildir.patch
|
Patch15: dracut-027-find-systemdutildir.patch
|
||||||
Patch16: dracut-032-nfs-var-statd-sm.patch
|
Patch16: dracut-032-nfs-var-statd-sm.patch
|
||||||
Patch17: dracut-032-fix-libdirs.patch
|
Patch17: dracut-032-fix-libdirs.patch
|
||||||
Patch18: dracut-040-fix-udevdir-detection.patch
|
Patch18: dracut-040-fix-udevdir-detection.patch
|
||||||
Patch19: dracut-040-no-gzip-rsyncable.patch
|
Patch19: dracut-040-no-gzip-rsyncable.patch
|
||||||
|
Patch20: dracut-040-fix-autofs4-ipv6-modules.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -105,24 +97,16 @@ This package conatins extra optional modules for dracut.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
#%patch2 -p1
|
|
||||||
#%patch3 -p1
|
|
||||||
#%patch4 -p1
|
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
#%patch7 -p1
|
|
||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
#%patch9 -p1
|
|
||||||
%patch10 -p1
|
%patch10 -p1
|
||||||
#%patch11 -p1
|
|
||||||
#%patch12 -p1
|
|
||||||
#%patch13 -p1
|
|
||||||
#%patch14 -p1
|
|
||||||
%patch15 -p1
|
%patch15 -p1
|
||||||
%patch16 -p1
|
%patch16 -p1
|
||||||
#%patch17 -p1
|
#%patch17 -p1
|
||||||
%patch18 -p1
|
%patch18 -p1
|
||||||
%patch19 -p1
|
%patch19 -p1
|
||||||
|
%patch20 -p1
|
||||||
chmod +x modules.d/99squash-live/*
|
chmod +x modules.d/99squash-live/*
|
||||||
|
|
||||||
# remove *.orig files created by patched to prevent from being installed
|
# remove *.orig files created by patched to prevent from being installed
|
||||||
@ -350,6 +334,9 @@ ln -s ../bin/mkinitrd %{buildroot}%{_sbindir}/mkinitrd
|
|||||||
#%doc NEWS README README.generic README.kernel README.modules TODO
|
#%doc NEWS README README.generic README.kernel README.modules TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 10 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 040-4mamba
|
||||||
|
- added patch to fix error loading autofs4 and ipv6 modules
|
||||||
|
|
||||||
* Sat Nov 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 040-3mamba
|
* Sat Nov 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 040-3mamba
|
||||||
- patch to not use gzip with --rsyncable missing option
|
- patch to not use gzip with --rsyncable missing option
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user