automatic version update by autodist [release 1.8.11-1mamba;Tue Apr 19 2016]
This commit is contained in:
parent
6c8fc881d4
commit
ed0b7a5497
104
doxygen-1.8.10-flex-2.6.patch
Normal file
104
doxygen-1.8.10-flex-2.6.patch
Normal file
@ -0,0 +1,104 @@
|
|||||||
|
From cf936efb8ae99dd297b6afb9c6a06beb81f5b0fb Mon Sep 17 00:00:00 2001
|
||||||
|
From: Heiko Becker <heirecka@exherbo.org>
|
||||||
|
Date: Thu, 19 Nov 2015 12:00:54 +0100
|
||||||
|
Subject: [PATCH] Support flex-2.6.0
|
||||||
|
|
||||||
|
The version checks only considered YY_FLEX_SUBMINOR_VERSION and did not
|
||||||
|
take YY_FLEX_MINOR_VERSION into account, which made them fail with
|
||||||
|
flex-2.6.0.
|
||||||
|
---
|
||||||
|
src/code.l | 2 +-
|
||||||
|
src/commentscan.l | 4 ++--
|
||||||
|
src/fortrancode.l | 2 +-
|
||||||
|
src/pycode.l | 2 +-
|
||||||
|
src/vhdlcode.l | 2 +-
|
||||||
|
src/xmlcode.l | 2 +-
|
||||||
|
6 files changed, 7 insertions(+), 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/code.l b/src/code.l
|
||||||
|
index 3323580..25719af 100644
|
||||||
|
--- a/src/code.l
|
||||||
|
+++ b/src/code.l
|
||||||
|
@@ -3700,7 +3700,7 @@ void codeFreeScanner()
|
||||||
|
extern "C" { // some bogus code to keep the compiler happy
|
||||||
|
void codeYYdummy() { yy_flex_realloc(0,0); }
|
||||||
|
}
|
||||||
|
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||||
|
+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
|
||||||
|
#error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
diff --git a/src/commentscan.l b/src/commentscan.l
|
||||||
|
index cf892a0..2629857 100644
|
||||||
|
--- a/src/commentscan.l
|
||||||
|
+++ b/src/commentscan.l
|
||||||
|
@@ -1128,7 +1128,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
|
||||||
|
// but we need to know the position in the input buffer where this
|
||||||
|
// rule matched.
|
||||||
|
// for flex 2.5.33+ we should use YY_CURRENT_BUFFER_LVALUE
|
||||||
|
-#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
|
||||||
|
+#if YY_FLEX_MINOR_VERSION>5 || YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
|
||||||
|
inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf);
|
||||||
|
#else
|
||||||
|
inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf);
|
||||||
|
@@ -1190,7 +1190,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
|
||||||
|
g_memberGroupHeader.resize(0);
|
||||||
|
parseMore=TRUE;
|
||||||
|
needNewEntry = TRUE;
|
||||||
|
-#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
|
||||||
|
+#if YY_FLEX_MINOR_VERSION>5 || YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
|
||||||
|
inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf) + strlen(yytext);
|
||||||
|
#else
|
||||||
|
inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf) + strlen(yytext);
|
||||||
|
diff --git a/src/fortrancode.l b/src/fortrancode.l
|
||||||
|
index fb91a83..352912b 100644
|
||||||
|
--- a/src/fortrancode.l
|
||||||
|
+++ b/src/fortrancode.l
|
||||||
|
@@ -1306,7 +1306,7 @@ void parseFortranCode(CodeOutputInterface &od,const char *className,const QCStri
|
||||||
|
extern "C" { // some bogus code to keep the compiler happy
|
||||||
|
void fortrancodeYYdummy() { yy_flex_realloc(0,0); }
|
||||||
|
}
|
||||||
|
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||||
|
+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
|
||||||
|
#error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
|
||||||
|
#else
|
||||||
|
extern "C" { // some bogus code to keep the compiler happy
|
||||||
|
diff --git a/src/pycode.l b/src/pycode.l
|
||||||
|
index 3c41a69..f58f7c1 100644
|
||||||
|
--- a/src/pycode.l
|
||||||
|
+++ b/src/pycode.l
|
||||||
|
@@ -1503,7 +1503,7 @@ void parsePythonCode(CodeOutputInterface &od,const char * /*className*/,
|
||||||
|
extern "C" { // some bogus code to keep the compiler happy
|
||||||
|
void pycodeYYdummy() { yy_flex_realloc(0,0); }
|
||||||
|
}
|
||||||
|
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||||
|
+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
|
||||||
|
#error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
|
||||||
|
#endif
|
||||||
|
|
||||||
|
diff --git a/src/vhdlcode.l b/src/vhdlcode.l
|
||||||
|
index 369ae48..6957048 100644
|
||||||
|
--- a/src/vhdlcode.l
|
||||||
|
+++ b/src/vhdlcode.l
|
||||||
|
@@ -1613,7 +1613,7 @@ void codeFreeVhdlScanner()
|
||||||
|
extern "C" { // some bogus code to keep the compiler happy
|
||||||
|
void vhdlcodeYYdummy() { yy_flex_realloc(0,0); }
|
||||||
|
}
|
||||||
|
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||||
|
+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
|
||||||
|
#error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
diff --git a/src/xmlcode.l b/src/xmlcode.l
|
||||||
|
index 15b5d7e..2bef4a0 100644
|
||||||
|
--- a/src/xmlcode.l
|
||||||
|
+++ b/src/xmlcode.l
|
||||||
|
@@ -407,7 +407,7 @@ void resetXmlCodeParserState()
|
||||||
|
extern "C" { // some bogus code to keep the compiler happy
|
||||||
|
void xmlcodeYYdummy() { yy_flex_realloc(0,0); }
|
||||||
|
}
|
||||||
|
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||||
|
+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
|
||||||
|
#error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
|
||||||
|
#endif
|
||||||
|
|
55
doxygen.spec
55
doxygen.spec
@ -7,7 +7,7 @@
|
|||||||
%define pck_docdir %{_datadir}/doc/doxygen-%{version}
|
%define pck_docdir %{_datadir}/doc/doxygen-%{version}
|
||||||
|
|
||||||
Name: doxygen
|
Name: doxygen
|
||||||
Version: 1.8.9.1
|
Version: 1.8.11
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A documentation system for C, C++, Java, IDL, Objective-C, PHP, C# and D
|
Summary: A documentation system for C, C++, Java, IDL, Objective-C, PHP, C# and D
|
||||||
Group: Applications/Development
|
Group: Applications/Development
|
||||||
@ -19,6 +19,7 @@ Source: ftp://ftp.stack.nl/pub/users/dimitri/doxygen-%{version}.src.tar.g
|
|||||||
Patch1: doxygen-1.7.1-config.patch
|
Patch1: doxygen-1.7.1-config.patch
|
||||||
Patch2: doxygen-1.6.2-timestamp.patch
|
Patch2: doxygen-1.6.2-timestamp.patch
|
||||||
Patch3: doxygen-1.7.2-fix_cftchapfont.patch
|
Patch3: doxygen-1.7.2-fix_cftchapfont.patch
|
||||||
|
Patch4: doxygen-1.8.10-flex-2.6.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -69,37 +70,46 @@ This package contains the documentation in HTML format and PDF format.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch1 -p1
|
#%patch4 -p1
|
||||||
#%patch2 -p1
|
|
||||||
#%patch3 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %{with_qt_wiz}
|
%if %{with_qt_wiz}
|
||||||
unset QTDIR || : ; . /etc/profile.d/libqt4.sh
|
unset QTDIR || : ; . /etc/profile.d/libqt4.sh
|
||||||
export QMAKE=%{_qt4_qmake}
|
export QMAKE=%{_qt4_qmake}
|
||||||
%endif
|
%endif
|
||||||
# note: not a standard configure script
|
%cmake -d build \
|
||||||
./configure \
|
-Dbuild_search=ON \
|
||||||
--prefix %{_prefix} \
|
|
||||||
--docdir %{pck_docdir} \
|
|
||||||
--shared \
|
|
||||||
--release \
|
|
||||||
--install %{_bindir}/install \
|
|
||||||
%if %{with_qt_wiz}
|
%if %{with_qt_wiz}
|
||||||
--with-doxywizard \
|
-Dbuild_wizard=ON \
|
||||||
%endif
|
%endif
|
||||||
|
-Dbuild_doc=ON \
|
||||||
|
-Duse_sqlite3=ON \
|
||||||
|
-Duse_libclang=ON
|
||||||
|
|
||||||
%make all
|
## note: not a standard configure script
|
||||||
|
#./configure \
|
||||||
|
# --prefix %{_prefix} \
|
||||||
|
# --docdir %{pck_docdir} \
|
||||||
|
# --shared \
|
||||||
|
# --release \
|
||||||
|
# --install %{_bindir}/install \
|
||||||
|
#%if %{with_qt_wiz}
|
||||||
|
# --with-doxywizard \
|
||||||
|
#% endif
|
||||||
|
|
||||||
|
%make
|
||||||
make docs
|
make docs
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%{expand:%%define MAN1DIR %(echo %_mandir/man1 | sed "s,%{_prefix}/,,")}
|
%{expand:%%define MAN1DIR %(echo %_mandir/man1 | sed "s,%{_prefix}/,,")}
|
||||||
make install install_docs \
|
%makeinstall -C build
|
||||||
INSTALL=%{buildroot}%{_prefix} \
|
|
||||||
MAN1DIR=%{MAN1DIR} \
|
# install_docs \
|
||||||
DOCDIR=%{buildroot}%{pck_docdir}
|
# INSTALL=%{buildroot}%{_prefix} \
|
||||||
|
# MAN1DIR=%{MAN1DIR} \
|
||||||
|
# DOCDIR=%{buildroot}%{pck_docdir}
|
||||||
|
|
||||||
iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
|
iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
|
||||||
touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
|
touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
|
||||||
@ -118,8 +128,12 @@ find examples -type f | xargs chmod -x
|
|||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/doxygen
|
%{_bindir}/doxygen
|
||||||
|
%{_bindir}/doxyindexer
|
||||||
|
%{_bindir}/doxysearch.cgi
|
||||||
#%{_bindir}/doxytag
|
#%{_bindir}/doxytag
|
||||||
%{_mandir}/man1/doxygen.1*
|
%{_mandir}/man1/doxygen.1*
|
||||||
|
%{_mandir}/man1/doxyindexer.1*
|
||||||
|
%{_mandir}/man1/doxysearch.1*
|
||||||
#%{_mandir}/man1/doxytag.1*
|
#%{_mandir}/man1/doxytag.1*
|
||||||
%doc LICENSE
|
%doc LICENSE
|
||||||
|
|
||||||
@ -133,11 +147,14 @@ find examples -type f | xargs chmod -x
|
|||||||
|
|
||||||
%files doc
|
%files doc
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_datadir}/doc/doxygen-%{version}
|
%dir %{_datadir}/doc/packages/doxygen
|
||||||
%{_datadir}/doc/doxygen-%{version}/*
|
%{_datadir}/doc/packages/doxygen/*
|
||||||
%doc LANGUAGE.HOWTO examples
|
%doc LANGUAGE.HOWTO examples
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 19 2016 Automatic Build System <autodist@mambasoft.it> 1.8.11-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Mon Jan 05 2015 Automatic Build System <autodist@mambasoft.it> 1.8.9.1-1mamba
|
* Mon Jan 05 2015 Automatic Build System <autodist@mambasoft.it> 1.8.9.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user