automatic version update by autodist [release 1.8.16-1mamba;Tue Oct 29 2019]
This commit is contained in:
parent
14fd2953bd
commit
1e1b21601c
48
doxygen-1.8.16-compat.patch
Normal file
48
doxygen-1.8.16-compat.patch
Normal file
@ -0,0 +1,48 @@
|
|||||||
|
From 4a72a9b07e805b4ba27560e8e921bcee0002ef4c Mon Sep 17 00:00:00 2001
|
||||||
|
From: albert-github <albert.tests@gmail.com>
|
||||||
|
Date: Mon, 9 Sep 2019 13:28:28 +0200
|
||||||
|
Subject: [PATCH] issue #7248: Including external tag files with TOC produces a
|
||||||
|
broken index.qhp
|
||||||
|
|
||||||
|
Ignore automatically generated anchor names when importing a tag file.
|
||||||
|
---
|
||||||
|
src/tagreader.cpp | 19 ++++++++++++++++++-
|
||||||
|
1 file changed, 18 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/tagreader.cpp b/src/tagreader.cpp
|
||||||
|
index 56dbe7df9..d79d9b5c5 100644
|
||||||
|
--- a/src/tagreader.cpp
|
||||||
|
+++ b/src/tagreader.cpp
|
||||||
|
@@ -494,6 +494,23 @@ class TagFileParser : public QXmlDefaultHandler
|
||||||
|
|
||||||
|
void endDocAnchor()
|
||||||
|
{
|
||||||
|
+ // Check whether or not the tag is automatically generate, in that case ignore the tag.
|
||||||
|
+ switch(m_state)
|
||||||
|
+ {
|
||||||
|
+ case InClass:
|
||||||
|
+ case InFile:
|
||||||
|
+ case InNamespace:
|
||||||
|
+ case InGroup:
|
||||||
|
+ case InPage:
|
||||||
|
+ case InMember:
|
||||||
|
+ case InPackage:
|
||||||
|
+ case InDir:
|
||||||
|
+ if (QString(m_curString).startsWith("autotoc_md")) return;
|
||||||
|
+ break;
|
||||||
|
+ default:
|
||||||
|
+ warn("Unexpected tag 'docanchor' found");
|
||||||
|
+ return;
|
||||||
|
+ }
|
||||||
|
switch(m_state)
|
||||||
|
{
|
||||||
|
case InClass: m_curClass->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
|
||||||
|
@@ -504,7 +521,7 @@ class TagFileParser : public QXmlDefaultHandler
|
||||||
|
case InMember: m_curMember->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
|
||||||
|
case InPackage: m_curPackage->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
|
||||||
|
case InDir: m_curDir->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
|
||||||
|
- default: warn("Unexpected tag 'docanchor' found"); break;
|
||||||
|
+ default: warn("Unexpected tag 'docanchor' found"); break; // Not really necessary anymore
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
49
doxygen.spec
49
doxygen.spec
@ -7,7 +7,7 @@
|
|||||||
%define pck_docdir %{_datadir}/doc/doxygen-%{version}
|
%define pck_docdir %{_datadir}/doc/doxygen-%{version}
|
||||||
|
|
||||||
Name: doxygen
|
Name: doxygen
|
||||||
Version: 1.8.15
|
Version: 1.8.16
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A documentation system for C, C++, Java, IDL, Objective-C, PHP, C# and D
|
Summary: A documentation system for C, C++, Java, IDL, Objective-C, PHP, C# and D
|
||||||
Group: Applications/Development
|
Group: Applications/Development
|
||||||
@ -22,15 +22,20 @@ Patch2: doxygen-1.6.2-timestamp.patch
|
|||||||
Patch3: doxygen-1.7.2-fix_cftchapfont.patch
|
Patch3: doxygen-1.7.2-fix_cftchapfont.patch
|
||||||
Patch4: doxygen-1.8.10-flex-2.6.patch
|
Patch4: doxygen-1.8.10-flex-2.6.patch
|
||||||
Patch5: doxygen-1.8.14-upstream-bug-789168-segfault.patch
|
Patch5: doxygen-1.8.14-upstream-bug-789168-segfault.patch
|
||||||
|
Patch6: doxygen-1.8.16-compat.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libqt5-devel
|
||||||
|
BuildRequires: libsqlite-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libxapian-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
%if "%{stage1}" != "1"
|
%if "%{stage1}" != "1"
|
||||||
BuildRequires: graphviz
|
BuildRequires: graphviz
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: libgcc
|
|
||||||
BuildRequires: libstdc++6-devel
|
|
||||||
## AUTOBUILDREQ-END
|
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
BuildRequires: ghostscript
|
BuildRequires: ghostscript
|
||||||
@ -74,32 +79,25 @@ This package contains the documentation in HTML format and PDF format.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch4 -p1
|
#%patch4 -p1
|
||||||
%patch5 -R -p1
|
#%patch5 -R -p1
|
||||||
|
%patch6 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %{with_qt_wiz}
|
# FIXME: % cmake macro fails
|
||||||
unset QTDIR || : ; . /etc/profile.d/libqt4.sh
|
mkdir build
|
||||||
export QMAKE=%{_qt4_qmake}
|
cd build
|
||||||
%endif
|
cmake -d build \
|
||||||
%cmake -d build \
|
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
||||||
-Dbuild_search=ON \
|
-DDOC_INSTALL_DIR:PATH=share/doc/doxygen \
|
||||||
%if %{with_qt_wiz}
|
%if %{with_qt_wiz}
|
||||||
-Dbuild_wizard=ON \
|
-Dbuild_wizard=ON \
|
||||||
%endif
|
%endif
|
||||||
-Dbuild_doc=ON \
|
-Dbuild_doc=ON \
|
||||||
-Duse_sqlite3=ON \
|
-Duse_sqlite3=ON \
|
||||||
-Duse_libclang=OFF
|
-Dbuild_search=ON \
|
||||||
|
..
|
||||||
|
|
||||||
## note: not a standard configure script
|
# -Duse_libclang=ON \
|
||||||
#./configure \
|
|
||||||
# --prefix %{_prefix} \
|
|
||||||
# --docdir %{pck_docdir} \
|
|
||||||
# --shared \
|
|
||||||
# --release \
|
|
||||||
# --install %{_bindir}/install \
|
|
||||||
#%if %{with_qt_wiz}
|
|
||||||
# --with-doxywizard \
|
|
||||||
#% endif
|
|
||||||
|
|
||||||
%make
|
%make
|
||||||
make docs
|
make docs
|
||||||
@ -151,11 +149,14 @@ find examples -type f | xargs chmod -x
|
|||||||
|
|
||||||
%files doc
|
%files doc
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_datadir}/doc/packages/doxygen
|
%dir %{_datadir}/doc/doxygen
|
||||||
%{_datadir}/doc/packages/doxygen/*
|
%{_datadir}/doc/doxygen/*
|
||||||
%doc LANGUAGE.HOWTO examples
|
%doc LANGUAGE.HOWTO examples
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 29 2019 Automatic Build System <autodist@mambasoft.it> 1.8.16-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sun Mar 31 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.15-1mamba
|
* Sun Mar 31 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.15-1mamba
|
||||||
- update to 1.8.15
|
- update to 1.8.15
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user