update to 0.8.8 [release 0.8.8-1mamba;Sun Oct 24 2021]

This commit is contained in:
Silvan Calarco 2024-01-05 21:51:58 +01:00
parent ca6d3b2827
commit 7c091ab807
4 changed files with 183 additions and 0 deletions

View File

@ -1,2 +1,6 @@
# docbook2X
Docbook2X is a software package that converts DocBook documents into the traditional Unix man page format and the GNU Texinfo format.
Notable features include table support for man pages, internationalization support, and easy customization of the output using XSLT.
Easy, because unlike other converters, the docbook2X stylesheets are written in a modular way, and the character escaping and whitespace issues with the man-page and Texinfo formats are encapsulated away from the user.

View File

@ -0,0 +1,11 @@
--- docbook2X-0.8.5/perl/Makefile.in.orig 2005-10-18 15:31:59.000000000 +0200
+++ docbook2X-0.8.5/perl/Makefile.in 2005-10-18 15:32:24.000000000 +0200
@@ -286,7 +286,7 @@
install-data-local:
if test ! -e XML ; then cp -dpR $(srcdir)/XML . ; fi
- cd XML/Handler && perl Makefile.PL PREFIX=$(prefix) && $(MAKE) install_perl
+ cd XML/Handler && perl Makefile.PL PREFIX=$(prefix) INSTALLDIRS=vendor && $(MAKE) install_vendor
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.

50
docbook2X-docbook2man Normal file
View File

@ -0,0 +1,50 @@
#!/bin/sh
#
# docbook2man - An SGML docbook to man pages converter using sgmlspl
#
# Copyright (c) 2005 by Silvan Calarco <silvan.calarco@qilinux.it>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
function usage() {
echo "\
docbook2man - An SGML docbook to man pages converter using sgmlspl
Copyright (c) 2005 by Silvan Calarco <silvan.calarco@qilinux.it>
usage: docbook2man sourcefile [sourcefile...]
sourcefile: the SGML source file for man pages
" >&2
}
SOURCEFILES=
while test -n "$1" ; do
case $1 in
-h) usage; exit ;;
*) SOURCEFILES="$SOURCEFILES $1" ;;
esac
shift
done
[ "$SOURCEFILES" ] || { usage; exit 1; }
tmpfile=`mktemp -q -t ${0##*/}.XXXXXXXX` ||
{ echo "${0##*/}: error: cannot create temporary files." >&2
{ (exit 1); exit 1; }; }
trap "rm -f $tmpfile" 0 1 2 5 15
for source in $SOURCEFILES; do
/usr/bin/onsgmls $source > $tmpfile || \
{ echo "Error $? parsing SGML document; aborting." >&2; exit 1; }
/usr/bin/sgmlspl /usr/bin/docbook2man-spec.pl < $tmpfile > /dev/null || \
{ echo "Error $? converting $source; aborting." >&2; exit 1; }
done

118
docbook2X.spec Normal file
View File

@ -0,0 +1,118 @@
Name: docbook2X
Version: 0.8.8
Release: 1mamba
Summary: Converts DocBook documents into man pages and Texinfo documents
Group: Applications/Publishing
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://docbook2x.sourceforge.net/
Source: https://downloads.sourceforge.net/docbook2x/%{name}-%{version}.tar.gz
Source1: %{name}-docbook2man
Patch: %{name}-0.8.5-install_vendor_perl.patch
License: MIT
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libperl
BuildRequires: perl-XML-SAX
BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRequires: OpenSP >= 1.5.1
BuildRequires: texinfo >= 4.8
BuildRequires: libxml2-utils >= 2.6.22
BuildRequires: perl >= 5.8.0
BuildRequires: perl-XML-SAX >= 0.12
#BuildRequires: tidy
BuildRequires: /usr/bin/xsltproc
Requires: docbook-xsl
Requires: docbook2man-sgmlspl
Requires: OpenSP
%description
Docbook2X is a software package that converts DocBook documents into the traditional Unix man page format and the GNU Texinfo format.
Notable features include table support for man pages, internationalization support, and easy customization of the output using XSLT.
Easy, because unlike other converters, the docbook2X stylesheets are written in a modular way, and the character escaping and whitespace issues with the man-page and Texinfo formats are encapsulated away from the user.
%debug_package
%prep
%setup -q
#%patch -p1
%build
%configure \
--program-transform-name 's,docbook2,db2x_docbook2,'
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
#install -m 0755 -D %{SOURCE1} %{buildroot}%{_bindir}/docbook2man
find %{buildroot} \( \
-name perllocal.pod -or -name .packlist \) -exec rm -f {} \;
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%define info_files %{name} docbook2man-xslt docbook2texi-xslt
%post
for info_file in %info_files
do %install_info $info_file.info
done
:
%preun
for info_file in %info_files
do %uninstall_info $info_file.info
done
:
%files
%defattr(-,root,root)
%{_bindir}/db2x_docbook2man
%{_bindir}/db2x_docbook2texi
%{_bindir}/db2x_manxml
%{_bindir}/db2x_texixml
%{_bindir}/db2x_xsltproc
%{_bindir}/sgml2xml-isoent
%{_bindir}/utf8trans
%dir %{_datadir}/doc/%{name}/
%{_datadir}/doc/%{name}/*
%dir %{_datadir}/%{name}
%{_datadir}/%{name}/*
%{_infodir}/%{name}.*
%{_infodir}/docbook2man-xslt.*
%{_infodir}/docbook2texi-xslt.*
%{_mandir}/man1/db2x_*.1*
%{_mandir}/man1/sgml2xml-isoent.1.gz
%{_mandir}/man1/utf8trans.1.gz
%doc AUTHORS COPYING
%changelog
* Sun Oct 24 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.8-1mamba
- update to 0.8.8
* Mon Feb 27 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 0.8.5-6qilnx
- fixed license
- removed jre as build requirement
* Tue Oct 18 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.8.5-5qilnx
- install/uninstall info pages
- patched to install perl files in the vendor subtree
* Tue Jun 21 2005 Silvan Calarco <silvan.calarco@qilinux.it> 0.8.5-4qilnx
- added a new docbook2man script using sgmlspl; it should work now
* Tue Jun 21 2005 Silvan Calarco <silvan.calarco@qilinux.it> 0.8.5-3qilnx
- rebuilt with perl 5.8.7
* Fri May 13 2005 Silvan Calarco <silvan.calarco@qilinux.it> 0.8.5-2qilnx
- changed j2sdk build requirement to jre
- rebuilt with new OpenSP build
* Fri Nov 19 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.8.5-1qilnx
- package created by autospec