update to 4.20.0 [release 4.20.0-1mamba;Thu Apr 25 2024]
This commit is contained in:
parent
2435b8926a
commit
eea09b430f
@ -1,33 +0,0 @@
|
||||
--- dnf-2.7.5/dnf/cli/output.py.orig 2019-06-02 13:54:58.348422061 +0200
|
||||
+++ dnf-2.7.5/dnf/cli/output.py 2019-06-02 13:55:32.693582235 +0200
|
||||
@@ -1032,14 +1032,14 @@
|
||||
easy-to-read format.
|
||||
"""
|
||||
|
||||
- forward_actions = {
|
||||
- hawkey.UPGRADE,
|
||||
- hawkey.UPGRADE_ALL,
|
||||
- hawkey.DISTUPGRADE,
|
||||
- hawkey.DISTUPGRADE_ALL,
|
||||
- hawkey.DOWNGRADE,
|
||||
+ forward_actions = \
|
||||
+ hawkey.UPGRADE|\
|
||||
+ hawkey.UPGRADE_ALL|\
|
||||
+ hawkey.DISTUPGRADE|\
|
||||
+ hawkey.DISTUPGRADE_ALL|\
|
||||
+ hawkey.DOWNGRADE|\
|
||||
hawkey.INSTALL
|
||||
- }
|
||||
+
|
||||
skipped_conflicts = set()
|
||||
skipped_broken = set()
|
||||
|
||||
@@ -1096,7 +1096,7 @@
|
||||
# show skipped conflicting packages
|
||||
if not self.conf.best and forward_actions & self.base._goal.actions:
|
||||
lines = []
|
||||
- upgrade_type = True if {hawkey.UPGRADE, hawkey.UPGRADE_ALL} & self.base._goal.actions \
|
||||
+ upgrade_type = True if (hawkey.UPGRADE|hawkey.UPGRADE_ALL) & self.base._goal.actions \
|
||||
else False
|
||||
skipped_conflicts, skipped_broken = self._skipped_packages(upgrade_type=upgrade_type)
|
||||
for pkg in sorted(skipped_conflicts):
|
@ -1,32 +0,0 @@
|
||||
Only in dnf-4.0.4/dnf/cli: output.py.orig
|
||||
Only in dnf-4.0.4/dnf/cli: output.py.rej
|
||||
diff -ru dnf-4.0.4.orig/dnf/yum/rpmtrans.py dnf-4.0.4/dnf/yum/rpmtrans.py
|
||||
--- dnf-4.0.4.orig/dnf/yum/rpmtrans.py 2019-06-02 15:21:54.000000000 +0200
|
||||
+++ dnf-4.0.4/dnf/yum/rpmtrans.py 2019-06-02 15:30:53.916853857 +0200
|
||||
@@ -245,12 +245,8 @@
|
||||
pass
|
||||
elif what == rpm.RPMCALLBACK_TRANS_PROGRESS:
|
||||
self._trans_progress(amount, total)
|
||||
- elif what == rpm.RPMCALLBACK_ELEM_PROGRESS:
|
||||
- # This callback type is issued every time the next transaction
|
||||
- # element is about to be processed by RPM, before any other
|
||||
- # callbacks are issued. "amount" carries the index of the element.
|
||||
- self._elemProgress(key, amount)
|
||||
elif what == rpm.RPMCALLBACK_INST_OPEN_FILE:
|
||||
+ self._elemProgress(key, amount)
|
||||
return self._instOpenFile(key)
|
||||
elif what == rpm.RPMCALLBACK_INST_CLOSE_FILE:
|
||||
self._instCloseFile(key)
|
||||
@@ -268,10 +264,6 @@
|
||||
self._unpackError(key)
|
||||
elif what == rpm.RPMCALLBACK_SCRIPT_ERROR:
|
||||
self._scriptError(amount, total, key)
|
||||
- elif what == rpm.RPMCALLBACK_SCRIPT_START:
|
||||
- self._script_start(key)
|
||||
- elif what == rpm.RPMCALLBACK_SCRIPT_STOP:
|
||||
- self._scriptStop()
|
||||
except Exception:
|
||||
exc_type, exc_value, exc_traceback = sys.exc_info()
|
||||
except_list = traceback.format_exception(exc_type, exc_value, exc_traceback)
|
||||
Only in dnf-4.0.4/dnf/yum: rpmtrans.py.orig
|
||||
Only in dnf-4.0.4/dnf/yum: rpmtrans.py.rej
|
@ -1,55 +0,0 @@
|
||||
diff -ru dnf-4.0.4.orig/dnf/base.py dnf-4.0.4/dnf/base.py
|
||||
--- dnf-4.0.4.orig/dnf/base.py 2019-06-02 15:21:54.000000000 +0200
|
||||
+++ dnf-4.0.4/dnf/base.py 2019-06-02 15:25:36.054431946 +0200
|
||||
@@ -513,14 +513,13 @@
|
||||
'nodocs': rpm.RPMTRANS_FLAG_NODOCS,
|
||||
'test': rpm.RPMTRANS_FLAG_TEST,
|
||||
'justdb': rpm.RPMTRANS_FLAG_JUSTDB,
|
||||
- 'nocontexts': rpm.RPMTRANS_FLAG_NOCONTEXTS,
|
||||
- 'nocrypto': rpm.RPMTRANS_FLAG_NOFILEDIGEST}
|
||||
+ 'nocontexts': 0,
|
||||
+ 'nocrypto': 0}
|
||||
if hasattr(rpm, 'RPMTRANS_FLAG_NOCAPS'):
|
||||
# Introduced in rpm-4.14
|
||||
_TS_FLAGS_TO_RPM['nocaps'] = rpm.RPMTRANS_FLAG_NOCAPS
|
||||
|
||||
- _TS_VSFLAGS_TO_RPM = {'nocrypto': rpm._RPMVSF_NOSIGNATURES |
|
||||
- rpm._RPMVSF_NODIGESTS}
|
||||
+ _TS_VSFLAGS_TO_RPM = {'nocrypto': rpm.RPMVSF_NODSAHEADER}
|
||||
|
||||
@property
|
||||
def goal(self):
|
||||
@@ -1675,7 +1674,7 @@
|
||||
|
||||
installroot = self.conf.installroot
|
||||
myts = dnf.rpm.transaction.initReadOnlyTransaction(root=installroot)
|
||||
- myts.pushVSFlags(~(rpm._RPMVSF_NOSIGNATURES | rpm._RPMVSF_NODIGESTS))
|
||||
+ myts.pushVSFlags(~(rpm.RPMVSF_NODSAHEADER))
|
||||
idx = myts.dbMatch('name', 'gpg-pubkey')
|
||||
keys = len(idx)
|
||||
del idx
|
||||
Only in dnf-4.0.4/dnf: base.py.orig
|
||||
Only in dnf-4.0.4/dnf: base.py.rej
|
||||
diff -ru dnf-4.0.4.orig/dnf/rpm/__init__.py dnf-4.0.4/dnf/rpm/__init__.py
|
||||
--- dnf-4.0.4.orig/dnf/rpm/__init__.py 2019-06-02 15:21:54.000000000 +0200
|
||||
+++ dnf-4.0.4/dnf/rpm/__init__.py 2019-06-02 15:24:13.154063464 +0200
|
||||
@@ -31,7 +31,7 @@
|
||||
"""Calculate the release version for the system."""
|
||||
|
||||
ts = transaction.initReadOnlyTransaction(root=installroot)
|
||||
- ts.pushVSFlags(~(rpm._RPMVSF_NOSIGNATURES | rpm._RPMVSF_NODIGESTS))
|
||||
+ ts.pushVSFlags(~(rpm.RPMVSF_NODSAHEADER))
|
||||
for distroverpkg in dnf.const.DISTROVERPKG:
|
||||
if dnf.pycomp.PY3:
|
||||
distroverpkg = bytes(distroverpkg, 'utf-8')
|
||||
Only in dnf-4.0.4/dnf/rpm: __init__.py.orig
|
||||
diff -ru dnf-4.0.4.orig/dnf/rpm/transaction.py dnf-4.0.4/dnf/rpm/transaction.py
|
||||
--- dnf-4.0.4.orig/dnf/rpm/transaction.py 2019-06-02 15:21:54.000000000 +0200
|
||||
+++ dnf-4.0.4/dnf/rpm/transaction.py 2019-06-02 15:24:13.154063464 +0200
|
||||
@@ -119,5 +119,5 @@
|
||||
|
||||
def initReadOnlyTransaction(root='/'):
|
||||
read_ts = TransactionWrapper(root=root)
|
||||
- read_ts.pushVSFlags((rpm._RPMVSF_NOSIGNATURES|rpm._RPMVSF_NODIGESTS))
|
||||
+ read_ts.pushVSFlags(rpm.RPMVSF_NODSAHEADER)
|
||||
return read_ts
|
22
dnf.spec
22
dnf.spec
@ -1,5 +1,5 @@
|
||||
Name: dnf
|
||||
Version: 4.18.2
|
||||
Version: 4.20.0
|
||||
Release: 1mamba
|
||||
Summary: Package manager based on libdnf and libsolv
|
||||
Group: System/Management
|
||||
@ -8,12 +8,9 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/rpm-software-management/dnf
|
||||
Source: https://github.com/rpm-software-management/dnf.git/%{version}/dnf-%{version}.tar.bz2
|
||||
Patch0: dnf-4.0.4-rpm5.patch
|
||||
Patch1: dnf-4.2.7-openmamba-detect-release.patch
|
||||
Patch2: dnf-2.7.5-hawkey-0.6.4.1.patch
|
||||
Patch3: dnf-2.7.5-python-2.7.15.patch
|
||||
Patch4: dnf-4.13.0-conf-no_gpg_check.patch
|
||||
Patch5: dnf-4.0.4-rpm5-CALLBACK.patch
|
||||
Patch6: dnf-4.2.18-i586-default-arch.patch
|
||||
Patch7: dnf-4.2.18-arm-default-arch.patch
|
||||
Patch8: dnf-4.14.0-debuginfo-suffix-openmamba.patch
|
||||
@ -21,6 +18,7 @@ License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libpython311-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: bash-completion-devel
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libsystemd-devel >= 2:248
|
||||
Requires: librepo
|
||||
@ -70,12 +68,9 @@ This package provides a configuration compatibility layer with YUM.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch 0 -p1
|
||||
%patch 1 -p1
|
||||
%patch 2 -p1
|
||||
#%patch 3 -p1
|
||||
%patch 4 -p1
|
||||
#%patch 5 -p1
|
||||
%patch 6 -p1
|
||||
%patch 7 -p1
|
||||
%patch 8 -p1
|
||||
@ -150,11 +145,11 @@ mkdir -p %{buildroot}%{_sysconfdir}/yum
|
||||
%{_unitdir}/dnf-makecache.service
|
||||
%{_unitdir}/dnf-makecache.timer
|
||||
%{_tmpfilesdir}/dnf.conf
|
||||
%{_datadir}/bash-completion/completions/dnf
|
||||
%{_mandir}/man5/dnf.conf.5*
|
||||
%{_mandir}/man5/dnf-transaction-json.5*
|
||||
%{_mandir}/man7/dnf.modularity.7*
|
||||
%{_mandir}/man8/dnf.8*
|
||||
%{_datadir}/bash-completion/completions/dnf-3
|
||||
%{_mandir}/man5/dnf4-transaction-json.5*
|
||||
%{_mandir}/man5/dnf4.conf.5*
|
||||
%{_mandir}/man7/dnf4.modularity.7*
|
||||
%{_mandir}/man8/dnf4.8*
|
||||
%{_mandir}/man8/dnf-automatic.8*
|
||||
%{_mandir}/man8/yum2dnf.8*
|
||||
%doc AUTHORS COPYING
|
||||
@ -169,6 +164,9 @@ mkdir -p %{buildroot}%{_sysconfdir}/yum
|
||||
%{_mandir}/man8/yum.8*
|
||||
|
||||
%changelog
|
||||
* Thu Apr 25 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 4.20.0-1mamba
|
||||
- update to 4.20.0
|
||||
|
||||
* Mon Feb 12 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 4.18.2-1mamba
|
||||
- update to 4.18.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user