i586: added a patch to set i586 as default name for x86 basearch [release 4.2.5-2mamba;Thu Jul 04 2019]
This commit is contained in:
parent
321e50bc2e
commit
eaf8ab1642
@ -1,44 +0,0 @@
|
||||
diff -ru dnf-4.0.4.orig/dnf/base.py dnf-4.0.4/dnf/base.py
|
||||
--- dnf-4.0.4.orig/dnf/base.py 2019-06-02 15:26:56.912792437 +0200
|
||||
+++ dnf-4.0.4/dnf/base.py 2019-06-02 15:27:29.783939255 +0200
|
||||
@@ -1676,7 +1676,7 @@
|
||||
myts = dnf.rpm.transaction.initReadOnlyTransaction(root=installroot)
|
||||
myts.pushVSFlags(~(rpm.RPMVSF_NODSAHEADER))
|
||||
idx = myts.dbMatch('name', 'gpg-pubkey')
|
||||
- keys = len(idx)
|
||||
+ keys = idx.count()
|
||||
del idx
|
||||
del myts
|
||||
|
||||
Only in dnf-4.0.4/dnf: base.py.orig
|
||||
diff -ru dnf-4.0.4.orig/dnf/const.py.in dnf-4.0.4/dnf/const.py.in
|
||||
--- dnf-4.0.4.orig/dnf/const.py.in 2019-06-02 15:21:54.000000000 +0200
|
||||
+++ dnf-4.0.4/dnf/const.py.in 2019-06-02 15:27:59.991074300 +0200
|
||||
@@ -25,7 +25,7 @@
|
||||
CONF_AUTOMATIC_FILENAME='/etc/dnf/automatic.conf'
|
||||
DISTROVERPKG=('system-release(releasever)', 'system-release',
|
||||
'distribution-release(releasever)', 'distribution-release',
|
||||
- 'redhat-release', 'suse-release')
|
||||
+ 'openmamba-release', 'redhat-release', 'suse-release')
|
||||
GROUP_PACKAGE_TYPES = ('mandatory', 'default', 'conditional') # :api
|
||||
INSTALLONLYPKGS=['kernel', 'kernel-PAE',
|
||||
'installonlypkg(kernel)',
|
||||
Only in dnf-4.0.4/dnf: const.py.in.orig
|
||||
Only in dnf-4.0.4/dnf: const.py.in.rej
|
||||
diff -ru dnf-4.0.4.orig/dnf/rpm/__init__.py dnf-4.0.4/dnf/rpm/__init__.py
|
||||
--- dnf-4.0.4.orig/dnf/rpm/__init__.py 2019-06-02 15:26:56.912792437 +0200
|
||||
+++ dnf-4.0.4/dnf/rpm/__init__.py 2019-06-02 15:27:29.783939255 +0200
|
||||
@@ -39,10 +39,10 @@
|
||||
idx = ts.dbMatch('provides', distroverpkg)
|
||||
except (TypeError, rpm.error) as e:
|
||||
raise dnf.exceptions.Error('Error: %s' % str(e))
|
||||
- if not len(idx):
|
||||
+ if idx.count() == 0:
|
||||
continue
|
||||
try:
|
||||
- hdr = next(idx)
|
||||
+ hdr = idx.next()
|
||||
except StopIteration:
|
||||
msg = 'Error: rpmdb failed to list provides. Try: rpm --rebuilddb'
|
||||
raise dnf.exceptions.Error(msg)
|
||||
Only in dnf-4.0.4/dnf/rpm: __init__.py.orig
|
22
dnf-4.2.5-arm-default-arch.patch
Normal file
22
dnf-4.2.5-arm-default-arch.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- dnf-4.2.5/dnf/conf/config.py.orig 2019-07-14 19:47:18.855318185 +0200
|
||||
+++ dnf-4.2.5/dnf/conf/config.py 2019-07-14 19:48:16.491705469 +0200
|
||||
@@ -374,6 +374,8 @@
|
||||
@arch.setter
|
||||
def arch(self, val):
|
||||
# :api
|
||||
+ if val in ['armv7l','armv6l','armv5tl','armv5tel','armv5tejl']:
|
||||
+ val = "arm"
|
||||
|
||||
if val is None:
|
||||
self.substitutions.pop('arch', None)
|
||||
--- dnf-4.2.5/dnf/rpm/__init__.py.orig 2019-07-14 19:43:35.349345247 +0200
|
||||
+++ dnf-4.2.5/dnf/rpm/__init__.py 2019-07-14 19:44:12.447014782 +0200
|
||||
@@ -83,7 +83,7 @@
|
||||
'aarch64': ('aarch64',),
|
||||
'alpha': ('alpha', 'alphaev4', 'alphaev45', 'alphaev5', 'alphaev56',
|
||||
'alphaev6', 'alphaev67', 'alphaev68', 'alphaev7', 'alphapca56'),
|
||||
- 'arm': ('armv5tejl', 'armv5tel', 'armv5tl', 'armv6l', 'armv7l', 'armv8l'),
|
||||
+ 'arm': ('arm','armv5tejl', 'armv5tel', 'armv5tl', 'armv6l', 'armv7l', 'armv8l'),
|
||||
'armhfp': ('armv6hl', 'armv7hl', 'armv7hnl', 'armv8hl', 'armv8hnl', 'armv8hcnl'),
|
||||
'i586': ('i386', 'athlon', 'geode', 'i386', 'i486', 'i586', 'i686'),
|
||||
'ia64': ('ia64',),
|
11
dnf-4.2.5-i586-default-arch.patch
Normal file
11
dnf-4.2.5-i586-default-arch.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- dnf-4.2.5/dnf/rpm/__init__.py.orig 2019-07-04 14:09:45.007728624 +0200
|
||||
+++ dnf-4.2.5/dnf/rpm/__init__.py 2019-07-04 14:09:52.604763252 +0200
|
||||
@@ -85,7 +85,7 @@
|
||||
'alphaev6', 'alphaev67', 'alphaev68', 'alphaev7', 'alphapca56'),
|
||||
'arm': ('armv5tejl', 'armv5tel', 'armv5tl', 'armv6l', 'armv7l', 'armv8l'),
|
||||
'armhfp': ('armv6hl', 'armv7hl', 'armv7hnl', 'armv8hl', 'armv8hnl', 'armv8hcnl'),
|
||||
- 'i386': ('i386', 'athlon', 'geode', 'i386', 'i486', 'i586', 'i686'),
|
||||
+ 'i586': ('i386', 'athlon', 'geode', 'i386', 'i486', 'i586', 'i686'),
|
||||
'ia64': ('ia64',),
|
||||
'mips': ('mips',),
|
||||
'mipsel': ('mipsel',),
|
12
dnf-4.2.7-openmamba-detect-release.patch
Normal file
12
dnf-4.2.7-openmamba-detect-release.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ru dnf-4.0.4.orig/dnf/const.py.in dnf-4.0.4/dnf/const.py.in
|
||||
--- dnf-4.0.4.orig/dnf/const.py.in 2019-06-02 15:21:54.000000000 +0200
|
||||
+++ dnf-4.0.4/dnf/const.py.in 2019-06-02 15:27:59.991074300 +0200
|
||||
@@ -25,7 +25,7 @@
|
||||
CONF_AUTOMATIC_FILENAME='/etc/dnf/automatic.conf'
|
||||
DISTROVERPKG=('system-release(releasever)', 'system-release',
|
||||
'distribution-release(releasever)', 'distribution-release',
|
||||
- 'redhat-release', 'suse-release')
|
||||
+ 'openmamba-release', 'redhat-release', 'suse-release')
|
||||
GROUP_PACKAGE_TYPES = ('mandatory', 'default', 'conditional') # :api
|
||||
INSTALLONLYPKGS=['kernel', 'kernel-PAE',
|
||||
'installonlypkg(kernel)',
|
29
dnf.spec
29
dnf.spec
@ -1,5 +1,5 @@
|
||||
Name: dnf
|
||||
Version: 4.0.4
|
||||
Version: 4.2.5
|
||||
Release: 2mamba
|
||||
Summary: Package manager based on libdnf and libsolv
|
||||
Group: System/Management
|
||||
@ -9,11 +9,13 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/rpm-software-management/dnf
|
||||
Source: https://github.com/rpm-software-management/dnf.git/%{version}/dnf-%{version}.tar.bz2
|
||||
Patch0: dnf-4.0.4-rpm5.patch
|
||||
Patch1: dnf-4.0.4-rpm5-detect-release.patch
|
||||
Patch1: dnf-4.2.7-openmamba-detect-release.patch
|
||||
Patch2: dnf-2.7.5-hawkey-0.6.4.1.patch
|
||||
Patch3: dnf-2.7.5-python-2.7.15.patch
|
||||
Patch4: dnf-2.7.5-openmamba-conf.patch
|
||||
Patch5: dnf-4.0.4-rpm5-CALLBACK.patch
|
||||
Patch6: dnf-4.2.5-i586-default-arch.patch
|
||||
Patch7: dnf-4.2.5-arm-default-arch.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libpython-devel
|
||||
@ -22,7 +24,7 @@ BuildRequires: cmake
|
||||
Requires: librepo
|
||||
Requires: libcomps
|
||||
Requires: libsolv
|
||||
Requires: libdnf
|
||||
Requires: libdnf >= 0.31.0
|
||||
Requires: python-gpg
|
||||
Requires: python-backports-lzma
|
||||
Requires: python-iniparse
|
||||
@ -34,12 +36,16 @@ Package manager based on libdnf and libsolv. Replaces YUM.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
#%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
#%patch5 -p1
|
||||
%patch6 -p1
|
||||
%ifarch arm
|
||||
%patch7 -p1
|
||||
%endif
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
@ -63,6 +69,7 @@ install -d %{buildroot}/lib
|
||||
mv %{buildroot}%{_prefix}/lib/systemd %{buildroot}/lib/
|
||||
|
||||
mv %{buildroot}%{_mandir}/man8/yum.8 %{buildroot}%{_mandir}/man8/yum-dnf.8
|
||||
mv %{buildroot}%{_mandir}/man1/yum-aliases.1 %{buildroot}%{_mandir}/man1/yum-aliases-dnf.1
|
||||
mv %{buildroot}%{_mandir}/man5/yum.conf.5 %{buildroot}%{_mandir}/man5/yum.conf-dnf.5
|
||||
mv %{buildroot}%{_mandir}/man8/yum-shell.8 %{buildroot}%{_mandir}/man8/yum-shell-dnf.8
|
||||
|
||||
@ -74,10 +81,12 @@ mv %{buildroot}%{_mandir}/man8/yum-shell.8 %{buildroot}%{_mandir}/man8/yum-shell
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%dir %{_sysconfdir}/dnf
|
||||
%{_sysconfdir}/dnf/aliases.d/zypper.conf
|
||||
%config %{_sysconfdir}/dnf/automatic.conf
|
||||
%config %{_sysconfdir}/dnf/dnf.conf
|
||||
%dir %{_sysconfdir}/dnf/protected.d
|
||||
%config %{_sysconfdir}/dnf/protected.d/dnf.conf
|
||||
%{_sysconfdir}/dnf/protected.d/yum.conf
|
||||
%{_sysconfdir}/libreport/events.d/collect_dnf.conf
|
||||
%{_sysconfdir}/logrotate.d/dnf
|
||||
%{_bindir}/dnf
|
||||
@ -99,7 +108,9 @@ mv %{buildroot}%{_mandir}/man8/yum-shell.8 %{buildroot}%{_mandir}/man8/yum-shell
|
||||
%{_tmpfilesdir}/dnf.conf
|
||||
%{_datadir}/bash-completion/completions/dnf
|
||||
%{_mandir}/man5/dnf.conf.5*
|
||||
%{_mandir}/man1/yum-aliases-dnf.1*
|
||||
%{_mandir}/man5/yum.conf-dnf.5*
|
||||
#%{_mandir}/man7/dnf.modularity.7*
|
||||
%{_mandir}/man8/dnf.8*
|
||||
%{_mandir}/man8/dnf.automatic.8*
|
||||
%{_mandir}/man8/yum-dnf.8*
|
||||
@ -108,6 +119,14 @@ mv %{buildroot}%{_mandir}/man8/yum-shell.8 %{buildroot}%{_mandir}/man8/yum-shell
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%changelog
|
||||
* Thu Jul 04 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.5-2mamba
|
||||
- i586: added a patch to set i586 as default name for x86 basearch
|
||||
|
||||
* Sat Jun 22 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.5-1mamba
|
||||
- update to 4.2.5
|
||||
- removed rpm5 patches
|
||||
- rebuilt with libdnf 0.31.0 (rpm 4)
|
||||
|
||||
* Sun Jun 02 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.4-2mamba
|
||||
- remove man pages conflicting with yum
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user