automatic version update by autodist [release 4.2.18-1mamba;Thu Jan 16 2020]
This commit is contained in:
parent
450f6856d1
commit
c65d0aaa8a
24
dnf-4.2.18-arm-default-arch.patch
Normal file
24
dnf-4.2.18-arm-default-arch.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ru dnf-4.2.18.orig/dnf/conf/config.py dnf-4.2.18/dnf/conf/config.py
|
||||
--- dnf-4.2.18.orig/dnf/conf/config.py 2020-01-16 14:28:11.000000000 +0100
|
||||
+++ dnf-4.2.18/dnf/conf/config.py 2020-01-16 15:57:18.198000000 +0100
|
||||
@@ -419,6 +419,8 @@
|
||||
@arch.setter
|
||||
def arch(self, val):
|
||||
# :api
|
||||
+ if val in ['armv7l','armv6l','armv5tl','armv5tel','armv5tejl']:
|
||||
+ val = "arm"
|
||||
|
||||
if val is None:
|
||||
self.substitutions.pop('arch', None)
|
||||
diff -ru dnf-4.2.18.orig/dnf/rpm/__init__.py dnf-4.2.18/dnf/rpm/__init__.py
|
||||
--- dnf-4.2.18.orig/dnf/rpm/__init__.py 2020-01-16 15:56:44.044000000 +0100
|
||||
+++ dnf-4.2.18/dnf/rpm/__init__.py 2020-01-16 15:57:48.680000000 +0100
|
||||
@@ -89,7 +89,7 @@
|
||||
'aarch64': ('aarch64',),
|
||||
'alpha': ('alpha', 'alphaev4', 'alphaev45', 'alphaev5', 'alphaev56',
|
||||
'alphaev6', 'alphaev67', 'alphaev68', 'alphaev7', 'alphapca56'),
|
||||
- 'arm': ('armv5tejl', 'armv5tel', 'armv5tl', 'armv6l', 'armv7l', 'armv8l'),
|
||||
+ 'arm': ('arm', 'armv5tejl', 'armv5tel', 'armv5tl', 'armv6l', 'armv7l', 'armv8l'),
|
||||
'armhfp': ('armv6hl', 'armv7hl', 'armv7hnl', 'armv8hl'),
|
||||
'i586': ('i386', 'athlon', 'geode', 'i386', 'i486', 'i586', 'i686'),
|
||||
'ia64': ('ia64',),
|
@ -1,9 +1,9 @@
|
||||
--- dnf-4.2.5/dnf/rpm/__init__.py.orig 2019-07-04 14:09:45.007728624 +0200
|
||||
+++ dnf-4.2.5/dnf/rpm/__init__.py 2019-07-04 14:09:52.604763252 +0200
|
||||
@@ -85,7 +85,7 @@
|
||||
--- dnf-4.2.18/dnf/rpm/__init__.py.orig 2020-01-16 15:54:52.565000000 +0100
|
||||
+++ dnf-4.2.18/dnf/rpm/__init__.py 2020-01-16 15:55:05.252000000 +0100
|
||||
@@ -91,7 +91,7 @@
|
||||
'alphaev6', 'alphaev67', 'alphaev68', 'alphaev7', 'alphapca56'),
|
||||
'arm': ('armv5tejl', 'armv5tel', 'armv5tl', 'armv6l', 'armv7l', 'armv8l'),
|
||||
'armhfp': ('armv6hl', 'armv7hl', 'armv7hnl', 'armv8hl', 'armv8hnl', 'armv8hcnl'),
|
||||
'armhfp': ('armv6hl', 'armv7hl', 'armv7hnl', 'armv8hl'),
|
||||
- 'i386': ('i386', 'athlon', 'geode', 'i386', 'i486', 'i586', 'i686'),
|
||||
+ 'i586': ('i386', 'athlon', 'geode', 'i386', 'i486', 'i586', 'i686'),
|
||||
'ia64': ('ia64',),
|
@ -1,22 +0,0 @@
|
||||
--- dnf-4.2.5/dnf/conf/config.py.orig 2019-07-14 19:47:18.855318185 +0200
|
||||
+++ dnf-4.2.5/dnf/conf/config.py 2019-07-14 19:48:16.491705469 +0200
|
||||
@@ -374,6 +374,8 @@
|
||||
@arch.setter
|
||||
def arch(self, val):
|
||||
# :api
|
||||
+ if val in ['armv7l','armv6l','armv5tl','armv5tel','armv5tejl']:
|
||||
+ val = "arm"
|
||||
|
||||
if val is None:
|
||||
self.substitutions.pop('arch', None)
|
||||
--- dnf-4.2.5/dnf/rpm/__init__.py.orig 2019-07-14 19:43:35.349345247 +0200
|
||||
+++ dnf-4.2.5/dnf/rpm/__init__.py 2019-07-14 19:44:12.447014782 +0200
|
||||
@@ -83,7 +83,7 @@
|
||||
'aarch64': ('aarch64',),
|
||||
'alpha': ('alpha', 'alphaev4', 'alphaev45', 'alphaev5', 'alphaev56',
|
||||
'alphaev6', 'alphaev67', 'alphaev68', 'alphaev7', 'alphapca56'),
|
||||
- 'arm': ('armv5tejl', 'armv5tel', 'armv5tl', 'armv6l', 'armv7l', 'armv8l'),
|
||||
+ 'arm': ('arm','armv5tejl', 'armv5tel', 'armv5tl', 'armv6l', 'armv7l', 'armv8l'),
|
||||
'armhfp': ('armv6hl', 'armv7hl', 'armv7hnl', 'armv8hl', 'armv8hnl', 'armv8hcnl'),
|
||||
'i586': ('i386', 'athlon', 'geode', 'i386', 'i486', 'i586', 'i686'),
|
||||
'ia64': ('ia64',),
|
16
dnf.spec
16
dnf.spec
@ -1,6 +1,6 @@
|
||||
Name: dnf
|
||||
Version: 4.2.6
|
||||
Release: 2mamba
|
||||
Version: 4.2.18
|
||||
Release: 1mamba
|
||||
Summary: Package manager based on libdnf and libsolv
|
||||
Group: System/Management
|
||||
Vendor: openmamba
|
||||
@ -14,8 +14,8 @@ Patch2: dnf-2.7.5-hawkey-0.6.4.1.patch
|
||||
Patch3: dnf-2.7.5-python-2.7.15.patch
|
||||
Patch4: dnf-2.7.5-openmamba-conf.patch
|
||||
Patch5: dnf-4.0.4-rpm5-CALLBACK.patch
|
||||
Patch6: dnf-4.2.5-i586-default-arch.patch
|
||||
Patch7: dnf-4.2.5-arm-default-arch.patch
|
||||
Patch6: dnf-4.2.18-i586-default-arch.patch
|
||||
Patch7: dnf-4.2.18-arm-default-arch.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libpython-devel
|
||||
@ -130,9 +130,10 @@ mkdir -p %{buildroot}%{_sysconfdir}/yum
|
||||
%dir %{_sysconfdir}/dnf
|
||||
%{_sysconfdir}/dnf/aliases.d/zypper.conf
|
||||
%config %{_sysconfdir}/dnf/automatic.conf
|
||||
%config %{_sysconfdir}/dnf/dnf.conf
|
||||
%config(noreplace) %{_sysconfdir}/dnf/dnf.conf
|
||||
%dir %{_sysconfdir}/dnf/protected.d
|
||||
%config %{_sysconfdir}/dnf/protected.d/dnf.conf
|
||||
%config %{_sysconfdir}/dnf/dnf-strict.conf
|
||||
%{_sysconfdir}/libreport/events.d/collect_dnf.conf
|
||||
%{_sysconfdir}/logrotate.d/dnf
|
||||
%{_bindir}/dnf
|
||||
@ -154,7 +155,7 @@ mkdir -p %{buildroot}%{_sysconfdir}/yum
|
||||
%{_tmpfilesdir}/dnf.conf
|
||||
%{_datadir}/bash-completion/completions/dnf
|
||||
%{_mandir}/man5/dnf.conf.5*
|
||||
#%{_mandir}/man7/dnf.modularity.7*
|
||||
%{_mandir}/man7/dnf.modularity.7*
|
||||
%{_mandir}/man8/dnf.8*
|
||||
%{_mandir}/man8/dnf-automatic.8*
|
||||
%{_mandir}/man8/yum2dnf.8*
|
||||
@ -175,6 +176,9 @@ mkdir -p %{buildroot}%{_sysconfdir}/yum
|
||||
%{_mandir}/man8/yum.8*
|
||||
|
||||
%changelog
|
||||
* Thu Jan 16 2020 Automatic Build System <autodist@mambasoft.it> 4.2.18-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 02 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.6-2mamba
|
||||
- require python-rpm
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user