automatic version update by autodist [release 3.0.13-1mamba;Fri Mar 08 2024]

This commit is contained in:
Automatic Build System 2024-03-09 11:43:21 +01:00
parent fc61af1eb4
commit fd85d71196
5 changed files with 9 additions and 120 deletions

View File

@ -1,19 +0,0 @@
--- dkms-2.4.0/dkms.orig 2017-06-18 16:14:10.760200880 +0200
+++ dkms-2.4.0/dkms 2017-06-18 16:17:02.255901350 +0200
@@ -515,7 +515,7 @@
[[ $3 ]] && read_conf_file="$3"
[[ -r $read_conf_file ]] || die 4 $"Could not locate dkms.conf file." \
- $"File: $conf does not exist."
+ $"File: $read_conf_file does not exist."
[[ $last_mvka = $module/$module_version/$1/$2 && \
$last_mvka_conf = $(readlink -f $read_conf_file) ]] && return
@@ -1558,6 +1558,7 @@
is_module_added() {
[[ $1 && $2 ]] || return 1
[[ -d $dkms_tree/$1/$2 ]] || return 2
+ [[ -d $dkms_tree/$1/$2/source/ ]] || return 2
[[ -L $dkms_tree/$1/$2/source || -d $dkms_tree/$1/$2/source ]];
}

View File

@ -1,12 +0,0 @@
diff -Nru dkms-2.8.3.orig/dkms dkms-2.8.3/dkms
--- dkms-2.8.3.orig/dkms 2020-07-17 03:57:34.000000000 +0200
+++ dkms-2.8.3/dkms 2020-07-24 10:23:30.880000000 +0200
@@ -702,6 +702,8 @@
[[ ! $make_command ]] && make_command="make -C $kernel_source_dir SUBDIRS=$dkms_tree/$module/$module_version/build modules"
[[ ! $clean ]] && clean="make -C $kernel_source_dir SUBDIRS=$dkms_tree/$module/$module_version/build clean"
else
+ make_command="${make_command/SUBDIRS=/M=}"
+ clean="${clean/SUBDIRS=/M=}"
[[ ! $make_command ]] && make_command="make -C $kernel_source_dir M=$dkms_tree/$module/$module_version/build"
[[ ! $clean ]] && clean="make -C $kernel_source_dir M=$dkms_tree/$module/$module_version/build clean"
fi

View File

@ -1,11 +0,0 @@
[Unit]
Description=Dynamic Kernel Modules System
[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/usr/lib/systemd/scripts/dkms start
ExecStop=/usr/lib/systemd/scripts/dkms stop
[Install]
WantedBy=multi-user.target

View File

@ -1,5 +1,5 @@
Name: dkms
Version: 3.0.12
Version: 3.0.13
Release: 1mamba
Summary: Dynamic Kernel Module Support
Group: System/Tools
@ -8,10 +8,6 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/dell/dkms
Source: https://github.com/dell/dkms.git/v%{version}/dkms-%{version}.tar.bz2
Source1: dkms.service
Source2: dkms.systemd
Patch0: dkms-2.4.0-dont_fail_if_module_source_removed.patch
Patch1: dkms-2.8.3-kernel-5.4.patch
License: GPL
## AUTOBUILDREQ-BEGIN
## AUTOBUILDREQ-END
@ -23,13 +19,12 @@ DKMS stands for Dynamic Kernel Module Support. It is designed to create a framew
%prep
%setup -q
#%patch1 -p1
%build
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
make install-redhat DESTDIR=%{buildroot}
make install-redhat SBIN=%{_bindir} DESTDIR=%{buildroot}
install -d %{buildroot}%{_presetdir}
cat > %{buildroot}%{_presetdir}/50-dkms.preset << _EOF
@ -67,9 +62,6 @@ find /var/lib/dkms -xtype l -exec rm -f {} \;
%files
%defattr(-,root,root)
%dir %{_sysconfdir}/dkms
#%{_sysconfdir}/dkms/sign_helper.sh
#%{_sysconfdir}/dkms/template-dkms-mkrpm.spec
#%{_sysconfdir}/dkms/template-dkms-redhat-kmod.spec
%{_sysconfdir}/dkms/framework.conf
%dir %{_sysconfdir}/kernel/install.d
%{_sysconfdir}/kernel/install.d/40-dkms.install
@ -77,22 +69,22 @@ find /var/lib/dkms -xtype l -exec rm -f {} \;
%{_sysconfdir}/kernel/postinst.d/dkms
%dir %{_sysconfdir}/kernel/prerm.d
%{_sysconfdir}/kernel/prerm.d/dkms
%{_sbindir}/dkms
%{_bindir}/dkms
%{_presetdir}/50-dkms.preset
%{_unitdir}/dkms.service
%dir %{_prefix}/lib/dkms
%{_prefix}/lib/dkms/common.postinst
%{_prefix}/lib/dkms/dkms_autoinstaller
#%{_prefix}/lib/dkms/find-provides
#%{_prefix}/lib/dkms/lsb_release
#%{_prefix}/lib/dkms/mkkerneldoth
%dir %{_localstatedir}/lib/dkms
#%{_localstatedir}/lib/dkms/dkms_dbversion
%{_presetdir}/50-dkms.preset
%{_unitdir}/dkms.service
%{_datadir}/bash-completion/completions/dkms
%{_datadir}/zsh/site-functions/_dkms
%{_mandir}/man8/dkms.8*
%doc COPYING
%changelog
* Fri Mar 08 2024 Automatic Build System <autodist@openmamba.org> 3.0.13-1mamba
- automatic version update by autodist
* Mon Oct 02 2023 Automatic Build System <autodist@mambasoft.it> 3.0.12-1mamba
- automatic version update by autodist

View File

@ -1,61 +0,0 @@
#!/bin/bash
. /etc/default/dkms
# list dkms modules for the current running kernel
list_dkms_modules() {
shopt -s nullglob
declare -a DKMS_MOULES
# dkms status needs uname -r to list correctly intalled version for current kernel
local modules_path=($(dkms status -k "$(uname -r)"|sed -rn 's#(.*), (.*), (.*), (.*): installed#\1/\2/\3/\4#p'))
for p in "${modules_path[@]}"; do
for m in /var/lib/dkms/"$p"/module/*.ko{,gz}; do
m=${m##*/}
m=${m%.gz}
m=${m%.ko}
DKMS_MODULES+=("$m")
done
done
}
# load installed kernel modules for the current kernel version
load_dkms_modules() {
local ret=0
list_dkms_modules
for m in "${DKMS_MODULES[@]}"; do
modprobe "$m"
ret+=$?
done
return $ret
}
# unload installed kernel modules for the current kernel version
unload_dkms_modules() {
list_dkms_modules
# ask for removal
for m in "${DKMS_MODULES[@]}"; do
modprobe --remove --quiet "$m"
done
# check modules are unloaded
# sometimes modprobe -r fail but modules are removed
for m in "${DKMS_MODULES[@]}"; do
[[ -e /sys/modules/$m ]] && return 1
done
return 0
}
case "$1" in
start)
dkms autoinstall -k "$(uname -r)"
[[ $LOAD =~ [Yy][Ee][Ss] ]] && load_dkms_modules
;;
stop)
[[ $UNLOAD =~ [Yy][Ee][Ss] ]] && unload_dkms_modules
;;
*)
echo "usage: $0 {start|stop}" >&2
;;
esac
:
# vim:set ts=2 sw=2 ft=sh et: