update to 8.3.0_1 [release 8.3.0_1-1mamba;Wed Apr 03 2024]
This commit is contained in:
parent
450bd861a1
commit
bc977c779e
@ -1,46 +0,0 @@
|
|||||||
--- digikam-5.0.0-beta4/core/libs/dngwriter/tests/CMakeLists.txt 2016-03-09 18:30:31.194854884 +0100
|
|
||||||
+++ digikam-5.0.0-beta4/core/libs/dngwriter/tests/CMakeLists.txt.orig 2016-03-09 18:30:18.607840912 +0100
|
|
||||||
@@ -46,6 +46,7 @@
|
|
||||||
target_link_libraries(raw2dng
|
|
||||||
digikamcore
|
|
||||||
libdng
|
|
||||||
+ astro
|
|
||||||
${EXPAT_LIBRARY}
|
|
||||||
${CMAKE_THREAD_LIBS_INIT}
|
|
||||||
)
|
|
||||||
--- digikam-5.0.0-beta3/core/app/CMakeLists.txt.orig 2016-03-09 20:51:47.377576526 +0100
|
|
||||||
+++ digikam-5.0.0-beta3/core/app/CMakeLists.txt 2016-03-09 21:01:35.679674116 +0100
|
|
||||||
@@ -142,6 +142,9 @@
|
|
||||||
target_link_libraries(digikamcore PUBLIC ${MARBLE_LIBRARIES}
|
|
||||||
KF5::ItemModels)
|
|
||||||
|
|
||||||
+ target_link_libraries(digikamcore PUBLIC ${ASTRO_LIBRARIES}
|
|
||||||
+ KF5::ItemModels)
|
|
||||||
+
|
|
||||||
if(KF5Bookmarks_FOUND)
|
|
||||||
target_link_libraries(digikamcore PRIVATE KF5::Bookmarks)
|
|
||||||
endif()
|
|
||||||
@@ -362,6 +365,7 @@
|
|
||||||
queuemanager
|
|
||||||
advancedrename
|
|
||||||
importui
|
|
||||||
+ astro
|
|
||||||
|
|
||||||
Qt5::Core
|
|
||||||
Qt5::Gui
|
|
||||||
@@ -390,6 +394,7 @@
|
|
||||||
|
|
||||||
if(${MARBLE_FOUND})
|
|
||||||
target_link_libraries(digikamgui PUBLIC ${MARBLE_LIBRARIES})
|
|
||||||
+ target_link_libraries(digikamgui PUBLIC ${ASTRO_LIBRARIES})
|
|
||||||
endif()
|
|
||||||
|
|
||||||
if(APPLE)
|
|
||||||
@@ -454,6 +459,7 @@
|
|
||||||
digikamgui
|
|
||||||
|
|
||||||
libdng
|
|
||||||
+ astro
|
|
||||||
|
|
||||||
Qt5::Core
|
|
||||||
Qt5::Gui
|
|
@ -1,38 +0,0 @@
|
|||||||
From: Gilles Caulier <caulier.gilles@gmail.com>
|
|
||||||
Date: Wed, 02 Mar 2016 04:55:26 +0000
|
|
||||||
Subject: Remove unused method since panorama and expoblending tools are moved to DK core
|
|
||||||
X-Git-Url: http://quickgit.kde.org/?p=digikam.git&a=commitdiff&h=0cdafd38a0759c5751cf7b5c81417e6c427be372
|
|
||||||
---
|
|
||||||
Remove unused method since panorama and expoblending tools are moved to DK core
|
|
||||||
BUGS: 359897
|
|
||||||
FIXED-IN: 5.0.0
|
|
||||||
---
|
|
||||||
|
|
||||||
|
|
||||||
--- a/utilities/kdesupport/kipi/kipiinterface.cpp
|
|
||||||
+++ b/utilities/kdesupport/kipi/kipiinterface.cpp
|
|
||||||
@@ -581,23 +581,6 @@
|
|
||||||
return( decoder.loadRawPreview(image, url.toLocalFile()) );
|
|
||||||
}
|
|
||||||
|
|
||||||
- uint decodeRawImage(const QUrl& url, QByteArray& imageData, int& width, int& height, int& rgbmax)
|
|
||||||
- {
|
|
||||||
- DRawDecoderSettings settings;
|
|
||||||
- KSharedConfig::Ptr config = KSharedConfig::openConfig();
|
|
||||||
- KConfigGroup group = config->group(QLatin1String("ImageViewer Settings"));
|
|
||||||
- DRawDecoderWidget::readSettings(settings, group);
|
|
||||||
-
|
|
||||||
- if (decoder.decodeRAWImage(url.toLocalFile(), settings, imageData, width, height, rgbmax))
|
|
||||||
- return settings.sixteenBitsImage ? 16 : 8;
|
|
||||||
-
|
|
||||||
- return 0;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
- void cancel()
|
|
||||||
- {
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
bool isRawFile(const QUrl& url)
|
|
||||||
{
|
|
||||||
return (decoder.isRawFile(url));
|
|
||||||
|
|
@ -1,30 +0,0 @@
|
|||||||
--- a/libs/rawengine/libraw/libraw/libraw_types.h
|
|
||||||
+++ b/libs/rawengine/libraw/libraw/libraw_types.h
|
|
||||||
@@ -612,10 +612,10 @@
|
|
||||||
#elif defined(__INTEL__)
|
|
||||||
#define LibRawBigEndian 0
|
|
||||||
|
|
||||||
-#elif defined(_M_IX86)
|
|
||||||
+#elif defined(_M_IX86) || defined(__i386__)
|
|
||||||
#define LibRawBigEndian 0
|
|
||||||
|
|
||||||
-#elif defined(_M_X64) || defined(__amd64__)
|
|
||||||
+#elif defined(_M_X64) || defined(__amd64__) || defined(__x86_64__)
|
|
||||||
#define LibRawBigEndian 0
|
|
||||||
|
|
||||||
#elif defined(__LITTLE_ENDIAN__)
|
|
||||||
@@ -625,6 +625,13 @@
|
|
||||||
#define LibRawBigEndian 1
|
|
||||||
#elif defined(_ARM_)
|
|
||||||
#define LibRawBigEndian 0
|
|
||||||
+
|
|
||||||
+#elif __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
|
|
||||||
+#define LibRawBigEndian 0
|
|
||||||
+
|
|
||||||
+#elif __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
|
|
||||||
+#define LibRawBigEndian 1
|
|
||||||
+
|
|
||||||
#else
|
|
||||||
#ifndef qXCodeRez
|
|
||||||
#error Unable to figure out byte order.
|
|
||||||
|
|
@ -1,28 +0,0 @@
|
|||||||
From 51efe295a222070743187af0367b0bf957879337 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Antonio Rojas <arojas@archlinux.org>
|
|
||||||
Date: Fri, 22 Apr 2022 19:13:28 +0200
|
|
||||||
Subject: [PATCH] Fix build with akonadi-contacts 22.04
|
|
||||||
|
|
||||||
---
|
|
||||||
core/utilities/extrasupport/addressbook/akonadiiface.cpp | 4 ++++
|
|
||||||
1 file changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/core/utilities/extrasupport/addressbook/akonadiiface.cpp b/core/utilities/extrasupport/addressbook/akonadiiface.cpp
|
|
||||||
index 6a78863cf6..8e65a405da 100644
|
|
||||||
--- a/core/utilities/extrasupport/addressbook/akonadiiface.cpp
|
|
||||||
+++ b/core/utilities/extrasupport/addressbook/akonadiiface.cpp
|
|
||||||
@@ -49,7 +49,11 @@
|
|
||||||
#include <AkonadiCore/Item>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 19, 80)
|
|
||||||
+#include <Akonadi/ContactSearchJob>
|
|
||||||
+#else
|
|
||||||
#include <Akonadi/Contact/ContactSearchJob>
|
|
||||||
+#endif
|
|
||||||
#include <KContacts/Addressee>
|
|
||||||
|
|
||||||
#if defined(Q_OS_DARWIN) && defined(Q_CC_CLANG)
|
|
||||||
--
|
|
||||||
GitLab
|
|
||||||
|
|
24
digikam.spec
24
digikam.spec
@ -1,8 +1,9 @@
|
|||||||
%define libname lib%{name}
|
%define libname lib%{name}
|
||||||
|
%define dirver %(echo %version | cut -d_ -f1)
|
||||||
%define pkgver %(echo %version | tr _ -)
|
%define pkgver %(echo %version | tr _ -)
|
||||||
|
|
||||||
Name: digikam
|
Name: digikam
|
||||||
Version: 8.3.0
|
Version: 8.3.0_1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: An advanced digital photo management application Linux, Windows and Mac-OSX
|
Summary: An advanced digital photo management application Linux, Windows and Mac-OSX
|
||||||
Group: Graphical Desktop/Applications/Graphics
|
Group: Graphical Desktop/Applications/Graphics
|
||||||
@ -10,11 +11,7 @@ Vendor: openmamba
|
|||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://www.digikam.org
|
URL: https://www.digikam.org
|
||||||
Source: http://download.kde.org/stable/digikam/%{version}/digiKam-%{pkgver}.tar.xz
|
Source: http://download.kde.org/stable/digikam/%{dirver}/digiKam-%{pkgver}.tar.xz
|
||||||
Patch0: digikam-5.0.0_beta4-add_libastro.patch
|
|
||||||
Patch1: digikam-5.0.0_beta4-upstream-fix-1.patch
|
|
||||||
Patch2: digikam-5.1.0-gcc-6.1.patch
|
|
||||||
Patch3: digikam-7.6.0-libakonadi-22.04.1.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -89,12 +86,10 @@ BuildRequires: qt5-qtbase-devel
|
|||||||
BuildRequires: qt5-qtdeclarative-devel
|
BuildRequires: qt5-qtdeclarative-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libksane-devel >= 24.02.0
|
BuildRequires: libksane-devel >= 24.02.0
|
||||||
#BuildRequires: libplist-devel >= 1.11-1mamba
|
|
||||||
BuildRequires: ufraw
|
BuildRequires: ufraw
|
||||||
BuildRequires: mysql
|
BuildRequires: mysql
|
||||||
BuildRequires: shared-desktop-ontologies-devel
|
BuildRequires: shared-desktop-ontologies-devel
|
||||||
BuildRequires: soprano-backend-redland
|
BuildRequires: soprano-backend-redland
|
||||||
#BuildRequires: libmediawiki-devel
|
|
||||||
BuildRequires: libkvkontakte-devel
|
BuildRequires: libkvkontakte-devel
|
||||||
BuildRequires: libqtav-devel
|
BuildRequires: libqtav-devel
|
||||||
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
@ -240,10 +235,9 @@ Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{pkgver}
|
%setup -q -n %{name}-%{dirver}
|
||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
#%patch3 -p1 -b .libakonadi-22.04.1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
@ -255,13 +249,6 @@ Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
-DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=OFF \
|
-DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=OFF \
|
||||||
-DCMAKE_CXX_FLAGS="%{optflags}"
|
-DCMAKE_CXX_FLAGS="%{optflags}"
|
||||||
|
|
||||||
# -DDIGIKAMSC_COMPILE_LIBKFACE=on \
|
|
||||||
# -DDIGIKAMSC_COMPILE_LIBKGEOMAP=on
|
|
||||||
|
|
||||||
#%ifarch arm
|
|
||||||
# -DWITH_OpenGL:BOOL=false
|
|
||||||
#%endif
|
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
#|| %make -j1
|
#|| %make -j1
|
||||||
@ -327,6 +314,9 @@ Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
%{_libdir}/cmake/DigikamPlugin/DigikamPluginConfig.cmake
|
%{_libdir}/cmake/DigikamPlugin/DigikamPluginConfig.cmake
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 03 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 8.3.0_1-1mamba
|
||||||
|
- update to 8.3.0_1
|
||||||
|
|
||||||
* Fri Mar 15 2024 Automatic Build System <autodist@openmamba.org> 8.3.0-1mamba
|
* Fri Mar 15 2024 Automatic Build System <autodist@openmamba.org> 8.3.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user