automatic version update by autodist [release 4.14.0-1mamba;Sat Dec 26 2015]
This commit is contained in:
parent
efef0e7b4d
commit
a93f084186
@ -1,68 +0,0 @@
|
||||
commit 25cc9c9876a5233bd630105d0110319892d4e18c
|
||||
Author: Gilles Caulier <caulier.gilles@gmail.com>
|
||||
Date: Tue Jan 3 15:16:37 2012 +0100
|
||||
|
||||
enable checkall and clearall buttons only with libkipi version 1.4.0
|
||||
BUGS: 290496
|
||||
|
||||
diff --git a/utilities/setup/setupplugins.cpp b/utilities/setup/setupplugins.cpp
|
||||
index 0f4030a..b8efb35 100644
|
||||
--- a/utilities/setup/setupplugins.cpp
|
||||
+++ b/utilities/setup/setupplugins.cpp
|
||||
@@ -6,8 +6,8 @@
|
||||
* Date : 2004-01-02
|
||||
* Description : setup Kipi plugins tab.
|
||||
*
|
||||
- * Copyright (C) 2004-2011 by Gilles Caulier <caulier dot gilles at gmail dot com>
|
||||
- * Copyright (C) 2011 by Andi Clemens <andi dot clemens at googlemail dot com>
|
||||
+ * Copyright (C) 2004-2012 by Gilles Caulier <caulier dot gilles at gmail dot com>
|
||||
+ * Copyright (C) 2011-2012 by Andi Clemens <andi dot clemens at googlemail dot com>
|
||||
*
|
||||
* This program is free software; you can redistribute it
|
||||
* and/or modify it under the terms of the GNU General
|
||||
@@ -100,6 +100,11 @@ SetupPlugins::SetupPlugins(QWidget* parent)
|
||||
|
||||
panel->setLayout(mainLayout);
|
||||
|
||||
+#if KIPI_VERSION < 0x010400
|
||||
+ d->checkAllBtn->setVisible(false);
|
||||
+ d->clearBtn->setVisible(false);
|
||||
+#endif
|
||||
+
|
||||
initPlugins();
|
||||
|
||||
// --------------------------------------------------------
|
||||
@@ -158,14 +163,18 @@ void SetupPlugins::applyPlugins()
|
||||
void SetupPlugins::slotCheckAll()
|
||||
{
|
||||
QApplication::setOverrideCursor(Qt::WaitCursor);
|
||||
+#if KIPI_VERSION >= 0x010400
|
||||
d->kipiConfig->slotCheckAll();
|
||||
+#endif
|
||||
QApplication::restoreOverrideCursor();
|
||||
}
|
||||
|
||||
void SetupPlugins::slotClear()
|
||||
{
|
||||
QApplication::setOverrideCursor(Qt::WaitCursor);
|
||||
+#if KIPI_VERSION >= 0x010400
|
||||
d->kipiConfig->slotClear();
|
||||
+#endif
|
||||
QApplication::restoreOverrideCursor();
|
||||
}
|
||||
|
||||
diff --git a/utilities/setup/setupplugins.h b/utilities/setup/setupplugins.h
|
||||
index 271a569..114e0fa 100644
|
||||
--- a/utilities/setup/setupplugins.h
|
||||
+++ b/utilities/setup/setupplugins.h
|
||||
@@ -6,8 +6,8 @@
|
||||
* Date : 2004-01-02
|
||||
* Description : setup Kipi plugins tab.
|
||||
*
|
||||
- * Copyright (C) 2004-2011 by Gilles Caulier <caulier dot gilles at gmail dot com>
|
||||
- * Copyright (C) 2011 by Andi Clemens <andi dot clemens at googlemail dot com>
|
||||
+ * Copyright (C) 2004-2012 by Gilles Caulier <caulier dot gilles at gmail dot com>
|
||||
+ * Copyright (C) 2011-2012 by Andi Clemens <andi dot clemens at googlemail dot com>
|
||||
*
|
||||
* This program is free software; you can redistribute it
|
||||
* and/or modify it under the terms of the GNU General
|
71
digikam.spec
71
digikam.spec
@ -1,8 +1,8 @@
|
||||
%define libname lib%{name}
|
||||
|
||||
Name: digikam
|
||||
Version: 4.12.0
|
||||
Release: 2mamba
|
||||
Version: 4.14.0
|
||||
Release: 1mamba
|
||||
Summary: An advanced digital photo management application Linux, Windows and Mac-OSX
|
||||
Group: Graphical Desktop/Applications/Graphics
|
||||
Vendor: openmamba
|
||||
@ -10,7 +10,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.digikam.org
|
||||
Source: http://download.kde.org/stable/digikam/digikam-%{version}.tar.bz2
|
||||
Patch0: %{name}-2.5.0-libkipi-4.7.4.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: baloo-devel
|
||||
@ -74,10 +73,12 @@ BuildRequires: ufraw
|
||||
BuildRequires: mysql
|
||||
BuildRequires: shared-desktop-ontologies-devel
|
||||
BuildRequires: soprano-backend-redland
|
||||
BuildRequires: libkipi-devel >= 4.14
|
||||
BuildRequires: libkipi-devel >= 15.08
|
||||
BuildRequires: libkdcraw-devel >= 4.14
|
||||
BuildRequires: libmarble-devel >= 4.14
|
||||
BuildRequires: libgphoto2-devel >= 1:2.5
|
||||
#BuildRequires: libkface-devel >= 15.08
|
||||
#BuildRequires: libkgeomap-devel >= 15.08
|
||||
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: kipi-plugins = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: kdelibs >= %{_kde4_version}
|
||||
@ -245,8 +246,10 @@ Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
-DCMAKE_SKIP_RPATH=OFF \
|
||||
-DBUILD_tests=OFF \
|
||||
-DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=off \
|
||||
-DDIGIKAMSC_COMPILE_LIBKFACE=on \
|
||||
-DDIGIKAMSC_COMPILE_LIBKGEOMAP=on
|
||||
-DCMAKE_CXX_FLAGS="%{optflags} -L%{_kde4_libdir}"
|
||||
|
||||
# -DDIGIKAMSC_COMPILE_LIBKFACE=on \
|
||||
# -DDIGIKAMSC_COMPILE_LIBKGEOMAP=on
|
||||
|
||||
#%ifarch arm
|
||||
# -DWITH_OpenGL:BOOL=false
|
||||
@ -344,34 +347,31 @@ done
|
||||
#%{_kde4_libdir}/libPropertyBrowser.a
|
||||
#%doc NEWS README
|
||||
|
||||
%post -n libkface -p /sbin/ldconfig
|
||||
%postun -n libkface -p /sbin/ldconfig
|
||||
#%post -n libkface -p /sbin/ldconfig
|
||||
#%postun -n libkface -p /sbin/ldconfig
|
||||
|
||||
%files -n libkface
|
||||
%defattr(-,root,root)
|
||||
%{_kde4_datadir}/libkface/
|
||||
%{_kde4_libdir}/libkface.so.*
|
||||
%{_kde4_libdir}/libkface.so
|
||||
#%files -n libkface
|
||||
#%defattr(-,root,root)
|
||||
#%{_kde4_datadir}/libkface/
|
||||
#%{_kde4_libdir}/libkface.so.*
|
||||
#%{_kde4_libdir}/libkface.so
|
||||
|
||||
%files -n libkface-devel
|
||||
%defattr(-,root,root)
|
||||
%{_kde4_bindir}/libkgeomap_demo
|
||||
%dir %{_kde4_libdir}/cmake/Kface-*
|
||||
%{_kde4_libdir}/cmake/Kface-*/Kface-*.cmake
|
||||
%{_kde4_libdir}/cmake/Kface-*/kface-*.cmake
|
||||
#%{_kde4_datadir}/cmake/modules/FindKface.cmake
|
||||
#%{_kde4_includedir}/libkface/
|
||||
#%{_libdir}/pkgconfig/libkface.pc
|
||||
|
||||
%post -n libkgeomap -p /sbin/ldconfig
|
||||
%postun -n libkgeomap -p /sbin/ldconfig
|
||||
|
||||
%files -n libkgeomap
|
||||
%defattr(-,root,root)
|
||||
#%files -n libkface-devel
|
||||
#%defattr(-,root,root)
|
||||
#%{_kde4_bindir}/libkgeomap_demo
|
||||
%{_kde4_datadir}/libkgeomap/
|
||||
%{_kde4_libdir}/libkgeomap.so.*
|
||||
%{_kde4_libdir}/libkgeomap.so
|
||||
#%dir %{_kde4_libdir}/cmake/Kface-*
|
||||
#%{_kde4_libdir}/cmake/Kface-*/Kface-*.cmake
|
||||
#%{_kde4_libdir}/cmake/Kface-*/kface-*.cmake
|
||||
|
||||
#%post -n libkgeomap -p /sbin/ldconfig
|
||||
#%postun -n libkgeomap -p /sbin/ldconfig
|
||||
|
||||
#%files -n libkgeomap
|
||||
#%defattr(-,root,root)
|
||||
##%{_kde4_bindir}/libkgeomap_demo
|
||||
#%{_kde4_datadir}/libkgeomap/
|
||||
#%{_kde4_libdir}/libkgeomap.so.*
|
||||
#%{_kde4_libdir}/libkgeomap.so
|
||||
|
||||
#%files -n libkgeomap-devel
|
||||
#%defattr(-,root,root)
|
||||
@ -412,8 +412,10 @@ done
|
||||
#%{_kde4_bindir}/dnginfo
|
||||
%{_kde4_bindir}/expoblending
|
||||
%{_kde4_bindir}/panoramagui
|
||||
%ifarch x86_64
|
||||
%{_kde4_bindir}/scangui
|
||||
%{_kde4_datadir}/gpssync/*.png
|
||||
%endif
|
||||
#%{_kde4_datadir}/gpssync/*.png
|
||||
%dir %{_kde4_datadir}/kipi
|
||||
%{_kde4_datadir}/kipi/tips
|
||||
%{_kde4_datadir}/kipi/kipiplugin_*.rc
|
||||
@ -446,7 +448,9 @@ done
|
||||
%{_kde4_xdgappsdir}/kipiplugins.desktop
|
||||
%{_kde4_xdgappsdir}/expoblending.desktop
|
||||
%{_kde4_xdgappsdir}/panoramagui.desktop
|
||||
%ifarch x86_64
|
||||
%{_kde4_xdgappsdir}/scangui.desktop
|
||||
%endif
|
||||
%{_kde4_servicesdir}/kipiplugin_*.desktop
|
||||
%doc %lang(en) %{_kde4_htmldir}/en/kipi-plugins
|
||||
%doc %lang(en) %{_kde4_htmldir}/en/showfoto
|
||||
@ -459,6 +463,9 @@ done
|
||||
%{_kde4_libdir}/libkipiplugins.so.*
|
||||
|
||||
%changelog
|
||||
* Sat Dec 26 2015 Automatic Build System <autodist@mambasoft.it> 4.14.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Aug 15 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 4.12.0-2mamba
|
||||
- don't provide again libkipi translations conflicting with kde-i18n
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user