depot_tools/depot_tools.spec

72 lines
2.8 KiB
RPMSpec

Name: depot_tools
Version: svn20101127
Release: 3mamba
Summary: A package of scripts called used to manage checkouts and code reviews
Group: Development/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://www.chromium.org/developers/how-tos/depottools/
# svn co http://src.chromium.org/svn/trunk/tools/depot_tools
# mv depot_tools/ depot_tools-svn20101127
# tar cjvf ../SOURCES/depot_tools-svn20101127.tar.bz2
Source: http://src.chromium.org/depot_tools-%{version}.tar.bz2
License: BSD
Requires: python
%description
Chromium uses a package of scripts, the depot_tools, to manage interaction with the Chromium source code repository and the Chromium development process. It contains the following utilities:
gclient: Meta-checkout tool managing both subversion and git checkouts. It is similar to repo tool except that it works on linux, mac and windows and supports both svn and git. On the other hand, gclient doesn't integrate any code review functionality.
gcl: Rietveld code review tool for subversion. The gcl tool runs presubmit scripts.
git-cl: Rietveld code review tool for git. The git-cl tool runs presubmit scripts.
hammer: (Obsolete) Wrapper script for building Chromium with the SCons software construction tool.
drover: Quickly revert svn commits.
presubmit_support.py: Runs PRESUBMIT.py presubmit checks.
repo: The repo tool.
trychange.py: Try server tool. It is wrapped by gcl try and git-try.
git-try: Try change tool for git users
wtf: Displays the active git branches in a chromium os checkout.
weekly: Displays the log of checkins for a particular developer since a particular date for git checkouts.
git-gs: Wrapper for git grep with relevant source types.
zsh-goodies: Completion for zsh users.
%prep
%setup -q
find . -type d -name .svn -exec rm -rf {} \; || true
# python 2.4 components
rm -rf third_party/pymox
rm -rf cpplint.py
%build
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
install -d -m0755 %{buildroot}%{_datadir}/%{name}
cp -a * %{buildroot}%{_datadir}/%{name}
install -d -m0755 %{buildroot}%{_bindir}
cat > %{buildroot}%{_bindir}/gclient << _EOF
#!/bin/sh
%{_datadir}/%{name}/gclient \$@
_EOF
chmod +x %{buildroot}%{_bindir}/gclient
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/gclient
%dir %{_datadir}/depot_tools
%{_datadir}/depot_tools/*
%doc LICENSE README README.gclient
%changelog
* Sat Sep 03 2022 Automatic Build System <autodist@mambasoft.it> svn20101127-3mamba
- automatic rebuild by autodist
* Sat Sep 03 2022 Automatic Build System <autodist@mambasoft.it> svn20101127-2mamba
- automatic rebuild by autodist
* Sat Nov 27 2010 Silvan Calarco <silvan.calarco@mambasoft.it> svn20101127-1mamba
- package created by autospec