update to 2.6.42+20241104git.a324f8c6 [release 2.6.42+20241104git.a324f8c6-1mamba;Sun Nov 17 2024]
This commit is contained in:
parent
4b2cc7fe12
commit
fcfb9c1362
33
denemo-2.6.42+20241104git.a324f8c6-evince-46.3.1.patch
Normal file
33
denemo-2.6.42+20241104git.a324f8c6-evince-46.3.1.patch
Normal file
@ -0,0 +1,33 @@
|
||||
--- denemo-2.6.42+20241104git.a324f8c6/src/source/proof.c.orig 2024-11-17 11:53:44.081783775 +0100
|
||||
+++ denemo-2.6.42+20241104git.a324f8c6/src/source/proof.c 2024-11-17 11:56:20.681094390 +0100
|
||||
@@ -274,13 +274,14 @@
|
||||
press (EvView * view, GdkEventButton *event, EvDocumentModel *model)
|
||||
{
|
||||
EvDocument *doc = ev_document_model_get_document (model);
|
||||
+ EvDocumentAnnotations *document_annots = EV_DOCUMENT_ANNOTATIONS(doc);
|
||||
|
||||
gint i = ev_document_model_get_page (model);
|
||||
if (event->button != 1)
|
||||
infodialog (help_text);
|
||||
nearest_annotation_text = NULL;
|
||||
extern EvMappingList * ev_document_annotations_get_annotations();
|
||||
- EvMappingList *mapping_list = ev_document_annotations_get_annotations (doc, ev_document_get_page(doc, i));
|
||||
+ EvMappingList *mapping_list = ev_document_annotations_get_annotations (document_annots, ev_document_get_page(doc, i));
|
||||
if(mapping_list)
|
||||
{
|
||||
gdouble nearest = G_MAXDOUBLE;
|
||||
@@ -308,12 +309,13 @@
|
||||
find_annotated_pages (EvDocumentModel *model)
|
||||
{
|
||||
EvDocument *doc = ev_document_model_get_document (model);
|
||||
+ EvDocumentAnnotations *document_annots = EV_DOCUMENT_ANNOTATIONS(doc);
|
||||
|
||||
gint i;
|
||||
for (i=0; i< ev_document_get_n_pages(doc);i++)
|
||||
{
|
||||
extern EvMappingList * ev_document_annotations_get_annotations();
|
||||
- EvMappingList *mapping_list = ev_document_annotations_get_annotations (doc, ev_document_get_page(doc, i));
|
||||
+ EvMappingList *mapping_list = ev_document_annotations_get_annotations (document_annots, ev_document_get_page(doc, i));
|
||||
if(mapping_list)
|
||||
{
|
||||
annotated_pages = g_list_append (annotated_pages, GINT_TO_POINTER(i));
|
25
denemo.spec
25
denemo.spec
@ -1,15 +1,15 @@
|
||||
%define gittag %(echo %version | cut -d. -f4)
|
||||
%define gittag %(echo %version | cut -d+ -f2 | cut -d. -f2)
|
||||
Name: denemo
|
||||
Version: 2.6.20.20230309git.e8378c1
|
||||
Version: 2.6.42+20241104git.a324f8c6
|
||||
Release: 1mamba
|
||||
Summary: A music notation program that helps you quickly prepare notation for publishing with Lilypond
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.denemo.org
|
||||
Source: https://git.savannah.gnu.org/git/denemo.git/master@%{gitver}/denemo-%{version}.tar.bz2
|
||||
#Source: http://ftp.gnu.org/gnu/denemo/denemo-%{version}.tar.gz
|
||||
URL: https://denemo.org/
|
||||
Source: https://git.savannah.gnu.org/git/denemo.git/master@%{gittag}/denemo-%{version}.tar.bz2
|
||||
Patch0: denemo-2.6.42+20241104git.a324f8c6-evince-46.3.1.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: evince-devel
|
||||
@ -17,7 +17,6 @@ BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libat-spi2-core-devel
|
||||
BuildRequires: libaubio-devel
|
||||
BuildRequires: libblkid-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libfftw-devel
|
||||
@ -27,16 +26,12 @@ BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgc-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgmp-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk3-devel
|
||||
BuildRequires: libgtksourceview3-devel
|
||||
BuildRequires: libguile-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: libmount-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libportaudio-devel
|
||||
BuildRequires: libportmidi-devel
|
||||
BuildRequires: librsvg-devel
|
||||
@ -45,11 +40,10 @@ BuildRequires: libselinux-devel
|
||||
BuildRequires: libsepol-devel
|
||||
BuildRequires: libsmf-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libunistring-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libportmidi-devel >= 1:2.0.4-1mamba
|
||||
BuildRequires: librubberband-devel
|
||||
Requires: lilypond
|
||||
Provides: denemo-devel
|
||||
@ -62,6 +56,7 @@ Denemo is a music notation program for Linux that helps you quickly prepare nota
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch 0 -p1
|
||||
./autogen.sh
|
||||
|
||||
%build
|
||||
@ -79,7 +74,6 @@ Denemo is a music notation program for Linux that helps you quickly prepare nota
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
#%config %{_sysconfdir}/denemo/denemo.conf
|
||||
%{_bindir}/annotator
|
||||
%{_bindir}/pageswitcher
|
||||
%{_bindir}/pageturner
|
||||
@ -87,8 +81,8 @@ Denemo is a music notation program for Linux that helps you quickly prepare nota
|
||||
%{_bindir}/cairo_svg2path
|
||||
%{_bindir}/denemo
|
||||
%{_bindir}/denemo_file_update
|
||||
%{_datadir}/appdata/org.denemo.Denemo.appdata.xml
|
||||
%{_datadir}/applications/org.denemo.Denemo.desktop
|
||||
%{_metainfodir}/org.denemo.Denemo.metainfo.xml
|
||||
%dir %{_datadir}/denemo
|
||||
%dir %{_datadir}/denemo/actions
|
||||
%{_datadir}/denemo/actions/*
|
||||
@ -113,6 +107,9 @@ Denemo is a music notation program for Linux that helps you quickly prepare nota
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%changelog
|
||||
* Sun Nov 17 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.42+20241104git.a324f8c6-1mamba
|
||||
- update to 2.6.42+20241104git.a324f8c6
|
||||
|
||||
* Fri Mar 10 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.20.20230309git.e8378c1-1mamba
|
||||
- update to 2.6.20.20230309git.e8378c1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user