200 lines
6.5 KiB
RPMSpec
200 lines
6.5 KiB
RPMSpec
%define fontdir %{_datadir}/fonts/truetype/ttf-dejavu
|
|
# default path for openjdk
|
|
%define lgcfontdir %{_datadir}/fonts/dejavu-lgc
|
|
%define Blocks %{_datadir}/unicode/ucd/Blocks.txt
|
|
%define UnicodeData %{_datadir}/unicode/ucd/UnicodeData.txt
|
|
Name: dejavu-fonts-ttf
|
|
Version: 2.37
|
|
Release: 1mamba
|
|
Summary: A font family based on the Bitstream Vera Fonts with a wider range of characters
|
|
Group: System/Fonts
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://sourceforge.net/projects/dejavu/
|
|
Source: http://downloads.sourceforge.net/project/dejavu/dejavu/%{version}/dejavu-fonts-%{version}.tar.bz2
|
|
License: GPL
|
|
Provides: dejavu-fonts = %{?epoch:%epoch:}%{version}-%{release}
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
#BuildArch: noarch
|
|
BuildRequires: fontforge
|
|
BuildRequires: mkfontdir
|
|
BuildRequires: mkfontscale
|
|
BuildRequires: perl(Font::TTF)
|
|
BuildRequires: unicode-ucd
|
|
Requires: dejavu-fonts-common = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
A font family based on the Bitstream Vera Fonts with a wider range of characters.
|
|
|
|
%package -n dejavu-fonts-common
|
|
Group: System/Fonts
|
|
Summary: Common files for the Dejavu font set
|
|
|
|
%description -n dejavu-fonts-common
|
|
The DejaVu fonts are a font family based on the Bitstream Vera Fonts (http://gnome.org/fonts/). Its purpose is to provide a wider range of characters (see status.txt for more information) while maintaining the original look and feel.
|
|
This package consists of files used by other DejaVu packages.
|
|
|
|
%package -n dejavu-lgc-fonts-ttf
|
|
Group: System/Fonts
|
|
Summary: Variable-width serif font faces, Latin-Greek-Cyrillic subset
|
|
Provides: dejavu-lgc-fonts = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: dejavu-fonts-common = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n dejavu-lgc-fonts-ttf
|
|
The DejaVu fonts are a font family based on the Bitstream Vera Fonts (http://gnome.org/fonts/). Its purpose is to provide a wider range of characters (see status.txt for more information) while maintaining the original look and feel.
|
|
DejaVu fonts are based on Bitstream Vera fonts version 1.10.
|
|
|
|
Available fonts (Sans = sans serif, Mono = monospaced):
|
|
|
|
DejaVu Sans Mono
|
|
DejaVu Sans Mono Bold
|
|
DejaVu Sans Mono Bold Oblique
|
|
DejaVu Sans Mono Oblique
|
|
DejaVu Sans
|
|
DejaVu Sans Bold
|
|
DejaVu Sans Bold Oblique
|
|
DejaVu Sans Oblique
|
|
DejaVu Sans ExtraLight (experimental)
|
|
DejaVu Serif
|
|
DejaVu Serif Bold
|
|
DejaVu Serif Bold Italic (experimental)
|
|
DejaVu Serif Italic (experimental)
|
|
DejaVu Sans Condensed (experimental)
|
|
DejaVu Sans Condensed Bold (experimental)
|
|
DejaVu Sans Condensed Bold Oblique (experimental)
|
|
DejaVu Sans Condensed Oblique (experimental)
|
|
DejaVu Serif Condensed (experimental)
|
|
DejaVu Serif Condensed Bold (experimental)
|
|
DejaVu Serif Condensed Bold Italic (experimental)
|
|
DejaVu Serif Condensed Italic (experimental)
|
|
|
|
All fonts are also available as derivative called DejaVu LGC with support only for Latin, Greek and Cyrillic scripts.
|
|
|
|
%prep
|
|
%setup -q -n dejavu-fonts-%{version}
|
|
|
|
%build
|
|
%make VERSION=%{version} FC-LANG="" BLOCKS=%{Blocks} UNICODEDATA=%{UnicodeData}
|
|
|
|
bzip2 -9 build/status.txt
|
|
|
|
%check
|
|
make check
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
install -d %{buildroot}%{fontdir} %{buildroot}%{_sysconfdir}/fonts/{conf.d,conf.avail}
|
|
install -d %{buildroot}%{lgcfontdir}
|
|
mkdir dejavulgc
|
|
mv build/DejaVuLGC*.ttf dejavulgc
|
|
install -m0644 dejavulgc/*.ttf %{buildroot}%{lgcfontdir}
|
|
install -m0644 build/*.ttf %{buildroot}%{fontdir}
|
|
install -m0644 fontconfig/*.conf %{buildroot}%{_sysconfdir}/fonts/conf.avail
|
|
pushd %{buildroot}%{_sysconfdir}/fonts/conf.avail
|
|
for f in *.conf; do
|
|
ln -s ../conf.avail/$f ../conf.d/$f
|
|
done
|
|
popd
|
|
|
|
mkfontdir %{buildroot}%{fontdir}
|
|
mkfontscale %{buildroot}%{fontdir}
|
|
|
|
mkfontdir %{buildroot}%{lgcfontdir}
|
|
mkfontscale %{buildroot}%{lgcfontdir}
|
|
|
|
%post
|
|
if [ -x %{_bindir}/fc-cache ]; then
|
|
%{_bindir}/fc-cache %{_datadir}/fonts
|
|
fi
|
|
:
|
|
|
|
%postun
|
|
if [ "$1" = "0" ]; then
|
|
if [ -x %{_bindir}/fc-cache ]; then
|
|
%{_bindir}/fc-cache %{_datadir}/fonts
|
|
fi
|
|
fi
|
|
:
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/fonts/conf.avail/*-dejavu-sans.conf
|
|
%{_sysconfdir}/fonts/conf.avail/*-dejavu-sans-mono.conf
|
|
%{_sysconfdir}/fonts/conf.avail/*-dejavu-serif.conf
|
|
%{_sysconfdir}/fonts/conf.d/*-dejavu-sans.conf
|
|
%{_sysconfdir}/fonts/conf.d/*-dejavu-sans-mono.conf
|
|
%{_sysconfdir}/fonts/conf.d/*-dejavu-serif.conf
|
|
%{fontdir}/*.ttf
|
|
%verify(not md5 size mtime) %{fontdir}/fonts.dir
|
|
%verify(not md5 size mtime) %{fontdir}/fonts.scale
|
|
|
|
|
|
%post -n dejavu-lgc-fonts-ttf
|
|
if [ -x %{_bindir}/fc-cache ]; then
|
|
%{_bindir}/fc-cache %{_datadir}/fonts
|
|
fi
|
|
:
|
|
|
|
%postun -n dejavu-lgc-fonts-ttf
|
|
if [ "$1" = "0" ]; then
|
|
if [ -x %{_bindir}/fc-cache ]; then
|
|
%{_bindir}/fc-cache %{_datadir}/fonts
|
|
fi
|
|
fi
|
|
:
|
|
|
|
%files -n dejavu-lgc-fonts-ttf
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/fonts/conf.avail/*-lgc-*.conf
|
|
%{_sysconfdir}/fonts/conf.d/*-lgc-*.conf
|
|
%{lgcfontdir}/*.ttf
|
|
%verify(not md5 size mtime) %{lgcfontdir}/fonts.dir
|
|
%verify(not md5 size mtime) %{lgcfontdir}/fonts.scale
|
|
|
|
%files -n dejavu-fonts-common
|
|
%defattr(-,root,root)
|
|
%doc AUTHORS LICENSE
|
|
%doc build/unicover.txt build/status.txt.bz2
|
|
|
|
%changelog
|
|
* Fri Feb 05 2021 Automatic Build System <autodist@mambasoft.it> 2.37-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 05 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.33-3mamba
|
|
- rebuilt using UCD database from unicode-ucd package
|
|
|
|
* Sun Mar 06 2011 gil <puntogil@libero.it> 2.33-2mamba
|
|
- update to 2.33
|
|
- rebuilt for devel java from source archive
|
|
|
|
* Sat Mar 05 2011 Automatic Build System <autodist@mambasoft.it> 2.33-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Dec 28 2010 gil <puntogil@libero.it> 2.32-3mamba
|
|
- edit spec file
|
|
- rebuilt with perl-Font-TTF and fontforge support
|
|
- add check section
|
|
- add new sub packages: dejavu-fonts-common, dejavu-lgc-fonts-ttf
|
|
|
|
* Fri Nov 05 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32-2mamba
|
|
- change install path to %{_datadir}/fonts/truetype/ttf-dejavu
|
|
|
|
* Sat Aug 28 2010 Automatic Build System <autodist@mambasoft.it> 2.32-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon May 31 2010 Automatic Build System <autodist@mambasoft.it> 2.31-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Aug 28 2009 Automatic Build System <autodist@mambasoft.it> 2.30-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Jul 03 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.29-1mamba
|
|
- package created by autospec
|