automatic version update by autodist [release 1.2.28-1mamba;Tue May 21 2013]

This commit is contained in:
Automatic Build System 2024-01-05 21:42:37 +01:00
parent b170cfdac0
commit d439bd56ce
3 changed files with 257 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# debiandoc-sgml # debiandoc-sgml
This is an SGML-based documentation formatting package used for the Debian manuals. It reads markup files and produces HTML, LaTeX, DVI (via LaTeX), PostScript (via LaTeX/DVI), PDF (via LaTeX), Texinfo, Info (via Texinfo), DebianDoc SGML, DocBook XML, plain text (with overstrikes a la troff as well as without) files. . The LaTeX based output needs the libpaperg, tetex-bin and tetex-extra packages. In addition to this, Chinese and Japanese need cjk-latex and corresponding font packages while Korean needs hlatex and corresponding font packages. The Texinfo based output needs the texinfo package. . Homepage: http://alioth.debian.org/projects/debiandoc-sgml/

View File

@ -0,0 +1,140 @@
--- debiandoc-sgml-1.1.101/Makefile 2006-03-12 09:43:27.000000000 +0100
+++ debiandoc-sgml-1.1.101/Makefile-gil 2008-10-03 10:48:59.000000000 +0200
@@ -4,7 +4,7 @@
## ----------------------------------------------------------------------
## General directory definitions
-prefix := /usr/local
+prefix := /usr
bin_dir := $(prefix)/bin
share_dir := $(prefix)/share
ifeq ($(prefix),/usr/local)
@@ -16,10 +16,11 @@
perl_version := 5.8.2
perl_dir := $(share_dir)/perl/$(perl_version)
else
-perl_dir := $(share_dir)/perl5
+perl_dir := /usr/lib/perl5
endif
sgml_dir := $(share_dir)/sgml
+DESTDIR := /var/tmp/debiandoc-sgml-root
## ----------------------------------------------------------------------
## Manual pages directory definitions
man1 := 1
@@ -67,7 +68,7 @@
## General (un)install definitions
SHELL := bash
INSTALL := /usr/bin/install
-INSTALL_DIR := $(INSTALL) -d -m 755
+INSTALL_DIR := mkdir -p
INSTALL_SCRIPT := $(INSTALL) -p -m 755
INSTALL_FILE := $(INSTALL) -p -m 644
LN := /bin/ln -sf
@@ -92,83 +93,84 @@
install: all
set -e; \
- $(INSTALL_DIR) $(pkg_dtd_dir); \
+
+ $(INSTALL_DIR) $(DESTDIR)$(pkg_dtd_dir); \
for f in $(DTDS); \
do \
- $(INSTALL_FILE) sgml/dtd/$$f $(pkg_dtd_dir); \
+ $(INSTALL_FILE) sgml/dtd/$$f $(DESTDIR)$(pkg_dtd_dir); \
done
set -e; \
- $(INSTALL_DIR) $(pkg_ent_dir); \
+ $(INSTALL_DIR) $(DESTDIR)$(pkg_ent_dir); \
for f in $(ENTITIES); \
do \
- $(INSTALL_FILE) sgml/entities/$$f $(pkg_ent_dir); \
+ $(INSTALL_FILE) sgml/entities/$$f $(DESTDIR)$(pkg_ent_dir); \
done
set -e; \
- $(INSTALL_DIR) $(pkg_format_dir); \
+ $(INSTALL_DIR) $(DESTDIR)$(pkg_format_dir); \
for f in `ls tools/lib/Format/*.pm`; \
do \
- $(INSTALL_FILE) $$f $(pkg_format_dir); \
+ $(INSTALL_FILE) $$f $(DESTDIR)$(pkg_format_dir); \
done
set -e; \
- $(INSTALL_DIR) $(pkg_locale_dir); \
+ $(INSTALL_DIR) $(DESTDIR)$(pkg_locale_dir); \
for f in `ls tools/lib/Locale/*.pm`; \
do \
- $(INSTALL_FILE) $$f $(pkg_locale_dir); \
+ $(INSTALL_FILE) $$f $(DESTDIR)$(pkg_locale_dir); \
done
for d in `ls -d tools/lib/Locale/*_*`; \
do \
- $(INSTALL_DIR) $(pkg_locale_dir)/`basename $$d`; \
+ $(INSTALL_DIR) $(DESTDIR)$(pkg_locale_dir)/`basename $$d`; \
for f in $(FORMATS); \
do \
- $(INSTALL_FILE) $$d/$$f $(pkg_locale_dir)/`basename $$d`; \
+ $(INSTALL_FILE) $$d/$$f $(DESTDIR)$(pkg_locale_dir)/`basename $$d`; \
done; \
done
for d in `ls -d tools/lib/Locale/*_*`; \
do \
- $(INSTALL_DIR) $(pkg_locale_dir)/`basename $$d`; \
+ $(INSTALL_DIR) $(DESTDIR)$(pkg_locale_dir)/`basename $$d`; \
for f in $(XFORMATS); \
do \
- $(INSTALL_FILE) tools/lib/Locale/$$f $(pkg_locale_dir)/`basename $$d`; \
+ $(INSTALL_FILE) tools/lib/Locale/$$f $(DESTDIR)$(pkg_locale_dir)/`basename $$d`; \
done; \
done
set -e; \
- $(INSTALL_DIR) $(pkg_map_dir); \
+ $(INSTALL_DIR) $(DESTDIR)$(pkg_map_dir); \
for f in `ls tools/lib/Map/*.pm`; \
do \
- $(INSTALL_FILE) $$f $(pkg_map_dir); \
+ $(INSTALL_FILE) $$f $(DESTDIR)$(pkg_map_dir); \
done
set -e; \
- $(INSTALL_DIR) $(pkg_bin_dir); \
+ $(INSTALL_DIR) $(DESTDIR)$(pkg_bin_dir); \
for f in $(HELPERS); \
do \
- $(INSTALL_SCRIPT) tools/bin/$$f $(pkg_bin_dir); \
+ $(INSTALL_SCRIPT) tools/bin/$$f $(DESTDIR)$(pkg_bin_dir); \
done
set -e; \
- $(INSTALL_DIR) $(bin_dir); \
+ $(INSTALL_DIR) $(DESTDIR)$(bin_dir); \
for f in $(BCONVS); \
do \
- $(INSTALL_SCRIPT) tools/bin/$$f $(bin_dir); \
+ $(INSTALL_SCRIPT) tools/bin/$$f $(DESTDIR)$(bin_dir); \
done
for f in $(PSPECS); \
do \
- $(LN) $(dtd_name)2latex$$f $(bin_dir)/$(dtd_name)2$$f; \
+ $(LN) $(dtd_name)2latex$$f $(DESTDIR)$(bin_dir)/$(dtd_name)2$$f; \
done
set -e; \
- $(INSTALL_DIR) $(man1_dir); \
+ $(INSTALL_DIR) $(DESTDIR)$(man1_dir); \
for f in $(MAN1S); \
do \
- $(INSTALL_FILE) tools/man/$$f.$(man1) $(man1_dir)/$$f.$(man1); \
+ $(INSTALL_FILE) tools/man/$$f.$(man1) $(DESTDIR)$(man1_dir)/$$f.$(man1); \
done; \
for f in $(TOOLS); \
do \
- $(LN) $(firstword $(MAN1S)).$(man1) $(man1_dir)/$$f.$(man1); \
+ $(LN) $(firstword $(MAN1S)).$(man1) $(DESTDIR)$(man1_dir)/$$f.$(man1); \
done
uninstall:

115
debiandoc-sgml.spec Normal file
View File

@ -0,0 +1,115 @@
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
Name: debiandoc-sgml
Version: 1.2.28
Release: 1mamba
Summary: SGML DTD and formatting tools
Group: Applications/Publishing
Vendor: openmamba
Distribution: openmamba
Packager: Automatic Build System <autodist@mambasoft.it>
URL: http://packages.debian.org/etch/debiandoc-sgml
Source: http://ftp.de.debian.org/debian/pool/main/d/debiandoc-sgml/debiandoc-sgml_%{version}.orig.tar.gz
Patch: debiandoc-sgml-1.1.101-Makefile.patch
License: GPL
Requires: perl-HTML-Parser
Requires: perl-Roman
Requires: perl-SGMLSpm
Requires: perl-Text-Format
Requires: perl-URI
## AUTOBUILDREQ-BEGIN
BuildRequires: perl-devel
BuildRequires: perl-HTML-Parser
BuildRequires: perl-Roman
BuildRequires: perl-SGMLSpm
BuildRequires: perl-Text-Format
BuildRequires: perl-URI
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
This is an SGML-based documentation formatting package used for the Debian manuals. It reads markup files and produces HTML, LaTeX, DVI (via LaTeX), PostScript (via LaTeX/DVI), PDF (via LaTeX), Texinfo, Info (via Texinfo), DebianDoc SGML, DocBook XML, plain text (with overstrikes a la troff as well as without) files. . The LaTeX based output needs the libpaperg, tetex-bin and tetex-extra packages. In addition to this, Chinese and Japanese need cjk-latex and corresponding font packages while Korean needs hlatex and corresponding font packages. The Texinfo based output needs the texinfo package. . Homepage: http://alioth.debian.org/projects/debiandoc-sgml/
%prep
%setup -q
#%patch -p1
%build
%make prefix=%{_prefix} perl_dir=%{_libdir}/perl5/%{perl_major_ver}/
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall prefix=%{_prefix} perl_dir=%{buildroot}%{_libdir}/perl5/
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/debiandoc2dbk
%{_bindir}/debiandoc2dvi
%{_bindir}/debiandoc2html
%{_bindir}/debiandoc2info
%{_bindir}/debiandoc2latex
%{_bindir}/debiandoc2latexdvi
%{_bindir}/debiandoc2latexpdf
%{_bindir}/debiandoc2latexps
%{_bindir}/debiandoc2pdf
%{_bindir}/debiandoc2ps
#%{_bindir}/debiandoc2sgml
%{_bindir}/debiandoc2texinfo
%{_bindir}/debiandoc2text
%{_bindir}/debiandoc2textov
%{_bindir}/debiandoc2wiki
#%{_bindir}/debiandoc2xml
%dir %{_libdir}/perl5/DebianDoc_SGML/Format
%{_libdir}/perl5/DebianDoc_SGML/Format/*.pm
%dir %{_libdir}/perl5/DebianDoc_SGML/Locale
%{_libdir}/perl5/DebianDoc_SGML/Locale/*
%dir %{_libdir}/perl5/DebianDoc_SGML/Map
%{_libdir}/perl5/DebianDoc_SGML/Map/*.pm
%dir %{_datadir}/debiandoc-sgml
%{_datadir}/debiandoc-sgml/fixlatex
%{_datadir}/debiandoc-sgml/saspconvert
%dir %{_datadir}/sgml/debiandoc/dtd/sgml/1.0
%{_datadir}/sgml/debiandoc/dtd/sgml/1.0/catalog
%{_datadir}/sgml/debiandoc/dtd/sgml/1.0/debiandoc.dcl
%{_datadir}/sgml/debiandoc/dtd/sgml/1.0/debiandoc.dtd
%dir %{_datadir}/sgml/debiandoc/entities
%{_datadir}/sgml/debiandoc/entities/catalog
%{_datadir}/sgml/debiandoc/entities/debiandoc-lat1
%{_datadir}/sgml/debiandoc/entities/debiandoc-lat2
%{_mandir}/man1/debiandoc2*.1.gz
%{_mandir}/man1/debiandoc-sgml.1.gz
%doc COPYING README
%changelog
* Tue May 21 2013 Automatic Build System <autodist@mambasoft.it> 1.2.28-1mamba
- automatic version update by autodist
* Sat Aug 11 2012 Automatic Build System <autodist@mambasoft.it> 1.2.27-1mamba
- automatic version update by autodist
* Thu Apr 26 2012 Automatic Build System <autodist@mambasoft.it> 1.2.26-1mamba
- automatic version update by autodist
* Mon Jun 27 2011 Automatic Build System <autodist@mambasoft.it> 1.2.25-1mamba
- automatic update by autodist
* Fri Jun 25 2010 Automatic Build System <autodist@mambasoft.it> 1.2.15-1mamba
- automatic update by autodist
* Mon Jan 25 2010 Automatic Build System <autodist@mambasoft.it> 1.2.13-1mamba
- automatic update by autodist
* Thu Oct 15 2009 Automatic Build System <autodist@mambasoft.it> 1.2.12-1mamba
- automatic update by autodist
* Sat Sep 05 2009 Automatic Build System <autodist@mambasoft.it> 1.2.10-1mamba
- automatic update by autodist
* Thu Feb 05 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.9-1mamba
- automatic update by autodist
* Fri Oct 03 2008 gil <puntogil@libero.it> 1.1.101-1mamba
- package created by autospec