automatic version update by autodist [release 3.4.1-1mamba;Thu Aug 15 2024]
This commit is contained in:
parent
bb2860454e
commit
04d5fc9485
@ -1,27 +0,0 @@
|
|||||||
# --- T2-COPYRIGHT-NOTE-BEGIN ---
|
|
||||||
# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
|
|
||||||
#
|
|
||||||
# T2 SDE: package/.../ddd/gcc44.patch
|
|
||||||
# Copyright (C) 2010 The T2 SDE Project
|
|
||||||
#
|
|
||||||
# More information can be found in the files COPYING and README.
|
|
||||||
#
|
|
||||||
# This patch file is dual-licensed. It is available under the license the
|
|
||||||
# patched project is licensed under, as long as it is an OpenSource license
|
|
||||||
# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
|
|
||||||
# of the GNU General Public License as published by the Free Software
|
|
||||||
# Foundation; either version 2 of the License, or (at your option) any later
|
|
||||||
# version.
|
|
||||||
# --- T2-COPYRIGHT-NOTE-END ---
|
|
||||||
|
|
||||||
diff -Nur ddd-3.3.12-orig/ddd/strclass.C ddd-3.3.12/ddd/strclass.C
|
|
||||||
--- ddd-3.3.12-orig/ddd/strclass.C 2010-05-11 11:41:11.404406436 +0000
|
|
||||||
+++ ddd-3.3.12/ddd/strclass.C 2010-05-11 11:42:01.802908366 +0000
|
|
||||||
@@ -38,6 +38,7 @@
|
|
||||||
#include <ctype.h>
|
|
||||||
#include <limits.h>
|
|
||||||
#include <new>
|
|
||||||
+#include <cstdio>
|
|
||||||
#include <stdlib.h>
|
|
||||||
|
|
||||||
void string::error(const char* msg) const
|
|
34
ddd.spec
34
ddd.spec
@ -1,5 +1,5 @@
|
|||||||
Name: ddd
|
Name: ddd
|
||||||
Version: 3.4.0
|
Version: 3.4.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A graphical front-end for command-line debuggers
|
Summary: A graphical front-end for command-line debuggers
|
||||||
Group: Graphical Desktop/Applications/Development
|
Group: Graphical Desktop/Applications/Development
|
||||||
@ -9,7 +9,6 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: http://www.gnu.org/software/ddd/
|
URL: http://www.gnu.org/software/ddd/
|
||||||
Source: http://ftp.gnu.org/gnu/ddd/ddd-%{version}.tar.gz
|
Source: http://ftp.gnu.org/gnu/ddd/ddd-%{version}.tar.gz
|
||||||
Source1: ddd.desktop
|
Source1: ddd.desktop
|
||||||
Patch0: ddd-3.3.12-gcc-4.4.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -18,21 +17,17 @@ BuildRequires: libSM-devel
|
|||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXaw-devel
|
BuildRequires: libXaw-devel
|
||||||
BuildRequires: libXext-devel
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libXft-devel
|
||||||
BuildRequires: libXmu-devel
|
BuildRequires: libXmu-devel
|
||||||
BuildRequires: libXp-devel
|
BuildRequires: libXp-devel
|
||||||
BuildRequires: libXpm-devel
|
BuildRequires: libXpm-devel
|
||||||
BuildRequires: libXt-devel
|
BuildRequires: libXt-devel
|
||||||
BuildRequires: libbrotli-devel
|
|
||||||
BuildRequires: libbzip2-devel
|
|
||||||
BuildRequires: libelf-devel
|
BuildRequires: libelf-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libglib-devel
|
|
||||||
BuildRequires: libgraphite2-devel
|
|
||||||
BuildRequires: liblesstif-devel
|
BuildRequires: liblesstif-devel
|
||||||
BuildRequires: libncurses-devel
|
BuildRequires: libncurses-devel
|
||||||
BuildRequires: libpcre-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libz-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
Requires(post):%{__install_info}
|
Requires(post):%{__install_info}
|
||||||
|
|
||||||
@ -44,7 +39,6 @@ Besides ``usual'' front-end features such as viewing source texts, DDD has becom
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch 0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -64,13 +58,13 @@ rm -f %{buildroot}%{_datadir}/%{name}-%{version}/COPYING \
|
|||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%post
|
#% post
|
||||||
%install_info %{name}.info
|
#% install_info %{name}.info
|
||||||
%install_info %{name}-themes.info
|
#% install_info %{name}-themes.info
|
||||||
|
|
||||||
%preun
|
#% preun
|
||||||
%install_info %{name}.info
|
#% install_info %{name}.info
|
||||||
%install_info %{name}-themes.info
|
#% install_info %{name}-themes.info
|
||||||
:
|
:
|
||||||
|
|
||||||
%files
|
%files
|
||||||
@ -78,13 +72,15 @@ rm -f %{buildroot}%{_datadir}/%{name}-%{version}/COPYING \
|
|||||||
%{_bindir}/%{name}
|
%{_bindir}/%{name}
|
||||||
%{_datadir}/%{name}-%{version}
|
%{_datadir}/%{name}-%{version}
|
||||||
%{_datadir}/applications/%{name}.desktop
|
%{_datadir}/applications/%{name}.desktop
|
||||||
%{_infodir}/%{name}.info*
|
#%{_infodir}/%{name}.info*
|
||||||
%{_infodir}/%{name}-themes.info*
|
#%{_infodir}/%{name}-themes.info*
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
%doc AUTHORS COPYING COPYING.DOC CREDITS
|
%doc doc/AUTHORS doc/COPYING* doc/CREDITS
|
||||||
#NEWS README TODO
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 15 2024 Automatic Build System <autodist@openmamba.org> 3.4.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri Sep 01 2023 Automatic Build System <autodist@mambasoft.it> 3.4.0-1mamba
|
* Fri Sep 01 2023 Automatic Build System <autodist@mambasoft.it> 3.4.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user