update to 1.15.12
fix requirements for pre and post scripts, other specfile fixes [release 1.15.12-1mamba;Thu Dec 05 2024]
This commit is contained in:
parent
becbd6b0a4
commit
5cdd8f8804
@ -1,28 +0,0 @@
|
||||
--- dbus-1.6.8.orig/bus/messagebus.in 2011-07-13 22:42:21.000000000 +0200
|
||||
+++ dbus-1.6.8/bus/messagebus.in 2013-03-29 14:19:22.268683800 +0100
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
-# messagebus: The D-BUS systemwide message bus
|
||||
+# dbus: The D-BUS systemwide message bus
|
||||
#
|
||||
# chkconfig: 345 22 85
|
||||
# description: This is a daemon which broadcasts notifications of system events \
|
||||
@@ -10,7 +10,7 @@
|
||||
# pidfile: @DBUS_SYSTEM_PID_FILE@
|
||||
#
|
||||
### BEGIN INIT INFO
|
||||
-# Provides: messagebus
|
||||
+# Provides: dbus
|
||||
# Required-Start: $syslog $local_fs
|
||||
# Required-Stop: $syslog $local_fs
|
||||
# Default-Start: 2 3 4 5
|
||||
@@ -28,7 +28,7 @@
|
||||
|
||||
# so we can rearrange this easily
|
||||
processname=dbus-daemon
|
||||
-servicename=messagebus
|
||||
+servicename=dbus
|
||||
|
||||
RETVAL=0
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -Nru dbus-1.8.12.orig/bus/dbus.service.in dbus-1.8.12/bus/dbus.service.in
|
||||
--- dbus-1.8.12.orig/bus/dbus.service.in 2014-11-04 15:51:05.000000000 +0100
|
||||
+++ dbus-1.8.12/bus/dbus.service.in 2014-12-04 12:20:18.198000000 +0100
|
||||
@@ -2,6 +2,7 @@
|
||||
Description=D-Bus System Message Bus
|
||||
Documentation=man:dbus-daemon(1)
|
||||
Requires=dbus.socket
|
||||
+Before=basic.target
|
||||
|
||||
[Service]
|
||||
ExecStart=@EXPANDED_BINDIR@/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
|
@ -1,78 +0,0 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# messagebus: The D-BUS systemwide message bus
|
||||
#
|
||||
# chkconfig: 345 15 80
|
||||
# description: This is a daemon which broadcasts notifications of system events \
|
||||
# and other messages. See http://www.freedesktop.org/software/dbus/
|
||||
#
|
||||
# processname: dbus-daemon
|
||||
# pidfile: /var/run/dbus/pid
|
||||
#
|
||||
|
||||
# Sanity checks.
|
||||
[ -x /usr/bin/dbus-daemon ] || exit 0
|
||||
|
||||
# Source function library.
|
||||
. /etc/rc.d/init.d/functions
|
||||
|
||||
# so we can rearrange this easily
|
||||
processname=dbus-daemon
|
||||
servicename=messagebus
|
||||
|
||||
RETVAL=0
|
||||
|
||||
start() {
|
||||
echo -n $"Starting system message bus: "
|
||||
daemon --check $servicename $processname --system
|
||||
RETVAL=$?
|
||||
echo
|
||||
[ $RETVAL -eq 0 ] && touch /var/lock/subsys/$servicename
|
||||
}
|
||||
|
||||
stop() {
|
||||
echo -n $"Stopping system message bus: "
|
||||
|
||||
## we don't want to kill all the per-user $processname, we want
|
||||
## to use the pid file *only*; because we use the fake nonexistent
|
||||
## program name "$servicename" that should be safe-ish
|
||||
killproc -p /var/run/messagebus.pid $servicename -TERM
|
||||
RETVAL=$?
|
||||
echo
|
||||
if [ $RETVAL -eq 0 ]; then
|
||||
rm -f /var/lock/subsys/$servicename
|
||||
rm -f /var/run/messagebus.pid
|
||||
fi
|
||||
}
|
||||
|
||||
# See how we were called.
|
||||
case "$1" in
|
||||
start)
|
||||
start
|
||||
;;
|
||||
stop)
|
||||
stop
|
||||
;;
|
||||
status)
|
||||
status $processname
|
||||
RETVAL=$?
|
||||
;;
|
||||
restart)
|
||||
stop
|
||||
start
|
||||
;;
|
||||
condrestart)
|
||||
if [ -f /var/lock/subsys/$servicename ]; then
|
||||
stop
|
||||
start
|
||||
fi
|
||||
;;
|
||||
reload)
|
||||
echo "Message bus can't reload its configuration, you have to restart it"
|
||||
RETVAL=$?
|
||||
;;
|
||||
*)
|
||||
echo $"Usage: $0 {start|stop|status|restart|condrestart|reload}"
|
||||
;;
|
||||
esac
|
||||
exit $RETVAL
|
@ -1,11 +0,0 @@
|
||||
dbus_session_file=~/.dbus/session-bus/$(cat /var/lib/dbus/machine-id)-0
|
||||
if [ -e "$dbus_session_file" ]; then
|
||||
. "$dbus_session_file"
|
||||
if [ "$DBUS_SESSION_BUS_PID" -a -e /proc/$DBUS_SESSION_BUS_PID -a \
|
||||
"`readlink /proc/$DBUS_SESSION_BUS_PID/exe`" = "/usr/bin/dbus-daemon" ]; then
|
||||
export DBUS_SESSION_BUS_ADDRESS DBUS_SESSION_BUS_PID DBUS_SESSION_BUS_WINDOWID
|
||||
else
|
||||
unset DBUS_SESSION_BUS_ADDRESS DBUS_SESSION_BUS_PID DBUS_SESSION_BUS_WINDOWID
|
||||
fi
|
||||
fi
|
||||
unset dbus_session_file
|
52
dbus.spec
52
dbus.spec
@ -2,7 +2,7 @@
|
||||
%define messagebus_gid 25
|
||||
|
||||
Name: dbus
|
||||
Version: 1.15.8
|
||||
Version: 1.15.12
|
||||
Release: 1mamba
|
||||
Summary: A message bus, used for sending messages between applications
|
||||
Group: System/Servers
|
||||
@ -11,55 +11,37 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.freedesktop.org/wiki/Software/dbus/
|
||||
Source: http://dbus.freedesktop.org/releases/dbus/%{name}-%{version}.tar.xz
|
||||
Source1: dbus-initscript
|
||||
Source2: %{name}-session-profile.sh
|
||||
Patch0: %{name}-1.0.1-cve_2006_6107.patch
|
||||
Patch1: dbus-1.6.8-initscript-rename.patch
|
||||
Patch2: dbus-1.8.12-systemd-fix-shutdown-hangs.patch
|
||||
Patch0: dbus-1.0.1-cve_2006_6107.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
%endif
|
||||
BuildRequires: libapparmor-devel
|
||||
BuildRequires: libaudit-devel
|
||||
BuildRequires: libcap-ng-devel
|
||||
BuildRequires: libdw-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: systemd-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
## AUTOBUILDREQ-END
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
%endif
|
||||
BuildRequires: pkgconfig >= 0.19
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libxml2-utils
|
||||
BuildRequires: libglib-devel
|
||||
%if "%{_build}" == "%{_host}"
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: xmlto
|
||||
%endif
|
||||
Requires(pre): /usr/sbin/useradd
|
||||
Requires(pre): /sbin/chkconfig
|
||||
Requires(pre): filesystem >= 2.2-19mamba
|
||||
Requires(pre): shadow
|
||||
Requires(pre): systemd
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: user(messagebus)
|
||||
Provides: group(messagebus)
|
||||
Provides: dbus-tools
|
||||
Obsoletes: dbus-tools < 1.14.0
|
||||
## *AUTOSPEC-OFF*
|
||||
Obsoletes: dbus-viewer < 1.14.0
|
||||
Obsoletes: dbus1-viewer < 1.14.0
|
||||
Obsoletes: dbus1 < 1.14.0
|
||||
## *AUTOSPEC-ON*
|
||||
|
||||
%description
|
||||
D-BUS is a message bus, used for sending messages between applications.
|
||||
@ -88,15 +70,13 @@ Group: Development/Libraries
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Obsoletes: dbus-devel < 1.14.0
|
||||
Provides: dbus-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
## *AUTOSPEC-OFF*
|
||||
Obsoletes: dbus1-devel < 1.14.0
|
||||
Provides: dbus1-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
## *AUTOSPEC-ON*
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
D-BUS is a message bus, used for sending messages between applications.
|
||||
Conceptually, it fits somewhere in between raw sockets and CORBA in terms of complexity.
|
||||
This package contains static libraries and header files need for development.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%package apidocs
|
||||
Group: Documentation
|
||||
@ -112,7 +92,6 @@ This package includes the %{name} API documentation.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch 0 -p1 -b .cve_2006_6107
|
||||
#%patch2 -p1
|
||||
|
||||
%build
|
||||
%meson \
|
||||
@ -155,8 +134,6 @@ fi
|
||||
%post
|
||||
%systemd_post %{name}
|
||||
if [ $1 -ge 1 ]; then
|
||||
/sbin/ldconfig
|
||||
[ $1 -eq 1 ] && systemctl -q start dbus
|
||||
%{_bindir}/dbus-uuidgen --ensure
|
||||
fi
|
||||
:
|
||||
@ -174,14 +151,6 @@ fi
|
||||
%systemd_postun %{name}
|
||||
:
|
||||
|
||||
%posttrans
|
||||
# clean old sysv broken links
|
||||
find /etc/rc[0-6].d/ -type l -xtype l -exec rm -f {} \;
|
||||
:
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%dir %{_sysconfdir}/dbus-1
|
||||
@ -215,7 +184,6 @@ find /etc/rc[0-6].d/ -type l -xtype l -exec rm -f {} \;
|
||||
%dir %{_datadir}/xml/dbus-1
|
||||
%{_datadir}/xml/dbus-1/*.dtd
|
||||
%{_datadir}/xml/dbus-1/catalog.xml
|
||||
#%dir %{_var}/run/dbus
|
||||
%dir %{_var}/lib/dbus
|
||||
%{_mandir}/man1/dbus-cleanup-sockets.*
|
||||
%{_mandir}/man1/dbus-daemon.*
|
||||
@ -250,6 +218,10 @@ find /etc/rc[0-6].d/ -type l -xtype l -exec rm -f {} \;
|
||||
%{_docdir}/dbus/*
|
||||
|
||||
%changelog
|
||||
* Thu Dec 05 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.15.12-1mamba
|
||||
- update to 1.15.12
|
||||
- fix requirements for pre and post scripts, other specfile fixes
|
||||
|
||||
* Tue Feb 20 2024 Automatic Build System <autodist@openmamba.org> 1.15.8-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user