package created by autospec

fixed bug 580609 [release 0.9.2-1mamba;Mon Nov 29 2010]
This commit is contained in:
Stefano Cotta Ramusino 2024-01-05 21:37:14 +01:00
parent 85c952b834
commit 7e8d565bac
3 changed files with 61 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# curlftpfs
CurlFtpFS is a filesystem for accessing FTP hosts based on FUSE and libcurl.

View File

@ -0,0 +1,10 @@
--- ftpfs.c.orig 2008-04-30 01:05:47.000000000 +0200
+++ ftpfs.c 2010-05-21 13:01:42.569006163 +0200
@@ -503,7 +503,6 @@ static void *ftpfs_write_thread(void *da
curl_easy_setopt_or_die(fh->write_conn, CURLOPT_URL, fh->full_path);
curl_easy_setopt_or_die(fh->write_conn, CURLOPT_UPLOAD, 1);
- curl_easy_setopt_or_die(fh->write_conn, CURLOPT_INFILESIZE, -1);
curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READFUNCTION, write_data_bg);
curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READDATA, fh);
curl_easy_setopt_or_die(fh->write_conn, CURLOPT_LOW_SPEED_LIMIT, 1);

49
curlftpfs.spec Normal file
View File

@ -0,0 +1,49 @@
Name: curlftpfs
Version: 0.9.2
Release: 1mamba
Summary: A FTP filesystem based on cURL and FUSE
Group: Applications/Networking
Vendor: openmamba
Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
URL: http://curlftpfs.sourceforge.net/
Source: http://downloads.sourceforge.net/project/curlftpfs/curlftpfs/%{version}/curlftpfs-%{version}.tar.gz
Patch: curlftpfs-0.9.2-file_upload.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libcurl-devel
BuildRequires: libfuse-devel
BuildRequires: libglib-devel
## AUTOBUILDREQ-END
Requires: fuse
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
CurlFtpFS is a filesystem for accessing FTP hosts based on FUSE and libcurl.
%prep
%setup -q
%patch
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/curlftpfs
%{_mandir}/man1/curlftpfs.1.gz
%doc COPYING ChangeLog README
%changelog
* Mon Nov 29 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.9.2-1mamba
- package created by autospec
- fixed bug 580609