automatic version update by autodist [release 8.10.0-1mamba;Mon Sep 16 2024]
This commit is contained in:
parent
0279a3e734
commit
65100aa976
@ -1,26 +0,0 @@
|
||||
https://github.com/curl/curl/commit/3eec5afbd0b6377eca893c392569b2faf094d970
|
||||
From: Daniel Stenberg <daniel@haxx.se>
|
||||
Date: Mon, 5 Aug 2024 00:17:17 +0200
|
||||
Subject: [PATCH] sigpipe: init the struct so that first apply ignores
|
||||
|
||||
Initializes 'no_signal' to TRUE, so that a call to sigpipe_apply() after
|
||||
init ignores the signal (unless CURLOPT_NOSIGNAL) is set.
|
||||
|
||||
I have read the existing code multiple times now and I think it gets the
|
||||
initial state reversed this missing to ignore.
|
||||
|
||||
Regression from 17e6f06ea37136c36d27
|
||||
|
||||
Reported-by: Rasmus Thomsen
|
||||
Fixes #14344
|
||||
Closes #14390
|
||||
--- a/lib/sigpipe.h
|
||||
+++ b/lib/sigpipe.h
|
||||
@@ -39,6 +39,7 @@ struct sigpipe_ignore {
|
||||
static void sigpipe_init(struct sigpipe_ignore *ig)
|
||||
{
|
||||
memset(ig, 0, sizeof(*ig));
|
||||
+ ig->no_signal = TRUE;
|
||||
}
|
||||
|
||||
/*
|
21
curl.spec
21
curl.spec
@ -1,8 +1,8 @@
|
||||
%define libname libcurl
|
||||
|
||||
Name: curl
|
||||
Version: 8.9.1
|
||||
Release: 2mamba
|
||||
Version: 8.10.0
|
||||
Release: 1mamba
|
||||
Summary: A tool for transfering data with URL syntax that supports many protocols
|
||||
Group: Applications/Networking
|
||||
Vendor: openmamba
|
||||
@ -10,7 +10,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://curl.se/
|
||||
Source: http://curl.haxx.se/download/curl-%{version}.tar.bz2
|
||||
Patch0: curl-8.9.1-sigpipe.patch
|
||||
License: MIT
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -39,14 +38,6 @@ BuildRequires: perl
|
||||
Provides: curl-gnutls
|
||||
Obsoletes: curl-gnutls < 7.82.0
|
||||
|
||||
# FIXME, not compiled in:
|
||||
# krb4 support: no (--with-krb4*)
|
||||
# SPNEGO support: no (--with-spnego)
|
||||
|
||||
# LDAPS support: no (--enable-ldaps)
|
||||
# SSPI support: no (--enable-sspi)
|
||||
# ca cert path: no
|
||||
|
||||
%description
|
||||
Curl is a tool for transfering data with URL syntax, supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP.
|
||||
This tool offer a myriad of powerful features and full protocol control.
|
||||
@ -92,7 +83,6 @@ This package contains static libraries and header files needed for development.
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch 0 -p1 -b .sigpipe
|
||||
|
||||
mkdir gnutls
|
||||
cd gnutls
|
||||
@ -183,8 +173,6 @@ cd gnutls/lib/
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n %{libname} -p /sbin/ldconfig
|
||||
%postun -n %{libname} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
@ -215,9 +203,12 @@ cd gnutls/lib/
|
||||
%{_mandir}/man3/*
|
||||
%doc docs/FAQ
|
||||
%doc docs/KNOWN_BUGS docs/THANKS docs/TODO
|
||||
%doc CHANGES README RELEASE-NOTES
|
||||
%doc README RELEASE-NOTES
|
||||
|
||||
%changelog
|
||||
* Mon Sep 16 2024 Automatic Build System <autodist@openmamba.org> 8.10.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Aug 05 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 8.9.1-2mamba
|
||||
- apply patch resolving a sigpipe issue reported with transmission
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user