automatic version update by autodist [release 7.36.0-1mamba;Wed Mar 26 2014]
This commit is contained in:
parent
d723b1de97
commit
3d8ba120a9
@ -1,2 +1,5 @@
|
|||||||
# curl
|
# curl
|
||||||
|
|
||||||
|
Curl is a tool for transfering data with URL syntax, supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP.
|
||||||
|
This tool offer a myriad of powerful features and full protocol control.
|
||||||
|
|
||||||
|
67
curl-7.21.2-gnutls.patch
Normal file
67
curl-7.21.2-gnutls.patch
Normal file
@ -0,0 +1,67 @@
|
|||||||
|
diff -Nru gnutls/docs/examples/Makefile.am gnutls-gil/docs/examples/Makefile.am
|
||||||
|
--- gnutls/docs/examples/Makefile.am 2010-09-18 23:00:20.000000000 +0200
|
||||||
|
+++ gnutls-gil/docs/examples/Makefile.am 2010-10-17 15:23:48.000000000 +0200
|
||||||
|
@@ -29,7 +29,7 @@
|
||||||
|
CPPFLAGS = -DCURL_NO_OLDIES $(STATICCPPFLAGS)
|
||||||
|
|
||||||
|
# Dependencies
|
||||||
|
-LDADD = $(LIBDIR)/libcurl.la
|
||||||
|
+LDADD = $(LIBDIR)/libcurl-gnutls.la
|
||||||
|
|
||||||
|
# Makefile.inc provides the check_PROGRAMS and COMPLICATED_EXAMPLES defines
|
||||||
|
include Makefile.inc
|
||||||
|
diff -Nru gnutls/lib/Makefile.am gnutls-gil/lib/Makefile.am
|
||||||
|
--- gnutls/lib/Makefile.am 2010-09-18 23:00:21.000000000 +0200
|
||||||
|
+++ gnutls-gil/lib/Makefile.am 2010-10-17 15:24:59.000000000 +0200
|
||||||
|
@@ -42,7 +42,7 @@
|
||||||
|
|
||||||
|
CLEANFILES = $(DSP) $(VCPROJ)
|
||||||
|
|
||||||
|
-lib_LTLIBRARIES = libcurl.la
|
||||||
|
+lib_LTLIBRARIES = libcurl-gnutls.la
|
||||||
|
LIBCURL_LIBS = @LIBCURL_LIBS@
|
||||||
|
|
||||||
|
# This might hold -Werror
|
||||||
|
@@ -116,12 +116,12 @@
|
||||||
|
MIMPURE = -mimpure-text
|
||||||
|
endif
|
||||||
|
|
||||||
|
-libcurl_la_LDFLAGS = $(UNDEF) $(VERSIONINFO) $(MIMPURE) $(LIBCURL_LIBS)
|
||||||
|
+libcurl_gnutls_la_LDFLAGS = $(UNDEF) $(VERSIONINFO) $(MIMPURE) $(LIBCURL_LIBS)
|
||||||
|
|
||||||
|
# Makefile.inc provides the CSOURCES and HHEADERS defines
|
||||||
|
include Makefile.inc
|
||||||
|
|
||||||
|
-libcurl_la_SOURCES = $(CSOURCES) $(HHEADERS)
|
||||||
|
+libcurl_gnutls_la_SOURCES = $(CSOURCES) $(HHEADERS)
|
||||||
|
|
||||||
|
WIN32SOURCES = $(CSOURCES)
|
||||||
|
WIN32HEADERS = $(HHEADERS) config-win32.h
|
||||||
|
diff -Nru gnutls/src/Makefile.am gnutls-gil/src/Makefile.am
|
||||||
|
--- gnutls/src/Makefile.am 2010-09-18 23:00:22.000000000 +0200
|
||||||
|
+++ gnutls-gil/src/Makefile.am 2010-10-17 15:25:38.000000000 +0200
|
||||||
|
@@ -49,8 +49,8 @@
|
||||||
|
# This might hold -Werror
|
||||||
|
CFLAGS += @CURL_CFLAG_EXTRAS@
|
||||||
|
|
||||||
|
-curl_LDADD = $(top_builddir)/lib/libcurl.la @CURL_LIBS@
|
||||||
|
-curl_DEPENDENCIES = $(top_builddir)/lib/libcurl.la
|
||||||
|
+curl_LDADD = $(top_builddir)/lib/libcurl-gnutls.la @CURL_LIBS@
|
||||||
|
+curl_DEPENDENCIES = $(top_builddir)/lib/libcurl-gnutls.la
|
||||||
|
BUILT_SOURCES = hugehelp.c
|
||||||
|
CLEANFILES = hugehelp.c
|
||||||
|
# Use the C locale to ensure that only ASCII characters appear in the
|
||||||
|
diff -Nru gnutls/tests/libtest/Makefile.am gnutls-gil/tests/libtest/Makefile.am
|
||||||
|
--- gnutls/tests/libtest/Makefile.am 2010-09-18 23:00:22.000000000 +0200
|
||||||
|
+++ gnutls-gil/tests/libtest/Makefile.am 2010-10-17 15:26:35.000000000 +0200
|
||||||
|
@@ -54,8 +54,8 @@
|
||||||
|
test1022.pl Makefile.inc
|
||||||
|
|
||||||
|
# Dependencies (may need to be overriden)
|
||||||
|
-LDADD = $(top_builddir)/lib/libcurl.la @CURL_LIBS@
|
||||||
|
-DEPENDENCIES = $(top_builddir)/lib/libcurl.la
|
||||||
|
+LDADD = $(top_builddir)/lib/libcurl-gnutls.la @CURL_LIBS@
|
||||||
|
+DEPENDENCIES = $(top_builddir)/lib/libcurl-gnutls.la
|
||||||
|
|
||||||
|
# Makefile.inc provides the source defines (TESTUTIL, SUPPORTFILES,
|
||||||
|
# noinst_PROGRAMS, lib*_SOURCES, and lib*_CFLAGS)
|
11
curl-7.34.0-dns-resolver-prefer-ipv4.patch
Normal file
11
curl-7.34.0-dns-resolver-prefer-ipv4.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- curl-7.34.0/lib/asyn-ares.c 2013-12-16 23:02:35.000000000 +0100
|
||||||
|
+++ curl-7.34.0.patched/lib/asyn-ares.c 2013-12-25 21:32:07.973208137 +0100
|
||||||
|
@@ -518,7 +518,7 @@
|
||||||
|
|
||||||
|
switch(conn->ip_version) {
|
||||||
|
default:
|
||||||
|
-#if ARES_VERSION >= 0x010601
|
||||||
|
+#if 0
|
||||||
|
family = PF_UNSPEC; /* supported by c-ares since 1.6.1, so for older
|
||||||
|
c-ares versions this just falls through and defaults
|
||||||
|
to PF_INET */
|
349
curl.spec
Normal file
349
curl.spec
Normal file
@ -0,0 +1,349 @@
|
|||||||
|
%define libname libcurl
|
||||||
|
|
||||||
|
Name: curl
|
||||||
|
Version: 7.36.0
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A tool for transfering data with URL syntax that supports many protocols
|
||||||
|
Group: Applications/Networking
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||||
|
URL: http://curl.haxx.se
|
||||||
|
Source: http://curl.haxx.se/download/curl-%{version}.tar.bz2
|
||||||
|
Patch0: %{name}-7.21.2-gnutls.patch
|
||||||
|
Patch1: curl-7.34.0-dns-resolver-prefer-ipv4.patch
|
||||||
|
License: MIT
|
||||||
|
BuildRequires: bash
|
||||||
|
BuildRequires: ldconfig
|
||||||
|
BuildRequires: libgssapi-devel
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libcares-devel
|
||||||
|
BuildRequires: libe2fs-devel
|
||||||
|
BuildRequires: libgcrypt-devel
|
||||||
|
BuildRequires: libgnutls-devel
|
||||||
|
BuildRequires: libgpg-error-devel
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
BuildRequires: libidn-devel
|
||||||
|
BuildRequires: libopenldap-devel
|
||||||
|
BuildRequires: libsasl-devel
|
||||||
|
BuildRequires: libkrb5-devel
|
||||||
|
%endif
|
||||||
|
BuildRequires: libopenssl-devel
|
||||||
|
BuildRequires: libssh2-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: pkgconfig
|
||||||
|
BuildRequires: libopenssl-devel
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
BuildRequires: groff
|
||||||
|
%endif
|
||||||
|
BuildRequires: perl
|
||||||
|
Provides: curl-gnutls
|
||||||
|
Obsoletes: curl-gnutls
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
# FIXME, not compiled in:
|
||||||
|
# krb4 support: no (--with-krb4*)
|
||||||
|
# SPNEGO support: no (--with-spnego)
|
||||||
|
|
||||||
|
# LDAPS support: no (--enable-ldaps)
|
||||||
|
# SSPI support: no (--enable-sspi)
|
||||||
|
# ca cert path: no
|
||||||
|
|
||||||
|
%description
|
||||||
|
Curl is a tool for transfering data with URL syntax, supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP.
|
||||||
|
This tool offer a myriad of powerful features and full protocol control.
|
||||||
|
|
||||||
|
%package -n %{libname}
|
||||||
|
Summary: Dynamic Libraries for cURL
|
||||||
|
Group: System/Libraries
|
||||||
|
Provides: %{libname}-gnutls
|
||||||
|
Obsoletes: %{libname}-gnutls
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
Requires: ca-certificates
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description -n %{libname}
|
||||||
|
Libcurl is a library for transfering data with URL syntax, supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP.
|
||||||
|
This library offer a myriad of powerful features and full protocol control.
|
||||||
|
|
||||||
|
%package -n %{libname}-devel
|
||||||
|
Summary: Static libraries and header for %{libname}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Provides: %{libname}-gnutls-devel
|
||||||
|
Obsoletes: %{libname}-gnutls-devel
|
||||||
|
|
||||||
|
%description -n %{libname}-devel
|
||||||
|
Curl is a tool and libcurl is a library for transfering data with URL syntax, supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP.
|
||||||
|
The tool and library offer a myriad of powerful features and full protocol control.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure \
|
||||||
|
--enable-shared \
|
||||||
|
--enable-static \
|
||||||
|
--enable-cookies \
|
||||||
|
--enable-crypto-auth \
|
||||||
|
--enable-http \
|
||||||
|
--enable-ftp \
|
||||||
|
--enable-file \
|
||||||
|
--enable-dict \
|
||||||
|
--enable-telnet \
|
||||||
|
--enable-tftp \
|
||||||
|
--enable-ipv6 \
|
||||||
|
--with-ssl \
|
||||||
|
--with-gnutls \
|
||||||
|
--with-zlib \
|
||||||
|
--with-random \
|
||||||
|
--with-nss \
|
||||||
|
--enable-verbose \
|
||||||
|
--disable-sspi \
|
||||||
|
--with-libssh2 \
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
--with-gssapi \
|
||||||
|
--enable-ldap \
|
||||||
|
--with-libidn \
|
||||||
|
--enable-manual \
|
||||||
|
--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
|
||||||
|
%else
|
||||||
|
--without-krb5 \
|
||||||
|
%endif
|
||||||
|
--enable-ares
|
||||||
|
|
||||||
|
# --enable-hidden-symbols
|
||||||
|
# --with-spnego
|
||||||
|
|
||||||
|
%make \
|
||||||
|
%if "%{_host}" != "%{_build}"
|
||||||
|
CFLAGS="-lcares -lssh2"
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
# install development documentation
|
||||||
|
install -d curls_develpck_docs
|
||||||
|
install -m644 \
|
||||||
|
CHANGES COPYING README RELEASE-NOTES \
|
||||||
|
docs/BUGS docs/FAQ docs/FEATURES docs/HISTORY docs/KNOWN_BUGS \
|
||||||
|
docs/MANUAL docs/SSLCERTS docs/THANKS docs/TODO \
|
||||||
|
curls_develpck_docs/
|
||||||
|
|
||||||
|
install -d curls_develpck_docs/{libcurl,examples}
|
||||||
|
#install -m644 docs/libcurl/libcurl.m4 curls_develpck_docs/libcurl/libcurl.m4
|
||||||
|
install -m644 docs/examples/{Makefile.example,README,*.c} \
|
||||||
|
curls_develpck_docs/examples/
|
||||||
|
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -n %{libname} -p /sbin/ldconfig
|
||||||
|
%postun -n %{libname} -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/curl
|
||||||
|
%{_mandir}/man1/curl.*
|
||||||
|
|
||||||
|
%files -n %{libname}
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libcurl.so.*
|
||||||
|
%doc COPYING
|
||||||
|
|
||||||
|
%files -n %{libname}-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/curl-config
|
||||||
|
%{_includedir}/curl/
|
||||||
|
%{_libdir}/libcurl.a
|
||||||
|
%{_libdir}/libcurl.la
|
||||||
|
%{_libdir}/libcurl.so
|
||||||
|
%{_libdir}/pkgconfig/libcurl.pc
|
||||||
|
%{_datadir}/aclocal/libcurl.m4
|
||||||
|
%{_mandir}/man1/curl-config.1*
|
||||||
|
#%{_mandir}/man1/mk-ca-bundle.1*
|
||||||
|
%{_mandir}/man3/*
|
||||||
|
%doc curls_develpck_docs/*
|
||||||
|
%doc docs/BUGS docs/FAQ docs/FEATURES docs/HISTORY
|
||||||
|
%doc docs/KNOWN_BUGS docs/MANUAL docs/SSLCERTS docs/THANKS docs/TODO
|
||||||
|
%doc CHANGES README RELEASE-NOTES
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Mar 26 2014 Automatic Build System <autodist@mambasoft.it> 7.36.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Jan 29 2014 Automatic Build System <autodist@mambasoft.it> 7.35.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Dec 25 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 7.34.0-2mamba
|
||||||
|
- repatched to prefer ipv4 address resolution
|
||||||
|
|
||||||
|
* Wed Dec 18 2013 Automatic Build System <autodist@mambasoft.it> 7.34.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Oct 15 2013 Automatic Build System <autodist@mambasoft.it> 7.33.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Aug 12 2013 Automatic Build System <autodist@mambasoft.it> 7.32.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Jun 22 2013 Automatic Build System <autodist@mambasoft.it> 7.31.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Apr 12 2013 Automatic Build System <autodist@mambasoft.it> 7.30.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Feb 06 2013 Automatic Build System <autodist@mambasoft.it> 7.29.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Nov 20 2012 Automatic Build System <autodist@mambasoft.it> 7.28.1-1mamba
|
||||||
|
- update to 7.28.1
|
||||||
|
|
||||||
|
* Thu Oct 11 2012 Automatic Build System <autodist@mambasoft.it> 7.28.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Jul 28 2012 Automatic Build System <autodist@mambasoft.it> 7.27.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Jun 06 2012 Automatic Build System <autodist@mambasoft.it> 7.26.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Mar 23 2012 Automatic Build System <autodist@mambasoft.it> 7.25.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Jan 26 2012 Automatic Build System <autodist@mambasoft.it> 7.24.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Nov 18 2011 Automatic Build System <autodist@mambasoft.it> 7.23.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Nov 16 2011 Automatic Build System <autodist@mambasoft.it> 7.23.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Sep 14 2011 Automatic Build System <autodist@mambasoft.it> 7.22.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Jun 23 2011 Automatic Build System <autodist@mambasoft.it> 7.21.7-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sun Apr 24 2011 Davide Madrisan <davide.madrisan@gmail.com> 7.21.6-1mamba
|
||||||
|
- update to 7.21.6
|
||||||
|
|
||||||
|
* Mon Apr 18 2011 Automatic Build System <autodist@mambasoft.it> 7.21.5-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat Mar 05 2011 Automatic Build System <autodist@mambasoft.it> 7.21.4-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Oct 14 2010 Davide Madrisan <davide.madrisan@gmail.com> 7.21.2-1mamba
|
||||||
|
- update to 7.21.2
|
||||||
|
|
||||||
|
* Wed Jun 16 2010 Automatic Build System <autodist@mambasoft.it> 7.21.0-1mamba
|
||||||
|
- automatic update to 7.21.0 by autodist
|
||||||
|
|
||||||
|
* Fri May 28 2010 Automatic Build System <autodist@mambasoft.it> 7.20.1-1mamba
|
||||||
|
- automatic update to 7.20.1 by autodist
|
||||||
|
|
||||||
|
* Tue Feb 09 2010 Automatic Build System <autodist@mambasoft.it> 7.20.0-1mamba
|
||||||
|
- automatic update to 7.20.0 by autodist
|
||||||
|
|
||||||
|
* Wed Nov 04 2009 Automatic Build System <autodist@mambasoft.it> 7.19.7-1mamba
|
||||||
|
- automatic update to 7.19.7 by autodist
|
||||||
|
|
||||||
|
* Thu Aug 13 2009 Automatic Build System <autodist@mambasoft.it> 7.19.6-1mamba
|
||||||
|
- automatic update to 7.19.6 by autodist
|
||||||
|
|
||||||
|
* Mon May 18 2009 Automatic Build System <autodist@mambasoft.it> 7.19.5-1mamba
|
||||||
|
- automatic update to 7.19.5 by autodist
|
||||||
|
|
||||||
|
* Tue Mar 03 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 7.19.4-1mamba
|
||||||
|
- automatic update to 7.19.4 by autodist
|
||||||
|
|
||||||
|
* Wed Jan 21 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 7.19.3-1mamba
|
||||||
|
- automatic update to 7.19.3 by autodist
|
||||||
|
|
||||||
|
* Fri Nov 14 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 7.19.2-1mamba
|
||||||
|
- automatic update to 7.19.2 by autodist
|
||||||
|
|
||||||
|
* Wed Nov 12 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 7.19.1-1mamba
|
||||||
|
- automatic update to 7.19.1 by autodist
|
||||||
|
|
||||||
|
* Tue Oct 14 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 7.19.0-2mamba
|
||||||
|
- enabled static library build as required by pycurl
|
||||||
|
- added a patch that enables ipv4 search by default insted of ipv6; use -6 to force ipv6 lookups
|
||||||
|
|
||||||
|
* Sun Oct 12 2008 gil <puntogil@libero.it> 7.19.0-1mamba
|
||||||
|
- update to 7.19.0
|
||||||
|
|
||||||
|
* Fri Aug 29 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 7.18.2-1mamba
|
||||||
|
- update to 7.18.2
|
||||||
|
|
||||||
|
* Thu Jun 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 7.18.1-2mamba
|
||||||
|
- added build of curl-gnutls packages
|
||||||
|
|
||||||
|
* Tue Jun 03 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 7.18.1-1mamba
|
||||||
|
- update to 7.18.1
|
||||||
|
|
||||||
|
* Tue Nov 20 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 7.17.1-1mamba
|
||||||
|
- update to 7.17.1
|
||||||
|
- rebuild with c-ares support (async DNS queries)
|
||||||
|
|
||||||
|
* Sun Oct 14 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 7.17.0-1mamba
|
||||||
|
- update to 7.17.0
|
||||||
|
|
||||||
|
* Thu Jul 12 2007 Aleph0 <aleph0@openmamba.org> 7.16.4-2mamba
|
||||||
|
- add all the available documentation for developers to the devel subpackage
|
||||||
|
|
||||||
|
* Wed Jul 11 2007 Aleph0 <aleph0@openmamba.org> 7.16.4-1mamba
|
||||||
|
- update to 7.16.4
|
||||||
|
|
||||||
|
* Thu Apr 12 2007 Davide Madrisan <davide.madrisan@gmail.com> 7.16.2-2mamba
|
||||||
|
- esnabled LIBSSH2 support
|
||||||
|
|
||||||
|
* Thu Apr 12 2007 Davide Madrisan <davide.madrisan@gmail.com> 7.16.2-1mamba
|
||||||
|
- update to version 7.16.2 by autospec
|
||||||
|
- do not build the static library
|
||||||
|
- enabled GSSAPI support
|
||||||
|
|
||||||
|
* Mon Apr 02 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 7.16.1-1mamba
|
||||||
|
- update to version 7.16.1 by autospec
|
||||||
|
|
||||||
|
* Tue Jun 13 2006 Davide Madrisan <davide.madrisan@qilinux.it> 7.15.4-1qilnx
|
||||||
|
- update to version 7.15.4 by autospec
|
||||||
|
|
||||||
|
* Mon Mar 20 2006 Davide Madrisan <davide.madrisan@qilinux.it> 7.15.3-1qilnx
|
||||||
|
- update to version 7.15.3 by autospec
|
||||||
|
- also fixes the TFTP packet buffer overflow vulnerability
|
||||||
|
|
||||||
|
* Thu Mar 02 2006 Davide Madrisan <davide.madrisan@qilinux.it> 7.15.2-1qilnx
|
||||||
|
- update to version 7.15.2 by autospec
|
||||||
|
|
||||||
|
* Wed Dec 07 2005 Davide Madrisan <davide.madrisan@qilinux.it> 7.15.1-1qilnx
|
||||||
|
- update to version 7.15.1 by autospec
|
||||||
|
|
||||||
|
* Mon Oct 17 2005 Davide Madrisan <davide.madrisan@qilinux.it> 7.15.0-1qilnx
|
||||||
|
- update to version 7.15.0 by autospec
|
||||||
|
- also fixes the security issue QSA-2005-120 (CAN-2005-3185)
|
||||||
|
|
||||||
|
* Sun Oct 02 2005 Davide Madrisan <davide.madrisan@qilinux.it> 7.14.1-2qilnx
|
||||||
|
- new package curl
|
||||||
|
- curl-config manpage moved to devel package
|
||||||
|
- own %{_datadir}/curl and %{_includedir}/curl
|
||||||
|
|
||||||
|
* Wed Sep 07 2005 Davide Madrisan <davide.madrisan@qilinux.it> 7.14.1-1qilnx
|
||||||
|
- update to version 7.14.1 by autospec
|
||||||
|
|
||||||
|
* Mon Mar 07 2005 Davide Madrisan <davide.madrisan@qilinux.it> 7.13.1-1qilnx
|
||||||
|
- update to version 7.13.1 by autospec
|
||||||
|
- also include security fix (CAN-2005-0490)
|
||||||
|
- added missing build requirement: libidn-devel, libkrb5-devel
|
||||||
|
|
||||||
|
* Mon Jul 26 2004 Davide Madrisan <davide.madrisan@qilinux.it> 7.12.0-1qilnx
|
||||||
|
- first build
|
Loading…
Reference in New Issue
Block a user