automatic version update by autodist [release 8.6.0-1mamba;Thu Feb 01 2024]

This commit is contained in:
Automatic Build System 2024-02-01 20:38:03 +01:00
parent 5166577b78
commit 3c31e8b9e2
5 changed files with 5 additions and 150 deletions

View File

@ -1,67 +0,0 @@
diff -Nru gnutls/docs/examples/Makefile.am gnutls-gil/docs/examples/Makefile.am
--- gnutls/docs/examples/Makefile.am 2010-09-18 23:00:20.000000000 +0200
+++ gnutls-gil/docs/examples/Makefile.am 2010-10-17 15:23:48.000000000 +0200
@@ -29,7 +29,7 @@
CPPFLAGS = -DCURL_NO_OLDIES $(STATICCPPFLAGS)
# Dependencies
-LDADD = $(LIBDIR)/libcurl.la
+LDADD = $(LIBDIR)/libcurl-gnutls.la
# Makefile.inc provides the check_PROGRAMS and COMPLICATED_EXAMPLES defines
include Makefile.inc
diff -Nru gnutls/lib/Makefile.am gnutls-gil/lib/Makefile.am
--- gnutls/lib/Makefile.am 2010-09-18 23:00:21.000000000 +0200
+++ gnutls-gil/lib/Makefile.am 2010-10-17 15:24:59.000000000 +0200
@@ -42,7 +42,7 @@
CLEANFILES = $(DSP) $(VCPROJ)
-lib_LTLIBRARIES = libcurl.la
+lib_LTLIBRARIES = libcurl-gnutls.la
LIBCURL_LIBS = @LIBCURL_LIBS@
# This might hold -Werror
@@ -116,12 +116,12 @@
MIMPURE = -mimpure-text
endif
-libcurl_la_LDFLAGS = $(UNDEF) $(VERSIONINFO) $(MIMPURE) $(LIBCURL_LIBS)
+libcurl_gnutls_la_LDFLAGS = $(UNDEF) $(VERSIONINFO) $(MIMPURE) $(LIBCURL_LIBS)
# Makefile.inc provides the CSOURCES and HHEADERS defines
include Makefile.inc
-libcurl_la_SOURCES = $(CSOURCES) $(HHEADERS)
+libcurl_gnutls_la_SOURCES = $(CSOURCES) $(HHEADERS)
WIN32SOURCES = $(CSOURCES)
WIN32HEADERS = $(HHEADERS) config-win32.h
diff -Nru gnutls/src/Makefile.am gnutls-gil/src/Makefile.am
--- gnutls/src/Makefile.am 2010-09-18 23:00:22.000000000 +0200
+++ gnutls-gil/src/Makefile.am 2010-10-17 15:25:38.000000000 +0200
@@ -49,8 +49,8 @@
# This might hold -Werror
CFLAGS += @CURL_CFLAG_EXTRAS@
-curl_LDADD = $(top_builddir)/lib/libcurl.la @CURL_LIBS@
-curl_DEPENDENCIES = $(top_builddir)/lib/libcurl.la
+curl_LDADD = $(top_builddir)/lib/libcurl-gnutls.la @CURL_LIBS@
+curl_DEPENDENCIES = $(top_builddir)/lib/libcurl-gnutls.la
BUILT_SOURCES = hugehelp.c
CLEANFILES = hugehelp.c
# Use the C locale to ensure that only ASCII characters appear in the
diff -Nru gnutls/tests/libtest/Makefile.am gnutls-gil/tests/libtest/Makefile.am
--- gnutls/tests/libtest/Makefile.am 2010-09-18 23:00:22.000000000 +0200
+++ gnutls-gil/tests/libtest/Makefile.am 2010-10-17 15:26:35.000000000 +0200
@@ -54,8 +54,8 @@
test1022.pl Makefile.inc
# Dependencies (may need to be overriden)
-LDADD = $(top_builddir)/lib/libcurl.la @CURL_LIBS@
-DEPENDENCIES = $(top_builddir)/lib/libcurl.la
+LDADD = $(top_builddir)/lib/libcurl-gnutls.la @CURL_LIBS@
+DEPENDENCIES = $(top_builddir)/lib/libcurl-gnutls.la
# Makefile.inc provides the source defines (TESTUTIL, SUPPORTFILES,
# noinst_PROGRAMS, lib*_SOURCES, and lib*_CFLAGS)

View File

@ -1,11 +0,0 @@
--- curl-7.34.0/lib/asyn-ares.c 2013-12-16 23:02:35.000000000 +0100
+++ curl-7.34.0.patched/lib/asyn-ares.c 2013-12-25 21:32:07.973208137 +0100
@@ -518,7 +518,7 @@
switch(conn->ip_version) {
default:
-#if ARES_VERSION >= 0x010601
+#if 0
family = PF_UNSPEC; /* supported by c-ares since 1.6.1, so for older
c-ares versions this just falls through and defaults
to PF_INET */

View File

@ -1,32 +0,0 @@
From 5c0e66d63214e0306197c5a3f162441e074f3401 Mon Sep 17 00:00:00 2001
From: Steve Holme <steve_holme@hotmail.com>
Date: Thu, 8 Jan 2015 19:23:53 +0000
Subject: [PATCH] sasl_gssapi: Fixed build on NetBSD with built-in GSS-API
Bug: http://curl.haxx.se/bug/view.cgi?id=1469
Reported-by: Thomas Klausner
---
lib/curl_sasl_gssapi.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/lib/curl_sasl_gssapi.c b/lib/curl_sasl_gssapi.c
index 6dda0e9..a50646a 100644
--- a/lib/curl_sasl_gssapi.c
+++ b/lib/curl_sasl_gssapi.c
@@ -6,6 +6,7 @@
* \___|\___/|_| \_\_____|
*
* Copyright (C) 2014, Steve Holme, <steve_holme@hotmail.com>.
+ * Copyright (C) 2015, Daniel Stenberg, <daniel@haxx.se>, et al.
*
* This software is licensed as described in the file COPYING, which
* you should have received as part of this distribution. The terms
@@ -126,7 +127,7 @@ CURLcode Curl_sasl_create_gssapi_user_message(struct SessionHandle *data,
/* Import the SPN */
gss_major_status = gss_import_name(&gss_minor_status, &spn_token,
- gss_nt_service_name, &krb5->spn);
+ GSS_C_NT_HOSTBASED_SERVICE, &krb5->spn);
if(GSS_ERROR(gss_major_status)) {
Curl_gss_log_error(data, gss_minor_status, "gss_import_name() failed: ");

View File

@ -1,26 +0,0 @@
From e2e7f54b7bea521fa8373095d0f43261a720cda0 Mon Sep 17 00:00:00 2001
From: Daniel Stenberg <daniel@haxx.se>
Date: Mon, 27 Jun 2022 08:46:21 +0200
Subject: [PATCH] easy_lock.h: include sched.h if available to fix build
Patched-by: Harry Sintonen
Closes #9054
---
lib/easy_lock.h | 3 +++
1 file changed, 3 insertions(+)
diff --git a/lib/easy_lock.h b/lib/easy_lock.h
index 819f50ce815b8..1f54289ceb2d3 100644
--- a/lib/easy_lock.h
+++ b/lib/easy_lock.h
@@ -36,6 +36,9 @@
#elif defined (HAVE_ATOMIC)
#include <stdatomic.h>
+#if defined(HAVE_SCHED_YIELD)
+#include <sched.h>
+#endif
#define curl_simple_lock atomic_bool
#define CURL_SIMPLE_LOCK_INIT false

View File

@ -1,7 +1,7 @@
%define libname libcurl %define libname libcurl
Name: curl Name: curl
Version: 8.5.0 Version: 8.6.0
Release: 1mamba Release: 1mamba
Summary: A tool for transfering data with URL syntax that supports many protocols Summary: A tool for transfering data with URL syntax that supports many protocols
Group: Applications/Networking Group: Applications/Networking
@ -10,10 +10,6 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://curl.se/ URL: https://curl.se/
Source: http://curl.haxx.se/download/curl-%{version}.tar.bz2 Source: http://curl.haxx.se/download/curl-%{version}.tar.bz2
Patch0: %{name}-7.21.2-gnutls.patch
Patch1: curl-7.34.0-dns-resolver-prefer-ipv4.patch
Patch2: curl-7.40.0-libgss-1.0.3.patch
Patch3: curl-7.84.0-upstream-fix-build-include_sched_h.patch
License: MIT License: MIT
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
@ -95,7 +91,6 @@ This package contains static libraries and header files needed for development.
%setup -q %setup -q
#-D -T #-D -T
#:<< _EOF #:<< _EOF
#%patch3 -p1 -b .upstream-fix-build-include_sched_h
mkdir gnutls mkdir gnutls
cd gnutls cd gnutls
@ -132,9 +127,6 @@ cp -r ../* . || true
%endif %endif
--enable-ares --enable-ares
# --enable-hidden-symbols
# --with-spnego
%make \ %make \
%if "%{_host}" != "%{_build}" %if "%{_host}" != "%{_build}"
CFLAGS="-lcares -lssh2" CFLAGS="-lcares -lssh2"
@ -175,8 +167,6 @@ autoreconf -f -i
%endif %endif
--enable-ares --enable-ares
# --with-nss \
cd lib cd lib
%make %make
@ -197,7 +187,6 @@ cd gnutls/lib/
%files %files
%defattr(-,root,root) %defattr(-,root,root)
%{_bindir}/curl %{_bindir}/curl
#%{_datadir}/zsh/site-functions/_curl
%{_mandir}/man1/curl.* %{_mandir}/man1/curl.*
%files -n %{libname} %files -n %{libname}
@ -221,14 +210,16 @@ cd gnutls/lib/
%{_libdir}/pkgconfig/libcurl.pc %{_libdir}/pkgconfig/libcurl.pc
%{_datadir}/aclocal/libcurl.m4 %{_datadir}/aclocal/libcurl.m4
%{_mandir}/man1/curl-config.1* %{_mandir}/man1/curl-config.1*
#%{_mandir}/man1/mk-ca-bundle.1* %{_mandir}/man1/mk-ca-bundle.1*
%{_mandir}/man3/* %{_mandir}/man3/*
#%doc curls_develpck_docs/*
%doc docs/FAQ %doc docs/FAQ
%doc docs/KNOWN_BUGS docs/THANKS docs/TODO %doc docs/KNOWN_BUGS docs/THANKS docs/TODO
%doc CHANGES README RELEASE-NOTES %doc CHANGES README RELEASE-NOTES
%changelog %changelog
* Thu Feb 01 2024 Automatic Build System <autodist@openmamba.org> 8.6.0-1mamba
- automatic version update by autodist
* Thu Dec 07 2023 Automatic Build System <autodist@mambasoft.it> 8.5.0-1mamba * Thu Dec 07 2023 Automatic Build System <autodist@mambasoft.it> 8.5.0-1mamba
- automatic version update by autodist - automatic version update by autodist