update to 6.18.1+20241116git.05aa93e [release 6.18.1+20241116git.05aa93e-1mamba;Sun Nov 17 2024]
This commit is contained in:
parent
712a0a05d2
commit
e4fd7a662c
@ -1,20 +0,0 @@
|
||||
--- Csound5.10.1/install.py.orig 2009-03-31 11:31:45.000000000 +0100
|
||||
+++ Csound5.10.1/install.py 2009-03-31 11:32:01.000000000 +0100
|
||||
@@ -152,7 +152,7 @@
|
||||
fileList += [fileName]
|
||||
fullName = concatPath([instDir, fileName])
|
||||
err = runCmd(['install', '-p', '-m', perm, src, fullName])
|
||||
- if err == 0 and stripMode != '':
|
||||
+ if err == 0 and stripMode == 'packman':
|
||||
err = runCmd(['strip', stripMode, fullName])
|
||||
if err == 0:
|
||||
addMD5(fullName, fileName)
|
||||
@@ -333,7 +333,7 @@
|
||||
for i in xmgList:
|
||||
makeDir(concatPath([xmgDir, i, 'LC_MESSAGES']))
|
||||
src = 'po/' + i + '/LC_MESSAGES/csound5.mo'
|
||||
- fileName = concatPath([xmgDir, i, 'LC_MESSAGES/csound5.mo'])
|
||||
+ fileName = concatPath([instDir, xmgDir, i, 'LC_MESSAGES/csound5.mo'])
|
||||
err = runCmd(['install', '-p', '-m', '0644', src, fileName])
|
||||
if err == 0:
|
||||
addMD5(fileName, fileName)
|
@ -1,67 +0,0 @@
|
||||
diff -Nru Csound5.19.01.orig/frontends/CsoundAC/cmake_install.cmake Csound5.19.01/frontends/CsoundAC/cmake_install.cmake
|
||||
--- Csound5.19.01.orig/frontends/CsoundAC/cmake_install.cmake 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ Csound5.19.01/frontends/CsoundAC/cmake_install.cmake 2013-05-31 06:29:34.000000000 +0200
|
||||
@@ -0,0 +1,63 @@
|
||||
+# Install script for directory: C:/Users/Michael/csound-csound6-git/frontends/CsoundAC
|
||||
+
|
||||
+# Set the install prefix
|
||||
+IF(NOT DEFINED CMAKE_INSTALL_PREFIX)
|
||||
+ SET(CMAKE_INSTALL_PREFIX "C:/Program Files (x86)/Csound")
|
||||
+ENDIF(NOT DEFINED CMAKE_INSTALL_PREFIX)
|
||||
+STRING(REGEX REPLACE "/$" "" CMAKE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}")
|
||||
+
|
||||
+# Set the install configuration name.
|
||||
+IF(NOT DEFINED CMAKE_INSTALL_CONFIG_NAME)
|
||||
+ IF(BUILD_TYPE)
|
||||
+ STRING(REGEX REPLACE "^[^A-Za-z0-9_]+" ""
|
||||
+ CMAKE_INSTALL_CONFIG_NAME "${BUILD_TYPE}")
|
||||
+ ELSE(BUILD_TYPE)
|
||||
+ SET(CMAKE_INSTALL_CONFIG_NAME "RelWithDebInfo")
|
||||
+ ENDIF(BUILD_TYPE)
|
||||
+ MESSAGE(STATUS "Install configuration: \"${CMAKE_INSTALL_CONFIG_NAME}\"")
|
||||
+ENDIF(NOT DEFINED CMAKE_INSTALL_CONFIG_NAME)
|
||||
+
|
||||
+# Set the component getting installed.
|
||||
+IF(NOT CMAKE_INSTALL_COMPONENT)
|
||||
+ IF(COMPONENT)
|
||||
+ MESSAGE(STATUS "Install component: \"${COMPONENT}\"")
|
||||
+ SET(CMAKE_INSTALL_COMPONENT "${COMPONENT}")
|
||||
+ ELSE(COMPONENT)
|
||||
+ SET(CMAKE_INSTALL_COMPONENT)
|
||||
+ ENDIF(COMPONENT)
|
||||
+ENDIF(NOT CMAKE_INSTALL_COMPONENT)
|
||||
+
|
||||
+IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
|
||||
+ FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/lib" TYPE STATIC_LIBRARY OPTIONAL FILES "C:/Users/Michael/csound-csound6-git/libCsoundAC.dll.a")
|
||||
+ IF(EXISTS "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/libCsoundAC.dll.a" AND
|
||||
+ NOT IS_SYMLINK "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/libCsoundAC.dll.a")
|
||||
+ IF(CMAKE_INSTALL_DO_STRIP)
|
||||
+ EXECUTE_PROCESS(COMMAND "C:/mingw32-4.7.2/bin/strip.exe" "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/libCsoundAC.dll.a")
|
||||
+ ENDIF(CMAKE_INSTALL_DO_STRIP)
|
||||
+ ENDIF()
|
||||
+ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
|
||||
+
|
||||
+IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
|
||||
+ FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/lib" TYPE MODULE FILES "C:/Users/Michael/csound-csound6-git/_CsoundAC.pyd")
|
||||
+ IF(EXISTS "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/_CsoundAC.pyd" AND
|
||||
+ NOT IS_SYMLINK "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/_CsoundAC.pyd")
|
||||
+ IF(CMAKE_INSTALL_DO_STRIP)
|
||||
+ EXECUTE_PROCESS(COMMAND "C:/mingw32-4.7.2/bin/strip.exe" "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/_CsoundAC.pyd")
|
||||
+ ENDIF(CMAKE_INSTALL_DO_STRIP)
|
||||
+ ENDIF()
|
||||
+ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
|
||||
+
|
||||
+IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
|
||||
+ FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/lib" TYPE FILE FILES "C:/Users/Michael/csound-csound6-git/CsoundAC.py")
|
||||
+ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
|
||||
+
|
||||
+IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
|
||||
+ FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/lib" TYPE MODULE FILES "C:/Users/Michael/csound-csound6-git/luaCsoundAC.dll")
|
||||
+ IF(EXISTS "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/luaCsoundAC.dll" AND
|
||||
+ NOT IS_SYMLINK "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/luaCsoundAC.dll")
|
||||
+ IF(CMAKE_INSTALL_DO_STRIP)
|
||||
+ EXECUTE_PROCESS(COMMAND "C:/mingw32-4.7.2/bin/strip.exe" "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/luaCsoundAC.dll")
|
||||
+ ENDIF(CMAKE_INSTALL_DO_STRIP)
|
||||
+ ENDIF()
|
||||
+ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
|
||||
+
|
31
csound-6.18.1-upstream-fix_liblo_calls.patch
Normal file
31
csound-6.18.1-upstream-fix_liblo_calls.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 596667daba1ed99eda048e491ff8f36200f09429 Mon Sep 17 00:00:00 2001
|
||||
From: vlazzarini <victor.lazzarini@mu.ie>
|
||||
Date: Sat, 3 Jun 2023 18:06:59 +0100
|
||||
Subject: [PATCH] fixing liblo calls
|
||||
|
||||
---
|
||||
Opcodes/OSC.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Opcodes/OSC.c b/Opcodes/OSC.c
|
||||
index 4868a04c5e0..b37f5dac1e6 100644
|
||||
--- a/Opcodes/OSC.c
|
||||
+++ b/Opcodes/OSC.c
|
||||
@@ -483,7 +483,7 @@ static int32_t OSCcounter(CSOUND *csound, OSCcount *p)
|
||||
}
|
||||
|
||||
static int32_t OSC_handler(const char *path, const char *types,
|
||||
- lo_arg **argv, int32_t argc, void *data, void *p)
|
||||
+ lo_arg **argv, int32_t argc, lo_message data, void *p)
|
||||
{
|
||||
IGN(argc); IGN(data);
|
||||
OSC_PORT *pp = (OSC_PORT*) p;
|
||||
@@ -548,7 +548,7 @@ static int32_t OSC_handler(const char *path, const char *types,
|
||||
case 'b':
|
||||
{
|
||||
int32_t len =
|
||||
- lo_blobsize((lo_blob*)argv[i]);
|
||||
+ lo_blobsize((lo_blob)argv[i]);
|
||||
m->args[i].blob =
|
||||
csound->Malloc(csound,len);
|
||||
memcpy(m->args[i].blob, argv[i], len);
|
84
csound.spec
84
csound.spec
@ -1,6 +1,7 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
%define gitcommit %(echo %version | cut -d+ -f2 | cut -d. -f2)
|
||||
Name: csound
|
||||
Version: 6.18.1
|
||||
Version: 6.18.1+20241116git.05aa93e
|
||||
Release: 1mamba
|
||||
Summary: A sound and music synthesis system providing facilities for composition and performance over a wide range of platforms
|
||||
Group: Applications/Multimedia
|
||||
@ -8,9 +9,8 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.csounds.com/
|
||||
Source: https://github.com/csound/csound.git/%{version}/csound-%{version}.tar.bz2
|
||||
Patch0: %{name}-5.10.1-fix-locale-install.patch
|
||||
Patch1: csound-5.19.01-missing-cmake-file.patch
|
||||
Source: https://github.com/csound/csound.git/develop@%{gitcommit}/csound-%{version}.tar.bz2
|
||||
Patch0: csound-6.18.1-upstream-fix_liblo_calls.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -19,17 +19,16 @@ BuildRequires: libcurl-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: liblo-devel
|
||||
BuildRequires: liblua-devel
|
||||
BuildRequires: libportaudio-devel
|
||||
BuildRequires: libportmidi-devel
|
||||
BuildRequires: libpulseaudio-devel
|
||||
BuildRequires: libpython3-devel
|
||||
BuildRequires: libpulseaudio-glib-devel
|
||||
BuildRequires: libpython311-devel
|
||||
BuildRequires: libsamplerate-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: java-gcj-compat
|
||||
BuildRequires: liblua51-devel
|
||||
BuildRequires: libportmidi-devel >= 1:2.0.4-1mamba
|
||||
Requires: libcsound = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description
|
||||
@ -38,6 +37,7 @@ Csound is a sound and music synthesis system, providing facilities for compositi
|
||||
%package -n libcsound
|
||||
Summary: A sound and music synthesis library providing facilities for composition and performance over a wide range of platforms
|
||||
Group: System/Libraries
|
||||
Obsoletes: java-csound <= 6.18.1
|
||||
|
||||
%description -n libcsound
|
||||
Csound is a sound and music synthesis system, providing facilities for composition and performance over a wide range of platforms. It is not restricted to any style of music, having been used for many years in at least classical, pop, techno, ambient...
|
||||
@ -66,13 +66,9 @@ This package contains the Java library.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch 0 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%cmake -d build \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DPYTHON=%{__python3} \
|
||||
@ -80,54 +76,12 @@ This package contains the Java library.
|
||||
-DUSE_LIB64=ON
|
||||
%endif
|
||||
|
||||
# -DLUA_INCLUDE_DIR=%{_includedir}/lua5.3 \
|
||||
# -DLUA_LIBRARY=%{_libdir}/liblua.so.5.3 \
|
||||
|
||||
# -DPYTHON_LIBRARY=%{_libdir}/libpython%{python_version}.so \
|
||||
# -DPYTHON_INCLUDE_DIR=%{_includedir}/python%{python_version}
|
||||
|
||||
#scons dynamicCsoundLibrary=1 \
|
||||
# buildRelease=0 \
|
||||
# noDebug=0 \
|
||||
# disableGStabs=1 \
|
||||
# buildInterfaces=1 \
|
||||
# useGettext=1 \
|
||||
# useALSA=1 \
|
||||
# usePortAudio=0 \
|
||||
# usePortMIDI=0 \
|
||||
# useOGG=1 \
|
||||
# useOSC=1 \
|
||||
# useJack=1 \
|
||||
# useFLTK=1 \
|
||||
# buildVirtual=1 \
|
||||
# useFluidsynth=1 \
|
||||
# generatePdf=0 \
|
||||
# buildCsound5GUI=1 \
|
||||
# pythonVersion=2.6 \
|
||||
# buildPythonOpcodes=1 \
|
||||
# buildPythonWrapper=1 \
|
||||
# buildLuaWrapper=1 \
|
||||
# buildTclcsound=1 \
|
||||
# buildJavaWrapper=1 \
|
||||
# buildDSSI=1 \
|
||||
# buildUtilities=1 \
|
||||
# prefix=%{_prefix} \
|
||||
# customCCFLAGS="%{optflags}" \
|
||||
# customCXXFLAGS="%{optflags}" \
|
||||
# tclversion=8.5
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
install -d %{buildroot}%{_datadir}/java/
|
||||
mv %{buildroot}%{_libdir}/*.jar %{buildroot}%{_datadir}/java/
|
||||
install -d %{buildroot}%{_libdir}/csound/lua
|
||||
mv %{buildroot}%{_libdir}/lua* %{buildroot}%{_libdir}/csound/lua/
|
||||
mv %{buildroot}%{_libdir}/lib_jcsound* %{buildroot}%{_libdir}/csound/
|
||||
|
||||
%find_lang %{name} --all-name
|
||||
|
||||
%clean
|
||||
@ -142,30 +96,28 @@ mv %{buildroot}%{_libdir}/lib_jcsound* %{buildroot}%{_libdir}/csound/
|
||||
%files -n libcsound
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libcsound*.so.*
|
||||
%{_libdir}/libcsnd*.so.*
|
||||
%dir %{_libdir}/csound
|
||||
%dir %{_libdir}/csound/plugins*
|
||||
%{_libdir}/csound/plugins*/*.so
|
||||
%{_libdir}/csound/lua/luaCsnd6.so
|
||||
%{_libdir}/csound/lib_jcsound6.so
|
||||
%{python3_sitearch}/ctcsound.py
|
||||
%{python3_sitelib}/ctcsound.py
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n libcsound-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/csound
|
||||
%{_includedir}/csound/*
|
||||
#%{_libdir}/csoundapi~.pd_linux
|
||||
#%{_libdir}/libCsoundAC.so
|
||||
%{_libdir}/libcsnd*.so
|
||||
%{_libdir}/libcsound*.so
|
||||
%{_datadir}/cmake/Csound/FindCsound.cmake
|
||||
%dir %{_datadir}/csound
|
||||
%{_datadir}/csound/Csound*.cmake
|
||||
|
||||
%files -n java-csound
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/java/csnd6.jar
|
||||
#%files -n java-csound
|
||||
#%defattr(-,root,root)
|
||||
#%{_datadir}/java/csnd6.jar
|
||||
|
||||
%changelog
|
||||
* Sun Nov 17 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 6.18.1+20241116git.05aa93e-1mamba
|
||||
- update to 6.18.1+20241116git.05aa93e
|
||||
|
||||
* Thu Nov 24 2022 Automatic Build System <autodist@mambasoft.it> 6.18.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user