update to 5.19.01

python 2.7 rebuild [release 5.19.01-1mamba;Sat Jun 01 2013]
This commit is contained in:
Silvan Calarco 2024-01-05 21:34:43 +01:00
parent 6ab56eabe0
commit 33b43004cb
4 changed files with 290 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# csound
Csound is a sound and music synthesis system, providing facilities for composition and performance over a wide range of platforms. It is not restricted to any style of music, having been used for many years in at least classical, pop, techno, ambient...

View File

@ -0,0 +1,20 @@
--- Csound5.10.1/install.py.orig 2009-03-31 11:31:45.000000000 +0100
+++ Csound5.10.1/install.py 2009-03-31 11:32:01.000000000 +0100
@@ -152,7 +152,7 @@
fileList += [fileName]
fullName = concatPath([instDir, fileName])
err = runCmd(['install', '-p', '-m', perm, src, fullName])
- if err == 0 and stripMode != '':
+ if err == 0 and stripMode == 'packman':
err = runCmd(['strip', stripMode, fullName])
if err == 0:
addMD5(fullName, fileName)
@@ -333,7 +333,7 @@
for i in xmgList:
makeDir(concatPath([xmgDir, i, 'LC_MESSAGES']))
src = 'po/' + i + '/LC_MESSAGES/csound5.mo'
- fileName = concatPath([xmgDir, i, 'LC_MESSAGES/csound5.mo'])
+ fileName = concatPath([instDir, xmgDir, i, 'LC_MESSAGES/csound5.mo'])
err = runCmd(['install', '-p', '-m', '0644', src, fileName])
if err == 0:
addMD5(fileName, fileName)

View File

@ -0,0 +1,67 @@
diff -Nru Csound5.19.01.orig/frontends/CsoundAC/cmake_install.cmake Csound5.19.01/frontends/CsoundAC/cmake_install.cmake
--- Csound5.19.01.orig/frontends/CsoundAC/cmake_install.cmake 1970-01-01 01:00:00.000000000 +0100
+++ Csound5.19.01/frontends/CsoundAC/cmake_install.cmake 2013-05-31 06:29:34.000000000 +0200
@@ -0,0 +1,63 @@
+# Install script for directory: C:/Users/Michael/csound-csound6-git/frontends/CsoundAC
+
+# Set the install prefix
+IF(NOT DEFINED CMAKE_INSTALL_PREFIX)
+ SET(CMAKE_INSTALL_PREFIX "C:/Program Files (x86)/Csound")
+ENDIF(NOT DEFINED CMAKE_INSTALL_PREFIX)
+STRING(REGEX REPLACE "/$" "" CMAKE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}")
+
+# Set the install configuration name.
+IF(NOT DEFINED CMAKE_INSTALL_CONFIG_NAME)
+ IF(BUILD_TYPE)
+ STRING(REGEX REPLACE "^[^A-Za-z0-9_]+" ""
+ CMAKE_INSTALL_CONFIG_NAME "${BUILD_TYPE}")
+ ELSE(BUILD_TYPE)
+ SET(CMAKE_INSTALL_CONFIG_NAME "RelWithDebInfo")
+ ENDIF(BUILD_TYPE)
+ MESSAGE(STATUS "Install configuration: \"${CMAKE_INSTALL_CONFIG_NAME}\"")
+ENDIF(NOT DEFINED CMAKE_INSTALL_CONFIG_NAME)
+
+# Set the component getting installed.
+IF(NOT CMAKE_INSTALL_COMPONENT)
+ IF(COMPONENT)
+ MESSAGE(STATUS "Install component: \"${COMPONENT}\"")
+ SET(CMAKE_INSTALL_COMPONENT "${COMPONENT}")
+ ELSE(COMPONENT)
+ SET(CMAKE_INSTALL_COMPONENT)
+ ENDIF(COMPONENT)
+ENDIF(NOT CMAKE_INSTALL_COMPONENT)
+
+IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
+ FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/lib" TYPE STATIC_LIBRARY OPTIONAL FILES "C:/Users/Michael/csound-csound6-git/libCsoundAC.dll.a")
+ IF(EXISTS "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/libCsoundAC.dll.a" AND
+ NOT IS_SYMLINK "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/libCsoundAC.dll.a")
+ IF(CMAKE_INSTALL_DO_STRIP)
+ EXECUTE_PROCESS(COMMAND "C:/mingw32-4.7.2/bin/strip.exe" "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/libCsoundAC.dll.a")
+ ENDIF(CMAKE_INSTALL_DO_STRIP)
+ ENDIF()
+ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
+
+IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
+ FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/lib" TYPE MODULE FILES "C:/Users/Michael/csound-csound6-git/_CsoundAC.pyd")
+ IF(EXISTS "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/_CsoundAC.pyd" AND
+ NOT IS_SYMLINK "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/_CsoundAC.pyd")
+ IF(CMAKE_INSTALL_DO_STRIP)
+ EXECUTE_PROCESS(COMMAND "C:/mingw32-4.7.2/bin/strip.exe" "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/_CsoundAC.pyd")
+ ENDIF(CMAKE_INSTALL_DO_STRIP)
+ ENDIF()
+ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
+
+IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
+ FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/lib" TYPE FILE FILES "C:/Users/Michael/csound-csound6-git/CsoundAC.py")
+ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
+
+IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
+ FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/lib" TYPE MODULE FILES "C:/Users/Michael/csound-csound6-git/luaCsoundAC.dll")
+ IF(EXISTS "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/luaCsoundAC.dll" AND
+ NOT IS_SYMLINK "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/luaCsoundAC.dll")
+ IF(CMAKE_INSTALL_DO_STRIP)
+ EXECUTE_PROCESS(COMMAND "C:/mingw32-4.7.2/bin/strip.exe" "$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/luaCsoundAC.dll")
+ ENDIF(CMAKE_INSTALL_DO_STRIP)
+ ENDIF()
+ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL "Unspecified")
+

201
csound.spec Normal file
View File

@ -0,0 +1,201 @@
%define majver %(echo %version | cut -d. -f1-2)
Name: csound
Version: 5.19.01
Release: 1mamba
Summary: A sound and music synthesis system providing facilities for composition and performance over a wide range of platforms
Group: Applications/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.csounds.com/
Source: http://downloads.sourceforge.net/project/csound/csound5/csound%{majver}/Csound%{version}.tar.gz
Patch0: %{name}-5.10.1-fix-locale-install.patch
Patch1: csound-5.19.01-missing-cmake-file.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: fluidsynth-devel
BuildRequires: glibc-devel
BuildRequires: libalsa-devel
BuildRequires: libfltk-devel
BuildRequires: libgcc
BuildRequires: libGL-devel
BuildRequires: libgomp-devel
BuildRequires: libICE-devel
BuildRequires: libjack-devel
BuildRequires: liblo-devel
BuildRequires: liblua-devel
BuildRequires: libpng-devel
BuildRequires: libportaudio-devel
BuildRequires: libportmidi-devel
BuildRequires: libpulseaudio-devel
BuildRequires: libpython3-devel
BuildRequires: libSM-devel
BuildRequires: libsndfile-devel
BuildRequires: libstdc++6-devel
BuildRequires: libtcl-devel
BuildRequires: libtk-devel
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: java-gcj-compat
BuildRequires: liblua51-devel
Requires: libcsound = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Csound is a sound and music synthesis system, providing facilities for composition and performance over a wide range of platforms. It is not restricted to any style of music, having been used for many years in at least classical, pop, techno, ambient...
%package -n libcsound
Summary: A sound and music synthesis library providing facilities for composition and performance over a wide range of platforms
Group: System/Libraries
%description -n libcsound
Csound is a sound and music synthesis system, providing facilities for composition and performance over a wide range of platforms. It is not restricted to any style of music, having been used for many years in at least classical, pop, techno, ambient...
This package contains static libraries and header files needed for development.
%package -n libcsound-devel
Summary: Static libraries and headers for %{name}
Group: Development/Libraries
Requires: libcsound = %{?epoch:%epoch:}%{version}-%{release}
Provides: csound-devel
Obsoletes: csound-devel
%description -n libcsound-devel
Csound is a sound and music synthesis system, providing facilities for composition and performance over a wide range of platforms. It is not restricted to any style of music, having been used for many years in at least classical, pop, techno, ambient...
This package contains static libraries and header files needed for development.
%prep
%setup -q -n Csound%{version}
#%patch0 -p1
%patch1 -p1
%build
%cmake \
-DLUA_INCLUDE_DIR=%{_includedir}/lua5.1 \
-DLUA_LIBRARY=%{_libdir}/liblua.so.5.1 \
-DTCL_VERSION=8.5 \
-DPYTHON=%{__python} \
-DPYTHON_LIBRARY=%{_libdir}/libpython%{python_version}.so \
-DPYTHON_INCLUDE_DIR=%{_includedir}/python%{python_version}
#scons dynamicCsoundLibrary=1 \
# buildRelease=0 \
# noDebug=0 \
# disableGStabs=1 \
# buildInterfaces=1 \
# useGettext=1 \
# useALSA=1 \
# usePortAudio=0 \
# usePortMIDI=0 \
# useOGG=1 \
# useOSC=1 \
# useJack=1 \
# useFLTK=1 \
# buildVirtual=1 \
# useFluidsynth=1 \
# generatePdf=0 \
# buildCsound5GUI=1 \
# pythonVersion=2.6 \
# buildPythonOpcodes=1 \
# buildPythonWrapper=1 \
# buildLuaWrapper=1 \
# buildTclcsound=1 \
# buildJavaWrapper=1 \
# buildDSSI=1 \
# buildUtilities=1 \
# prefix=%{_prefix} \
# customCCFLAGS="%{optflags}" \
# customCXXFLAGS="%{optflags}" \
# tclversion=8.5
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
install -d %{buildroot}%{python_sitearch}
mv %{buildroot}%{_libdir}/*.py %{buildroot}%{python_sitearch}/
install -d %{buildroot}%{_datadir}/java/
mv %{buildroot}%{_libdir}/*.jar %{buildroot}%{_datadir}/java/
install -d %{buildroot}%{_libdir}/csound/lua
mv %{buildroot}%{_libdir}/lua* %{buildroot}%{_libdir}/csound/lua/
%find_lang %{name}5
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}5.lang
%defattr(-,root,root)
%{_bindir}/atsa
%{_bindir}/cs
%{_bindir}/csb64enc
%{_bindir}/csbeats
%{_bindir}/csound
%{_bindir}/cstclsh
%{_bindir}/cswish
%{_bindir}/cvanal
%{_bindir}/dnoise
%{_bindir}/envext
%{_bindir}/extract
%{_bindir}/extractor
%{_bindir}/het_export
%{_bindir}/het_import
%{_bindir}/hetro
%{_bindir}/lpanal
%{_bindir}/lpc_export
%{_bindir}/lpc_import
%{_bindir}/makecsd
%{_bindir}/mixer
%{_bindir}/pv_export
%{_bindir}/pv_import
%{_bindir}/pvanal
%{_bindir}/pvlook
%{_bindir}/scale
%{_bindir}/scot
%{_bindir}/scsort
%{_bindir}/sdif2ad
%{_bindir}/sndinfo
%{_bindir}/srconv
%files -n libcsound
%defattr(-,root,root)
%{_libdir}/libCsoundAC.so.*
%{_libdir}/libcsound64.so.*
%{_libdir}/libcsnd.so.*
%dir %{_libdir}/csound
%dir %{_libdir}/csound/plugins-*
%{_libdir}/csound/plugins-*/*.so
%{python_sitearch}/CsoundAC.py
%{python_sitearch}/csnd.py
%{_libdir}/_CsoundAC.so
%{_libdir}/_csnd.so
%{_datadir}/java/csnd.jar
%{_libdir}/lib_jcsound.so
%{_libdir}/csound/lua/luaCsnd.so
%{_libdir}/csound/lua/luaCsoundAC.so
%{_libdir}/tclcsound.so
%doc AUTHORS COPYING
%files -n libcsound-devel
%defattr(-,root,root)
%dir %{_includedir}/csound
%{_includedir}/csound/*
%{_libdir}/csoundapi~.pd_linux
%{_libdir}/libCsoundAC.so
%{_libdir}/libcsnd.so
%{_libdir}/libcsound64.so
#%{_libdir}/libcsound.so
#%doc ChangeLog readme-csound5.txt
%changelog
* Sat Jun 01 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 5.19.01-1mamba
- update to 5.19.01
- python 2.7 rebuild
* Sun Jun 20 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 5.12.1-1mamba
- package created by autospec