automatic version update by autodist [release 0.9.13-1mamba;Sun Sep 10 2023]
This commit is contained in:
parent
b0689f3f55
commit
c03787e4a6
556
crrcsim-0.9.13-aarch64-support-added.patch
Normal file
556
crrcsim-0.9.13-aarch64-support-added.patch
Normal file
@ -0,0 +1,556 @@
|
||||
From 4aa931913b02b49f0d9a455746c07d1ae658a7c7 Mon Sep 17 00:00:00 2001
|
||||
From: Damian Wrobel <dwrobel@ertelnet.rybnik.pl>
|
||||
Date: Thu, 21 Dec 2017 10:35:29 +0100
|
||||
Subject: [PATCH] aarch64 support added
|
||||
|
||||
upstream report: http://preview.tinyurl.com/cass62h
|
||||
---
|
||||
config.guess | 77 +++++++++++++++++++++-----------
|
||||
config.sub | 144 ++++++++++++++++++++++++++++++++++++++++-------------------
|
||||
2 files changed, 151 insertions(+), 70 deletions(-)
|
||||
|
||||
diff --git a/config.guess b/config.guess
|
||||
index 666c5ad..cf7b6b3 100755
|
||||
--- a/config.guess
|
||||
+++ b/config.guess
|
||||
@@ -1,10 +1,10 @@
|
||||
#! /bin/sh
|
||||
# Attempt to guess a canonical system name.
|
||||
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
|
||||
-# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
|
||||
-# Free Software Foundation, Inc.
|
||||
+# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
|
||||
+# 2011, 2012 Free Software Foundation, Inc.
|
||||
|
||||
-timestamp='2009-11-20'
|
||||
+timestamp='2012-09-25'
|
||||
|
||||
# This file is free software; you can redistribute it and/or modify it
|
||||
# under the terms of the GNU General Public License as published by
|
||||
@@ -17,9 +17,7 @@ timestamp='2009-11-20'
|
||||
# General Public License for more details.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License
|
||||
-# along with this program; if not, write to the Free Software
|
||||
-# Foundation, Inc., 51 Franklin Street - Fifth Floor, Boston, MA
|
||||
-# 02110-1301, USA.
|
||||
+# along with this program; if not, see <http://www.gnu.org/licenses/>.
|
||||
#
|
||||
# As a special exception to the GNU General Public License, if you
|
||||
# distribute this file as part of a program that contains a
|
||||
@@ -56,8 +54,9 @@ version="\
|
||||
GNU config.guess ($timestamp)
|
||||
|
||||
Originally written by Per Bothner.
|
||||
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
|
||||
-2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
|
||||
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
|
||||
+2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012
|
||||
+Free Software Foundation, Inc.
|
||||
|
||||
This is free software; see the source for copying conditions. There is NO
|
||||
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
|
||||
@@ -154,7 +153,7 @@ test -f /etc/SuSE-release -o -f /.buildenv && VENDOR=suse
|
||||
case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
|
||||
*:NetBSD:*:*)
|
||||
# NetBSD (nbsd) targets should (where applicable) match one or
|
||||
- # more of the tupples: *-*-netbsdelf*, *-*-netbsdaout*,
|
||||
+ # more of the tuples: *-*-netbsdelf*, *-*-netbsdaout*,
|
||||
# *-*-netbsdecoff* and *-*-netbsd*. For targets that recently
|
||||
# switched to ELF, *-*-netbsd* would select the old
|
||||
# object file format. This provides both forward
|
||||
@@ -211,6 +210,10 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
|
||||
# CPU_TYPE-MANUFACTURER-OPERATING_SYSTEM is used.
|
||||
echo "${machine}-${os}${release}"
|
||||
exit ;;
|
||||
+ *:Bitrig:*:*)
|
||||
+ UNAME_MACHINE_ARCH=`arch | sed 's/Bitrig.//'`
|
||||
+ echo ${UNAME_MACHINE_ARCH}-unknown-bitrig${UNAME_RELEASE}
|
||||
+ exit ;;
|
||||
*:OpenBSD:*:*)
|
||||
UNAME_MACHINE_ARCH=`arch | sed 's/OpenBSD.//'`
|
||||
echo ${UNAME_MACHINE_ARCH}-${VENDOR}-openbsd${UNAME_RELEASE}
|
||||
@@ -310,8 +313,8 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
|
||||
arm:RISC*:1.[012]*:*|arm:riscix:1.[012]*:*)
|
||||
echo arm-acorn-riscix${UNAME_RELEASE}
|
||||
exit ;;
|
||||
- arm:riscos:*:*|arm:RISCOS:*:*)
|
||||
- echo arm-${VENDOR}-riscos
|
||||
+ arm*:riscos:*:*|arm*:RISCOS:*:*)
|
||||
+ echo arm-unknown-riscos
|
||||
exit ;;
|
||||
SR2?01:HI-UX/MPP:*:* | SR8000:HI-UX/MPP:*:*)
|
||||
echo hppa1.1-hitachi-hiuxmpp
|
||||
@@ -798,21 +801,26 @@ EOF
|
||||
echo ${UNAME_MACHINE}-${VENDOR}-bsdi${UNAME_RELEASE}
|
||||
exit ;;
|
||||
*:FreeBSD:*:*)
|
||||
- case ${UNAME_MACHINE} in
|
||||
- pc98)
|
||||
- echo i386-${VENDOR}-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
+ UNAME_PROCESSOR=`/usr/bin/uname -p`
|
||||
+ case ${UNAME_PROCESSOR} in
|
||||
amd64)
|
||||
echo x86_64-${VENDOR}-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
*)
|
||||
- echo ${UNAME_MACHINE}-${VENDOR}-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
+ echo ${UNAME_PROCESSOR}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
esac
|
||||
exit ;;
|
||||
i*:CYGWIN*:*)
|
||||
echo ${UNAME_MACHINE}-pc-cygwin
|
||||
exit ;;
|
||||
+ *:MINGW64*:*)
|
||||
+ echo ${UNAME_MACHINE}-pc-mingw64
|
||||
+ exit ;;
|
||||
*:MINGW*:*)
|
||||
echo ${UNAME_MACHINE}-pc-mingw32
|
||||
exit ;;
|
||||
+ i*:MSYS*:*)
|
||||
+ echo ${UNAME_MACHINE}-pc-msys
|
||||
+ exit ;;
|
||||
i*:windows32*:*)
|
||||
# uname -m includes "-pc" on this system.
|
||||
echo ${UNAME_MACHINE}-mingw32
|
||||
@@ -867,6 +875,13 @@ EOF
|
||||
i*86:Minix:*:*)
|
||||
echo ${UNAME_MACHINE}-pc-minix
|
||||
exit ;;
|
||||
+ aarch64:Linux:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
+ aarch64_be:Linux:*:*)
|
||||
+ UNAME_MACHINE=aarch64_be
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
alpha:Linux:*:*)
|
||||
case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
|
||||
EV5) UNAME_MACHINE=alphaev5 ;;
|
||||
@@ -895,13 +910,16 @@ EOF
|
||||
echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
|
||||
exit ;;
|
||||
cris:Linux:*:*)
|
||||
- echo cris-axis-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-axis-linux-gnu
|
||||
exit ;;
|
||||
crisv32:Linux:*:*)
|
||||
- echo crisv32-axis-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-axis-linux-gnu
|
||||
exit ;;
|
||||
frv:Linux:*:*)
|
||||
- echo frv-${VENDOR}-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
+ hexagon:Linux:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
i*86:Linux:*:*)
|
||||
LIBC=gnu
|
||||
@@ -943,7 +961,7 @@ EOF
|
||||
test x"${CPU}" != x && { echo "${CPU}-${VENDOR}-linux-gnu"; exit; }
|
||||
;;
|
||||
or32:Linux:*:*)
|
||||
- echo or32-${VENDOR}-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
padre:Linux:*:*)
|
||||
echo sparc-${VENDOR}-linux-gnu
|
||||
@@ -975,13 +993,16 @@ EOF
|
||||
echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
|
||||
exit ;;
|
||||
sparc:Linux:*:* | sparc64:Linux:*:*)
|
||||
- echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
+ tile*:Linux:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
vax:Linux:*:*)
|
||||
echo ${UNAME_MACHINE}-dec-linux-gnu
|
||||
exit ;;
|
||||
x86_64:Linux:*:*)
|
||||
- echo x86_64-${VENDOR}-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
xtensa*:Linux:*:*)
|
||||
echo ${UNAME_MACHINE}-${VENDOR}-linux-gnu
|
||||
@@ -1188,6 +1209,9 @@ EOF
|
||||
BePC:Haiku:*:*) # Haiku running on Intel PC compatible.
|
||||
echo i586-pc-haiku
|
||||
exit ;;
|
||||
+ x86_64:Haiku:*:*)
|
||||
+ echo x86_64-unknown-haiku
|
||||
+ exit ;;
|
||||
SX-4:SUPER-UX:*:*)
|
||||
echo sx4-nec-superux${UNAME_RELEASE}
|
||||
exit ;;
|
||||
@@ -1240,7 +1264,10 @@ EOF
|
||||
*:QNX:*:4*)
|
||||
echo i386-pc-qnx
|
||||
exit ;;
|
||||
- NSE-?:NONSTOP_KERNEL:*:*)
|
||||
+ NEO-?:NONSTOP_KERNEL:*:*)
|
||||
+ echo neo-tandem-nsk${UNAME_RELEASE}
|
||||
+ exit ;;
|
||||
+ NSE-*:NONSTOP_KERNEL:*:*)
|
||||
echo nse-tandem-nsk${UNAME_RELEASE}
|
||||
exit ;;
|
||||
NSR-?:NONSTOP_KERNEL:*:*)
|
||||
@@ -1309,11 +1336,11 @@ EOF
|
||||
i*86:AROS:*:*)
|
||||
echo ${UNAME_MACHINE}-pc-aros
|
||||
exit ;;
|
||||
+ x86_64:VMkernel:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-esx
|
||||
+ exit ;;
|
||||
esac
|
||||
|
||||
-#echo '(No uname command or uname output not recognized.)' 1>&2
|
||||
-#echo "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" 1>&2
|
||||
-
|
||||
eval $set_cc_for_build
|
||||
cat >$dummy.c <<EOF
|
||||
#ifdef _SEQUENT_
|
||||
diff --git a/config.sub b/config.sub
|
||||
index 2a55a50..b9004e7 100755
|
||||
--- a/config.sub
|
||||
+++ b/config.sub
|
||||
@@ -1,10 +1,10 @@
|
||||
#! /bin/sh
|
||||
# Configuration validation subroutine script.
|
||||
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
|
||||
-# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
|
||||
-# Free Software Foundation, Inc.
|
||||
+# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
|
||||
+# 2011, 2012 Free Software Foundation, Inc.
|
||||
|
||||
-timestamp='2009-11-20'
|
||||
+timestamp='2012-10-10'
|
||||
|
||||
# This file is (in principle) common to ALL GNU software.
|
||||
# The presence of a machine in this file suggests that SOME GNU software
|
||||
@@ -21,9 +21,7 @@ timestamp='2009-11-20'
|
||||
# GNU General Public License for more details.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License
|
||||
-# along with this program; if not, write to the Free Software
|
||||
-# Foundation, Inc., 51 Franklin Street - Fifth Floor, Boston, MA
|
||||
-# 02110-1301, USA.
|
||||
+# along with this program; if not, see <http://www.gnu.org/licenses/>.
|
||||
#
|
||||
# As a special exception to the GNU General Public License, if you
|
||||
# distribute this file as part of a program that contains a
|
||||
@@ -75,8 +73,9 @@ Report bugs and patches to <config-patches@gnu.org>."
|
||||
version="\
|
||||
GNU config.sub ($timestamp)
|
||||
|
||||
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
|
||||
-2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
|
||||
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
|
||||
+2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012
|
||||
+Free Software Foundation, Inc.
|
||||
|
||||
This is free software; see the source for copying conditions. There is NO
|
||||
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
|
||||
@@ -123,13 +122,18 @@ esac
|
||||
# Here we must recognize all the valid KERNEL-OS combinations.
|
||||
maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
|
||||
case $maybe_os in
|
||||
- nto-qnx* | linux-gnu* | linux-dietlibc | linux-newlib* | linux-uclibc* | \
|
||||
- uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | knetbsd*-gnu* | netbsd*-gnu* | \
|
||||
+ nto-qnx* | linux-gnu* | linux-android* | linux-dietlibc | linux-newlib* | \
|
||||
+ linux-musl* | linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
|
||||
+ knetbsd*-gnu* | netbsd*-gnu* | \
|
||||
kopensolaris*-gnu* | \
|
||||
storm-chaos* | os2-emx* | rtmk-nova*)
|
||||
os=-$maybe_os
|
||||
basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
|
||||
;;
|
||||
+ android-linux)
|
||||
+ os=-linux-android
|
||||
+ basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`-unknown
|
||||
+ ;;
|
||||
*)
|
||||
basic_machine=`echo $1 | sed 's/-[^-]*$//'`
|
||||
if [ $basic_machine != $1 ]
|
||||
@@ -152,7 +156,7 @@ case $os in
|
||||
-convergent* | -ncr* | -news | -32* | -3600* | -3100* | -hitachi* |\
|
||||
-c[123]* | -convex* | -sun | -crds | -omron* | -dg | -ultra | -tti* | \
|
||||
-harris | -dolphin | -highlevel | -gould | -cbm | -ns | -masscomp | \
|
||||
- -apple | -axis | -knuth | -cray | -microblaze)
|
||||
+ -apple | -axis | -knuth | -cray | -microblaze*)
|
||||
os=
|
||||
basic_machine=$1
|
||||
;;
|
||||
@@ -221,6 +225,12 @@ case $os in
|
||||
-isc*)
|
||||
basic_machine=`echo $1 | sed -e 's/86-.*/86-pc/'`
|
||||
;;
|
||||
+ -lynx*178)
|
||||
+ os=-lynxos178
|
||||
+ ;;
|
||||
+ -lynx*5)
|
||||
+ os=-lynxos5
|
||||
+ ;;
|
||||
-lynx*)
|
||||
os=-lynxos
|
||||
;;
|
||||
@@ -245,20 +255,25 @@ case $basic_machine in
|
||||
# Some are omitted here because they have special meanings below.
|
||||
1750a | 580 \
|
||||
| a29k \
|
||||
+ | aarch64 | aarch64_be \
|
||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
||||
| am33_2.0 \
|
||||
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
||||
+ | be32 | be64 \
|
||||
| bfin \
|
||||
| c4x | clipper \
|
||||
| d10v | d30v | dlx | dsp16xx \
|
||||
+ | epiphany \
|
||||
| fido | fr30 | frv \
|
||||
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
|
||||
+ | hexagon \
|
||||
| i370 | i860 | i960 | ia64 \
|
||||
| ip2k | iq2000 \
|
||||
+ | le32 | le64 \
|
||||
| lm32 \
|
||||
| m32c | m32r | m32rle | m68000 | m68k | m88k \
|
||||
- | maxq | mb | microblaze | mcore | mep | metag \
|
||||
+ | maxq | mb | microblaze | microblazeel | mcore | mep | metag \
|
||||
| mips | mipsbe | mipseb | mipsel | mipsle \
|
||||
| mips16 \
|
||||
| mips64 | mips64el \
|
||||
@@ -287,7 +302,7 @@ case $basic_machine in
|
||||
| pdp10 | pdp11 | pj | pjl \
|
||||
| powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
|
||||
| pyramid \
|
||||
- | rx \
|
||||
+ | rl78 | rx \
|
||||
| score \
|
||||
| sh | sh[1234] | sh[24]a | sh[24]aeb | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
|
||||
| sh64 | sh64le \
|
||||
@@ -296,14 +311,22 @@ case $basic_machine in
|
||||
| spu | strongarm \
|
||||
| tahoe | thumb | tic4x | tic80 | tron \
|
||||
| ubicom32 \
|
||||
- | v850 | v850e \
|
||||
+ | v850 | v850e | v850e1 | v850e2 | v850es | v850e2v3 \
|
||||
| we32k \
|
||||
| x86 | xc16x | xscale | xscalee[bl] | xstormy16 | xtensa \
|
||||
| z8k | z80)
|
||||
basic_machine=$basic_machine-unknown
|
||||
;;
|
||||
- m6811 | m68hc11 | m6812 | m68hc12 | picochip)
|
||||
- # Motorola 68HC11/12.
|
||||
+ c54x)
|
||||
+ basic_machine=tic54x-unknown
|
||||
+ ;;
|
||||
+ c55x)
|
||||
+ basic_machine=tic55x-unknown
|
||||
+ ;;
|
||||
+ c6x)
|
||||
+ basic_machine=tic6x-unknown
|
||||
+ ;;
|
||||
+ m6811 | m68hc11 | m6812 | m68hc12 | m68hcs12x | picochip)
|
||||
basic_machine=$basic_machine-unknown
|
||||
os=-none
|
||||
;;
|
||||
@@ -313,6 +336,21 @@ case $basic_machine in
|
||||
basic_machine=mt-unknown
|
||||
;;
|
||||
|
||||
+ strongarm | thumb | xscale)
|
||||
+ basic_machine=arm-unknown
|
||||
+ ;;
|
||||
+ xgate)
|
||||
+ basic_machine=$basic_machine-unknown
|
||||
+ os=-none
|
||||
+ ;;
|
||||
+ xscaleeb)
|
||||
+ basic_machine=armeb-unknown
|
||||
+ ;;
|
||||
+
|
||||
+ xscaleel)
|
||||
+ basic_machine=armel-unknown
|
||||
+ ;;
|
||||
+
|
||||
# We use `pc' rather than `unknown'
|
||||
# because (1) that's what they normally are, and
|
||||
# (2) the word "unknown" tends to confuse beginning users.
|
||||
@@ -327,11 +365,13 @@ case $basic_machine in
|
||||
# Recognize the basic CPU types with company name.
|
||||
580-* \
|
||||
| a29k-* \
|
||||
+ | aarch64-* | aarch64_be-* \
|
||||
| alpha-* | alphaev[4-8]-* | alphaev56-* | alphaev6[78]-* \
|
||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
||||
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
||||
| avr-* | avr32-* \
|
||||
+ | be32-* | be64-* \
|
||||
| bfin-* | bs2000-* \
|
||||
| c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
|
||||
| clipper-* | craynv-* | cydra-* \
|
||||
@@ -340,12 +380,15 @@ case $basic_machine in
|
||||
| f30[01]-* | f700-* | fido-* | fr30-* | frv-* | fx80-* \
|
||||
| h8300-* | h8500-* \
|
||||
| hppa-* | hppa1.[01]-* | hppa2.0-* | hppa2.0[nw]-* | hppa64-* \
|
||||
+ | hexagon-* \
|
||||
| i*86-* | i860-* | i960-* | ia64-* \
|
||||
| ip2k-* | iq2000-* \
|
||||
+ | le32-* | le64-* \
|
||||
| lm32-* \
|
||||
| m32c-* | m32r-* | m32rle-* \
|
||||
| m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
|
||||
- | m88110-* | m88k-* | maxq-* | mcore-* | metag-* | microblaze-* \
|
||||
+ | m88110-* | m88k-* | maxq-* | mcore-* | metag-* \
|
||||
+ | microblaze-* | microblazeel-* \
|
||||
| mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
|
||||
| mips16-* \
|
||||
| mips64-* | mips64el-* \
|
||||
@@ -373,17 +416,19 @@ case $basic_machine in
|
||||
| pdp10-* | pdp11-* | pj-* | pjl-* | pn-* | power-* \
|
||||
| powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
|
||||
| pyramid-* \
|
||||
- | romp-* | rs6000-* | rx-* \
|
||||
+ | rl78-* | romp-* | rs6000-* | rx-* \
|
||||
| sh-* | sh[1234]-* | sh[24]a-* | sh[24]aeb-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
|
||||
| shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
|
||||
| sparc-* | sparc64-* | sparc64b-* | sparc64v-* | sparc86x-* | sparclet-* \
|
||||
| sparclite-* \
|
||||
- | sparcv8-* | sparcv9-* | sparcv9b-* | sparcv9v-* | strongarm-* | sv1-* | sx?-* \
|
||||
- | tahoe-* | thumb-* \
|
||||
- | tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* | tile-* \
|
||||
+ | sparcv8-* | sparcv9-* | sparcv9b-* | sparcv9v-* | sv1-* | sx?-* \
|
||||
+ | tahoe-* \
|
||||
+ | tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
|
||||
+ | tile*-* \
|
||||
| tron-* \
|
||||
| ubicom32-* \
|
||||
- | v850-* | v850e-* | vax-* \
|
||||
+ | v850-* | v850e-* | v850e1-* | v850es-* | v850e2-* | v850e2v3-* \
|
||||
+ | vax-* \
|
||||
| we32k-* \
|
||||
| x86-* | x86_64-* | xc16x-* | xps100-* | xscale-* | xscalee[bl]-* \
|
||||
| xstormy16-* | xtensa*-* \
|
||||
@@ -674,7 +719,6 @@ case $basic_machine in
|
||||
i370-ibm* | ibm*)
|
||||
basic_machine=i370-ibm
|
||||
;;
|
||||
-# I'm not sure what "Sysv32" means. Should this be sysv3.2?
|
||||
i*86v32)
|
||||
basic_machine=`echo $1 | sed -e 's/86.*/86-pc/'`
|
||||
os=-sysv32
|
||||
@@ -732,9 +776,13 @@ case $basic_machine in
|
||||
basic_machine=ns32k-utek
|
||||
os=-sysv
|
||||
;;
|
||||
- microblaze)
|
||||
+ microblaze*)
|
||||
basic_machine=microblaze-xilinx
|
||||
;;
|
||||
+ mingw64)
|
||||
+ basic_machine=x86_64-pc
|
||||
+ os=-mingw64
|
||||
+ ;;
|
||||
mingw32)
|
||||
basic_machine=i386-pc
|
||||
os=-mingw32
|
||||
@@ -771,10 +819,18 @@ case $basic_machine in
|
||||
ms1-*)
|
||||
basic_machine=`echo $basic_machine | sed -e 's/ms1-/mt-/'`
|
||||
;;
|
||||
+ msys)
|
||||
+ basic_machine=i386-pc
|
||||
+ os=-msys
|
||||
+ ;;
|
||||
mvs)
|
||||
basic_machine=i370-ibm
|
||||
os=-mvs
|
||||
;;
|
||||
+ nacl)
|
||||
+ basic_machine=le32-unknown
|
||||
+ os=-nacl
|
||||
+ ;;
|
||||
ncr3000)
|
||||
basic_machine=i486-ncr
|
||||
os=-sysv4
|
||||
@@ -1073,20 +1129,8 @@ case $basic_machine in
|
||||
basic_machine=t90-cray
|
||||
os=-unicos
|
||||
;;
|
||||
- tic54x | c54x*)
|
||||
- basic_machine=tic54x-unknown
|
||||
- os=-coff
|
||||
- ;;
|
||||
- tic55x | c55x*)
|
||||
- basic_machine=tic55x-unknown
|
||||
- os=-coff
|
||||
- ;;
|
||||
- tic6x | c6x*)
|
||||
- basic_machine=tic6x-unknown
|
||||
- os=-coff
|
||||
- ;;
|
||||
tile*)
|
||||
- basic_machine=tile-unknown
|
||||
+ basic_machine=$basic_machine-unknown
|
||||
os=-linux-gnu
|
||||
;;
|
||||
tx39)
|
||||
@@ -1287,14 +1331,15 @@ case $os in
|
||||
| -nindy* | -vxsim* | -vxworks* | -ebmon* | -hms* | -mvs* \
|
||||
| -clix* | -riscos* | -uniplus* | -iris* | -rtu* | -xenix* \
|
||||
| -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* \
|
||||
- | -openbsd* | -solidbsd* \
|
||||
+ | -bitrig* | -openbsd* | -solidbsd* \
|
||||
| -ekkobsd* | -kfreebsd* | -freebsd* | -riscix* | -lynxos* \
|
||||
| -bosx* | -nextstep* | -cxux* | -aout* | -elf* | -oabi* \
|
||||
| -ptx* | -coff* | -ecoff* | -winnt* | -domain* | -vsta* \
|
||||
| -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
|
||||
| -chorusos* | -chorusrdb* | -cegcc* \
|
||||
- | -cygwin* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
|
||||
- | -mingw32* | -linux-gnu* | -linux-newlib* | -linux-uclibc* \
|
||||
+ | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
|
||||
+ | -mingw32* | -mingw64* | -linux-gnu* | -linux-android* \
|
||||
+ | -linux-newlib* | -linux-musl* | -linux-uclibc* \
|
||||
| -uxpv* | -beos* | -mpeix* | -udk* \
|
||||
| -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
|
||||
| -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
|
||||
@@ -1472,8 +1517,20 @@ case $basic_machine in
|
||||
arm*-semi)
|
||||
os=-aout
|
||||
;;
|
||||
- c4x-* | tic4x-*)
|
||||
- os=-coff
|
||||
+ c4x-* | tic4x-*)
|
||||
+ os=-coff
|
||||
+ ;;
|
||||
+ hexagon-*)
|
||||
+ os=-elf
|
||||
+ ;;
|
||||
+ tic54x-*)
|
||||
+ os=-coff
|
||||
+ ;;
|
||||
+ tic55x-*)
|
||||
+ os=-coff
|
||||
+ ;;
|
||||
+ tic6x-*)
|
||||
+ os=-coff
|
||||
;;
|
||||
# This must come before the *-dec entry.
|
||||
pdp10-*)
|
||||
@@ -1493,9 +1550,6 @@ case $basic_machine in
|
||||
;;
|
||||
m68000-sun)
|
||||
os=-sunos3
|
||||
- # This also exists in the configure program, but was not the
|
||||
- # default.
|
||||
- # os=-sunos4
|
||||
;;
|
||||
m68*-cisco)
|
||||
os=-aout
|
||||
--
|
||||
2.14.3
|
||||
|
27
crrcsim-0.9.13-gcc-7.patch
Normal file
27
crrcsim-0.9.13-gcc-7.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From 3f21b2fe5e4200bb7a96b78de953ad4d6d7bd73c Mon Sep 17 00:00:00 2001
|
||||
From: Damian Wrobel <dwrobel@ertelnet.rybnik.pl>
|
||||
Date: Thu, 21 Dec 2017 11:28:30 +0100
|
||||
Subject: [PATCH] gcc 7 fixes
|
||||
|
||||
fix for https://bugzilla.redhat.com/show_bug.cgi?id=1307411
|
||||
upstream report: https://sourceforge.net/p/crrcsim/bugs/35/
|
||||
---
|
||||
src/mod_video/crrc_animation.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/mod_video/crrc_animation.cpp b/src/mod_video/crrc_animation.cpp
|
||||
index ee7d7f4..855b106 100644
|
||||
--- a/src/mod_video/crrc_animation.cpp
|
||||
+++ b/src/mod_video/crrc_animation.cpp
|
||||
@@ -84,7 +84,7 @@ void createAnimation(SimpleXMLTransfer *animation, ssgEntity* model)
|
||||
else
|
||||
{
|
||||
std::cerr << "createAnimation: unknown animation type \'"
|
||||
- << type << "\'" << std::cerr;
|
||||
+ << type << "\'" << std::endl;
|
||||
}
|
||||
|
||||
if (anim != NULL)
|
||||
--
|
||||
2.14.3
|
||||
|
42
crrcsim-0.9.13-issue-41.patch
Normal file
42
crrcsim-0.9.13-issue-41.patch
Normal file
@ -0,0 +1,42 @@
|
||||
# HG changeset patch
|
||||
# User jreucker <slowhand_47@gmx.de>
|
||||
# Date 1530732562 -7200
|
||||
# Wed Jul 04 21:29:22 2018 +0200
|
||||
# Node ID e3a0407da6eba38b29e44e4fde0b2b020e8bce0a
|
||||
# Parent 85cacb3c4d9fba844f7b2e5a76a1cb5ec1cc180f
|
||||
Fix issue #41 (thanks go to Jan Yenya Kasprzak for the patch)
|
||||
|
||||
diff -r 85cacb3c4d9f -r e3a0407da6eb src/crrc_sound.cpp
|
||||
--- a/src/crrc_sound.cpp Fri Dec 22 12:30:01 2017 +0100
|
||||
+++ b/src/crrc_sound.cpp Wed Jul 04 21:29:22 2018 +0200
|
||||
@@ -334,10 +334,14 @@
|
||||
|
||||
for (int n = 0; n < nSndVarioSineLen; n++)
|
||||
{
|
||||
- sinewave[n] = (Sint16)(32767 * sin(2*M_PI*n/nSndVarioSineLen));
|
||||
+ sinewave.push_back((Sint16)(32767 * sin(2*M_PI*n/nSndVarioSineLen)));
|
||||
}
|
||||
printf("Initialized sine samples: %i\n", nSndVarioSineLen);
|
||||
|
||||
+ for (int n = 0; n < fmt->samples * getSampleSize(); n++)
|
||||
+ {
|
||||
+ dyn_buffer.push_back(0);
|
||||
+ }
|
||||
}
|
||||
|
||||
|
||||
diff -r 85cacb3c4d9f -r e3a0407da6eb src/crrc_soundserver.cpp
|
||||
--- a/src/crrc_soundserver.cpp Fri Dec 22 12:30:01 2017 +0100
|
||||
+++ b/src/crrc_soundserver.cpp Wed Jul 04 21:29:22 2018 +0200
|
||||
@@ -680,6 +680,11 @@
|
||||
#endif
|
||||
dyn_buffer.reserve(*len);
|
||||
}
|
||||
+
|
||||
+ while (dyn_buffer.size() < *len)
|
||||
+ {
|
||||
+ dyn_buffer.push_back(0);
|
||||
+ }
|
||||
|
||||
#if CRRC_SOUND_STEREO == 0
|
||||
// 16-bit mono samples, so we have to work through len/2 samples
|
83
crrcsim.spec
83
crrcsim.spec
@ -1,34 +1,39 @@
|
||||
Name: crrcsim
|
||||
Version: 0.9.12
|
||||
Release: 2mamba
|
||||
Version: 0.9.13
|
||||
Release: 1mamba
|
||||
Summary: CRRCSim is a model-airplane flight simulation program for Linux with ports to other platforms.
|
||||
Group: Graphical Desktop/Applications/Games
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||
URL: http://crrcsim.berlios.de/wiki/
|
||||
Source: http://garr.dl.sourceforge.net/project/crrcsim/crrcsim/crrcsim-%{version}/crrcsim-%{version}.tar.gz
|
||||
URL: http://18382.whserv.de/admin/index.php
|
||||
Source: https://downloads.sourceforge.net/project/crrcsim/crrcsim/crrcsim-%{version}/crrcsim-%{version}.tar.gz
|
||||
Patch0: crrcsim-0.9.13-gcc-7.patch
|
||||
Patch1: crrcsim-0.9.13-issue-41.patch
|
||||
Patch2: crrcsim-0.9.13-aarch64-support-added.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libglu-devel
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libplib-devel
|
||||
BuildRequires: libportaudio-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%debug_package
|
||||
|
||||
%description
|
||||
CRRCSim is a model-airplane flight simulation program for Linux with ports to other platforms. Using CRRCSim you can learn how to fly model aircraft, test new aircraft designs, and improve your skills by practicing in the relative safety of your pc.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch 0 -p1 -b .gcc-7
|
||||
%patch 1 -p1 -b .issue-41
|
||||
%patch 2 -p1 -b .aarch64-support-added
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -38,61 +43,27 @@ CRRCSim is a model-airplane flight simulation program for Linux with ports to ot
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/crrcsim
|
||||
%{_datadir}/crrcsim/icons/crrcsim.ico
|
||||
%{_datadir}/crrcsim/icons/crrcsim.png
|
||||
%{_datadir}/crrcsim/icons/crrcsim.xpm
|
||||
%{_datadir}/crrcsim/models/*.xml
|
||||
%{_datadir}/crrcsim/models/battery/*.xml
|
||||
%{_datadir}/crrcsim/models/engine/*.xml
|
||||
%{_datadir}/crrcsim/objects/*.ac
|
||||
%{_datadir}/crrcsim/objects/*.3ds
|
||||
%{_datadir}/crrcsim/scenery/*.xml
|
||||
%{_datadir}/crrcsim/sounds/*.wav
|
||||
%{_datadir}/crrcsim/sounds/f3f/default/*.wav
|
||||
%{_datadir}/crrcsim/sounds/f3f/sport/*.wav
|
||||
%{_datadir}/crrcsim/textures/*.rgb
|
||||
%{_datadir}/crrcsim/textures/*.txf
|
||||
%{_datadir}/crrcsim/textures/*.jpg
|
||||
%{_datadir}/crrcsim/textures/*.bw
|
||||
%{_datadir}/doc/crrcsim/*.txt
|
||||
%{_datadir}/doc/crrcsim/README
|
||||
%{_datadir}/doc/crrcsim/*.jpg
|
||||
%{_datadir}/doc/crrcsim/file_format/*.html
|
||||
%{_datadir}/doc/crrcsim/howto_create_models/*.html
|
||||
%{_datadir}/doc/crrcsim/howto_create_models/qc01.tex
|
||||
%{_datadir}/doc/crrcsim/index.html
|
||||
%{_datadir}/doc/crrcsim/input_method/CT6A/README
|
||||
%{_datadir}/doc/crrcsim/input_method/MNAV/Autopilot-CRRCSim.png
|
||||
%{_datadir}/doc/crrcsim/input_method/MNAV/autopilot.txt
|
||||
%{_datadir}/doc/crrcsim/input_method/MNAV/mnav.txt
|
||||
%{_datadir}/doc/crrcsim/input_method/PARALLEL_1_to_3/circuit.jpg
|
||||
%{_datadir}/doc/crrcsim/input_method/PARALLEL_1_to_3/crrcsim_at90s1200.asm
|
||||
%{_datadir}/doc/crrcsim/input_method/PARALLEL_1_to_3/crrcsim_at90s1200.hex
|
||||
%{_datadir}/doc/crrcsim/input_method/RCTRAN/README_old
|
||||
%{_datadir}/doc/crrcsim/input_method/SERIAL2/README
|
||||
%{_datadir}/doc/crrcsim/models/*.txt
|
||||
%{_datadir}/doc/crrcsim/power_propulsion/inline_dotgraph_1.dot.png
|
||||
%{_datadir}/doc/crrcsim/power_propulsion/power_propulsion.html
|
||||
%{_datadir}/doc/crrcsim/thermals/comp.gnuplot
|
||||
%{_datadir}/doc/crrcsim/thermals/*.png
|
||||
%{_datadir}/doc/crrcsim/thermals/*.cpp
|
||||
%{_datadir}/doc/crrcsim/thermals/thermals.txt
|
||||
%{_datadir}/doc/crrcsim/thermals/thermalsim.html
|
||||
%{_datadir}/doc/crrcsim/thermals/*.dat
|
||||
%{_datadir}/locale/de/LC_MESSAGES/crrcsim.mo
|
||||
%{_datadir}/locale/fr/LC_MESSAGES/crrcsim.mo
|
||||
%{_datadir}/locale/it/LC_MESSAGES/crrcsim.mo
|
||||
%{_mandir}/man1/crrcsim.1.gz
|
||||
%dir %{_datadir}/crrcsim
|
||||
%{_datadir}/crrcsim/*
|
||||
%dir %{_docdir}/crrcsim
|
||||
%{_docdir}/crrcsim/*
|
||||
%{_mandir}/man1/crrcsim.1*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%changelog
|
||||
* Sun Sep 10 2023 Automatic Build System <autodist@mambasoft.it> 0.9.13-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Apr 01 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.9.12-2mamba
|
||||
- added buildrequires
|
||||
|
||||
* Sun Apr 01 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.9.12-1mamba
|
||||
- package created by autospec
|
||||
|
Loading…
Reference in New Issue
Block a user