214 lines
7.5 KiB
RPMSpec
214 lines
7.5 KiB
RPMSpec
Name: cracklib
|
|
Version: 2.10.2
|
|
Release: 1mamba
|
|
Summary: A password-checking library
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
Source0: https://github.com/cracklib/cracklib/releases/download/v%{version}/cracklib-%{version}.tar.bz2
|
|
Source1: https://github.com/cracklib/cracklib/releases/download/v%{version}/cracklib-words-%{version}.gz
|
|
Patch0: cracklib-2.7-redhat.patch.bz2
|
|
URL: https://sourceforge.net/projects/cracklib
|
|
License: Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libpython311-devel
|
|
BuildRequires: libz-devel
|
|
## AUTOBUILDREQ-END
|
|
|
|
%description
|
|
CrackLib tests passwords to determine whether they match certain security-oriented characteristics.
|
|
You can use CrackLib to stop users from choosing passwords which would be easy to guess.
|
|
CrackLib performs certain tests:
|
|
|
|
* It tries to generate words from a username and gecos entry and checks those words against the password;
|
|
* It checks for simplistic patterns in passwords;
|
|
* It checks for the password in a dictionary.
|
|
|
|
CrackLib is actually a library containing a particular C function which is used to check the password, as well as other C functions.
|
|
CrackLib is not a replacement for a passwd program; it must be used in conjunction with an existing passwd program.
|
|
|
|
%package -n libcrack
|
|
Summary: A password-checking library
|
|
Group: System/Libraries
|
|
Provides: cracklib
|
|
Obsoletes: cracklib < 2.9.7
|
|
Requires: libcrack-dicts = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n libcrack
|
|
CrackLib tests passwords to determine whether they match certain security-oriented characteristics.
|
|
You can use CrackLib to stop users from choosing passwords which would be easy to guess.
|
|
CrackLib performs certain tests:
|
|
|
|
* It tries to generate words from a username and gecos entry and checks those words against the password;
|
|
* It checks for simplistic patterns in passwords;
|
|
* It checks for the password in a dictionary.
|
|
|
|
CrackLib is actually a library containing a particular C function which is used to check the password, as well as other C functions.
|
|
CrackLib is not a replacement for a passwd program; it must be used in conjunction with an existing passwd program.
|
|
|
|
%package -n libcrack-devel
|
|
Summary: cracklib link library & header file
|
|
Group: Development/Libraries
|
|
Requires: libcrack = %{?epoch:%epoch:}%{version}-%{release}
|
|
Provides: cracklib-devel
|
|
Obsoletes: cracklib-devel < 2.9.7
|
|
|
|
%description -n libcrack-devel
|
|
The cracklib devel package include the needed library link and header files for development.
|
|
|
|
%package -n libcrack-dicts
|
|
Summary: The standard CrackLib dictionaries
|
|
Group: System/Libraries
|
|
Provides: cracklib-dicts
|
|
Obsoletes: cracklib-dicts < 2.9.7
|
|
|
|
%description -n libcrack-dicts
|
|
The cracklib-dicts package includes the CrackLib dictionaries.
|
|
CrackLib will need to use the dictionary appropriate to your system, which is normally put in /usr/share/dict/words.
|
|
Cracklib-dicts also contains the utilities necessary for the creation of new dictionaries.
|
|
If you are installing CrackLib, you should also install cracklib-dicts.
|
|
|
|
%package -n python-cracklib
|
|
Summary: Python bindings to the cracklib library
|
|
Group: System/Libraries/Python
|
|
Requires: libcrack = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n python-cracklib
|
|
This package provides the Python bindings to the cracklib library.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
chmod +x util/cracklib-format
|
|
|
|
mkdir -p dicts
|
|
install %{SOURCE1} dicts/
|
|
|
|
%build
|
|
%configure
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
|
|
%makeinstall
|
|
util/cracklib-format dicts/cracklib* | util/cracklib-packer %{buildroot}/%{_datadir}/cracklib/pw_dict
|
|
|
|
%find_lang %{name}
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
|
|
%files -n libcrack -f %{name}.lang
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libcrack.so.*
|
|
%dir %{_datadir}/cracklib
|
|
%{_datadir}/cracklib/cracklib.magic
|
|
%doc COPYING.LIB
|
|
|
|
%files -n libcrack-devel
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libcrack.so
|
|
%{_includedir}/crack.h
|
|
%{_includedir}/packer.h
|
|
%{_libdir}/libcrack.a
|
|
%{_mandir}/man3/FascistCheck.3*
|
|
|
|
%files -n libcrack-dicts
|
|
%defattr(-,root,root)
|
|
%{_sbindir}/create-cracklib-dict
|
|
%{_sbindir}/cracklib-*
|
|
%{_datadir}/cracklib/cracklib-small
|
|
%{_datadir}/cracklib/pw_dict.hwm
|
|
%{_datadir}/cracklib/pw_dict.pwd
|
|
%{_datadir}/cracklib/pw_dict.pwi
|
|
%{_mandir}/man8/cracklib-*.8*
|
|
%{_mandir}/man8/create-cracklib-dict.8*
|
|
|
|
%files -n python-cracklib
|
|
%defattr(-,root,root)
|
|
%{python3_sitelib}/__pycache__/cracklib.cpython-311*.pyc
|
|
%{python3_sitelib}/__pycache__/test_cracklib.cpython-311*.pyc
|
|
%{python3_sitelib}/cracklib.py
|
|
%{python3_sitelib}/test_cracklib.py
|
|
%{python3_sitearch}/_cracklib.a
|
|
%{python3_sitearch}/_cracklib.so
|
|
|
|
%changelog
|
|
* Sun Aug 04 2024 Automatic Build System <autodist@openmamba.org> 2.10.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jul 27 2024 Automatic Build System <autodist@openmamba.org> 2.10.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jul 21 2024 Automatic Build System <autodist@openmamba.org> 2.10.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Apr 03 2023 Automatic Build System <autodist@mambasoft.it> 2.9.11-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 18 2023 Automatic Build System <autodist@mambasoft.it> 2.9.10-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 04 2022 Automatic Build System <autodist@mambasoft.it> 2.9.8-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 10 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.7-2mamba
|
|
- rebuilt with fixes
|
|
|
|
* Sat Oct 26 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.7-1mamba
|
|
- update to 2.9.7
|
|
|
|
* Sat Apr 30 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.9.6-1mamba
|
|
- update to 2.9.6
|
|
|
|
* Sun May 03 2015 Automatic Build System <autodist@mambasoft.it> 2.9.4-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon Aug 18 2014 Automatic Build System <autodist@mambasoft.it> 2.9.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jun 08 2013 Automatic Build System <autodist@mambasoft.it> 2.9.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 17 2012 Automatic Build System <autodist@mambasoft.it> 2.8.22-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 09 2010 Automatic Build System <autodist@mambasoft.it> 2.8.18-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat Aug 21 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.16-2mamba
|
|
- libcrack-dicts: do not require libcrack
|
|
|
|
* Tue Jun 22 2010 Automatic Build System <autodist@mambasoft.it> 2.8.16-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Jan 27 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.13-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Jun 24 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.10-1mamba
|
|
- update to 2.8.10
|
|
|
|
* Sat Oct 28 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7-5qilnx
|
|
- rename as libcrack (obsolete cracklib-*)
|
|
- fix libcrack.so: make it a symlink to libcrack.so.2.7 file
|
|
|
|
* Mon Dec 13 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7-4qilnx
|
|
- include libcrack.so.* in main package, not just libcrack.so.2.7
|
|
|
|
* Tue Jul 27 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.7-3qilnx
|
|
- trivial fixes in the specfile needed by the QiLinux distromatic parser
|
|
|
|
* Fri May 28 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.7-2qilnx
|
|
- added missing ldconfig calls
|
|
|
|
* Wed May 07 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it> 2.7-1qilnx
|
|
- creation of cracklib package
|