added chmod symlink patch to fix new error with rpmbuild [release 9.0-2mamba;Mon Nov 01 2021]

This commit is contained in:
Silvan Calarco 2024-01-05 21:31:12 +01:00
parent 5182e61a3e
commit 9f22ce91c1
3 changed files with 586 additions and 373 deletions

View File

@ -0,0 +1,114 @@
From c76e70637e529481478e26683ebd73c40621c382 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?P=C3=A1draig=20Brady?= <P@draigBrady.com>
Date: Fri, 24 Sep 2021 20:57:41 +0100
Subject: [PATCH] chmod: fix exit status when ignoring symlinks
* src/chmod.c: Reorder enum so CH_NOT_APPLIED
can be treated as a non error.
* tests/chmod/ignore-symlink.sh: A new test.
* tests/local.mk: Reference the new test.
* NEWS: Mention the bug fix.
Fixes https://bugs.gnu.org/50784
Upstream-commit: e8b56ebd536e82b15542a00c888109471936bfda
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
---
NEWS | 6 ++++++
src/chmod.c | 4 ++--
tests/chmod/ignore-symlink.sh | 31 +++++++++++++++++++++++++++++++
tests/local.mk | 1 +
4 files changed, 40 insertions(+), 2 deletions(-)
create mode 100755 tests/chmod/ignore-symlink.sh
diff --git a/NEWS b/NEWS
index f2fbcbb..5722a8b 100644
--- a/NEWS
+++ b/NEWS
@@ -143,6 +143,12 @@ GNU coreutils NEWS -*- outline -*-
where avx2 instructions are supported.
A new --debug option will indicate if avx2 is being used.
+** Bug fixes
+
+ chmod -R no longer exits with error status when encountering symlinks.
+ All files would be processed correctly, but the exit status was incorrect.
+ [bug introduced in coreutils-9.0]
+
* Noteworthy changes in release 8.32 (2020-03-05) [stable]
diff --git a/src/chmod.c b/src/chmod.c
index 37b04f5..57ac47f 100644
--- a/src/chmod.c
+++ b/src/chmod.c
@@ -44,8 +44,8 @@ struct change_status
enum
{
CH_NO_STAT,
- CH_NOT_APPLIED,
CH_FAILED,
+ CH_NOT_APPLIED,
CH_NO_CHANGE_REQUESTED,
CH_SUCCEEDED
}
@@ -322,7 +322,7 @@ process_file (FTS *fts, FTSENT *ent)
if ( ! recurse)
fts_set (fts, ent, FTS_SKIP);
- return CH_NO_CHANGE_REQUESTED <= ch.status;
+ return CH_NOT_APPLIED <= ch.status;
}
/* Recursively change the modes of the specified FILES (the last entry
diff --git a/tests/chmod/ignore-symlink.sh b/tests/chmod/ignore-symlink.sh
new file mode 100755
index 0000000..5ce3de8
--- /dev/null
+++ b/tests/chmod/ignore-symlink.sh
@@ -0,0 +1,31 @@
+#!/bin/sh
+# Test for proper exit code of chmod on a processed symlink.
+
+# Copyright (C) 2021 Free Software Foundation, Inc.
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+. "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
+print_ver_ chmod
+
+mkdir dir || framework_failure_
+touch dir/f || framework_failure_
+ln -s f dir/l || framework_failure_
+
+# This operation ignores symlinks but should succeed.
+chmod u+w -R dir 2> out || fail=1
+
+compare /dev/null out || fail=1
+
+Exit $fail
diff --git a/tests/local.mk b/tests/local.mk
index a76c808..a2164c9 100644
--- a/tests/local.mk
+++ b/tests/local.mk
@@ -458,6 +458,7 @@ all_tests = \
tests/chmod/c-option.sh \
tests/chmod/equal-x.sh \
tests/chmod/equals.sh \
+ tests/chmod/ignore-symlink.sh \
tests/chmod/inaccessible.sh \
tests/chmod/octal.sh \
tests/chmod/setgid.sh \
--
2.31.1

File diff suppressed because it is too large Load Diff

View File

@ -1,7 +1,7 @@
%define i18npatch_version 8.32
%define i18npatch_version 9.0
Name: coreutils
Version: 8.32
Release: 5mamba
Version: 9.0
Release: 2mamba
Summary: A GNU set of tools commonly used in shell scripts
Group: System/Tools
Vendor: openmamba
@ -23,6 +23,7 @@ Patch8: %{name}-6.9-rename_futimens.patch
Patch9: %{name}-8.4-cross_compile.patch
Patch10: %{name}-8.14-uname-1.patch
Patch11: coreutils-8.32-ls-removed-dir.patch
Patch12: coreutils-9.0-chmod-symlink.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -30,6 +31,7 @@ BuildRequires: libacl-devel
BuildRequires: libattr-devel
BuildRequires: libcap-devel
BuildRequires: libgmp-devel
BuildRequires: libopenssl-devel
BuildRequires: libselinux-devel
## AUTOBUILDREQ-END
%if "%{stage1}" != "1"
@ -103,11 +105,8 @@ Most of these programs have significant advantages over their Unix counterparts,
# maintain it here indefinitely
#%patch5 -p1 -b .pam
#%patch6 -p1 -b .uname_element_unknown.patch
#%patch10 -p1
%patch11 -p1
#%patch11 -p1
%patch12 -p1
# docs should say /var/run/[uw]tmp not /etc/[uw]tmp
sed -i 's,/etc/utmp,/var/run/utmp,g;
@ -215,6 +214,12 @@ done
%doc AUTHORS THANKS
%changelog
* Mon Nov 01 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 9.0-2mamba
- added chmod symlink patch to fix new error with rpmbuild
* Sun Oct 31 2021 Automatic Build System <autodist@mambasoft.it> 9.0-1mamba
- automatic version update by autodist
* Sun Apr 25 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 8.32-5mamba
- added patch to restore ls-removed-dir 8.31 behaviour (also fixes build on aarch64)