update to 1.9.0 [release 1.9.0-1mamba;Sun Jul 08 2012]

This commit is contained in:
Automatic Build System 2024-01-05 21:29:40 +01:00
parent d9f760ba41
commit 48f9dad8fa
4 changed files with 238 additions and 0 deletions

View File

@ -1,2 +1,28 @@
# conky
Conky has more than 250 built in objects, including support for:
* a plethora of OS stats (uname, uptime, CPU usage, mem usage, disk usage, "top" like process stats, and network monitoring, just to name a few)
* built in IMAP and POP3 support
* built in support for many popular music players (MPD, XMMS2, BMPx, Audacious)
... and much much more.
Conky can display this info either as text, or using simple progress bars and graph widgets, with different fonts and colours.
Conky is a free, light-weight system monitor for X, that displays any information on your desktop.
EXTRA
* Vim filetype detection and syntax highlighting scripts for conky.
Individual users can place them your personal .vim directory:
~/.vim/ftdetect/conkyrc.vim
~/.vim/syntax/conkyrc.vim
Refer to your vim site documentation for system-wide installation.
* conky.nanorc for nano text editor
Append the contents of conky.nanorc to your $HOME/.nanorc for nano
syntax coloring of your $HOME/.conkyrc file.

16
conky-1.6.0-rdtsc.patch Normal file
View File

@ -0,0 +1,16 @@
diff -up conky-1.6.0/src/linux.c.rdtsc conky-1.6.0/src/linux.c
--- conky-1.6.0/src/linux.c.rdtsc 2008-07-15 03:02:37.000000000 +0200
+++ conky-1.6.0/src/linux.c 2008-07-22 13:56:04.000000000 +0200
@@ -1061,9 +1061,11 @@ void get_adt746x_cpu(char *p_client_buff
unsigned long long int rdtsc(void)
{
unsigned long long int x;
+ unsigned int a, d;
- __asm__ volatile(".byte 0x0f, 0x31":"=A" (x));
- return x;
+ __asm__ volatile(".byte 0x0f, 0x31":"=a" (a),"=d" (d));
+ x = d;
+ return x << 32 | a;
}
#endif

24
conky-1.6.1-ifaddrs.patch Normal file
View File

@ -0,0 +1,24 @@
diff -up conky-1.6.1/src/linux.c.ifaddrs conky-1.6.1/src/linux.c
--- conky-1.6.1/src/linux.c.ifaddrs 2008-08-20 12:50:15.000000000 +0200
+++ conky-1.6.1/src/linux.c 2008-08-20 12:50:31.000000000 +0200
@@ -353,7 +353,7 @@ void update_net_stats(void)
for (i2 = 0; i2 < 16; i2++) {
struct net_stat *ns;
char *s, *p;
- char temp_addr[17];
+ char temp_addr[18];
long long r, t, last_recv, last_trans;
if (fgets(buf, 255, net_dev_fp) == NULL) {
@@ -380,9 +380,9 @@ void update_net_stats(void)
memset(&(ns->addr.sa_data), 0, 14);
if(NULL == ns->addrs)
- ns->addrs = (char*) malloc(17 * 16);
+ ns->addrs = (char*) malloc(17 * 16 + 1);
if(NULL != ns->addrs)
- memset(ns->addrs, 0, 17 * 16); /* Up to 17 chars per ip, max 16 interfaces. Nasty memory usage... */
+ memset(ns->addrs, 0, 17 * 16 + 1); /* Up to 17 chars per ip, max 16 interfaces. Nasty memory usage... */
last_recv = ns->recv;
last_trans = ns->trans;

172
conky.spec Normal file
View File

@ -0,0 +1,172 @@
Name: conky
Version: 1.9.0
Release: 1mamba
Summary: A light-weight system monitor
Group: System/X11
Vendor: openmamba
Distribution: openmamba
Packager: Automatic Build System <autodist@mambasoft.it>
URL: http://sourceforge.net/projects/conky/
Source: http://downloads.sourceforge.net/conky/conky-%{version}.tar.bz2
Patch0: conky-1.6.0-rdtsc.patch
Patch1: conky-1.6.1-ifaddrs.patch
License: GPL
BuildRequires: autoconf
BuildRequires: automake
## AUTOBUILDREQ-BEGIN
BuildRequires: audacious-devel
BuildRequires: glibc-devel
BuildRequires: libatk-devel
BuildRequires: libcairo-devel
BuildRequires: libcares-devel
BuildRequires: libcurl-devel
BuildRequires: libdbus-devel
BuildRequires: libdbus-glib-devel
BuildRequires: libe2fs-devel
BuildRequires: libexpat-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcrypt-devel
BuildRequires: libglib-devel
BuildRequires: libglitz-devel
BuildRequires: libgpg-error-devel
BuildRequires: libgtk-devel
BuildRequires: libidn-devel
BuildRequires: libiw-devel
BuildRequires: libkrb5-devel
BuildRequires: libmcs-devel
BuildRequires: libmowgli-devel
BuildRequires: libopenldap-devel
BuildRequires: libopenssl-devel
BuildRequires: libpango-devel
BuildRequires: libpixman-devel
BuildRequires: libpng-devel
BuildRequires: libsamplerate-devel
BuildRequires: libsasl-devel
BuildRequires: libselinux-devel
BuildRequires: libssh2-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libxcb-util-devel
BuildRequires: libXdamage-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXext-devel
BuildRequires: libXfixes-devel
BuildRequires: libXft-devel
BuildRequires: libxml2-devel
BuildRequires: libXrender-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
# * X11:
# X11 support: yes
# XDamage support: yes
# XDBE support: yes
# Xft support: yes
# * Music detection:
# Audacious: yes
# BMPx: no
# MPD: yes
# XMMS2: no
# * General:
# math: yes
# hddtemp: yes
# portmon: yes
# RSS: yes
# wireless: yes
# SMAPI: yes
# nvidia: no
# eve-online: yes
%description
Conky has more than 250 built in objects, including support for:
* a plethora of OS stats (uname, uptime, CPU usage, mem usage, disk usage, "top" like process stats, and network monitoring, just to name a few)
* built in IMAP and POP3 support
* built in support for many popular music players (MPD, XMMS2, BMPx, Audacious)
... and much much more.
Conky can display this info either as text, or using simple progress bars and graph widgets, with different fonts and colours.
Conky is a free, light-weight system monitor for X, that displays any information on your desktop.
EXTRA
* Vim filetype detection and syntax highlighting scripts for conky.
Individual users can place them your personal .vim directory:
~/.vim/ftdetect/conkyrc.vim
~/.vim/syntax/conkyrc.vim
Refer to your vim site documentation for system-wide installation.
* conky.nanorc for nano text editor
Append the contents of conky.nanorc to your $HOME/.nanorc for nano
syntax coloring of your $HOME/.conkyrc file.
%prep
%setup -q
#%patch1 -p1 -b .ifaddrs
%build
%configure --prefix=%{_prefix} \
--enable-wlan \
--enable-xft \
--enable-mpd \
--enable-audacious=yes \
--enable-seti \
--enable-rss \
--enable-double-buffer \
--enable-own-window \
--enable-debug \
--enable-proc-uptime \
--enable-smapi \
--enable-eve \
--with-x
## --enable-bmpx \ --enable-nvidia \
## --enable-xmms2 \
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%dir %{_sysconfdir}/conky
%config(noreplace) %{_sysconfdir}/conky/conky.conf
%config(noreplace) %{_sysconfdir}/conky/conky_no_x11.conf
%{_bindir}/conky
%{_mandir}/man1/conky.1.gz
%doc AUTHORS COPYING ChangeLog NEWS README TODO extras/*
%changelog
* Sun Jul 08 2012 Automatic Build System <autodist@mambasoft.it> 1.9.0-1mamba
- update to 1.9.0
* Sat Oct 09 2010 Automatic Build System <autodist@mambasoft.it> 1.8.1-1mamba
- automatic update by autodist
* Sun May 09 2010 Automatic Build System <autodist@mambasoft.it> 1.8.0-1mamba
- automatic update by autodist
* Fri Jun 19 2009 Automatic Build System <autodist@mambasoft.it> 1.6.1-3mamba
- automatic rebuild by autodist
* Sun May 17 2009 Automatic Build System <autodist@mambasoft.it> 1.6.1-2mamba
- automatic rebuild by autodist
* Thu Sep 04 2008 gil <puntogil@libero.it> 1.6.1-1mamba
- update to 1.6.1
- enable-audacious added options to configure
* Mon May 12 2008 gil <puntogil@libero.it> 1.5.1-1mamba
- package created by autospec