automatic version update by autodist [release 18.0.0-1mamba;Tue Jan 07 2025]
This commit is contained in:
parent
816f9659b0
commit
dedd5a9048
@ -1,28 +0,0 @@
|
|||||||
--- codelite-13.0/codelite_terminal/TextView.cpp.orig 2019-09-02 10:52:51.468000000 +0200
|
|
||||||
+++ codelite-13.0/codelite_terminal/TextView.cpp 2019-09-02 10:56:21.916000000 +0200
|
|
||||||
@@ -12,7 +12,7 @@
|
|
||||||
m_ctrl->SetCaretStyle(wxSTC_CARETSTYLE_BLOCK);
|
|
||||||
m_ctrl->SetYCaretPolicy(wxSTC_CARET_STRICT | wxSTC_CARET_SLOP, 4);
|
|
||||||
m_ctrl->SetLexer(wxSTC_LEX_CONTAINER);
|
|
||||||
- m_ctrl->StartStyling(0);
|
|
||||||
+ m_ctrl->StartStyling(0, 0);
|
|
||||||
m_ctrl->SetWrapMode(wxSTC_WRAP_CHAR);
|
|
||||||
#else
|
|
||||||
m_ctrl = new TextCtrl_t(this, wxID_ANY, "", wxDefaultPosition, wxDefaultSize,
|
|
||||||
@@ -61,7 +61,7 @@
|
|
||||||
{
|
|
||||||
#if USE_STC
|
|
||||||
m_defaultAttr = attr;
|
|
||||||
- m_ctrl->StartStyling(m_ctrl->GetLastPosition());
|
|
||||||
+ m_ctrl->StartStyling(m_ctrl->GetLastPosition(), 0);
|
|
||||||
#else
|
|
||||||
m_ctrl->SetDefaultStyle(attr);
|
|
||||||
#endif
|
|
||||||
@@ -210,6 +210,6 @@
|
|
||||||
#if USE_STC
|
|
||||||
m_ctrl->ClearAll();
|
|
||||||
m_ctrl->ClearDocumentStyle();
|
|
||||||
- m_ctrl->StartStyling(0);
|
|
||||||
+ m_ctrl->StartStyling(0, 0);
|
|
||||||
#endif
|
|
||||||
}
|
|
@ -1,21 +0,0 @@
|
|||||||
--- CMakeLists.txt 2019-10-09 12:20:58.359078260 +0200
|
|
||||||
+++ CMakeLists.txt 2019-10-09 13:30:15.743666144 +0200
|
|
||||||
@@ -245,14 +245,16 @@
|
|
||||||
find_package(GTK3)
|
|
||||||
set(CMAKE_MODULE_PATH ${OLD_CMAKE_MODULE_PATH}) # Reset, else the official path isn't used again :/
|
|
||||||
if (GTK3_FOUND)
|
|
||||||
- include_directories(${GTK3_INCLUDE_DIRS})
|
|
||||||
+ message("-- GTK3 found")
|
|
||||||
+ include_directories(${GTK3_INCLUDE_DIRS} /usr/include/harfbuzz/)
|
|
||||||
else (GTK3_FOUND)
|
|
||||||
message(FATAL_ERROR "Could not locate GTK.")
|
|
||||||
endif (GTK3_FOUND)
|
|
||||||
else()
|
|
||||||
find_package(GTK2)
|
|
||||||
if (GTK2_FOUND)
|
|
||||||
- include_directories(${GTK2_INCLUDE_DIRS})
|
|
||||||
+ message("-- GTK2 found")
|
|
||||||
+ include_directories(${GTK2_INCLUDE_DIRS} /usr/include/harfbuzz/)
|
|
||||||
else (GTK2_FOUND)
|
|
||||||
message(FATAL_ERROR "Could not locate GTK.")
|
|
||||||
endif (GTK2_FOUND)
|
|
@ -1,158 +0,0 @@
|
|||||||
diff -ru codelite-17.6.0/CodeLite/MSYS2.cpp codelite-17.6.0.patched/CodeLite/MSYS2.cpp
|
|
||||||
--- codelite-17.6.0/CodeLite/MSYS2.cpp 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/CodeLite/MSYS2.cpp 2023-09-01 16:05:31.191903677 +0200
|
|
||||||
@@ -6,11 +6,15 @@
|
|
||||||
#include <wx/arrstr.h>
|
|
||||||
#include <wx/stdpaths.h>
|
|
||||||
#include <wx/tokenzr.h>
|
|
||||||
+#include <wx/filename.h>
|
|
||||||
+#include <wx/utils.h>
|
|
||||||
|
|
||||||
#ifdef __WXMSW__
|
|
||||||
#include <wx/msw/registry.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+//using namespace std;
|
|
||||||
+
|
|
||||||
bool MSYS2::FindInstallDir(wxString* msyspath)
|
|
||||||
{
|
|
||||||
if(m_checked_for_install_dir) {
|
|
||||||
@@ -183,3 +187,4 @@
|
|
||||||
*value = ::wxJoin(paths_to_try, ';');
|
|
||||||
return true;
|
|
||||||
}
|
|
||||||
+
|
|
||||||
diff -ru codelite-17.6.0/CodeLite/MSYS2.hpp codelite-17.6.0.patched/CodeLite/MSYS2.hpp
|
|
||||||
--- codelite-17.6.0/CodeLite/MSYS2.hpp 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/CodeLite/MSYS2.hpp 2023-09-01 16:04:55.549773010 +0200
|
|
||||||
@@ -3,6 +3,8 @@
|
|
||||||
|
|
||||||
#include "PlatformCommon.hpp"
|
|
||||||
#include "codelite_exports.h"
|
|
||||||
+#include <wx/arrstr.h>
|
|
||||||
+//#include <wx/filename.h>
|
|
||||||
|
|
||||||
class WXDLLIMPEXP_CL MSYS2 : public PlatformCommon
|
|
||||||
{
|
|
||||||
diff -ru codelite-17.6.0/CodeLite/istorage.h codelite-17.6.0.patched/CodeLite/istorage.h
|
|
||||||
--- codelite-17.6.0/CodeLite/istorage.h 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/CodeLite/istorage.h 2023-09-01 16:17:34.974367687 +0200
|
|
||||||
@@ -31,6 +31,7 @@
|
|
||||||
#include "fileentry.h"
|
|
||||||
#include "pptable.h"
|
|
||||||
#include "tag_tree.h"
|
|
||||||
+#include <wx/filename.h>
|
|
||||||
|
|
||||||
#define MAX_SEARCH_LIMIT 250
|
|
||||||
|
|
||||||
diff -ru codelite-17.6.0/LiteEditor/ContextRust.cpp codelite-17.6.0.patched/LiteEditor/ContextRust.cpp
|
|
||||||
--- codelite-17.6.0/LiteEditor/ContextRust.cpp 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/LiteEditor/ContextRust.cpp 2023-09-01 19:41:34.386045403 +0200
|
|
||||||
@@ -33,6 +33,7 @@
|
|
||||||
#include "editor_config.h"
|
|
||||||
|
|
||||||
#include <unordered_set>
|
|
||||||
+#include <wx/xrc/xmlres.h>
|
|
||||||
|
|
||||||
ContextRust::ContextRust(clEditor* editor)
|
|
||||||
: ContextGeneric(editor, "rust")
|
|
||||||
diff -ru codelite-17.6.0/LiteEditor/clConfigurationSelectionCtrl.h codelite-17.6.0.patched/LiteEditor/clConfigurationSelectionCtrl.h
|
|
||||||
--- codelite-17.6.0/LiteEditor/clConfigurationSelectionCtrl.h 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/LiteEditor/clConfigurationSelectionCtrl.h 2023-09-01 19:50:31.153164609 +0200
|
|
||||||
@@ -6,6 +6,7 @@
|
|
||||||
|
|
||||||
#include <wx/arrstr.h>
|
|
||||||
#include <wx/panel.h>
|
|
||||||
+#include <wx/choice.h>
|
|
||||||
|
|
||||||
#define OPEN_CONFIG_MGR_STR _("Open Workspace Configuration Manager...")
|
|
||||||
|
|
||||||
diff -ru codelite-17.6.0/LiteEditor/tabgroupmanager.h codelite-17.6.0.patched/LiteEditor/tabgroupmanager.h
|
|
||||||
--- codelite-17.6.0/LiteEditor/tabgroupmanager.h 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/LiteEditor/tabgroupmanager.h 2023-09-01 20:14:29.012198636 +0200
|
|
||||||
@@ -33,6 +33,7 @@
|
|
||||||
#include <wx/arrstr.h>
|
|
||||||
#include <wx/event.h>
|
|
||||||
#include <wx/string.h>
|
|
||||||
+#include <wx/xml/xml.h>
|
|
||||||
|
|
||||||
/**
|
|
||||||
* Each pair consists of the tabgroup name, and an array of the names of the constituent tabs
|
|
||||||
diff -ru codelite-17.6.0/Plugin/DiffUI.h codelite-17.6.0.patched/Plugin/DiffUI.h
|
|
||||||
--- codelite-17.6.0/Plugin/DiffUI.h 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/Plugin/DiffUI.h 2023-09-01 16:27:07.076455148 +0200
|
|
||||||
@@ -29,6 +29,7 @@
|
|
||||||
#include <wx/persist/toplevel.h>
|
|
||||||
#include <wx/persist/treebook.h>
|
|
||||||
#endif
|
|
||||||
+#include <wx/frame.h>
|
|
||||||
|
|
||||||
#ifdef WXC_FROM_DIP
|
|
||||||
#undef WXC_FROM_DIP
|
|
||||||
diff -ru codelite-17.6.0/Plugin/clEditorEditEventsHandler.cpp codelite-17.6.0.patched/Plugin/clEditorEditEventsHandler.cpp
|
|
||||||
--- codelite-17.6.0/Plugin/clEditorEditEventsHandler.cpp 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/Plugin/clEditorEditEventsHandler.cpp 2023-09-01 16:41:58.642092030 +0200
|
|
||||||
@@ -6,6 +6,7 @@
|
|
||||||
#include <wx/stc/stc.h>
|
|
||||||
#include <wx/textctrl.h>
|
|
||||||
#include <wx/textentry.h>
|
|
||||||
+#include <wx/app.h>
|
|
||||||
|
|
||||||
clEditEventsHandler::clEditEventsHandler(wxStyledTextCtrl* wnd, const wxString& name)
|
|
||||||
: m_stc(wnd)
|
|
||||||
diff -ru codelite-17.6.0/Plugin/clFileSystemWorkspaceView.hpp codelite-17.6.0.patched/Plugin/clFileSystemWorkspaceView.hpp
|
|
||||||
--- codelite-17.6.0/Plugin/clFileSystemWorkspaceView.hpp 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/Plugin/clFileSystemWorkspaceView.hpp 2023-09-01 16:44:29.832448701 +0200
|
|
||||||
@@ -6,6 +6,7 @@
|
|
||||||
#include "clTreeCtrlPanel.h"
|
|
||||||
#include "cl_command_event.h"
|
|
||||||
#include "cl_config.h"
|
|
||||||
+#include <wx/choice.h>
|
|
||||||
|
|
||||||
class clThemedButton;
|
|
||||||
class WXDLLIMPEXP_SDK clFileSystemWorkspaceView : public clTreeCtrlPanel
|
|
||||||
diff -ru codelite-17.6.0/Plugin/clPluginsFindBar.h codelite-17.6.0.patched/Plugin/clPluginsFindBar.h
|
|
||||||
--- codelite-17.6.0/Plugin/clPluginsFindBar.h 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/Plugin/clPluginsFindBar.h 2023-09-01 16:28:53.779576592 +0200
|
|
||||||
@@ -33,6 +33,7 @@
|
|
||||||
#include <codelite_exports.h>
|
|
||||||
#include <wx/combobox.h>
|
|
||||||
#include <wx/panel.h>
|
|
||||||
+#include <wx/stattext.h>
|
|
||||||
|
|
||||||
class wxStyledTextCtrl;
|
|
||||||
|
|
||||||
diff -ru codelite-17.6.0/Plugin/wxTerminalCtrl/wxTerminalEvent.hpp codelite-17.6.0.patched/Plugin/wxTerminalCtrl/wxTerminalEvent.hpp
|
|
||||||
--- codelite-17.6.0/Plugin/wxTerminalCtrl/wxTerminalEvent.hpp 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/Plugin/wxTerminalCtrl/wxTerminalEvent.hpp 2023-09-01 17:16:16.773605826 +0200
|
|
||||||
@@ -6,6 +6,7 @@
|
|
||||||
#include <wx/arrstr.h>
|
|
||||||
#include <wx/ffile.h>
|
|
||||||
#include <wx/utils.h>
|
|
||||||
+#include <wx/event.h>
|
|
||||||
|
|
||||||
/// a wxCommandEvent that takes ownership of the clientData
|
|
||||||
class WXDLLIMPEXP_SDK wxTerminalEvent : public wxCommandEvent
|
|
||||||
diff -ru codelite-17.6.0/Plugin/wxTerminalCtrl/wxTerminalInputCtrl.cpp codelite-17.6.0.patched/Plugin/wxTerminalCtrl/wxTerminalInputCtrl.cpp
|
|
||||||
--- codelite-17.6.0/Plugin/wxTerminalCtrl/wxTerminalInputCtrl.cpp 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/Plugin/wxTerminalCtrl/wxTerminalInputCtrl.cpp 2023-09-01 17:18:48.056591588 +0200
|
|
||||||
@@ -14,6 +14,7 @@
|
|
||||||
#include <wx/dcmemory.h>
|
|
||||||
#include <wx/tokenzr.h>
|
|
||||||
#include <wx/uiaction.h>
|
|
||||||
+#include <wx/menu.h>
|
|
||||||
|
|
||||||
#define CAN_GO_BACK() (true)
|
|
||||||
#define CAN_DELETE() (true)
|
|
||||||
diff -ru codelite-17.6.0/Remoty/sample_codelite_remote_json.cpp codelite-17.6.0.patched/Remoty/sample_codelite_remote_json.cpp
|
|
||||||
--- codelite-17.6.0/Remoty/sample_codelite_remote_json.cpp 2023-08-31 20:09:33.000000000 +0200
|
|
||||||
+++ codelite-17.6.0.patched/Remoty/sample_codelite_remote_json.cpp 2023-09-01 19:11:03.703637315 +0200
|
|
||||||
@@ -1,6 +1,8 @@
|
|
||||||
#ifndef SAMPLE_CODELITE_REMOTE_JSON_HPP
|
|
||||||
#define SAMPLE_CODELITE_REMOTE_JSON_HPP
|
|
||||||
|
|
||||||
+#include <wx/string.h>
|
|
||||||
+
|
|
||||||
const wxString DEFAULT_CODELITE_REMOTE_JSON = R"EOF(
|
|
||||||
{
|
|
||||||
"Language Server Plugin": {
|
|
@ -1,5 +1,5 @@
|
|||||||
Name: codelite
|
Name: codelite
|
||||||
Version: 17.6.0
|
Version: 18.0.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: An IDE for the C/C++/PHP/Node.js programming languages
|
Summary: An IDE for the C/C++/PHP/Node.js programming languages
|
||||||
Group: Applications/Development
|
Group: Applications/Development
|
||||||
@ -8,9 +8,6 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://codelite.org/
|
URL: https://codelite.org/
|
||||||
Source: https://github.com/eranif/codelite.git/%{version}/codelite-%{version}.tar.bz2
|
Source: https://github.com/eranif/codelite.git/%{version}/codelite-%{version}.tar.bz2
|
||||||
Patch0: codelite-13.0-wxWidgets-3.0.4.patch
|
|
||||||
Patch1: codelite-16.1.0-include-harfbuzz.patch
|
|
||||||
Patch2: codelite-17.6.0-wxwidgets-3.2.2.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -26,7 +23,7 @@ BuildRequires: libsqlite-devel
|
|||||||
BuildRequires: libssh-devel
|
BuildRequires: libssh-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libuchardet-devel
|
BuildRequires: libuchardet-devel
|
||||||
BuildRequires: libyaml-cpp-devel
|
BuildRequires: libyaml-cpp
|
||||||
BuildRequires: wxwidgets-devel
|
BuildRequires: wxwidgets-devel
|
||||||
BuildRequires: wxwidgets-gtk3-devel
|
BuildRequires: wxwidgets-gtk3-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
@ -38,14 +35,8 @@ BuildRequires: liblldb-devel
|
|||||||
%description
|
%description
|
||||||
An IDE for the C/C++/PHP/Node.js programming languages.
|
An IDE for the C/C++/PHP/Node.js programming languages.
|
||||||
|
|
||||||
%debug_package
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
|
||||||
#%patch1 -p0 -b .include-harfbuzz
|
|
||||||
%patch 2 -p1
|
|
||||||
|
|
||||||
%ifarch x86_64 aarch64
|
%ifarch x86_64 aarch64
|
||||||
sed -i 's|"lib"|"lib64"|' CMakeLists.txt
|
sed -i 's|"lib"|"lib64"|' CMakeLists.txt
|
||||||
%endif
|
%endif
|
||||||
@ -72,22 +63,24 @@ sed -i 's|"lib"|"lib64"|' CMakeLists.txt
|
|||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/cc-wrapper
|
||||||
%{_bindir}/codelite*
|
%{_bindir}/codelite*
|
||||||
%{_bindir}/ctagsd*
|
%{_bindir}/ctagsd*
|
||||||
%dir %{_libdir}/codelite
|
%dir %{_libdir}/codelite
|
||||||
%{_libdir}/codelite/*.so
|
%{_libdir}/codelite/*.so
|
||||||
%dir %{_libdir}/codelite/debuggers
|
%dir %{_libdir}/codelite/debuggers
|
||||||
%{_libdir}/codelite/debuggers/DebuggerGDB.so
|
%{_libdir}/codelite/debuggers/DebuggerGDB.so
|
||||||
%{_datadir}/applications/codelite.desktop
|
%{_datadir}/applications/codelite*.desktop
|
||||||
%{_datadir}/icons/hicolor/*/apps/codelite.png
|
%{_metainfodir}/org.codelite.codelite.metainfo.xml
|
||||||
%dir %{_datadir}/codelite
|
%dir %{_datadir}/codelite
|
||||||
%{_datadir}/codelite/*
|
%{_datadir}/codelite/*
|
||||||
#%{_mandir}/man1/codelite-make.1*
|
%{_datadir}/icons/hicolor/*/apps/codelite.png
|
||||||
#%{_mandir}/man1/codelite.1*
|
|
||||||
#%{_mandir}/man1/codelite_fix_files.1*
|
|
||||||
%doc AUTHORS COPYING LICENSE
|
%doc AUTHORS COPYING LICENSE
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 07 2025 Automatic Build System <autodist@openmamba.org> 18.0.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Thu Aug 31 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 17.6.0-1mamba
|
* Thu Aug 31 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 17.6.0-1mamba
|
||||||
- update to 17.6.0
|
- update to 17.6.0
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user