update to 13.0 [release 13.0-1mamba;Sat Aug 31 2019]
This commit is contained in:
parent
c2f204e7d7
commit
28b88406b5
28
codelite-13.0-wxWidgets-3.0.4.patch
Normal file
28
codelite-13.0-wxWidgets-3.0.4.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
--- codelite-13.0/codelite_terminal/TextView.cpp.orig 2019-09-02 10:52:51.468000000 +0200
|
||||||
|
+++ codelite-13.0/codelite_terminal/TextView.cpp 2019-09-02 10:56:21.916000000 +0200
|
||||||
|
@@ -12,7 +12,7 @@
|
||||||
|
m_ctrl->SetCaretStyle(wxSTC_CARETSTYLE_BLOCK);
|
||||||
|
m_ctrl->SetYCaretPolicy(wxSTC_CARET_STRICT | wxSTC_CARET_SLOP, 4);
|
||||||
|
m_ctrl->SetLexer(wxSTC_LEX_CONTAINER);
|
||||||
|
- m_ctrl->StartStyling(0);
|
||||||
|
+ m_ctrl->StartStyling(0, 0);
|
||||||
|
m_ctrl->SetWrapMode(wxSTC_WRAP_CHAR);
|
||||||
|
#else
|
||||||
|
m_ctrl = new TextCtrl_t(this, wxID_ANY, "", wxDefaultPosition, wxDefaultSize,
|
||||||
|
@@ -61,7 +61,7 @@
|
||||||
|
{
|
||||||
|
#if USE_STC
|
||||||
|
m_defaultAttr = attr;
|
||||||
|
- m_ctrl->StartStyling(m_ctrl->GetLastPosition());
|
||||||
|
+ m_ctrl->StartStyling(m_ctrl->GetLastPosition(), 0);
|
||||||
|
#else
|
||||||
|
m_ctrl->SetDefaultStyle(attr);
|
||||||
|
#endif
|
||||||
|
@@ -210,6 +210,6 @@
|
||||||
|
#if USE_STC
|
||||||
|
m_ctrl->ClearAll();
|
||||||
|
m_ctrl->ClearDocumentStyle();
|
||||||
|
- m_ctrl->StartStyling(0);
|
||||||
|
+ m_ctrl->StartStyling(0, 0);
|
||||||
|
#endif
|
||||||
|
}
|
@ -1,5 +1,5 @@
|
|||||||
Name: codelite
|
Name: codelite
|
||||||
Version: 11.0
|
Version: 13.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: An IDE for the C/C++/PHP/Node.js programming languages
|
Summary: An IDE for the C/C++/PHP/Node.js programming languages
|
||||||
Group: Applications/Development
|
Group: Applications/Development
|
||||||
@ -9,6 +9,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: http://www.codelite.org/
|
URL: http://www.codelite.org/
|
||||||
## GITSOURCE https://github.com/eranif/codelite.git 9.1
|
## GITSOURCE https://github.com/eranif/codelite.git 9.1
|
||||||
Source: https://github.com/eranif/codelite.git/%{version}/codelite-%{version}.tar.bz2
|
Source: https://github.com/eranif/codelite.git/%{version}/codelite-%{version}.tar.bz2
|
||||||
|
Patch0: codelite-13.0-wxWidgets-3.0.4.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -40,13 +41,18 @@ An IDE for the C/C++/PHP/Node.js programming languages.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#-D -T
|
#-D -T
|
||||||
|
%patch0 -p1
|
||||||
%ifarch x86_64
|
%ifarch x86_64
|
||||||
sed -i 's|"lib"|"lib64"|' CMakeLists.txt
|
sed -i 's|"lib"|"lib64"|' CMakeLists.txt
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
-DPREFIX=%{_prefix}
|
-DPREFIX=%{_prefix} \
|
||||||
|
-DCMAKE_CXX_FLAGS="-I/usr/include/harfbuzz" \
|
||||||
|
-DENABLE_CLANG=1 \
|
||||||
|
-DENABLE_LLDB=1 \
|
||||||
|
-DWITH_MYSQL=1
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
@ -76,6 +82,9 @@ sed -i 's|"lib"|"lib64"|' CMakeLists.txt
|
|||||||
%doc AUTHORS COPYING LICENSE
|
%doc AUTHORS COPYING LICENSE
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Aug 31 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 13.0-1mamba
|
||||||
|
- update to 13.0
|
||||||
|
|
||||||
* Thu Nov 30 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 11.0-1mamba
|
* Thu Nov 30 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 11.0-1mamba
|
||||||
- update to 11.0
|
- update to 11.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user