automatic version update by autodist [release 13.12-1mamba;Sun Dec 29 2013]

This commit is contained in:
Automatic Build System 2024-01-05 21:28:00 +01:00
parent 6bf24b9fe3
commit 5b5cbdab89
3 changed files with 169 additions and 0 deletions

View File

@ -1,2 +1,11 @@
# codeblocks
Code::Blocks is a free C++ IDE built to meet the most demanding needs of its users.
It is designed to be very extensible and fully configurable.
An IDE with all the features you need, having a consistent look, feel and operation across platforms.
Built around a plugin framework, Code::Blocks can be extended with plugins.
Any kind of functionality can be added by installing/coding a plugin.
For instance, compiling and debugging functionality is already provided by plugins!

View File

@ -0,0 +1,11 @@
--- codeblocks-10.05-release/src/sdk/globals.cpp.orig 2010-05-22 12:10:05.000000000 +0200
+++ codeblocks-10.05-release/src/sdk/globals.cpp 2011-05-28 12:13:07.000000000 +0200
@@ -47,7 +47,7 @@
const wxString DEFAULT_ARRAY_SEP = _T(";");
#ifndef __WXMAC__
-const wxString DEFAULT_CONSOLE_TERM = _T("xterm -T $TITLE -e");
+const wxString DEFAULT_CONSOLE_TERM = _T("konsole --workdir=$WORKDIR --title $TITLE -e");
#else
const wxString DEFAULT_CONSOLE_TERM = _T("osascript -e 'tell app \"Terminal\"' -e 'activate' -e 'do script \"$SCRIPT\"' -e 'end tell'");
#endif

149
codeblocks.spec Normal file
View File

@ -0,0 +1,149 @@
%define libname libcodeblocks
Name: codeblocks
Version: 13.12
Release: 1mamba
Summary: An open source cross platform free C++ IDE
Group: Graphical Desktop/Applications/Development
Vendor: openmamba
Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
URL: http://www.codeblocks.org/
# FIXME: real url is http://download.berlios.de/codeblocks/codeblocks_12.11-1.tar.gz/from_sourceforge
Source: http://download.berlios.de/codeblocks/codeblocks_%{version}-1.tar.gz
Patch1: codeblocks-10.05-konsole.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libatk-devel
BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libgtk-devel
BuildRequires: libpango-devel
BuildRequires: libpng-devel
BuildRequires: libstdc++6-devel
BuildRequires: libwxBase-unicode-devel
BuildRequires: libwxGTK-unicode-devel
BuildRequires: libX11-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: udev-devel
Requires: konsole
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Code::Blocks is a free C++ IDE built to meet the most demanding needs of its users.
It is designed to be very extensible and fully configurable.
An IDE with all the features you need, having a consistent look, feel and operation across platforms.
Built around a plugin framework, Code::Blocks can be extended with plugins.
Any kind of functionality can be added by installing/coding a plugin.
For instance, compiling and debugging functionality is already provided by plugins!
%package -n %{libname}
Summary: Shared library for Code::Blocks
Group: System/Libraries
%description -n %{libname}
Shared libraries for Code::Blocks.
%package devel
Summary: Development headers for Code::Blocks
Group: Development/Libraries
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
This package contains static libraries and header files need for development.
%prep
%setup -q -c
mv codeblocks-%{version}*/* .
rm -rf codeblocks-%{version}*
%patch1 -p1
%build
%configure \
--with-contrib-plugins=all
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
# icons
install -d %{buildroot}%{_iconsdir}/hicolor/{16x16,32x32,48x48}/apps
convert -scale 48x48 src/mime/codeblocks.png \
%{buildroot}%{_iconsdir}/hicolor/48x48/apps/%{name}.png
convert -scale 32x32 src/mime/codeblocks.png \
%{buildroot}%{_iconsdir}/hicolor/32x32/apps/%{name}.png
convert -scale 16x16 src/mime/codeblocks.png \
%{buildroot}%{_iconsdir}/hicolor/16x16/apps/%{name}.png
for f in %{buildroot}%{_libdir}/codeblocks/plugins/*.so
do
[ "$(basename $f .so)" != "libwxsmithcontribitems" ] && \
{ chrpath --list $f && chrpath --delete $f || :; }
done
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n %{libname} -p /sbin/ldconfig
%postun -n %{libname} -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/cb_console_runner
%{_bindir}/cb_share_config
%{_bindir}/codeblocks
%{_bindir}/codesnippets
%dir %{_datadir}/codeblocks
%{_datadir}/codeblocks/*
%{_datadir}/applications/codeblocks.desktop
%{_datadir}/icons/hicolor/48x48/mimetypes/application-x-codeblocks-workspace.png
%{_datadir}/icons/hicolor/48x48/mimetypes/application-x-codeblocks.png
%{_datadir}/mime/packages/codeblocks.xml
%{_datadir}/pixmaps/codeblocks.png
%{_mandir}/man1/cb_console_runner.1*
%{_mandir}/man1/cb_share_config.1*
%{_mandir}/man1/codeblocks.1*
%{_mandir}/man1/codesnippets.1*
%files -n %{libname}
%defattr(-,root,root)
%{_libdir}/libcodeblocks.so.*
%{_libdir}/libwxsmithlib.so.*
%dir %{_libdir}/codeblocks
%{_libdir}/codeblocks/*
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
%dir %{_includedir}/codeblocks
%{_includedir}/codeblocks/*
%dir %{_includedir}/wxsmith
%{_includedir}/wxsmith/*
%{_libdir}/libcodeblocks.la
%{_libdir}/libcodeblocks.so
%{_libdir}/libwxsmithlib.la
%{_libdir}/libwxsmithlib.so
%{_libdir}/pkgconfig/*.pc
%doc BUGS ChangeLog NEWS README TODO
%doc COMPILERS
%changelog
* Sun Dec 29 2013 Automatic Build System <autodist@mambasoft.it> 13.12-1mamba
- automatic version update by autodist
* Sat May 11 2013 Automatic Build System <autodist@mambasoft.it> 12.11-1mamba
- automatic version update by autodist
* Fri Feb 25 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 10.05-1mamba
- package created by autospec