update to 6.60 [release 6.60-1mamba;Mon Jul 08 2024]
This commit is contained in:
parent
0456a0d3ac
commit
117bfd39f6
@ -1,2 +1,5 @@
|
||||
# cnijfilter2
|
||||
|
||||
IJ Printer Driver for Linux.
|
||||
This IJ Printer Driver provides printing functions for Canon Inkjet printers operating under the CUPS (Common UNIX Printing System) environment.
|
||||
|
||||
|
10
cnijfilter2-6.60-gcc-14.1.1.patch
Normal file
10
cnijfilter2-6.60-gcc-14.1.1.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- cnijfilter2-source-6.60-1/lgmon3/src/keytext.c.orig 2024-07-08 17:16:52.104688832 +0200
|
||||
+++ cnijfilter2-source-6.60-1/lgmon3/src/keytext.c 2024-07-08 17:17:24.210773686 +0200
|
||||
@@ -37,6 +37,7 @@
|
||||
#include <unistd.h>
|
||||
#include <libxml/parser.h> /* Ver.2.80 */
|
||||
#include <string.h>
|
||||
+#include <stdlib.h>
|
||||
|
||||
#include "keytext.h"
|
||||
|
138
cnijfilter2.spec
Normal file
138
cnijfilter2.spec
Normal file
@ -0,0 +1,138 @@
|
||||
Name: cnijfilter2
|
||||
Version: 6.60
|
||||
Release: 1mamba
|
||||
Summary: CUPS Printer Drivers for Canon printers
|
||||
Group: System/Spooling
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.canon.com.au/home-printers
|
||||
Source: https://gdlp01.c-wss.com/gds/3/0100011753/01/cnijfilter2-source-%{version}-1.tar.gz
|
||||
Patch0: cnijfilter2-6.60-gcc-14.1.1.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libcups-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libusb-devel
|
||||
BuildRequires: libxml2-devel
|
||||
## AUTOBUILDREQ-END
|
||||
|
||||
%description
|
||||
IJ Printer Driver for Linux.
|
||||
This IJ Printer Driver provides printing functions for Canon Inkjet printers operating under the CUPS (Common UNIX Printing System) environment.
|
||||
|
||||
%package %{MODEL}series
|
||||
Summary: CUPS Printers Driver for Canon %{MODEL} printers
|
||||
License: GPL
|
||||
Group: System/Spooling
|
||||
Requires: %{name}-common = %{version}-%{release}
|
||||
|
||||
%description %{MODEL}series
|
||||
IJ Printer Driver for Linux.
|
||||
This IJ Printer Driver provides printing functions for Canon Inkjet printers operating under the CUPS (Common UNIX Printing System) environment.
|
||||
This package contains the CUPS Printers Driver for Canon %{MODEL} printers.
|
||||
|
||||
%package common
|
||||
Summary: Common files used by CUPS Printers Driver for Canon printers
|
||||
License: GPL
|
||||
Group: System/Spooling
|
||||
Requires: cups
|
||||
Requires(post):udev
|
||||
|
||||
%description common
|
||||
IJ Printer Driver for Linux.
|
||||
This IJ Printer Driver provides printing functions for Canon Inkjet printers operating under the CUPS (Common UNIX Printing System) environment.
|
||||
This package contains common files used by CUPS Printers Driver for Canon printers.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-source-%{version}-1
|
||||
sed -e '/GET_PROTOCOL/ s:^int:extern &:g' -i 'lgmon3/src/cnijlgmon3.c'
|
||||
%patch 0 -p1
|
||||
|
||||
%build
|
||||
for d in cmdtocanonij2 cmdtocanonij3 cnijbe2 lgmon3 rastertocanonij tocanonij tocnpwg; do
|
||||
cd $d
|
||||
./autogen.sh --prefix=%{_prefix} \
|
||||
--enable-libpath=%{_libdir}/bjlib2 \
|
||||
--enable-progpath=%{_bindir} \
|
||||
--datadir=%{_datadir} \
|
||||
LDFLAGS="-L../../com/libs_bin_%{_target_cpu}"
|
||||
|
||||
make
|
||||
cd ..
|
||||
done
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
# make and install files for printer packages
|
||||
mkdir -p %{buildroot}%{_libdir}/bjlib2
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
mkdir -p %{buildroot}%{_prefix}/lib/cups/{filter,backend}
|
||||
mkdir -p %{buildroot}%{_datadir}/cups/model
|
||||
|
||||
install -m644 com/ini/cnnet.ini %{buildroot}%{_libdir}/bjlib2
|
||||
install -sm755 com/libs_bin_%{_target_cpu}/*.so.* %{buildroot}%{_libdir}
|
||||
|
||||
for d in cmdtocanonij2 cmdtocanonij3 cnijbe2 lgmon3 rastertocanonij tocanonij tocnpwg; do
|
||||
cd $d
|
||||
%makeinstall
|
||||
cd ..
|
||||
done
|
||||
|
||||
%find_lang %{name} --all-name
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post %{MODEL}series
|
||||
/sbin/ldconfig
|
||||
:
|
||||
|
||||
%postun %{MODEL}series
|
||||
/sbin/ldconfig
|
||||
:
|
||||
|
||||
%post common
|
||||
if [ $1 -ge 1 ]; then
|
||||
/sbin/ldconfig
|
||||
/sbin/udevadm control --reload-rules 2> /dev/null
|
||||
/sbin/udevadm trigger --action=add --subsystem-match=usb 2> /dev/null
|
||||
fi
|
||||
:
|
||||
|
||||
%postun common
|
||||
/sbin/ldconfig
|
||||
:
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/cnijlgmon3
|
||||
%{_bindir}/tocanonij
|
||||
%{_bindir}/tocnpwg
|
||||
%{_prefix}/lib/cups/backend/cnijbe2
|
||||
%{_prefix}/lib/cups/filter/cmdtocanonij2
|
||||
%{_prefix}/lib/cups/filter/cmdtocanonij3
|
||||
%{_prefix}/lib/cups/filter/rastertocanonij
|
||||
%{_libdir}/bjlib2/cnnet.ini
|
||||
%{_libdir}/libcnbpcnclapicom2.so.*
|
||||
%{_libdir}/libcnbpnet20.so.*
|
||||
%{_libdir}/libcnbpnet30.so.*
|
||||
%{_libdir}/libcnnet2.so.*
|
||||
%dir %{_datadir}/cmdtocanonij2
|
||||
%{_datadir}/cmdtocanonij2/*
|
||||
%dir %{_datadir}/cmdtocanonij3
|
||||
%{_datadir}/cmdtocanonij3/*
|
||||
%dir %{_datadir}/cnijlgmon3
|
||||
%{_datadir}/cnijlgmon3/*
|
||||
%doc cmdtocanonij2/AUTHORS cmdtocanonij2/LICENSE
|
||||
|
||||
%changelog
|
||||
* Mon Jul 08 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 6.60-1mamba
|
||||
- update to 6.60
|
||||
|
||||
* Fri Sep 28 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user