105 lines
3.3 KiB
RPMSpec
105 lines
3.3 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
#% define pkgver %(echo $(echo %version | cut -d. -f1,2)_$(echo %version | cut -d. -f3))
|
|
|
|
Name: clusterssh
|
|
Version: 4.18
|
|
Release: 1mamba
|
|
Summary: Cluster Admin Via SSH
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org
|
|
Source: https://github.com/duncs/clusterssh.git/v%{version}/clusterssh-%{version}.tar.bz2
|
|
License: GPL, Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-Exception-Class
|
|
BuildRequires: perl-Tk
|
|
BuildRequires: perl-Try-Tiny
|
|
BuildRequires: perl-X11-Protocol
|
|
BuildRequires: perl-X11-Protocol-Other
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-Test-Trap
|
|
BuildRequires: perl-Test-PerlTidy
|
|
BuildRequires: perl-CPAN-Changes
|
|
BuildRequires: perl-X11-Protocol-Other
|
|
BuildRequires: perl-Perl-Tidy >= 20200110
|
|
Requires: perl >= %perl_major_ver
|
|
Requires: perl-Exception-Class
|
|
Requires: perl-Tk
|
|
Requires: perl-Try-Tiny
|
|
Requires: perl-X11-Protocol
|
|
BuildArch: noarch
|
|
|
|
%description
|
|
ClusterSSH is a tool for making the same change on multiple servers at the same time.
|
|
The 'cssh' command opens an administration console and an xterm to all specified hosts.
|
|
Any text typed into the administration console is replicated to all windows.
|
|
All windows may also be typed into directly.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%{__perl} Build.PL installdirs=vendor
|
|
./Build
|
|
#./Build test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
./Build install \
|
|
destdir="%{buildroot}" \
|
|
--install_path bindoc="%{_mandir}/man1" \
|
|
--install_path libdoc="%{_mandir}/man3"
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm -f $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
%doc AUTHORS THANKS
|
|
#Changes
|
|
|
|
%changelog
|
|
* Sat Oct 19 2024 Automatic Build System <autodist@openmamba.org> 4.18-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Apr 18 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 4.16-1mamba
|
|
- update to 4.16
|
|
|
|
* Sat Mar 24 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 4.13.2-1mamba
|
|
- update to 4.13.2
|
|
|
|
* Wed Feb 14 2018 Automatic Build System <autodist@mambasoft.it> 4.13-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 17 2017 Automatic Build System <autodist@mambasoft.it> 4.10_02-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 21 2017 Automatic Build System <autodist@mambasoft.it> 4.09-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Dec 20 2016 Automatic Build System <autodist@mambasoft.it> 4.08-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Nov 29 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 4.05-1mamba
|
|
- update to 4.05
|
|
|
|
* Sun May 25 2014 Automatic Build System <autodist@mambasoft.it> 4.02.04-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Feb 19 2014 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 4.02.03-1mamba
|
|
- package created using the webbuild interface
|