automatic version update by autodist [release 1.3.3-1mamba;Mon Jul 22 2013]
This commit is contained in:
parent
5735f5415a
commit
e145b01115
@ -1,2 +1,4 @@
|
|||||||
# cln
|
# cln
|
||||||
|
|
||||||
|
CLN is a library for efficient computations with all kinds of numbers in arbitrary precision.
|
||||||
|
|
||||||
|
68
cln-1.3.2-Pre-processor-fix-for-ARM.patch
Normal file
68
cln-1.3.2-Pre-processor-fix-for-ARM.patch
Normal file
@ -0,0 +1,68 @@
|
|||||||
|
diff -dur cln-1.2.2.backup/src/base/digitseq/cl_asm_arm_.cc cln-1.2.2/src/base/digitseq/cl_asm_arm_.cc
|
||||||
|
--- cln-1.2.2.backup/src/base/digitseq/cl_asm_arm_.cc 2001-05-25 16:00:18.000000000 -0400
|
||||||
|
+++ cln-1.2.2/src/base/digitseq/cl_asm_arm_.cc 2009-08-18 12:21:20.000000000 -0400
|
||||||
|
@@ -42,6 +42,7 @@
|
||||||
|
|
||||||
|
#define C(x) _##x
|
||||||
|
#define EXPORT(x) EXPORT x
|
||||||
|
+#define DECLARE_WORD(x) x
|
||||||
|
#define DECLARE_FUNCTION(x)
|
||||||
|
#define GLABEL(x) _##x
|
||||||
|
#define LABEL(x) _##x
|
||||||
|
@@ -70,15 +71,33 @@
|
||||||
|
lr .req r14
|
||||||
|
pc .req r15
|
||||||
|
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+#ifdef ASM_UNDERSCORE
|
||||||
|
#define C(x) _##x
|
||||||
|
#define EXPORT(x) .global _##x
|
||||||
|
+#define DECLARE_WORD(x) .word _##x
|
||||||
|
#if defined(__NetBSD__)
|
||||||
|
#define DECLARE_FUNCTION(x) .type _##x,%function
|
||||||
|
#else
|
||||||
|
#define DECLARE_FUNCTION(x)
|
||||||
|
#endif
|
||||||
|
-#define GLABEL(x) _##x##:
|
||||||
|
-#define LABEL(x) x##:
|
||||||
|
+#define GLABEL(x) _##x:
|
||||||
|
+
|
||||||
|
+#else
|
||||||
|
+#define C(x) x
|
||||||
|
+#define EXPORT(x) .global x
|
||||||
|
+#define DECLARE_WORD(x) .word x
|
||||||
|
+#if defined(__NetBSD__)
|
||||||
|
+#define DECLARE_FUNCTION(x) .type x,%function
|
||||||
|
+#else
|
||||||
|
+#define DECLARE_FUNCTION(x)
|
||||||
|
+#endif
|
||||||
|
+#define GLABEL(x) x:
|
||||||
|
+
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+#define LABEL(x) x:
|
||||||
|
#define RRX rrx
|
||||||
|
#define END
|
||||||
|
|
||||||
|
@@ -128,17 +147,17 @@
|
||||||
|
|
||||||
|
#ifdef MULU32_HIGH
|
||||||
|
ptr_mulu32_high:
|
||||||
|
- .word _mulu32_high
|
||||||
|
+ DECLARE_WORD(mulu32_high)
|
||||||
|
.align 0
|
||||||
|
#endif
|
||||||
|
#ifdef DIVU_16_REST
|
||||||
|
ptr_divu_16_rest:
|
||||||
|
- .word _divu_16_rest
|
||||||
|
+ DECLARE_WORD(divu_16_rest)
|
||||||
|
.align 0
|
||||||
|
#endif
|
||||||
|
#ifdef DIVU_32_REST
|
||||||
|
ptr_divu_32_rest:
|
||||||
|
- .word _divu_32_rest
|
||||||
|
+ DECLARE_WORD(divu_32_rest)
|
||||||
|
.align 0
|
||||||
|
#endif
|
||||||
|
|
90
cln.spec
Normal file
90
cln.spec
Normal file
@ -0,0 +1,90 @@
|
|||||||
|
Name: cln
|
||||||
|
Version: 1.3.3
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Class Library for Numbers
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||||
|
URL: http://www.ginac.de/CLN/
|
||||||
|
Source: http://www.ginac.de/CLN/cln-%{version}.tar.bz2
|
||||||
|
Patch0: %{name}-1.3.2-Pre-processor-fix-for-ARM.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libgmp-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
Requires(post):%{__install_info}
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
CLN is a library for efficient computations with all kinds of numbers in arbitrary precision.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
CLN is a library for efficient computations with all kinds of numbers in arbitrary precision.
|
||||||
|
This package contains header files need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_bindir}/pi
|
||||||
|
rm -f %{buildroot}%{_mandir}/man1/pi.*
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%preun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%post devel
|
||||||
|
%install_info cln.info
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%preun devel
|
||||||
|
%uninstall_info cln.info
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libcln.so.*
|
||||||
|
%doc COPYING
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/cln
|
||||||
|
%{_includedir}/cln/*.h
|
||||||
|
%{_libdir}/libcln.a
|
||||||
|
%{_libdir}/libcln.la
|
||||||
|
%{_libdir}/libcln.so
|
||||||
|
%{_libdir}/pkgconfig/cln.pc
|
||||||
|
%{_infodir}/cln.info.*
|
||||||
|
%doc ChangeLog NEWS README TODO
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jul 22 2013 Automatic Build System <autodist@mambasoft.it> 1.3.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu May 12 2011 Automatic Build System <autodist@mambasoft.it> 1.3.2-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sun Nov 21 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.1-2mamba
|
||||||
|
- rename specfile like package name
|
||||||
|
|
||||||
|
* Sat Aug 14 2010 Davide Madrisan <davide.madrisan@gmail.com> 1.3.1-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user