automatic version update by autodist [release 1.3.7-1mamba;Tue Jan 30 2024]
This commit is contained in:
parent
4627d65c5a
commit
a4197305ed
@ -1,68 +0,0 @@
|
|||||||
diff -dur cln-1.2.2.backup/src/base/digitseq/cl_asm_arm_.cc cln-1.2.2/src/base/digitseq/cl_asm_arm_.cc
|
|
||||||
--- cln-1.2.2.backup/src/base/digitseq/cl_asm_arm_.cc 2001-05-25 16:00:18.000000000 -0400
|
|
||||||
+++ cln-1.2.2/src/base/digitseq/cl_asm_arm_.cc 2009-08-18 12:21:20.000000000 -0400
|
|
||||||
@@ -42,6 +42,7 @@
|
|
||||||
|
|
||||||
#define C(x) _##x
|
|
||||||
#define EXPORT(x) EXPORT x
|
|
||||||
+#define DECLARE_WORD(x) x
|
|
||||||
#define DECLARE_FUNCTION(x)
|
|
||||||
#define GLABEL(x) _##x
|
|
||||||
#define LABEL(x) _##x
|
|
||||||
@@ -70,15 +71,33 @@
|
|
||||||
lr .req r14
|
|
||||||
pc .req r15
|
|
||||||
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+#ifdef ASM_UNDERSCORE
|
|
||||||
#define C(x) _##x
|
|
||||||
#define EXPORT(x) .global _##x
|
|
||||||
+#define DECLARE_WORD(x) .word _##x
|
|
||||||
#if defined(__NetBSD__)
|
|
||||||
#define DECLARE_FUNCTION(x) .type _##x,%function
|
|
||||||
#else
|
|
||||||
#define DECLARE_FUNCTION(x)
|
|
||||||
#endif
|
|
||||||
-#define GLABEL(x) _##x##:
|
|
||||||
-#define LABEL(x) x##:
|
|
||||||
+#define GLABEL(x) _##x:
|
|
||||||
+
|
|
||||||
+#else
|
|
||||||
+#define C(x) x
|
|
||||||
+#define EXPORT(x) .global x
|
|
||||||
+#define DECLARE_WORD(x) .word x
|
|
||||||
+#if defined(__NetBSD__)
|
|
||||||
+#define DECLARE_FUNCTION(x) .type x,%function
|
|
||||||
+#else
|
|
||||||
+#define DECLARE_FUNCTION(x)
|
|
||||||
+#endif
|
|
||||||
+#define GLABEL(x) x:
|
|
||||||
+
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+#define LABEL(x) x:
|
|
||||||
#define RRX rrx
|
|
||||||
#define END
|
|
||||||
|
|
||||||
@@ -128,17 +147,17 @@
|
|
||||||
|
|
||||||
#ifdef MULU32_HIGH
|
|
||||||
ptr_mulu32_high:
|
|
||||||
- .word _mulu32_high
|
|
||||||
+ DECLARE_WORD(mulu32_high)
|
|
||||||
.align 0
|
|
||||||
#endif
|
|
||||||
#ifdef DIVU_16_REST
|
|
||||||
ptr_divu_16_rest:
|
|
||||||
- .word _divu_16_rest
|
|
||||||
+ DECLARE_WORD(divu_16_rest)
|
|
||||||
.align 0
|
|
||||||
#endif
|
|
||||||
#ifdef DIVU_32_REST
|
|
||||||
ptr_divu_32_rest:
|
|
||||||
- .word _divu_32_rest
|
|
||||||
+ DECLARE_WORD(divu_32_rest)
|
|
||||||
.align 0
|
|
||||||
#endif
|
|
||||||
|
|
16
cln.spec
16
cln.spec
@ -1,14 +1,13 @@
|
|||||||
Name: cln
|
Name: cln
|
||||||
Version: 1.3.6
|
Version: 1.3.7
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Class Library for Numbers
|
Summary: Class Library for Numbers
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.ginac.de/CLN/
|
URL: https://www.ginac.de/CLN/
|
||||||
Source: http://www.ginac.de/CLN/cln-%{version}.tar.bz2
|
Source: http://www.ginac.de/CLN/cln-%{version}.tar.bz2
|
||||||
Patch0: %{name}-1.3.2-Pre-processor-fix-for-ARM.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -17,7 +16,6 @@ BuildRequires: libgmp-devel
|
|||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
Requires(post):%{__install_info}
|
Requires(post):%{__install_info}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
CLN is a library for efficient computations with all kinds of numbers in arbitrary precision.
|
CLN is a library for efficient computations with all kinds of numbers in arbitrary precision.
|
||||||
@ -31,9 +29,10 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
CLN is a library for efficient computations with all kinds of numbers in arbitrary precision.
|
CLN is a library for efficient computations with all kinds of numbers in arbitrary precision.
|
||||||
This package contains header files need for development.
|
This package contains header files need for development.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -45,6 +44,7 @@ This package contains header files need for development.
|
|||||||
|
|
||||||
rm -f %{buildroot}%{_bindir}/pi
|
rm -f %{buildroot}%{_bindir}/pi
|
||||||
rm -f %{buildroot}%{_mandir}/man1/pi.*
|
rm -f %{buildroot}%{_mandir}/man1/pi.*
|
||||||
|
rm -f %{buildroot}%{_infodir}/dir
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -70,13 +70,15 @@ exit 0
|
|||||||
%dir %{_includedir}/cln
|
%dir %{_includedir}/cln
|
||||||
%{_includedir}/cln/*.h
|
%{_includedir}/cln/*.h
|
||||||
%{_libdir}/libcln.a
|
%{_libdir}/libcln.a
|
||||||
%{_libdir}/libcln.la
|
|
||||||
%{_libdir}/libcln.so
|
%{_libdir}/libcln.so
|
||||||
%{_libdir}/pkgconfig/cln.pc
|
%{_libdir}/pkgconfig/cln.pc
|
||||||
%{_infodir}/cln.info.*
|
%{_infodir}/cln.info.*
|
||||||
%doc ChangeLog NEWS README TODO
|
%doc ChangeLog NEWS README TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 30 2024 Automatic Build System <autodist@openmamba.org> 1.3.7-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sat Dec 07 2019 Automatic Build System <autodist@mambasoft.it> 1.3.6-1mamba
|
* Sat Dec 07 2019 Automatic Build System <autodist@mambasoft.it> 1.3.6-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user