179 lines
5.7 KiB
RPMSpec
179 lines
5.7 KiB
RPMSpec
%define gitver %(echo %version | tr _ -)
|
|
Name: clementine
|
|
Version: 1.4.1
|
|
Release: 1mamba
|
|
Summary: A modern music player and library organiser
|
|
Group: Graphical Desktop/Applications/Multimedia
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://github.com/clementine-player/clementine
|
|
Source: https://github.com/clementine-player/Clementine.git/%{gitver}/Clementine-%{version}.tar.bz2
|
|
Patch0: clementine-1.4.1-cmake-fix-version.patch
|
|
Patch1: clementine-1.4.1-libcryptopp-8.9.0.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libQt5Concurrent
|
|
BuildRequires: libQt5Core
|
|
BuildRequires: libQt5DBus
|
|
BuildRequires: libQt5Gui
|
|
BuildRequires: libQt5Network
|
|
BuildRequires: libQt5OpenGL
|
|
BuildRequires: libQt5Sql
|
|
BuildRequires: libQt5Widgets
|
|
BuildRequires: libQt5X11Extras-devel
|
|
BuildRequires: libQt5Xml
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libabseil-cpp-devel
|
|
BuildRequires: libalsa-devel
|
|
BuildRequires: libcdio-devel
|
|
BuildRequires: libchromaprint-devel
|
|
BuildRequires: libfftw-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libgpod-devel
|
|
BuildRequires: libgst-plugins-base-devel
|
|
BuildRequires: libgstreamer-devel
|
|
BuildRequires: liblastfm5-devel
|
|
BuildRequires: libmtp-devel
|
|
BuildRequires: libmygpo-qt-devel
|
|
BuildRequires: libprojectm3-devel
|
|
BuildRequires: libprotobuf-devel
|
|
BuildRequires: libpulseaudio-devel
|
|
BuildRequires: libsqlite-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libtag-devel
|
|
BuildRequires: libz-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: libprotobuf-devel >= 28.2
|
|
|
|
%description
|
|
Clementine is a modern music player and library organiser. Clementine is a port of Amarok 1.4, with some features rewritten to take advantage of Qt4.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n Clementine-%{version}
|
|
#-D -T
|
|
#:<< _EOF
|
|
%patch 0 -p1
|
|
%patch 1 -p1 -b .libcryptopp-8.9.0
|
|
|
|
%build
|
|
#:<< _EOF
|
|
%cmake -d build \
|
|
-DCMAKE_CXX_FLAGS="-fpermissive" \
|
|
-DCMAKE_CXX_STANDARD=17 \
|
|
-DCMAKE_EXE_LINKER_FLAGS="`pkgconf --libs protobuf`" \
|
|
-DFORCE_GIT_REVISION=%{version} \
|
|
-DBUILD_WERROR=OFF \
|
|
-DUSE_SYSTEM_PROJECTM=ON \
|
|
-DUSE_SYSTEM_TAGLIB=ON
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post
|
|
update-desktop-database &> /dev/null || :
|
|
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
|
|
|
%postun
|
|
update-desktop-database &> /dev/null || :
|
|
if [ $1 -eq 0 ] ; then
|
|
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
|
|
%{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|
fi
|
|
:
|
|
|
|
%posttrans
|
|
%{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/clementine-tagreader
|
|
%{_bindir}/clementine
|
|
%{_datadir}/applications/org.clementine_player.Clementine.desktop
|
|
%{_datadir}/metainfo/org.clementine_player.Clementine.appdata.xml
|
|
%{_datadir}/kservices5/clementine-*.protocol
|
|
%{_datadir}/icons/hicolor/*/apps/*.png
|
|
%{_datadir}/icons/hicolor/*/apps/*.svg
|
|
%doc COPYING
|
|
|
|
%changelog
|
|
* Tue Oct 15 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.1-1mamba
|
|
- update to 1.4.1
|
|
|
|
* Sat May 07 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.0rc1_814_g2b340da79-1mamba
|
|
- update to 1.4.0rc1_814_g2b340da79
|
|
|
|
* Fri Nov 22 2019 Automatic Build System <autodist@mambasoft.it> 1.3.1.r831.664c5a31f-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 15 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.1.20190815git-1mamba
|
|
- update to 1.3.1.20190815git
|
|
|
|
* Sun Jul 10 2016 Automatic Build System <autodist@mambasoft.it> 1.3.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 29 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.3-4mamba
|
|
- rebuilt by autoport with build requirements: libchromaprint-devel>=1.3.1-1mamba
|
|
|
|
* Tue Dec 29 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.3-3mamba
|
|
- mass rebuild with libtag 1.9.1
|
|
|
|
* Fri Sep 05 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.3-2mamba
|
|
- rebuilt by autoport with build requirements: libplist-devel>=1.11-1mamba
|
|
|
|
* Sun Apr 27 2014 Automatic Build System <autodist@mambasoft.it> 1.2.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.2-1mamba
|
|
- update to 1.2.2
|
|
|
|
* Tue Nov 26 2013 Automatic Build System <autodist@mambasoft.it> 1.2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 19 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.0-2mamba
|
|
- rebuilt with protobuf 2.5.0
|
|
|
|
* Sun Oct 20 2013 Automatic Build System <autodist@mambasoft.it> 1.2.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Nov 18 2012 Automatic Build System <autodist@mambasoft.it> 1.1.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 28 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.0-2mamba
|
|
- require gst-plugins-good010 and gst-pluguns-ugly010 (devel)
|
|
|
|
* Sat Oct 27 2012 Automatic Build System <autodist@mambasoft.it> 1.1.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Aug 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1-2mamba
|
|
- rebuilt with protobuf 2.4.1
|
|
|
|
* Tue May 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1-1mamba
|
|
- update to 1.0.1
|
|
|
|
* Thu Nov 10 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.1-1mamba
|
|
- update to 0.7.1
|
|
|
|
* Sat Feb 19 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6-1mamba
|
|
- update to 0.6
|
|
|
|
* Fri Dec 03 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.3-1mamba
|
|
- update to 0.5.3
|
|
|
|
* Tue Sep 21 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
|
- update to 0.5.1
|
|
|
|
* Mon Sep 20 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5-1mamba
|
|
- package created by autospec
|