rebuilt with specfile fixes [release 9.0.302-2mamba;Tue Aug 24 2021]
This commit is contained in:
parent
34fe3cbaba
commit
30c3a01125
@ -1,4 +1,4 @@
|
||||
# ckermit
|
||||
|
||||
C-Kermit is a combined network and serial communication software package
|
||||
C-Kermit is a combined network and serial communication software package.
|
||||
|
||||
|
48
ckermit-9.0.302-lockdir.patch
Normal file
48
ckermit-9.0.302-lockdir.patch
Normal file
@ -0,0 +1,48 @@
|
||||
commit f956d739e9b1451eff1592fa640358877dcf958c
|
||||
Author: Samuel Tardieu <sam@rfc1149.net>
|
||||
Date: Thu Jul 19 20:53:24 2012 +0200
|
||||
|
||||
Use LOCK_DIR environment variable if defined instead of /var/lock
|
||||
|
||||
diff --git a/ckutio.c b/ckutio.c
|
||||
index 05564de..14b11cd 100644
|
||||
--- a/ckutio.c
|
||||
+++ b/ckutio.c
|
||||
@@ -4971,6 +4971,11 @@ ttglckdir() { /* Get Lockfile directory name */
|
||||
#endif /* __OpenBSD__ */
|
||||
}
|
||||
|
||||
+char *get_lockdir() {
|
||||
+ char *lockdir = getenv("LOCK_DIR");
|
||||
+ return lockdir ? lockdir : LOCK_DIR;
|
||||
+}
|
||||
+
|
||||
static int
|
||||
ttlock(ttdev) char *ttdev; {
|
||||
|
||||
@@ -5077,8 +5082,7 @@ ttlock(ttdev) char *ttdev; {
|
||||
char symlock[LFNAML]; /* Name for symlink lockfile name */
|
||||
#endif /* CKSYMLINK */
|
||||
char tmpnam[LFNAML+30]; /* Temporary lockfile name. */
|
||||
- char *lockdir = LOCK_DIR; /* Defined near top of this file, */
|
||||
- /* or on cc command line. */
|
||||
+ char *lockdir = get_lockdir();
|
||||
haslock = 0; /* Not locked yet. */
|
||||
*flfnam = '\0'; /* Lockfile name is empty. */
|
||||
lock2[0] = '\0'; /* Clear secondary lockfile name. */
|
||||
diff --git a/ckuus4.c b/ckuus4.c
|
||||
index 946603a..ba9afaf 100644
|
||||
--- a/ckuus4.c
|
||||
+++ b/ckuus4.c
|
||||
@@ -13882,8 +13882,9 @@ nvlook(s) char *s; {
|
||||
#ifdef UNIX
|
||||
case VN_LCKDIR: {
|
||||
#ifndef NOUUCP
|
||||
- extern char * uucplockdir;
|
||||
- ckstrncpy(vvbuf,uucplockdir,VVBUFL);
|
||||
+ extern char *get_lockdir();
|
||||
+ char * lockdir = get_lockdir();
|
||||
+ ckstrncpy(vvbuf,lockdir,VVBUFL);
|
||||
x = strlen(vvbuf);
|
||||
if (x > 0) {
|
||||
if (vvbuf[x-1] != '/') {
|
12
ckermit-9.0.304.24-glibc-2.28.patch
Normal file
12
ckermit-9.0.304.24-glibc-2.28.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ru z/ckucmd.c k/ckucmd.c
|
||||
--- z/ckucmd.c 2004-01-07 10:04:04.000000000 -0800
|
||||
+++ k/ckucmd.c 2019-01-01 15:52:44.798864262 -0800
|
||||
@@ -7103,7 +7103,7 @@
|
||||
|
||||
/* Here we must look inside the stdin buffer - highly platform dependent */
|
||||
|
||||
-#ifdef _IO_file_flags /* Linux */
|
||||
+#ifdef _IO_EOF_SEEN /* Linux */
|
||||
x = (int) ((stdin->_IO_read_end) - (stdin->_IO_read_ptr));
|
||||
debug(F101,"cmdconchk _IO_file_flags","",x);
|
||||
#else /* _IO_file_flags */
|
49
ckermit.spec
49
ckermit.spec
@ -1,36 +1,52 @@
|
||||
%define kermit_minver 211
|
||||
%define minver %(echo %version | cut -d. -f3-)
|
||||
Name: ckermit
|
||||
Version: 9.0.302
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: C-Kermit is a combined network and serial communication software package
|
||||
Group: Applications/Communication
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
||||
URL: http://www.columbia.edu/kermit/ck80.html
|
||||
Source: ftp://kermit.columbia.edu/kermit/archives/cku%{kermit_minver}.tar.gz
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.kermitproject.org/ck90.html
|
||||
Source: https://www.kermitproject.org/ftp/kermit/archives/cku%{minver}.tar.gz
|
||||
Patch0: %{name}-8.0-ckutio.patch
|
||||
Patch1: %{name}-8.0-makefile.patch
|
||||
Patch2: ckermit-9.0.304.24-glibc-2.28.patch
|
||||
Patch3: ckermit-9.0.302-lockdir.patch
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: liblockdev-devel
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: lrzsz
|
||||
|
||||
%description
|
||||
C-Kermit is a combined network and serial communication software package
|
||||
C-Kermit is a combined network and serial communication software package.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -c %{name}-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
#%patch3 -p1
|
||||
|
||||
%build
|
||||
%make linux
|
||||
%make linux \
|
||||
KFLAGS="-O0 $RPM_OPT_FLAGS -Wall -DOPENSSL_097 -Dsdata=s_data -DHAVE_OPENPTY -D'krb5_init_ets(__ctx)='" \
|
||||
LNKFLAGS="%{?optflags} %{?__global_ldflags}" \
|
||||
K4LIB= \
|
||||
K4INC= \
|
||||
K5LIB=-lutil \
|
||||
K5INC=-I%{_includedir}/et \
|
||||
SSLLIB= \
|
||||
SSLINC= \
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall prefix=%{_prefix}
|
||||
install -d -m0755 %{buildroot}%{_bindir} %{buildroot}%{_mandir}/man1
|
||||
|
||||
%makeinstall prefix=%{_prefix} MANDIR=%{_mandir}/man1
|
||||
|
||||
# fix an rpm bug about symlinks
|
||||
rm -f %{buildroot}%{_bindir}/kermit-sshsub
|
||||
@ -45,12 +61,15 @@ rm -fr %{buildroot}%{_infodir}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/*
|
||||
%{_bindir}/kermit-sshsub
|
||||
%{_bindir}/kermit*
|
||||
%{_mandir}/man1/*
|
||||
%doc COPYING.TXT *.txt *.ini
|
||||
%doc COPYING.TXT
|
||||
#*.txt *.ini
|
||||
|
||||
%changelog
|
||||
* Tue Aug 24 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 9.0.302-2mamba
|
||||
- rebuilt with specfile fixes
|
||||
|
||||
* Wed Nov 12 2014 Automatic Build System <autodist@mambasoft.it> 9.0.302-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user