update to 0.16 [release 0.16-1mamba;Thu Mar 06 2014]

This commit is contained in:
Silvan Calarco 2024-01-05 21:20:47 +01:00
parent 0312ba5ecc
commit b5349b9011
3 changed files with 73 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# chrpath
Chrpath allows you to modify the dynamic library load path (rpath) of compiled programs.
Currently, only removing and modifying the rpath is supported.

View File

@ -0,0 +1,14 @@
--- killrpath.c 2010-11-28 23:58:20.000000000 +0100
+++ killrpath.c.fix 2010-11-29 00:00:50.000000000 +0100
@@ -74,7 +74,10 @@
dynpos++;
}
for (; dynpos < i; dynpos++)
- dyns[dynpos].d_tag = DT_NULL;
+ {
+ dyns[dynpos].d_tag = DT_NULL;
+ dyns[dynpos].d_un.d_val = 0x0;
+ }
if (lseek(fd, phdr.p_offset, SEEK_SET) == -1
|| write(fd, dyns, phdr.p_filesz) != (int)phdr.p_filesz)

56
chrpath.spec Normal file
View File

@ -0,0 +1,56 @@
Name: chrpath
Version: 0.16
Release: 1mamba
Summary: Dynamic library load path (rpath) alterer
Group: System/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@gmail.com>
URL: http://www.tux.org/pub/X-Windows/ftp.hungry.com/chrpath/
Source: https://alioth.debian.org/frs/download.php/file/3979/chrpath-%{version}.tar.gz
#http://www.tux.org/pub/X-Windows/ftp.hungry.com/chrpath/chrpath-%{version}.tar.gz
Patch: %{name}-0.13-NULL-entry.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Chrpath allows you to modify the dynamic library load path (rpath) of compiled programs.
Currently, only removing and modifying the rpath is supported.
%prep
%setup -q
#%patch -p0
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall
rm -fr %{buildroot}/usr/doc
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files
%defattr(-,root,root)
%{_bindir}/chrpath
%{_mandir}/man1/chrpath.*
%doc AUTHORS COPYING ChangeLog NEWS README
%changelog
* Thu Mar 06 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.16-1mamba
- update to 0.16
* Sun Nov 28 2010 Davide Madrisan <davide.madrisan@gmail.com> 0.13-3mamba
- fix last entry in .dynamic (by Christian Krause <chkr@plauener.de>).
* Tue Dec 04 2007 Aleph0 <aleph0@openmamba.org> 0.13-2mamba
- updated specfile
* Tue Aug 02 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.13-1qilnx
- package created by autospec