56 lines
2.6 KiB
Diff
56 lines
2.6 KiB
Diff
From ded379824f5de39357b6b1894578101aba5cdf05 Mon Sep 17 00:00:00 2001
|
|
From: Eugene Zemtsov <eugene@chromium.org>
|
|
Date: Fri, 29 Jul 2022 04:41:04 +0000
|
|
Subject: [PATCH] Roll src/third_party/ffmpeg/ 880df5ede..b71ecd02b (279
|
|
commits)
|
|
|
|
https://chromium.googlesource.com/chromium/third_party/ffmpeg.git/+log/880df5ede50a..b71ecd02b479
|
|
|
|
$ git log 880df5ede..b71ecd02b --date=short --no-merges --format='%ad %ae %s'
|
|
2022-07-27 eugene Roll for M106
|
|
2022-07-25 andreas.rheinhardt avcodec/x86/pngdsp: Remove obsolete ff_add_bytes_l2_mmx()
|
|
2022-07-22 andreas.rheinhardt avcodec/hevcdec: Output MD5-message in one piece
|
|
2022-07-24 epirat07 configure: properly require libx264 if enabled
|
|
2022-07-24 zane avformat/argo_cvg: expose loop/reverb/checksum via metadata
|
|
(...)
|
|
2022-05-03 leo.izen avcodec/libjxldec: properly tag output colorspace
|
|
2022-06-25 ffmpeg avfilter/Makefile: always make colorspace.o
|
|
2022-03-02 brad avutil/ppc/cpu: Use proper header for OpenBSD PPC CPU detection
|
|
2022-06-24 jamrial avformat/http: include version.h
|
|
2022-05-16 mbonda-at-nvidia.com AV1 VDPAU hwaccel Decode support
|
|
|
|
Created with:
|
|
roll-dep src/third_party/ffmpeg
|
|
|
|
ffmpeg usage fix:
|
|
Switch from AVFrame::pkt_duration to AVFrame::duration,
|
|
AVFrame::pkt_duration is deprecated
|
|
|
|
Bug: 1344646
|
|
Change-Id: Iaa3abf48ef81dae6d282bca8f0fa2a8dffeeba25
|
|
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3788638
|
|
Reviewed-by: Will Cassella <cassew@chromium.org>
|
|
Commit-Queue: Eugene Zemtsov <eugene@chromium.org>
|
|
Cr-Commit-Position: refs/heads/main@{#1029623}
|
|
---
|
|
media/filters/audio_file_reader.cc | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/media/filters/audio_file_reader.cc b/media/filters/audio_file_reader.cc
|
|
index e1be5aa9a5b..951c003956f 100644
|
|
--- a/media/filters/audio_file_reader.cc
|
|
+++ b/media/filters/audio_file_reader.cc
|
|
@@ -243,10 +243,10 @@ bool AudioFileReader::OnNewFrame(
|
|
// silence from being output. In the case where we are also discarding some
|
|
// portion of the packet (as indicated by a negative pts), we further want to
|
|
// adjust the duration downward by however much exists before zero.
|
|
- if (audio_codec_ == AudioCodec::kAAC && frame->pkt_duration) {
|
|
+ if (audio_codec_ == AudioCodec::kAAC && frame->duration) {
|
|
const base::TimeDelta pkt_duration = ConvertFromTimeBase(
|
|
glue_->format_context()->streams[stream_index_]->time_base,
|
|
- frame->pkt_duration + std::min(static_cast<int64_t>(0), frame->pts));
|
|
+ frame->duration + std::min(static_cast<int64_t>(0), frame->pts));
|
|
const base::TimeDelta frame_duration =
|
|
base::Seconds(frames_read / static_cast<double>(sample_rate_));
|
|
|