automatic version update by autodist [release 59.0.3071.86-1mamba;Mon Jun 12 2017]
This commit is contained in:
parent
88ab17d500
commit
f6a8f43d3e
48
chromium-55.0.2883.75-ffmpeg-3.2.2.patch
Normal file
48
chromium-55.0.2883.75-ffmpeg-3.2.2.patch
Normal file
@ -0,0 +1,48 @@
|
|||||||
|
--- a/media/ffmpeg/ffmpeg_common.h.orig 2016-09-09 13:16:07.757294768 +0000
|
||||||
|
+++ b/media/ffmpeg/ffmpeg_common.h 2016-09-09 13:16:41.705989273 +0000
|
||||||
|
@@ -22,10 +22,6 @@
|
||||||
|
|
||||||
|
// Include FFmpeg header files.
|
||||||
|
extern "C" {
|
||||||
|
-// Disable deprecated features which result in spammy compile warnings. This
|
||||||
|
-// list of defines must mirror those in the 'defines' section of FFmpeg's
|
||||||
|
-// BUILD.gn file or the headers below will generate different structures!
|
||||||
|
-#define FF_API_CONVERGENCE_DURATION 0
|
||||||
|
// Upstream libavcodec/utils.c still uses the deprecated
|
||||||
|
// av_dup_packet(), causing deprecation warnings.
|
||||||
|
// The normal fix for such things is to disable the feature as below,
|
||||||
|
@@ -35,7 +35,6 @@
|
||||||
|
MSVC_PUSH_DISABLE_WARNING(4244);
|
||||||
|
#include <libavcodec/avcodec.h>
|
||||||
|
#include <libavformat/avformat.h>
|
||||||
|
-#include <libavformat/internal.h>
|
||||||
|
#include <libavformat/avio.h>
|
||||||
|
#include <libavutil/avutil.h>
|
||||||
|
#include <libavutil/imgutils.h>
|
||||||
|
--- a/media/filters/ffmpeg_demuxer.cc.orig 2016-09-09 14:21:40.185828912 +0000
|
||||||
|
+++ b/media/filters/ffmpeg_demuxer.cc 2016-09-09 14:21:52.894089352 +0000
|
||||||
|
@@ -1185,24 +1185,6 @@
|
||||||
|
// If no estimate is found, the stream entry will be kInfiniteDuration.
|
||||||
|
std::vector<base::TimeDelta> start_time_estimates(format_context->nb_streams,
|
||||||
|
kInfiniteDuration);
|
||||||
|
- const AVFormatInternal* internal = format_context->internal;
|
||||||
|
- if (internal && internal->packet_buffer &&
|
||||||
|
- format_context->start_time != static_cast<int64_t>(AV_NOPTS_VALUE)) {
|
||||||
|
- struct AVPacketList* packet_buffer = internal->packet_buffer;
|
||||||
|
- while (packet_buffer != internal->packet_buffer_end) {
|
||||||
|
- DCHECK_LT(static_cast<size_t>(packet_buffer->pkt.stream_index),
|
||||||
|
- start_time_estimates.size());
|
||||||
|
- const AVStream* stream =
|
||||||
|
- format_context->streams[packet_buffer->pkt.stream_index];
|
||||||
|
- if (packet_buffer->pkt.pts != static_cast<int64_t>(AV_NOPTS_VALUE)) {
|
||||||
|
- const base::TimeDelta packet_pts =
|
||||||
|
- ConvertFromTimeBase(stream->time_base, packet_buffer->pkt.pts);
|
||||||
|
- if (packet_pts < start_time_estimates[stream->index])
|
||||||
|
- start_time_estimates[stream->index] = packet_pts;
|
||||||
|
- }
|
||||||
|
- packet_buffer = packet_buffer->next;
|
||||||
|
- }
|
||||||
|
- }
|
||||||
|
|
||||||
|
std::unique_ptr<MediaTracks> media_tracks(new MediaTracks());
|
||||||
|
|
13
chromium-55.0.2883.75-upstream-buildfix.patch
Normal file
13
chromium-55.0.2883.75-upstream-buildfix.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/gpu/command_buffer/client/shared_memory_limits.h b/gpu/command_buffer/client/shared_memory_limits.h
|
||||||
|
index de82173..53881de 100644
|
||||||
|
--- a/gpu/command_buffer/client/shared_memory_limits.h
|
||||||
|
+++ b/gpu/command_buffer/client/shared_memory_limits.h
|
||||||
|
@@ -10,6 +10,8 @@
|
||||||
|
namespace gpu {
|
||||||
|
|
||||||
|
struct SharedMemoryLimits {
|
||||||
|
+ SharedMemoryLimits() = default;
|
||||||
|
+
|
||||||
|
int32_t command_buffer_size = 1024 * 1024;
|
||||||
|
uint32_t start_transfer_buffer_size = 1 * 1024 * 1024;
|
||||||
|
uint32_t min_transfer_buffer_size = 1 * 256 * 1024;
|
86
chromium-59.0.3071.86-blink-gcc-6.2.patch
Normal file
86
chromium-59.0.3071.86-blink-gcc-6.2.patch
Normal file
@ -0,0 +1,86 @@
|
|||||||
|
--- chromium-59.0.3071.86/third_party/WebKit/Source/platform/wtf/LinkedHashSet.h.orig 2017-06-06 15:05:38.145247996 +0300
|
||||||
|
+++ chromium-59.0.3071.86/third_party/WebKit/Source/platform/wtf/LinkedHashSet.h 2017-06-06 15:06:13.866246667 +0300
|
||||||
|
@@ -685,6 +685,31 @@ inline LinkedHashSet<T, U, V, W>& Linked
|
||||||
|
return *this;
|
||||||
|
}
|
||||||
|
|
||||||
|
+inline void SwapAnchor(LinkedHashSetNodeBase& a, LinkedHashSetNodeBase& b) {
|
||||||
|
+ DCHECK(a.prev_);
|
||||||
|
+ DCHECK(a.next_);
|
||||||
|
+ DCHECK(b.prev_);
|
||||||
|
+ DCHECK(b.next_);
|
||||||
|
+ swap(a.prev_, b.prev_);
|
||||||
|
+ swap(a.next_, b.next_);
|
||||||
|
+ if (b.next_ == &a) {
|
||||||
|
+ DCHECK_EQ(b.prev_, &a);
|
||||||
|
+ b.next_ = &b;
|
||||||
|
+ b.prev_ = &b;
|
||||||
|
+ } else {
|
||||||
|
+ b.next_->prev_ = &b;
|
||||||
|
+ b.prev_->next_ = &b;
|
||||||
|
+ }
|
||||||
|
+ if (a.next_ == &b) {
|
||||||
|
+ DCHECK_EQ(a.prev_, &b);
|
||||||
|
+ a.next_ = &a;
|
||||||
|
+ a.prev_ = &a;
|
||||||
|
+ } else {
|
||||||
|
+ a.next_->prev_ = &a;
|
||||||
|
+ a.prev_->next_ = &a;
|
||||||
|
+ }
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
template <typename T, typename U, typename V, typename W>
|
||||||
|
inline void LinkedHashSet<T, U, V, W>::Swap(LinkedHashSet& other) {
|
||||||
|
impl_.Swap(other.impl_);
|
||||||
|
@@ -877,31 +902,6 @@ inline void LinkedHashSet<T, U, V, W>::e
|
||||||
|
erase(Find(value));
|
||||||
|
}
|
||||||
|
|
||||||
|
-inline void SwapAnchor(LinkedHashSetNodeBase& a, LinkedHashSetNodeBase& b) {
|
||||||
|
- DCHECK(a.prev_);
|
||||||
|
- DCHECK(a.next_);
|
||||||
|
- DCHECK(b.prev_);
|
||||||
|
- DCHECK(b.next_);
|
||||||
|
- swap(a.prev_, b.prev_);
|
||||||
|
- swap(a.next_, b.next_);
|
||||||
|
- if (b.next_ == &a) {
|
||||||
|
- DCHECK_EQ(b.prev_, &a);
|
||||||
|
- b.next_ = &b;
|
||||||
|
- b.prev_ = &b;
|
||||||
|
- } else {
|
||||||
|
- b.next_->prev_ = &b;
|
||||||
|
- b.prev_->next_ = &b;
|
||||||
|
- }
|
||||||
|
- if (a.next_ == &b) {
|
||||||
|
- DCHECK_EQ(a.prev_, &b);
|
||||||
|
- a.next_ = &a;
|
||||||
|
- a.prev_ = &a;
|
||||||
|
- } else {
|
||||||
|
- a.next_->prev_ = &a;
|
||||||
|
- a.prev_->next_ = &a;
|
||||||
|
- }
|
||||||
|
-}
|
||||||
|
-
|
||||||
|
inline void swap(LinkedHashSetNodeBase& a, LinkedHashSetNodeBase& b) {
|
||||||
|
DCHECK_NE(a.next_, &a);
|
||||||
|
DCHECK_NE(b.next_, &b);
|
||||||
|
--- chromium-59.0.3071.86/third_party/WebKit/Source/platform/graphics/gpu/SharedGpuContext.h.orig 2017-06-06 16:16:43.657661313 +0300
|
||||||
|
+++ chromium-59.0.3071.86/third_party/WebKit/Source/platform/graphics/gpu/SharedGpuContext.h 2017-06-06 16:16:50.911198032 +0300
|
||||||
|
@@ -5,6 +5,7 @@
|
||||||
|
#include "platform/PlatformExport.h"
|
||||||
|
#include "platform/wtf/ThreadSpecific.h"
|
||||||
|
|
||||||
|
+#include <functional>
|
||||||
|
#include <memory>
|
||||||
|
|
||||||
|
namespace gpu {
|
||||||
|
--- chromium-59.0.3071.86/third_party/WebKit/Source/platform/text/CharacterPropertyDataGenerator.cpp.orig 2017-06-16 11:15:14.424585523 +0200
|
||||||
|
+++ chromium-59.0.3071.86/third_party/WebKit/Source/platform/text/CharacterPropertyDataGenerator.cpp 2017-06-16 11:15:25.001641041 +0200
|
||||||
|
@@ -10,6 +10,7 @@
|
||||||
|
#include "CharacterProperty.h"
|
||||||
|
#include <cassert>
|
||||||
|
#include <cstring>
|
||||||
|
+#include <functional>
|
||||||
|
#include <memory>
|
||||||
|
#include <stdio.h>
|
||||||
|
#if !defined(USING_SYSTEM_ICU)
|
10
chromium-59.0.3071.86-winedevine.patch
Normal file
10
chromium-59.0.3071.86-winedevine.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
diff -upr chromium-48.0.2564.82.orig/third_party/widevine/cdm/stub/widevine_cdm_version.h chromium-48.0.2564.82/third_party/widevine/cdm/stub/widevine_cdm_version.h
|
||||||
|
--- chromium-48.0.2564.82.orig/third_party/widevine/cdm/stub/widevine_cdm_version.h 2016-01-14 01:05:17.000000000 +0200
|
||||||
|
+++ chromium-48.0.2564.82/third_party/widevine/cdm/stub/widevine_cdm_version.h 2016-01-21 19:18:51.287978456 +0200
|
||||||
|
@@ -12,4 +12,6 @@
|
||||||
|
|
||||||
|
#define WIDEVINE_CDM_AVAILABLE
|
||||||
|
|
||||||
|
+#define WIDEVINE_CDM_VERSION_STRING "@WIDEVINE_VERSION@"
|
||||||
|
+
|
||||||
|
#endif // WIDEVINE_CDM_VERSION_H_
|
217
chromium.spec
217
chromium.spec
@ -1,7 +1,7 @@
|
|||||||
Name: chromium
|
Name: chromium
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
Version: 53.0.2785.154
|
Version: 59.0.3071.86
|
||||||
Release: 2mamba
|
Release: 1mamba
|
||||||
Summary: An open-source browser project that aims to build a safer, faster, and more stable way to experience the web
|
Summary: An open-source browser project that aims to build a safer, faster, and more stable way to experience the web
|
||||||
Group: Graphical Desktop/Applications/Internet
|
Group: Graphical Desktop/Applications/Internet
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -40,6 +40,10 @@ Patch21: chromium-46.0.2490.86-buildfix.patch
|
|||||||
Patch22: chromium-51.0.2704.106-PNGImageDecoder.patch
|
Patch22: chromium-51.0.2704.106-PNGImageDecoder.patch
|
||||||
Patch23: chromium-53.0.2785.16-cups-2.2.0.patch
|
Patch23: chromium-53.0.2785.16-cups-2.2.0.patch
|
||||||
Patch24: chromium-53.0.2785.143-undef_MADV_FREE.patch
|
Patch24: chromium-53.0.2785.143-undef_MADV_FREE.patch
|
||||||
|
Patch25: chromium-55.0.2883.75-ffmpeg-3.2.2.patch
|
||||||
|
Patch26: chromium-55.0.2883.75-upstream-buildfix.patch
|
||||||
|
Patch27: chromium-59.0.3071.86-blink-gcc-6.2.patch
|
||||||
|
Patch28: chromium-59.0.3071.86-winedevine.patch
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: libGConf-devel
|
BuildRequires: libGConf-devel
|
||||||
@ -149,6 +153,8 @@ BuildRequires: libexif-devel
|
|||||||
BuildRequires: clang-devel
|
BuildRequires: clang-devel
|
||||||
BuildRequires: libXtst-devel
|
BuildRequires: libXtst-devel
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: libre2-devel
|
||||||
|
BuildRequires: libminizip-devel
|
||||||
Requires(post): %{__install_info}
|
Requires(post): %{__install_info}
|
||||||
Requires: xdg-utils
|
Requires: xdg-utils
|
||||||
Requires: libvdpau-Mesa
|
Requires: libvdpau-Mesa
|
||||||
@ -197,19 +203,59 @@ Chromium is an open-source browser project that aims to build a safer, faster, a
|
|||||||
#%patch17 -p1
|
#%patch17 -p1
|
||||||
#%patch18 -p2
|
#%patch18 -p2
|
||||||
%patch19 -p1
|
%patch19 -p1
|
||||||
%patch21 -p1
|
#%patch21 -p1
|
||||||
#%patch22 -p1
|
#%patch22 -p1
|
||||||
%patch23 -p1
|
#%patch23 -p1
|
||||||
%patch24 -p2
|
#%patch24 -p2
|
||||||
#(
|
#%patch25 -p1
|
||||||
#cd third_party/boringssl/src/
|
#%patch26 -R -p1
|
||||||
#%patch20 -p1
|
%patch27 -p1
|
||||||
#)
|
%patch28 -p1
|
||||||
|
|
||||||
# Download NaCL toolchains
|
# Use Python 2
|
||||||
python build/download_nacl_toolchains.py \
|
find . -name '*.py' -exec sed -i -r 's|/usr/bin/python$|&2|g' {} +
|
||||||
--packages nacl_x86_newlib,pnacl_newlib,pnacl_translator \
|
|
||||||
sync --extract
|
# There are still a lot of relative calls which need a workaround
|
||||||
|
mkdir -p python2-path
|
||||||
|
ln -sf %{_bindir}/python2 python2-path/python
|
||||||
|
|
||||||
|
mkdir -p third_party/node/linux/node-linux-x64/bin
|
||||||
|
ln -s %{_bindir}/node third_party/node/linux/node-linux-x64/bin/
|
||||||
|
|
||||||
|
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
|
||||||
|
# Keys are the names in the above script; values are the dependencies in Arch
|
||||||
|
declare -rgA _system_libs=(
|
||||||
|
#[ffmpeg]=ffmpeg # https://crbug.com/731766
|
||||||
|
[flac]=flac
|
||||||
|
[harfbuzz-ng]=harfbuzz-icu
|
||||||
|
#[icu]=icu # Enable again when upstream supports ICU 59
|
||||||
|
[libdrm]=
|
||||||
|
[libjpeg]=libjpeg
|
||||||
|
[libpng]=libpng
|
||||||
|
#[libvpx]=libvpx # https://bugs.gentoo.org/show_bug.cgi?id=611394
|
||||||
|
[libwebp]=libwebp
|
||||||
|
#[libxml]=libxml2 # https://bugs.gentoo.org/show_bug.cgi?id=616818
|
||||||
|
[libxslt]=libxslt
|
||||||
|
[re2]=re2
|
||||||
|
[snappy]=snappy
|
||||||
|
[yasm]=
|
||||||
|
[zlib]=libminizip
|
||||||
|
)
|
||||||
|
|
||||||
|
# Remove bundled libraries for which we will use the system copies; this
|
||||||
|
# *should* do what the remove_bundled_libraries.py script does, with the
|
||||||
|
# added benefit of not having to list all the remaining libraries
|
||||||
|
for l in ${!_system_libs[@]} ${_system_libs[libjpeg]+libjpeg_turbo}; do
|
||||||
|
find -type f -path "*third_party/${l}/*" \
|
||||||
|
\! -path "*third_party/${l}/chromium/*" \
|
||||||
|
\! -path "*third_party/${l}/google/*" \
|
||||||
|
\! -path "*base/third_party/icu/*" \
|
||||||
|
\! -regex '.*\.\(gn\|gni\|isolate\|py\)' \
|
||||||
|
-delete
|
||||||
|
done
|
||||||
|
|
||||||
|
python2 build/linux/unbundle/replace_gn_files.py \
|
||||||
|
--system-libraries "${!_system_libs[@]}"
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
@ -221,10 +267,9 @@ ln -sf %{_bindir}/clang third_party/llvm-build/Release+Asserts/bin/
|
|||||||
ln -sf %{_bindir}/clang++ third_party/llvm-build/Release+Asserts/bin/
|
ln -sf %{_bindir}/clang++ third_party/llvm-build/Release+Asserts/bin/
|
||||||
ln -sf %{_bindir}/llvm-symbolizer third_party/llvm-build/Release+Asserts/bin/
|
ln -sf %{_bindir}/llvm-symbolizer third_party/llvm-build/Release+Asserts/bin/
|
||||||
# clang 3.4 doesn't support this option
|
# clang 3.4 doesn't support this option
|
||||||
sed -i '/-Wno-absolute-value/d' \
|
#sed -i '/-Wno-absolute-value/d' \
|
||||||
build/common.gypi \
|
# build/common.gypi \
|
||||||
third_party/ffmpeg/ffmpeg.gyp
|
# third_party/ffmpeg/ffmpeg.gyp
|
||||||
#_EOF
|
|
||||||
#%ifarch x86_64
|
#%ifarch x86_64
|
||||||
#ln -sf %{_bindir}/ld.gold third_party/gold/gold64
|
#ln -sf %{_bindir}/ld.gold third_party/gold/gold64
|
||||||
#%else
|
#%else
|
||||||
@ -252,66 +297,87 @@ export BACKTRACE="-funwind-tables -rdynamic"
|
|||||||
#export GYP_GENERATORS=make
|
#export GYP_GENERATORS=make
|
||||||
#./build/gyp_chromium
|
#./build/gyp_chromium
|
||||||
chromium_conf=(
|
chromium_conf=(
|
||||||
-Dgoogle_api_key=AIzaSyBT3wXwxmFuUQcyeMyp0MbHHhhFwNfWKTc
|
'google_api_key="AIzaSyBT3wXwxmFuUQcyeMyp0MbHHhhFwNfWKTc"'
|
||||||
-Dgoogle_default_client_id=72870267994-r1bkll5bq0v275nnsa66d21h3t6ne10s.apps.googleusercontent.com
|
'google_default_client_id="72870267994-r1bkll5bq0v275nnsa66d21h3t6ne10s.apps.googleusercontent.com"'
|
||||||
-Dgoogle_default_client_secret=Pcdh5bzXx3nsECO_AlMlPXXk
|
'google_default_client_secret="Pcdh5bzXx3nsECO_AlMlPXXk"'
|
||||||
-Dwerror=
|
'is_clang=false'
|
||||||
-Dclang=1
|
'clang_use_chrome_plugins=false'
|
||||||
-Dclang_use_chrome_plugins=0
|
'is_debug=false'
|
||||||
-Dpython_ver=2.7
|
'fatal_linker_warnings=false'
|
||||||
-Dlinux_link_gsettings=1
|
'treat_warnings_as_errors=false'
|
||||||
-Dlinux_link_libpci=1
|
'fieldtrial_testing_like_official_build=true'
|
||||||
-Dlinux_link_libspeechd=1
|
'remove_webcore_debug_symbols=true'
|
||||||
-Dlinux_link_pulseaudio=1
|
'ffmpeg_branding="Chrome"'
|
||||||
-Dlinux_strip_binary=1
|
|
||||||
-Dlinux_use_bundled_binutils=0
|
|
||||||
-Dlinux_use_bundled_gold=0
|
|
||||||
-Dlinux_use_gold_flags=0
|
|
||||||
-Dlogging_like_official_build=1
|
|
||||||
-Dlinux_sandbox_path=/opt/chromium/chrome-sandbox
|
|
||||||
-Ddisable_nacl=1
|
|
||||||
-Duse_system_xdg_utils=1
|
|
||||||
-Duse_system_zlib=0
|
|
||||||
-Duse_system_libpng=1
|
|
||||||
-Duse_system_bzip2=1
|
|
||||||
-Duse_system_libbz2=1
|
|
||||||
-Duse_system_libjpeg=1
|
|
||||||
-Duse_system_libxml=1
|
|
||||||
-Duse_system_libxslt=1
|
|
||||||
-Duse_system_harfbuzz=1
|
|
||||||
-Duse_system_libevent=1
|
|
||||||
-Duse_system_yasm=1
|
|
||||||
-Duse_system_flac=1
|
|
||||||
-Duse_system_speex=1
|
|
||||||
-Duse_system_snappy=1
|
|
||||||
-Duse_system_ssl=0
|
|
||||||
-Duse_system_vpx=1
|
|
||||||
-Duse_system_ffmpeg=0
|
|
||||||
-Dffmpeg_branding=Chrome
|
|
||||||
-Dremove_webcore_debug_symbols=1
|
|
||||||
-Dusb_ids_path=/usr/share/hwdata/usb.ids
|
|
||||||
-Dlinux_fpic=1
|
|
||||||
-Ddisable_sse2=1
|
|
||||||
-Dlibspeechd_h_prefix=speech-dispatcher/
|
|
||||||
-Dno_strict_aliasing=1
|
|
||||||
-Duse_sysroot=0
|
|
||||||
%ifarch %{ix86}
|
|
||||||
-Drelease_extra_cflags="-fPIC -m32 -fno-delete-null-pointer-checks"
|
|
||||||
%else
|
|
||||||
-Drelease_extra_cflags="-fPIC -fno-delete-null-pointer-checks"
|
|
||||||
%endif
|
|
||||||
%ifarch arm
|
|
||||||
-Denable_webrtc=0
|
|
||||||
%endif
|
|
||||||
%ifnarch arm
|
%ifnarch arm
|
||||||
-Dproprietary_codecs=1
|
'proprietary_codecs=true'
|
||||||
%endif
|
%endif
|
||||||
|
'link_pulseaudio=true'
|
||||||
|
'linux_use_bundled_binutils=false'
|
||||||
|
'use_gtk3=true'
|
||||||
|
'use_gconf=false'
|
||||||
|
'use_gnome_keyring=false'
|
||||||
|
'use_gold=false'
|
||||||
|
'use_sysroot=false'
|
||||||
|
'enable_hangout_services_extension=true'
|
||||||
|
'enable_widevine=true'
|
||||||
|
'enable_nacl=false'
|
||||||
|
'enable_swiftshader=false'
|
||||||
)
|
)
|
||||||
|
# 'linux_sandbox_path="%{_libdir}/chromium/chrome-sandbox"'
|
||||||
|
# 'usb_ids_path="/usr/share/hwdata/usb.ids"'
|
||||||
|
# 'symbol_level=0'
|
||||||
|
# 'linux_link_gsettings=true'
|
||||||
|
# 'linux_link_libpci=true'
|
||||||
|
# 'linux_link_libspeechd=true'
|
||||||
|
# 'linux_strip_binary=true'
|
||||||
|
# 'linux_use_bundled_gold=false'
|
||||||
|
# 'linux_use_gold_flags=false'
|
||||||
|
# 'logging_like_official_build=true'
|
||||||
|
# 'use_system_xdg_utils=true'
|
||||||
|
# 'use_system_zlib=false'
|
||||||
|
# 'use_system_libpng=true'
|
||||||
|
# 'use_system_bzip2=true'
|
||||||
|
# 'use_system_libbz2=true'
|
||||||
|
# 'use_system_libjpeg=true'
|
||||||
|
# 'use_system_libxml=true'
|
||||||
|
# 'use_system_libxslt=true'
|
||||||
|
# 'use_system_harfbuzz=true'
|
||||||
|
# 'use_system_libevent=true'
|
||||||
|
# 'use_system_yasm=true'
|
||||||
|
# 'use_system_flac=true'
|
||||||
|
# 'use_system_speex=true'
|
||||||
|
# 'use_system_snappy=true'
|
||||||
|
# 'use_system_ssl=false'
|
||||||
|
# 'use_system_vpx=true'
|
||||||
|
# 'use_system_ffmpeg=false'
|
||||||
|
# 'linux_fpic=true'
|
||||||
|
# 'disable_sse2=true'
|
||||||
|
# 'libspeechd_h_prefix="speech-dispatcher/"'
|
||||||
|
# 'enable_hangout_services_extension=true'
|
||||||
|
# 'enable_widevine=true'
|
||||||
|
# 'enable_nacl=false'
|
||||||
|
# 'enable_nacl_nonsfi=false'
|
||||||
|
# 'no_strict_aliasing=true'
|
||||||
|
# 'use_sysroot=false'
|
||||||
|
#%ifarch %{ix86}
|
||||||
|
# 'release_extra_cflags="-fPIC -m32 -fno-delete-null-pointer-checks"'
|
||||||
|
#%else
|
||||||
|
# 'release_extra_cflags="-fPIC -fno-delete-null-pointer-checks"'
|
||||||
|
#%endif
|
||||||
|
#%ifarch arm
|
||||||
|
# 'enable_webrtc=false'
|
||||||
|
#%endif
|
||||||
|
|
||||||
build/linux/unbundle/replace_gyp_files.py "${chromium_conf[@]}"
|
# 'disable_nacl=true'
|
||||||
build/gyp_chromium --depth=. "${chromium_conf[@]}"
|
|
||||||
|
|
||||||
ninja -C out/Release chrome chrome_sandbox chromedriver
|
#build/linux/unbundle/replace_gyp_files.py "${chromium_conf[@]}"
|
||||||
|
#build/gyp_chromium --depth=. "${chromium_conf[@]}"
|
||||||
|
|
||||||
|
python2 tools/gn/bootstrap/bootstrap.py --gn-gen-args "${chromium_conf[*]}"
|
||||||
|
out/Release/gn gen out/Release --args="${chromium_conf[*]}" \
|
||||||
|
--script-executable=/usr/bin/python2
|
||||||
|
|
||||||
|
ninja -C out/Release chrome chrome_sandbox chromedriver widevinecdmadapter
|
||||||
#% make BUILDTYPE=Release chrome V=1
|
#% make BUILDTYPE=Release chrome V=1
|
||||||
|
|
||||||
# Build the required SUID SANDBOX helper
|
# Build the required SUID SANDBOX helper
|
||||||
@ -324,6 +390,8 @@ install -d -m0755 %{buildroot}%{_libdir}/chromium/ %{buildroot}%{_bindir}
|
|||||||
install -m0755 out/Release/chrome %{buildroot}%{_libdir}/chromium/chromium
|
install -m0755 out/Release/chrome %{buildroot}%{_libdir}/chromium/chromium
|
||||||
install -m0755 out/Release/chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
|
install -m0755 out/Release/chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
|
||||||
install -m0755 out/Release/chromedriver %{buildroot}%{_libdir}/chromium/chromedriver
|
install -m0755 out/Release/chromedriver %{buildroot}%{_libdir}/chromium/chromedriver
|
||||||
|
install -m0755 out/Release/libwidevinecdm.so %{buildroot}%{_libdir}/chromium/libwidevinecdm.so
|
||||||
|
install -m0755 out/Release/libwidevinecdmadapter.so %{buildroot}%{_libdir}/chromium/libwidevinecdmadapter.so
|
||||||
cp out/Release/*.bin %{buildroot}%{_libdir}/chromium/
|
cp out/Release/*.bin %{buildroot}%{_libdir}/chromium/
|
||||||
|
|
||||||
install -m0755 chrome/tools/build/linux/chrome-wrapper %{buildroot}%{_libdir}/chromium/
|
install -m0755 chrome/tools/build/linux/chrome-wrapper %{buildroot}%{_libdir}/chromium/
|
||||||
@ -441,6 +509,8 @@ fi
|
|||||||
%{_libdir}/chromium/chrome-wrapper
|
%{_libdir}/chromium/chrome-wrapper
|
||||||
%attr(4755,root,root) %{_libdir}/chromium/chrome-sandbox
|
%attr(4755,root,root) %{_libdir}/chromium/chrome-sandbox
|
||||||
%{_libdir}/chromium/icudtl.dat
|
%{_libdir}/chromium/icudtl.dat
|
||||||
|
%{_libdir}/chromium/libwidevinecdm.so
|
||||||
|
%{_libdir}/chromium/libwidevinecdmadapter.so
|
||||||
#/opt/chromium/libpdf.so
|
#/opt/chromium/libpdf.so
|
||||||
#/opt/chromium/nacl_helper
|
#/opt/chromium/nacl_helper
|
||||||
#/opt/chromium/nacl_helper-bootstrap
|
#/opt/chromium/nacl_helper-bootstrap
|
||||||
@ -464,6 +534,9 @@ fi
|
|||||||
%{_mandir}/man1/chromium.1*
|
%{_mandir}/man1/chromium.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 12 2017 Automatic Build System <autodist@mambasoft.it> 59.0.3071.86-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Apr 18 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 53.0.2785.154-2mamba
|
* Tue Apr 18 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 53.0.2785.154-2mamba
|
||||||
- rebuilt to workaround certificate expiration bug
|
- rebuilt to workaround certificate expiration bug
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user