update to 109.0.5414.119 [release 109.0.5414.119-1mamba;Thu Jan 26 2023]
This commit is contained in:
parent
6d107155e7
commit
c43c62f944
38
chromium-105.0.5195.102-angle-wayland-include-protocol.patch
Normal file
38
chromium-105.0.5195.102-angle-wayland-include-protocol.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
diff -upr third_party/angle.orig/BUILD.gn third_party/angle/BUILD.gn
|
||||||
|
--- third_party/angle.orig/BUILD.gn 2022-08-17 19:38:11.000000000 +0000
|
||||||
|
+++ third_party/angle/BUILD.gn 2022-08-18 11:04:09.061751111 +0000
|
||||||
|
@@ -489,6 +489,12 @@ config("angle_vulkan_wayland_config") {
|
||||||
|
if (angle_enable_vulkan && angle_use_wayland &&
|
||||||
|
defined(vulkan_wayland_include_dirs)) {
|
||||||
|
include_dirs = vulkan_wayland_include_dirs
|
||||||
|
+ } else if (angle_enable_vulkan && angle_use_wayland) {
|
||||||
|
+ include_dirs = [
|
||||||
|
+ "$wayland_gn_dir/src/src",
|
||||||
|
+ "$wayland_gn_dir/include/src",
|
||||||
|
+ "$wayland_gn_dir/include/protocol",
|
||||||
|
+ ]
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -1073,6 +1079,7 @@ if (angle_use_wayland) {
|
||||||
|
include_dirs = [
|
||||||
|
"$wayland_dir/egl",
|
||||||
|
"$wayland_dir/src",
|
||||||
|
+ "$wayland_gn_dir/include/protocol",
|
||||||
|
]
|
||||||
|
}
|
||||||
|
|
||||||
|
diff -upr third_party/angle.orig/src/third_party/volk/BUILD.gn third_party/angle/src/third_party/volk/BUILD.gn
|
||||||
|
--- third_party/angle.orig/src/third_party/volk/BUILD.gn 2022-08-17 19:38:12.000000000 +0000
|
||||||
|
+++ third_party/angle/src/third_party/volk/BUILD.gn 2022-08-18 11:04:36.499828006 +0000
|
||||||
|
@@ -21,6 +21,9 @@ source_set("volk") {
|
||||||
|
configs += [ "$angle_root:angle_no_cfi_icall" ]
|
||||||
|
public_deps = [ "$angle_vulkan_headers_dir:vulkan_headers" ]
|
||||||
|
if (angle_use_wayland) {
|
||||||
|
- include_dirs = [ "$wayland_dir/src" ]
|
||||||
|
+ include_dirs = [
|
||||||
|
+ "$wayland_dir/src",
|
||||||
|
+ "$wayland_gn_dir/include/protocol",
|
||||||
|
+ ]
|
||||||
|
}
|
||||||
|
}
|
@ -0,0 +1,55 @@
|
|||||||
|
From ded379824f5de39357b6b1894578101aba5cdf05 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Eugene Zemtsov <eugene@chromium.org>
|
||||||
|
Date: Fri, 29 Jul 2022 04:41:04 +0000
|
||||||
|
Subject: [PATCH] Roll src/third_party/ffmpeg/ 880df5ede..b71ecd02b (279
|
||||||
|
commits)
|
||||||
|
|
||||||
|
https://chromium.googlesource.com/chromium/third_party/ffmpeg.git/+log/880df5ede50a..b71ecd02b479
|
||||||
|
|
||||||
|
$ git log 880df5ede..b71ecd02b --date=short --no-merges --format='%ad %ae %s'
|
||||||
|
2022-07-27 eugene Roll for M106
|
||||||
|
2022-07-25 andreas.rheinhardt avcodec/x86/pngdsp: Remove obsolete ff_add_bytes_l2_mmx()
|
||||||
|
2022-07-22 andreas.rheinhardt avcodec/hevcdec: Output MD5-message in one piece
|
||||||
|
2022-07-24 epirat07 configure: properly require libx264 if enabled
|
||||||
|
2022-07-24 zane avformat/argo_cvg: expose loop/reverb/checksum via metadata
|
||||||
|
(...)
|
||||||
|
2022-05-03 leo.izen avcodec/libjxldec: properly tag output colorspace
|
||||||
|
2022-06-25 ffmpeg avfilter/Makefile: always make colorspace.o
|
||||||
|
2022-03-02 brad avutil/ppc/cpu: Use proper header for OpenBSD PPC CPU detection
|
||||||
|
2022-06-24 jamrial avformat/http: include version.h
|
||||||
|
2022-05-16 mbonda-at-nvidia.com AV1 VDPAU hwaccel Decode support
|
||||||
|
|
||||||
|
Created with:
|
||||||
|
roll-dep src/third_party/ffmpeg
|
||||||
|
|
||||||
|
ffmpeg usage fix:
|
||||||
|
Switch from AVFrame::pkt_duration to AVFrame::duration,
|
||||||
|
AVFrame::pkt_duration is deprecated
|
||||||
|
|
||||||
|
Bug: 1344646
|
||||||
|
Change-Id: Iaa3abf48ef81dae6d282bca8f0fa2a8dffeeba25
|
||||||
|
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3788638
|
||||||
|
Reviewed-by: Will Cassella <cassew@chromium.org>
|
||||||
|
Commit-Queue: Eugene Zemtsov <eugene@chromium.org>
|
||||||
|
Cr-Commit-Position: refs/heads/main@{#1029623}
|
||||||
|
---
|
||||||
|
media/filters/audio_file_reader.cc | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/media/filters/audio_file_reader.cc b/media/filters/audio_file_reader.cc
|
||||||
|
index e1be5aa9a5b..951c003956f 100644
|
||||||
|
--- a/media/filters/audio_file_reader.cc
|
||||||
|
+++ b/media/filters/audio_file_reader.cc
|
||||||
|
@@ -243,10 +243,10 @@ bool AudioFileReader::OnNewFrame(
|
||||||
|
// silence from being output. In the case where we are also discarding some
|
||||||
|
// portion of the packet (as indicated by a negative pts), we further want to
|
||||||
|
// adjust the duration downward by however much exists before zero.
|
||||||
|
- if (audio_codec_ == AudioCodec::kAAC && frame->pkt_duration) {
|
||||||
|
+ if (audio_codec_ == AudioCodec::kAAC && frame->duration) {
|
||||||
|
const base::TimeDelta pkt_duration = ConvertFromTimeBase(
|
||||||
|
glue_->format_context()->streams[stream_index_]->time_base,
|
||||||
|
- frame->pkt_duration + std::min(static_cast<int64_t>(0), frame->pts));
|
||||||
|
+ frame->duration + std::min(static_cast<int64_t>(0), frame->pts));
|
||||||
|
const base::TimeDelta frame_duration =
|
||||||
|
base::Seconds(frames_read / static_cast<double>(sample_rate_));
|
||||||
|
|
@ -1,8 +1,8 @@
|
|||||||
%define MAJver %(echo %version | cut -d. -f1)
|
%define MAJver %(echo %version | cut -d. -f1)
|
||||||
%define gcc_patchset 2
|
%define gcc_patchset 1
|
||||||
Name: chromium
|
Name: chromium
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
Version: 104.0.5112.101
|
Version: 109.0.5414.119
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: An open-source browser project that aims to build a safer, faster, and more stable way to experience the web
|
Summary: An open-source browser project that aims to build a safer, faster, and more stable way to experience the web
|
||||||
Group: Graphical Desktop/Applications/Internet
|
Group: Graphical Desktop/Applications/Internet
|
||||||
@ -53,6 +53,8 @@ Patch33: chromium-104.0.5112.79-roll-src-third_party-ffmpeg.patch
|
|||||||
Patch34: chromium-102.0.5005.61-iwyu-add-utility-for-std-exchange.patch
|
Patch34: chromium-102.0.5005.61-iwyu-add-utility-for-std-exchange.patch
|
||||||
Patch35: chromium-104.0.5112.79-remove-no-opaque-pointers-flag.patch
|
Patch35: chromium-104.0.5112.79-remove-no-opaque-pointers-flag.patch
|
||||||
Patch36: chromium-104.0.5112.79-tflite-system-zlib.patch
|
Patch36: chromium-104.0.5112.79-tflite-system-zlib.patch
|
||||||
|
Patch37: chromium-105.0.5195.102-angle-wayland-include-protocol.patch
|
||||||
|
Patch38: chromium-109.0.5414.119-REVERT-roll-src-third_party-ffmpeg-m106.patch
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -63,15 +65,17 @@ BuildRequires: libXext-devel
|
|||||||
BuildRequires: libXfixes-devel
|
BuildRequires: libXfixes-devel
|
||||||
BuildRequires: libXrandr-devel
|
BuildRequires: libXrandr-devel
|
||||||
BuildRequires: libalsa-devel
|
BuildRequires: libalsa-devel
|
||||||
BuildRequires: libat-spi2-atk-devel
|
BuildRequires: libaom-devel
|
||||||
BuildRequires: libat-spi2-core-devel
|
BuildRequires: libat-spi2-core-devel
|
||||||
BuildRequires: libatk-devel
|
|
||||||
BuildRequires: libatomic-devel
|
BuildRequires: libatomic-devel
|
||||||
BuildRequires: libavcodec-ffmpeg-devel
|
BuildRequires: libavcodec-ffmpeg-devel
|
||||||
BuildRequires: libavformat-ffmpeg-devel
|
BuildRequires: libavformat-ffmpeg-devel
|
||||||
|
BuildRequires: libavif-devel
|
||||||
BuildRequires: libavutil-ffmpeg-devel
|
BuildRequires: libavutil-ffmpeg-devel
|
||||||
|
BuildRequires: libbrotli-devel
|
||||||
BuildRequires: libcairo-devel
|
BuildRequires: libcairo-devel
|
||||||
BuildRequires: libcups-devel
|
BuildRequires: libcups-devel
|
||||||
|
BuildRequires: libdav1d-devel
|
||||||
BuildRequires: libdbus-devel
|
BuildRequires: libdbus-devel
|
||||||
BuildRequires: libdrm-devel
|
BuildRequires: libdrm-devel
|
||||||
BuildRequires: libexpat-devel
|
BuildRequires: libexpat-devel
|
||||||
@ -83,6 +87,7 @@ BuildRequires: libglib-devel
|
|||||||
BuildRequires: libharfbuzz-devel
|
BuildRequires: libharfbuzz-devel
|
||||||
BuildRequires: libicu-devel
|
BuildRequires: libicu-devel
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: libjsoncpp-devel
|
||||||
BuildRequires: libmesa-devel
|
BuildRequires: libmesa-devel
|
||||||
BuildRequires: libminizip1-devel
|
BuildRequires: libminizip1-devel
|
||||||
BuildRequires: libnspr-devel
|
BuildRequires: libnspr-devel
|
||||||
@ -96,6 +101,7 @@ BuildRequires: libsnappy-devel
|
|||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libwayland-devel
|
BuildRequires: libwayland-devel
|
||||||
BuildRequires: libwebp-devel
|
BuildRequires: libwebp-devel
|
||||||
|
BuildRequires: libwoff2-devel
|
||||||
BuildRequires: libxcb-devel
|
BuildRequires: libxcb-devel
|
||||||
BuildRequires: libxkbcommon-devel
|
BuildRequires: libxkbcommon-devel
|
||||||
BuildRequires: libxml2-devel
|
BuildRequires: libxml2-devel
|
||||||
@ -103,33 +109,33 @@ BuildRequires: libxslt-devel
|
|||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libharfbuzz-devel >= 3.0.0
|
BuildRequires: libharfbuzz-devel >= 3.0.0
|
||||||
BuildRequires: libpthread-stubs-devel
|
|
||||||
BuildRequires: libgnome-keyring-devel
|
BuildRequires: libgnome-keyring-devel
|
||||||
BuildRequires: gperf
|
BuildRequires: libbrotli-tools
|
||||||
BuildRequires: flex
|
|
||||||
BuildRequires: bison
|
|
||||||
BuildRequires: pam-devel
|
|
||||||
BuildRequires: yasm
|
|
||||||
BuildRequires: libdbus-glib-devel
|
BuildRequires: libdbus-glib-devel
|
||||||
BuildRequires: libXi-devel
|
BuildRequires: libXi-devel
|
||||||
BuildRequires: libXxf86vm-devel
|
BuildRequires: libXxf86vm-devel
|
||||||
BuildRequires: libkrb5-devel
|
BuildRequires: libkrb5-devel
|
||||||
BuildRequires: libe2fs-devel
|
BuildRequires: libe2fs-devel
|
||||||
BuildRequires: speech-dispatcher-devel >= 0.8-2mamba
|
|
||||||
BuildRequires: python-markupsafe-py3
|
|
||||||
BuildRequires: libxshmfence-devel
|
BuildRequires: libxshmfence-devel
|
||||||
BuildRequires: libkeyutils-devel
|
BuildRequires: libkeyutils-devel
|
||||||
BuildRequires: libgnutls-devel
|
BuildRequires: libgnutls-devel
|
||||||
BuildRequires: ninja
|
|
||||||
BuildRequires: libXcursor-devel
|
BuildRequires: libXcursor-devel
|
||||||
BuildRequires: libpci-devel
|
BuildRequires: libpci-devel
|
||||||
BuildRequires: libexif-devel
|
BuildRequires: libexif-devel
|
||||||
BuildRequires: libXtst-devel
|
BuildRequires: libXtst-devel
|
||||||
BuildRequires: llvm
|
BuildRequires: llvm
|
||||||
BuildRequires: llvm-tools
|
BuildRequires: llvm-tools
|
||||||
BuildRequires: gn
|
BuildRequires: bison
|
||||||
BuildRequires: clang
|
BuildRequires: clang
|
||||||
BuildRequires: compiler-rt
|
BuildRequires: compiler-rt
|
||||||
|
BuildRequires: flex
|
||||||
|
BuildRequires: gn
|
||||||
|
BuildRequires: gperf
|
||||||
|
BuildRequires: ninja
|
||||||
|
BuildRequires: pam-devel
|
||||||
|
BuildRequires: python-markupsafe-py3
|
||||||
|
BuildRequires: speech-dispatcher-devel >= 0.8-2mamba
|
||||||
|
BuildRequires: yasm
|
||||||
Requires(post): %{__install_info}
|
Requires(post): %{__install_info}
|
||||||
Requires: xdg-utils
|
Requires: xdg-utils
|
||||||
Requires: libvdpau-Mesa
|
Requires: libvdpau-Mesa
|
||||||
@ -145,6 +151,9 @@ Chromium is an open-source browser project that aims to build a safer, faster, a
|
|||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
|
# Don't clean build at the end
|
||||||
|
%global __spec_rmbuild_cmd /bin/true
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
#% setup -q -a2
|
#% setup -q -a2
|
||||||
%setup -q -D -T
|
%setup -q -D -T
|
||||||
@ -161,13 +170,15 @@ sed -i 's/OFFICIAL_BUILD/GOOGLE_CHROME_BUILD/' \
|
|||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%endif
|
%endif
|
||||||
%patch7 -p1 -b .use-oauth2-client-switches-as-default
|
%patch7 -p1 -b .use-oauth2-client-switches-as-default
|
||||||
%patch35 -p1 -b .remove-no-opaque-pointers-flag
|
#%patch35 -p1 -b .remove-no-opaque-pointers-flag
|
||||||
#%patch21 -p0 -b .unexpire-accelerated-video-decode-flag
|
#%patch21 -p0 -b .unexpire-accelerated-video-decode-flag
|
||||||
#%patch22 -Rp1 -b .add-a-TODO-about-a-missing-pnacl-flag
|
#%patch22 -Rp1 -b .add-a-TODO-about-a-missing-pnacl-flag
|
||||||
#%patch18 -Rp1 -b .use-ffile-compilation-dir
|
#%patch18 -Rp1 -b .use-ffile-compilation-dir
|
||||||
%patch36 -p1 -b .tflite-system-zlib
|
#%patch36 -p1 -b .tflite-system-zlib
|
||||||
%patch33 -Rp1 -b .roll-src-third_party-ffmpeg
|
%patch33 -Rp1 -b .roll-src-third_party-ffmpeg
|
||||||
%patch12 -p1 -b .sql-make-VirtualCursor-standard-layout-type
|
%patch12 -p1 -b .sql-make-VirtualCursor-standard-layout-type
|
||||||
|
%patch37 -p0 -b .angle-wayland-include-protocol
|
||||||
|
%patch38 -Rp1 -b .REVERT-roll-src-third_party-ffmpeg-m106
|
||||||
|
|
||||||
# Fixes for building with libstdc++ instead of libc++
|
# Fixes for building with libstdc++ instead of libc++
|
||||||
#patch -Np1 -i patches/chromium-102-fenced_frame_utils-include.patch
|
#patch -Np1 -i patches/chromium-102-fenced_frame_utils-include.patch
|
||||||
@ -197,12 +208,17 @@ sed -i -e 's/\<xmlMalloc\>/malloc/' -e 's/\<xmlFree\>/free/' \
|
|||||||
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
|
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
|
||||||
# Keys are the names in the above script; values are the dependencies in Arch
|
# Keys are the names in the above script; values are the dependencies in Arch
|
||||||
declare -rgA _system_libs=(
|
declare -rgA _system_libs=(
|
||||||
|
[brotli]=brotli
|
||||||
|
[dav1d]=dav1d
|
||||||
[ffmpeg]=ffmpeg
|
[ffmpeg]=ffmpeg
|
||||||
[flac]=flac
|
[flac]=flac
|
||||||
[fontconfig]=fontconfig
|
[fontconfig]=fontconfig
|
||||||
[freetype]=libfreetype
|
[freetype]=libfreetype
|
||||||
[harfbuzz-ng]=harfbuzz
|
[harfbuzz-ng]=harfbuzz
|
||||||
[icu]=icu
|
[icu]=icu
|
||||||
|
[jsoncpp]=jsoncpp
|
||||||
|
[libaom]=aom
|
||||||
|
[libavif]=libavif
|
||||||
[libdrm]=
|
[libdrm]=
|
||||||
[libjpeg]=libjpeg
|
[libjpeg]=libjpeg
|
||||||
[libpng]=libpng
|
[libpng]=libpng
|
||||||
@ -213,6 +229,7 @@ declare -rgA _system_libs=(
|
|||||||
[opus]=opus
|
[opus]=opus
|
||||||
[re2]=re2
|
[re2]=re2
|
||||||
[snappy]=snappy
|
[snappy]=snappy
|
||||||
|
[woff2]=woff2
|
||||||
[zlib]=libminizip1
|
[zlib]=libminizip1
|
||||||
)
|
)
|
||||||
|
|
||||||
@ -282,29 +299,33 @@ export BACKTRACE="-funwind-tables -rdynamic"
|
|||||||
chromium_conf=(
|
chromium_conf=(
|
||||||
'custom_toolchain="//build/toolchain/linux/unbundle:default"'
|
'custom_toolchain="//build/toolchain/linux/unbundle:default"'
|
||||||
'host_toolchain="//build/toolchain/linux/unbundle:default"'
|
'host_toolchain="//build/toolchain/linux/unbundle:default"'
|
||||||
|
'clang_base_path="/usr"'
|
||||||
'clang_use_chrome_plugins=false'
|
'clang_use_chrome_plugins=false'
|
||||||
'chrome_pgo_phase=0' # needs newer clang to read the bundled PGO profile
|
|
||||||
'is_official_build=true' # implies is_cfi=true on x86_64
|
'is_official_build=true' # implies is_cfi=true on x86_64
|
||||||
|
'symbol_level=0'
|
||||||
'treat_warnings_as_errors=false'
|
'treat_warnings_as_errors=false'
|
||||||
'fieldtrial_testing_like_official_build=true'
|
'disable_fieldtrial_testing_config=true'
|
||||||
|
'blink_enable_generated_code_formatting=false'
|
||||||
'ffmpeg_branding="Chrome"'
|
'ffmpeg_branding="Chrome"'
|
||||||
'proprietary_codecs=true'
|
'proprietary_codecs=true'
|
||||||
'rtc_use_pipewire=true'
|
'rtc_use_pipewire=true'
|
||||||
'link_pulseaudio=true'
|
'link_pulseaudio=true'
|
||||||
|
'use_custom_libcxx=false'
|
||||||
'use_gnome_keyring=false'
|
'use_gnome_keyring=false'
|
||||||
'use_sysroot=false'
|
'use_sysroot=false'
|
||||||
'use_custom_libcxx=false'
|
'use_system_libwayland=true'
|
||||||
|
'use_system_wayland_scanner=true'
|
||||||
'enable_hangout_services_extension=true'
|
'enable_hangout_services_extension=true'
|
||||||
'enable_widevine=true'
|
'enable_widevine=true'
|
||||||
'enable_nacl=false'
|
'enable_nacl=false'
|
||||||
'use_vaapi=true'
|
|
||||||
'google_api_key="AIzaSyBT3wXwxmFuUQcyeMyp0MbHHhhFwNfWKTc"'
|
'google_api_key="AIzaSyBT3wXwxmFuUQcyeMyp0MbHHhhFwNfWKTc"'
|
||||||
'symbol_level=0'
|
|
||||||
'is_debug=false'
|
'is_debug=false'
|
||||||
'icu_use_data_file=false'
|
'icu_use_data_file=false'
|
||||||
'toolprefix="%{_target_platform}-"'
|
'toolprefix="%{_target_platform}-"'
|
||||||
)
|
)
|
||||||
|
|
||||||
|
# 'use_vaapi=true'
|
||||||
|
# 'fieldtrial_testing_like_official_build=true'
|
||||||
# 'chrome_pgo_phase=0' # pgo incompatible with llvm 11
|
# 'chrome_pgo_phase=0' # pgo incompatible with llvm 11
|
||||||
# 'google_default_client_id="72870267994-r1bkll5bq0v275nnsa66d21h3t6ne10s.apps.googleusercontent.com"'
|
# 'google_default_client_id="72870267994-r1bkll5bq0v275nnsa66d21h3t6ne10s.apps.googleusercontent.com"'
|
||||||
# 'google_default_client_secret="Pcdh5bzXx3nsECO_AlMlPXXk"'
|
# 'google_default_client_secret="Pcdh5bzXx3nsECO_AlMlPXXk"'
|
||||||
@ -435,6 +456,9 @@ ln -s %{_libdir}/chromium/chromedriver %{buildroot}%{_bindir}/chromedriver
|
|||||||
%{_mandir}/man1/chromium.1*
|
%{_mandir}/man1/chromium.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 26 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 109.0.5414.119-1mamba
|
||||||
|
- update to 109.0.5414.119
|
||||||
|
|
||||||
* Mon Aug 29 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 104.0.5112.101-1mamba
|
* Mon Aug 29 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 104.0.5112.101-1mamba
|
||||||
- update to 104.0.5112.101
|
- update to 104.0.5112.101
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user