update to 72.0.3626.119 [release 72.0.3626.119-1mamba;Fri Mar 01 2019]
This commit is contained in:
parent
5bda18169b
commit
a74e350c76
@ -1,10 +0,0 @@
|
||||
diff -upr chromium-48.0.2564.82.orig/third_party/widevine/cdm/stub/widevine_cdm_version.h chromium-48.0.2564.82/third_party/widevine/cdm/stub/widevine_cdm_version.h
|
||||
--- chromium-48.0.2564.82.orig/third_party/widevine/cdm/stub/widevine_cdm_version.h 2016-01-14 01:05:17.000000000 +0200
|
||||
+++ chromium-48.0.2564.82/third_party/widevine/cdm/stub/widevine_cdm_version.h 2016-01-21 19:18:51.287978456 +0200
|
||||
@@ -12,4 +12,6 @@
|
||||
|
||||
#define WIDEVINE_CDM_AVAILABLE
|
||||
|
||||
+#define WIDEVINE_CDM_VERSION_STRING "@WIDEVINE_VERSION@"
|
||||
+
|
||||
#endif // WIDEVINE_CDM_VERSION_H_
|
29
chromium-65.0.3325.162-math-h.patch
Normal file
29
chromium-65.0.3325.162-math-h.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From 9f63f94a11abc34d40ede8b8712fa15b5844a8c0 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Anderson <thomasanderson@chromium.org>
|
||||
Date: Sat, 27 Jan 2018 20:03:37 +0000
|
||||
Subject: [PATCH] Fix build with glibc 2.27
|
||||
|
||||
BUG=806340
|
||||
TBR=hamelphi@chromium.org
|
||||
|
||||
Change-Id: Ib4e5091212d874d9ad88f3e9a1fdfee3ed7e0d5e
|
||||
Reviewed-on: https://chromium-review.googlesource.com/890059
|
||||
Reviewed-by: Thomas Anderson <thomasanderson@chromium.org>
|
||||
Reviewed-by: Philippe Hamel <hamelphi@chromium.org>
|
||||
Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#532249}
|
||||
---
|
||||
|
||||
diff --git a/components/assist_ranker/ranker_example_util.cc b/components/assist_ranker/ranker_example_util.cc
|
||||
index 54d4dbd..ceedd8f 100644
|
||||
--- a/components/assist_ranker/ranker_example_util.cc
|
||||
+++ b/components/assist_ranker/ranker_example_util.cc
|
||||
@@ -2,6 +2,8 @@
|
||||
// Use of this source code is governed by a BSD-style license that can be
|
||||
// found in the LICENSE file.
|
||||
|
||||
+#include <math.h>
|
||||
+
|
||||
#include "components/assist_ranker/ranker_example_util.h"
|
||||
#include "base/bit_cast.h"
|
||||
#include "base/format_macros.h"
|
@ -0,0 +1,20 @@
|
||||
--- chromium-66.0.3359.139/services/preferences/tracked/pref_hash_filter.cc.orig 2018-05-03 12:59:06.555426796 +0200
|
||||
+++ chromium-66.0.3359.139/services/preferences/tracked/pref_hash_filter.cc 2018-05-03 12:59:12.175451151 +0200
|
||||
@@ -21,7 +21,6 @@
|
||||
#include "components/prefs/pref_store.h"
|
||||
#include "services/preferences/public/cpp/tracked/pref_names.h"
|
||||
#include "services/preferences/tracked/dictionary_hash_store_contents.h"
|
||||
-#include "services/preferences/tracked/pref_hash_store.h"
|
||||
#include "services/preferences/tracked/pref_hash_store_transaction.h"
|
||||
#include "services/preferences/tracked/tracked_atomic_preference.h"
|
||||
#include "services/preferences/tracked/tracked_split_preference.h"
|
||||
--- chromium-66.0.3359.139/services/preferences/tracked/pref_hash_filter.h.orig 2018-05-03 13:13:08.676001497 +0200
|
||||
+++ chromium-66.0.3359.139/services/preferences/tracked/pref_hash_filter.h 2018-05-03 13:13:17.883040095 +0200
|
||||
@@ -20,6 +20,7 @@
|
||||
#include "base/optional.h"
|
||||
#include "services/preferences/public/mojom/preferences.mojom.h"
|
||||
#include "services/preferences/tracked/hash_store_contents.h"
|
||||
+#include "services/preferences/tracked/pref_hash_store.h"
|
||||
#include "services/preferences/tracked/interceptable_pref_filter.h"
|
||||
#include "services/preferences/tracked/tracked_preference.h"
|
||||
|
20
chromium-66.0.3359.139-gcc-7.3.0-std.patch
Normal file
20
chromium-66.0.3359.139-gcc-7.3.0-std.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- chromium-66.0.3359.139/device/fido/device_response_converter.cc.orig 2018-05-04 16:57:53.234808857 +0200
|
||||
+++ chromium-66.0.3359.139/device/fido/device_response_converter.cc 2018-05-04 17:02:30.469935529 +0200
|
||||
@@ -121,7 +121,7 @@
|
||||
response.SetNumCredentials(it->second.GetUnsigned());
|
||||
}
|
||||
|
||||
- return response;
|
||||
+ return std::move(response);
|
||||
}
|
||||
|
||||
base::Optional<AuthenticatorGetInfoResponse> ReadCTAPGetInfoResponse(
|
||||
@@ -241,7 +241,7 @@
|
||||
response.SetPinProtocols(std::move(supported_pin_protocols));
|
||||
}
|
||||
|
||||
- return response;
|
||||
+ return std::move(response);
|
||||
}
|
||||
|
||||
} // namespace device
|
39
chromium-67.0.3396.87-widevine-r2.patch
Normal file
39
chromium-67.0.3396.87-widevine-r2.patch
Normal file
@ -0,0 +1,39 @@
|
||||
Minimal patch to get chromium to compile with widevine support.
|
||||
|
||||
Exactly the same as -r1, but we now need to patch
|
||||
ninja to pretty please not terminate our build.
|
||||
|
||||
caveat emptor: it's in no way clear that building chromium this
|
||||
way is safer, from a security perspective, than whatever Google
|
||||
Chrome does.
|
||||
|
||||
Upstream appears to be cooking up a code-signing trust-chain
|
||||
which may protect users against malicious cdm blobs; I doubt
|
||||
we benefit from these using this kludge. Ideally, someone
|
||||
would look into this more carefully than I have ... tbh as
|
||||
soon as I got my "stories" back, I pretty much lost interest :)
|
||||
|
||||
-gmt
|
||||
|
||||
--
|
||||
--- a/third_party/widevine/cdm/stub/widevine_cdm_version.h
|
||||
+++ b/third_party/widevine/cdm/stub/widevine_cdm_version.h
|
||||
@@ -10,6 +10,7 @@
|
||||
|
||||
#include "third_party/widevine/cdm/widevine_cdm_common.h"
|
||||
|
||||
+#define WIDEVINE_CDM_VERSION_STRING "unknown"
|
||||
#define WIDEVINE_CDM_AVAILABLE
|
||||
|
||||
#endif // WIDEVINE_CDM_VERSION_H_
|
||||
--- a/third_party/widevine/cdm/BUILD.gn
|
||||
+++ b/third_party/widevine/cdm/BUILD.gn
|
||||
@@ -11,7 +11,7 @@ import("//third_party/widevine/cdm/widev
|
||||
# Internal Cast builds set enable_widevine=true to bring in Widevine support.
|
||||
# TODO(xhwang): Support component updated CDM on other platforms and remove this
|
||||
# assert.
|
||||
-assert(!enable_widevine || is_win || is_mac || is_chromecast,
|
||||
+assert(!enable_widevine || is_win || is_mac || is_chromecast || is_linux,
|
||||
"Component updated CDM only supported on Windows and Mac for now.")
|
||||
|
||||
widevine_arch = current_cpu
|
@ -0,0 +1,88 @@
|
||||
diff --git a/build/config/BUILDCONFIG.gn b/build/config/BUILDCONFIG.gn
|
||||
index fcc00ee..0c1b861 100644
|
||||
--- a/build/config/BUILDCONFIG.gn
|
||||
+++ b/build/config/BUILDCONFIG.gn
|
||||
|
||||
@@ -522,7 +522,6 @@
|
||||
"//build/config/compiler:afdo",
|
||||
"//build/config/compiler:afdo_optimize_size",
|
||||
"//build/config/compiler:compiler",
|
||||
- "//build/config/compiler:clang_stackrealign",
|
||||
"//build/config/compiler:compiler_arm_fpu",
|
||||
"//build/config/compiler:compiler_arm_thumb",
|
||||
"//build/config/compiler:chromium_code",
|
||||
|
||||
diff --git a/build/config/compiler/BUILD.gn b/build/config/compiler/BUILD.gn
|
||||
index a703551..71f8f18 100644
|
||||
--- a/build/config/compiler/BUILD.gn
|
||||
+++ b/build/config/compiler/BUILD.gn
|
||||
|
||||
@@ -1079,20 +1079,6 @@
|
||||
asmflags = cflags
|
||||
}
|
||||
|
||||
-# This is separate from :compiler_codegen (and not even a sub-config there)
|
||||
-# so that some targets can remove it from the list with:
|
||||
-# configs -= [ "//build/config/compiler:clang_stackrealign" ]
|
||||
-# See https://crbug.com/556393 for details of where it must be avoided.
|
||||
-config("clang_stackrealign") {
|
||||
- if (is_clang && current_cpu == "x86" && is_linux) {
|
||||
- cflags = [
|
||||
- # Align the stack on 16-byte boundaries, http://crbug.com/418554.
|
||||
- "-mstack-alignment=16",
|
||||
- "-mstackrealign",
|
||||
- ]
|
||||
- }
|
||||
-}
|
||||
-
|
||||
config("clang_revision") {
|
||||
if (is_clang && clang_base_path == default_clang_base_path) {
|
||||
update_args = [
|
||||
|
||||
diff --git a/components/crash/content/app/BUILD.gn b/components/crash/content/app/BUILD.gn
|
||||
index d4fa4c3..ec55236 100644
|
||||
--- a/components/crash/content/app/BUILD.gn
|
||||
+++ b/components/crash/content/app/BUILD.gn
|
||||
|
||||
@@ -76,11 +76,6 @@
|
||||
"//third_party/breakpad:client",
|
||||
"//third_party/crashpad/crashpad/snapshot",
|
||||
]
|
||||
-
|
||||
- # Clang's -mstackrealign doesn't work well with
|
||||
- # linux_syscall_support.h hand written asm syscalls.
|
||||
- # See https://crbug.com/556393
|
||||
- configs -= [ "//build/config/compiler:clang_stackrealign" ]
|
||||
}
|
||||
|
||||
if (is_win) {
|
||||
|
||||
diff --git a/third_party/breakpad/BUILD.gn b/third_party/breakpad/BUILD.gn
|
||||
index 01ea9fc..95b71bc 100644
|
||||
--- a/third_party/breakpad/BUILD.gn
|
||||
+++ b/third_party/breakpad/BUILD.gn
|
||||
|
||||
@@ -623,11 +623,6 @@
|
||||
cflags = [ "-marm" ]
|
||||
}
|
||||
|
||||
- # Clang's -mstackrealign doesn't work well with
|
||||
- # linux_syscall_support.h hand written asm syscalls.
|
||||
- # See https://crbug.com/556393
|
||||
- configs -= [ "//build/config/compiler:clang_stackrealign" ]
|
||||
-
|
||||
if (is_android) {
|
||||
sources += [ "breakpad/src/common/android/breakpad_getcontext.S" ]
|
||||
}
|
||||
@@ -737,11 +732,6 @@
|
||||
extra_dist_files = [ "$root_out_dir/linux_dumper_unittest_helper" ]
|
||||
}
|
||||
|
||||
- # Clang's -mstackrealign doesn't work well with
|
||||
- # linux_syscall_support.h hand written asm syscalls.
|
||||
- # See https://crbug.com/556393
|
||||
- configs -= [ "//build/config/compiler:clang_stackrealign" ]
|
||||
-
|
||||
# Add the breakpad unittest config at the end to override all configs.
|
||||
configs += [ ":breakpad_unittest_config" ]
|
||||
}
|
19
chromium-72.0.3626.119-blink-fix_zero_length_array.patch
Normal file
19
chromium-72.0.3626.119-blink-fix_zero_length_array.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff --git a/third_party/blink/renderer/platform/text/character_property_data.h b/third_party/blink/renderer/platform/text/character_property_data.h
|
||||
index 28fb6a9..bb4dbd7 100644
|
||||
--- a/third_party/blink/renderer/platform/text/character_property_data.h
|
||||
+++ b/third_party/blink/renderer/platform/text/character_property_data.h
|
||||
@@ -244,10 +244,12 @@ static const UChar32 kIsHangulRanges[] = {
|
||||
0xD7B0, 0xD7FF,
|
||||
// Halfwidth Hangul Jamo
|
||||
// https://www.unicode.org/charts/nameslist/c_FF00.html
|
||||
- 0xFFA0, 0xFFDC,
|
||||
+ 0xFFA0, 0xFFDB,
|
||||
};
|
||||
|
||||
-static const UChar32 kIsHangulArray[] = {};
|
||||
+static const UChar32 kIsHangulArray[] = {
|
||||
+ 0xFFDC,
|
||||
+};
|
||||
|
||||
#if !defined(USING_SYSTEM_ICU)
|
||||
// Freezed trie tree, see character_property_data_generator.cc.
|
10
chromium-72.0.3626.119-webrtc-missing-header.patch
Normal file
10
chromium-72.0.3626.119-webrtc-missing-header.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- third_party/webrtc/modules/desktop_capture/linux/window_capturer_x11.cc.orig 2019-01-20 10:57:09.166224517 +0000
|
||||
+++ third_party/webrtc/modules/desktop_capture/linux/window_capturer_x11.cc 2019-01-20 06:01:05.901545307 +0000
|
||||
@@ -14,6 +14,7 @@
|
||||
#include <X11/extensions/Xcomposite.h>
|
||||
#include <X11/extensions/Xrender.h>
|
||||
|
||||
+#include <string.h>
|
||||
#include <memory>
|
||||
#include <string>
|
||||
#include <utility>
|
22
chromium-72.0.3626.119-widevine.patch
Normal file
22
chromium-72.0.3626.119-widevine.patch
Normal file
@ -0,0 +1,22 @@
|
||||
diff -upr chromium-71.0.3578.80.orig/chrome/common/chrome_content_client.cc chromium-71.0.3578.80/chrome/common/chrome_content_client.cc
|
||||
--- chromium-71.0.3578.80.orig/chrome/common/chrome_content_client.cc 2018-12-03 20:16:43.000000000 +0000
|
||||
+++ chromium-71.0.3578.80/chrome/common/chrome_content_client.cc 2018-12-04 21:34:28.658206942 +0000
|
||||
@@ -99,7 +99,7 @@
|
||||
// Registers Widevine CDM if Widevine is enabled, the Widevine CDM is
|
||||
// bundled and not a component. When the Widevine CDM is a component, it is
|
||||
// registered in widevine_cdm_component_installer.cc.
|
||||
-#if BUILDFLAG(BUNDLE_WIDEVINE_CDM) && !BUILDFLAG(ENABLE_WIDEVINE_CDM_COMPONENT)
|
||||
+#if BUILDFLAG(ENABLE_WIDEVINE) && !BUILDFLAG(ENABLE_WIDEVINE_CDM_COMPONENT)
|
||||
#define REGISTER_BUNDLED_WIDEVINE_CDM
|
||||
#include "third_party/widevine/cdm/widevine_cdm_common.h" // nogncheck
|
||||
// TODO(crbug.com/663554): Needed for WIDEVINE_CDM_VERSION_STRING. Support
|
||||
diff -upr chromium-71.0.3578.80.orig/third_party/widevine/cdm/widevine_cdm_version.h chromium-71.0.3578.80/third_party/widevine/cdm/widevine_cdm_version.h
|
||||
--- chromium-71.0.3578.80.orig/third_party/widevine/cdm/widevine_cdm_version.h 2018-12-03 20:18:01.000000000 +0000
|
||||
+++ chromium-71.0.3578.80/third_party/widevine/cdm/widevine_cdm_version.h 2018-12-04 21:37:45.635374949 +0000
|
||||
@@ -12,4 +12,6 @@
|
||||
// - WIDEVINE_CDM_VERSION_STRING (with the version of the CDM that's available
|
||||
// as a string, e.g., "1.0.123.456").
|
||||
|
||||
+#define WIDEVINE_CDM_VERSION_STRING "unknown"
|
||||
+
|
||||
#endif // WIDEVINE_CDM_VERSION_H_
|
295
chromium.spec
295
chromium.spec
@ -1,6 +1,6 @@
|
||||
Name: chromium
|
||||
Epoch: 3
|
||||
Version: 59.0.3071.109
|
||||
Version: 72.0.3626.119
|
||||
Release: 1mamba
|
||||
Summary: An open-source browser project that aims to build a safer, faster, and more stable way to experience the web
|
||||
Group: Graphical Desktop/Applications/Internet
|
||||
@ -42,8 +42,15 @@ Patch23: chromium-53.0.2785.16-cups-2.2.0.patch
|
||||
Patch24: chromium-53.0.2785.143-undef_MADV_FREE.patch
|
||||
Patch25: chromium-55.0.2883.75-ffmpeg-3.2.2.patch
|
||||
Patch26: chromium-55.0.2883.75-upstream-buildfix.patch
|
||||
Patch27: chromium-59.0.3071.86-blink-gcc-6.2.patch
|
||||
Patch28: chromium-59.0.3071.86-winedevine.patch
|
||||
Patch27: chromium-59.0.3071.86-blink-gcc-6.2.patch
|
||||
Patch28: chromium-72.0.3626.119-widevine.patch
|
||||
Patch29: chromium-65.0.3325.162-math-h.patch
|
||||
Patch30: chromium-66.0.3359.139-fix-PrefHashStore-build-error-upstream.patch
|
||||
Patch31: chromium-66.0.3359.139-gcc-7.3.0-std.patch
|
||||
Patch32: chromium-67.0.3396.87-widevine-r2.patch
|
||||
Patch33: chromium-67.0.3396.99-x86-clang_stackrealign-no-longer-needed.patch
|
||||
Patch34: chromium-72.0.3626.119-webrtc-missing-header.patch
|
||||
Patch35: chromium-72.0.3626.119-blink-fix_zero_length_array.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libGConf-devel
|
||||
@ -155,6 +162,9 @@ BuildRequires: libXtst-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libre2-devel
|
||||
BuildRequires: libminizip-devel
|
||||
BuildRequires: llvm
|
||||
BuildRequires: llvm-tools
|
||||
BuildRequires: gn
|
||||
Requires(post): %{__install_info}
|
||||
Requires: xdg-utils
|
||||
Requires: libvdpau-Mesa
|
||||
@ -175,46 +185,34 @@ Chromium is an open-source browser project that aims to build a safer, faster, a
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#mv home/chrome-svn/tarball/chromium/src/* .
|
||||
#rm -rf home
|
||||
%patch0 -p2
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
#%patch3 -p1
|
||||
#%patch4 -p1
|
||||
#%patch5 -p1
|
||||
#%patch6 -p3
|
||||
#%patch7 -p2
|
||||
#%patch8 -p2
|
||||
#cd third_party/WebKit
|
||||
#%patch9 -p1
|
||||
#cd ../../
|
||||
#%patch10 -p1
|
||||
#%patch11 -p1
|
||||
%if "%{_distrib_codename}" == "milestone2-build10"
|
||||
%ifarch arm
|
||||
%patch12 -p1
|
||||
%endif
|
||||
%endif
|
||||
#%patch13 -p1
|
||||
#%patch14 -p1
|
||||
#%patch15 -p1
|
||||
#%patch16 -p2
|
||||
#%patch17 -p1
|
||||
#%patch18 -p2
|
||||
%patch19 -p1
|
||||
#%patch21 -p1
|
||||
#%patch22 -p1
|
||||
#%patch23 -p1
|
||||
#%patch24 -p2
|
||||
#%patch25 -p1
|
||||
#%patch26 -R -p1
|
||||
%patch27 -p1
|
||||
%patch28 -p1
|
||||
#%patch29 -p1
|
||||
#%patch30 -p1
|
||||
#%patch31 -p1
|
||||
#%patch32 -p1
|
||||
#%patch33 -p1
|
||||
%patch34 -p0
|
||||
%patch35 -p1
|
||||
|
||||
# Allow building against system libraries in official builds
|
||||
sed -i 's/OFFICIAL_BUILD/GOOGLE_CHROME_BUILD/' \
|
||||
tools/generate_shim_headers/generate_shim_headers.py
|
||||
|
||||
# Remove compiler flags not supported by our system clang
|
||||
sed -i \
|
||||
-e '/"-Wno-defaulted-function-deleted"/d' \
|
||||
build/config/compiler/BUILD.gn
|
||||
|
||||
# Use Python 2
|
||||
find . -name '*.py' -exec sed -i -r 's|/usr/bin/python$|&2|g' {} +
|
||||
|
||||
# https://crbug.com/893950
|
||||
sed -i -e 's/\<xmlMalloc\>/malloc/' -e 's/\<xmlFree\>/free/' \
|
||||
third_party/blink/renderer/core/xml/*.cc \
|
||||
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
|
||||
third_party/libxml/chromium/libxml_utils.cc
|
||||
|
||||
# There are still a lot of relative calls which need a workaround
|
||||
mkdir -p python2-path
|
||||
ln -sf %{_bindir}/python2 python2-path/python
|
||||
@ -225,17 +223,20 @@ ln -s %{_bindir}/node third_party/node/linux/node-linux-x64/bin/
|
||||
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
|
||||
# Keys are the names in the above script; values are the dependencies in Arch
|
||||
declare -rgA _system_libs=(
|
||||
#[ffmpeg]=ffmpeg # https://crbug.com/731766
|
||||
[ffmpeg]=ffmpeg
|
||||
[flac]=flac
|
||||
[fontconfig]=fontconfig
|
||||
[freetype]=libfreetype
|
||||
[harfbuzz-ng]=harfbuzz-icu
|
||||
#[icu]=icu # Enable again when upstream supports ICU 59
|
||||
[icu]=icu
|
||||
[libdrm]=
|
||||
[libjpeg]=libjpeg
|
||||
[libpng]=libpng
|
||||
#[libpng]=libpng
|
||||
#[libvpx]=libvpx # https://bugs.gentoo.org/show_bug.cgi?id=611394
|
||||
[libwebp]=libwebp
|
||||
#[libxml]=libxml2 # https://bugs.gentoo.org/show_bug.cgi?id=616818
|
||||
[libxml]=libxml2 # https://bugs.gentoo.org/show_bug.cgi?id=616818
|
||||
[libxslt]=libxslt
|
||||
[opus]=opus
|
||||
[re2]=re2
|
||||
[snappy]=snappy
|
||||
[yasm]=
|
||||
@ -246,36 +247,28 @@ declare -rgA _system_libs=(
|
||||
# *should* do what the remove_bundled_libraries.py script does, with the
|
||||
# added benefit of not having to list all the remaining libraries
|
||||
for l in ${!_system_libs[@]} ${_system_libs[libjpeg]+libjpeg_turbo}; do
|
||||
find -type f -path "*third_party/${l}/*" \
|
||||
\! -path "*third_party/${l}/chromium/*" \
|
||||
\! -path "*third_party/${l}/google/*" \
|
||||
\! -path "*base/third_party/icu/*" \
|
||||
find "third_party/${l}" -type f \
|
||||
\! -path "third_party/${l}/chromium/*" \
|
||||
\! -path "third_party/${l}/google/*" \
|
||||
\! -path 'third_party/yasm/run_yasm.py' \
|
||||
\! -regex '.*\.\(gn\|gni\|isolate\|py\)' \
|
||||
-delete
|
||||
done
|
||||
|
||||
python2 build/linux/unbundle/replace_gn_files.py \
|
||||
--system-libraries "${!_system_libs[@]}"
|
||||
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
#ln -sf %{_bindir}/ld.gold third_party/gold/ld.gold
|
||||
#ln -sf %{_bindir}/ld.bfd third_party/gold/ld.bfd
|
||||
# Build with clang as a temporary solution to startup crash with GCC 4.9
|
||||
mkdir -p third_party/llvm-build/Release+Asserts/bin
|
||||
ln -sf %{_bindir}/clang third_party/llvm-build/Release+Asserts/bin/
|
||||
ln -sf %{_bindir}/clang++ third_party/llvm-build/Release+Asserts/bin/
|
||||
ln -sf %{_bindir}/llvm-symbolizer third_party/llvm-build/Release+Asserts/bin/
|
||||
# clang 3.4 doesn't support this option
|
||||
#sed -i '/-Wno-absolute-value/d' \
|
||||
# build/common.gypi \
|
||||
# third_party/ffmpeg/ffmpeg.gyp
|
||||
#%ifarch x86_64
|
||||
#ln -sf %{_bindir}/ld.gold third_party/gold/gold64
|
||||
#%else
|
||||
#ln -sf %{_bindir}/ld.gold third_party/gold/gold64
|
||||
#ln -sf %{_bindir}/ld.gold third_party/gold/gold32
|
||||
#%endif
|
||||
export CC=clang
|
||||
export CXX=clang++
|
||||
export AR=ar
|
||||
export NM=nm
|
||||
|
||||
# Facilitate deterministic builds (taken from build/config/compiler/BUILD.gn)
|
||||
CFLAGS+=' -Wno-builtin-macro-redefined'
|
||||
CXXFLAGS+=' -Wno-builtin-macro-redefined'
|
||||
CPPFLAGS+=' -D__DATE__= -D__TIME__= -D__TIMESTAMP__='
|
||||
|
||||
%ifarch arm
|
||||
#export GYP_DEFINES="$GYP_DEFINES target_arch=arm disable_nacl=1 linux_use_tcmalloc=0 armv7=1 arm_neon=0 arm_thumb=1 arm_fpu=vfpv3-d16"
|
||||
export GYP_DEFINES="$GYP_DEFINES target_arch=arm linux_use_tcmalloc=0 armv7=1 arm_neon=0 arm_thumb=1 arm_fpu=vfp"
|
||||
@ -284,104 +277,50 @@ export BACKTRACE="-funwind-tables -rdynamic"
|
||||
#export CC="%{_build}-gcc $BACKTRACE $ARMIFY -B%{_bindir}/ld.gold"
|
||||
#export CXX="%{_build}-g++ $BACKTRACE $ARMIFY -B%{_bindir}/ld.gold"
|
||||
%endif
|
||||
#%ifarch x86_64
|
||||
#export GYP_DEFINES="linux_use_gold_binary=1 linux_use_gold_flags=1"
|
||||
#%endif
|
||||
#%ifarch %{ix86}
|
||||
#export GYP_DEFINES="linux_use_gold_binary=1 linux_use_gold_flags=1 target_arch=ia32"
|
||||
##export CC="%{_build}-gcc %{optflags} -m32"
|
||||
##export CXX="%{_build}-g++ %{optflags} -m32"
|
||||
#%endif
|
||||
|
||||
# openmamba api keys provided (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
#export GYP_GENERATORS=make
|
||||
#./build/gyp_chromium
|
||||
|
||||
chromium_conf=(
|
||||
'google_api_key="AIzaSyBT3wXwxmFuUQcyeMyp0MbHHhhFwNfWKTc"'
|
||||
'google_default_client_id="72870267994-r1bkll5bq0v275nnsa66d21h3t6ne10s.apps.googleusercontent.com"'
|
||||
'google_default_client_secret="Pcdh5bzXx3nsECO_AlMlPXXk"'
|
||||
'is_clang=false'
|
||||
'clang_use_chrome_plugins=false'
|
||||
'is_debug=false'
|
||||
'fatal_linker_warnings=false'
|
||||
'treat_warnings_as_errors=false'
|
||||
'fieldtrial_testing_like_official_build=true'
|
||||
'remove_webcore_debug_symbols=true'
|
||||
'ffmpeg_branding="Chrome"'
|
||||
%ifnarch arm
|
||||
'proprietary_codecs=true'
|
||||
%endif
|
||||
'link_pulseaudio=true'
|
||||
'linux_use_bundled_binutils=false'
|
||||
'use_gtk3=true'
|
||||
'use_gconf=false'
|
||||
'use_gnome_keyring=false'
|
||||
'use_gold=false'
|
||||
'use_sysroot=false'
|
||||
'enable_hangout_services_extension=true'
|
||||
'enable_widevine=true'
|
||||
'enable_nacl=false'
|
||||
'enable_swiftshader=false'
|
||||
'custom_toolchain="//build/toolchain/linux/unbundle:default"'
|
||||
'host_toolchain="//build/toolchain/linux/unbundle:default"'
|
||||
'clang_use_chrome_plugins=false'
|
||||
'is_official_build=true' # implies is_cfi=true on x86_64
|
||||
'treat_warnings_as_errors=false'
|
||||
'fieldtrial_testing_like_official_build=true'
|
||||
'ffmpeg_branding="Chrome"'
|
||||
'proprietary_codecs=true'
|
||||
'link_pulseaudio=true'
|
||||
'use_gnome_keyring=false'
|
||||
'use_sysroot=false'
|
||||
'use_kerberos=true'
|
||||
'use_pulseaudio=true'
|
||||
'use_sysroot=false'
|
||||
'use_system_freetype=true'
|
||||
'use_system_harfbuzz=true'
|
||||
'linux_use_bundled_binutils=false'
|
||||
'use_custom_libcxx=false'
|
||||
'enable_hangout_services_extension=true'
|
||||
'enable_widevine=true'
|
||||
'enable_nacl=false'
|
||||
'enable_swiftshader=false'
|
||||
'google_api_key="AIzaSyBT3wXwxmFuUQcyeMyp0MbHHhhFwNfWKTc"'
|
||||
'google_default_client_id="72870267994-r1bkll5bq0v275nnsa66d21h3t6ne10s.apps.googleusercontent.com"'
|
||||
'google_default_client_secret="Pcdh5bzXx3nsECO_AlMlPXXk"'
|
||||
'symbol_level=0'
|
||||
'is_debug=false'
|
||||
'remove_webcore_debug_symbols=true'
|
||||
)
|
||||
# 'linux_sandbox_path="%{_libdir}/chromium/chrome-sandbox"'
|
||||
# 'usb_ids_path="/usr/share/hwdata/usb.ids"'
|
||||
# 'symbol_level=0'
|
||||
# 'linux_link_gsettings=true'
|
||||
# 'linux_link_libpci=true'
|
||||
# 'linux_link_libspeechd=true'
|
||||
# 'linux_strip_binary=true'
|
||||
# 'linux_use_bundled_gold=false'
|
||||
# 'linux_use_gold_flags=false'
|
||||
# 'logging_like_official_build=true'
|
||||
# 'use_system_xdg_utils=true'
|
||||
# 'use_system_zlib=false'
|
||||
# 'use_system_libpng=true'
|
||||
# 'use_system_bzip2=true'
|
||||
# 'use_system_libbz2=true'
|
||||
# 'use_system_libjpeg=true'
|
||||
# 'use_system_libxml=true'
|
||||
# 'use_system_libxslt=true'
|
||||
# 'use_system_harfbuzz=true'
|
||||
# 'use_system_libevent=true'
|
||||
# 'use_system_yasm=true'
|
||||
# 'use_system_flac=true'
|
||||
# 'use_system_speex=true'
|
||||
# 'use_system_snappy=true'
|
||||
# 'use_system_ssl=false'
|
||||
# 'use_system_vpx=true'
|
||||
# 'use_system_ffmpeg=false'
|
||||
# 'linux_fpic=true'
|
||||
# 'disable_sse2=true'
|
||||
# 'libspeechd_h_prefix="speech-dispatcher/"'
|
||||
# 'enable_hangout_services_extension=true'
|
||||
# 'enable_widevine=true'
|
||||
# 'enable_nacl=false'
|
||||
# 'enable_nacl_nonsfi=false'
|
||||
# 'no_strict_aliasing=true'
|
||||
# 'use_sysroot=false'
|
||||
#%ifarch %{ix86}
|
||||
# 'release_extra_cflags="-fPIC -m32 -fno-delete-null-pointer-checks"'
|
||||
#%else
|
||||
# 'release_extra_cflags="-fPIC -fno-delete-null-pointer-checks"'
|
||||
#%endif
|
||||
#%ifarch arm
|
||||
# 'enable_webrtc=false'
|
||||
#%endif
|
||||
|
||||
# 'disable_nacl=true'
|
||||
# 'is_clang=true'
|
||||
# 'is_debug=false'
|
||||
# 'is_cfi=false'
|
||||
# 'use_lld=false'
|
||||
# 'remove_webcore_debug_symbols=true'
|
||||
|
||||
#build/linux/unbundle/replace_gyp_files.py "${chromium_conf[@]}"
|
||||
#build/gyp_chromium --depth=. "${chromium_conf[@]}"
|
||||
gn gen out/Release --args="${chromium_conf[*]}" \
|
||||
--script-executable=/usr/bin/python2 --fail-on-unused-args
|
||||
|
||||
python2 tools/gn/bootstrap/bootstrap.py --gn-gen-args "${chromium_conf[*]}"
|
||||
out/Release/gn gen out/Release --args="${chromium_conf[*]}" \
|
||||
--script-executable=/usr/bin/python2
|
||||
|
||||
ninja -C out/Release chrome chrome_sandbox chromedriver widevinecdmadapter
|
||||
#% make BUILDTYPE=Release chrome V=1
|
||||
|
||||
# Build the required SUID SANDBOX helper
|
||||
#% make BUILDTYPE=Release chrome_sandbox V=1
|
||||
ninja -C out/Release chrome chrome_sandbox chromedriver
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -390,25 +329,19 @@ install -d -m0755 %{buildroot}%{_libdir}/chromium/ %{buildroot}%{_bindir}
|
||||
install -m0755 out/Release/chrome %{buildroot}%{_libdir}/chromium/chromium
|
||||
install -m0755 out/Release/chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
|
||||
install -m0755 out/Release/chromedriver %{buildroot}%{_libdir}/chromium/chromedriver
|
||||
install -m0755 out/Release/libwidevinecdm.so %{buildroot}%{_libdir}/chromium/libwidevinecdm.so
|
||||
install -m0755 out/Release/libwidevinecdmadapter.so %{buildroot}%{_libdir}/chromium/libwidevinecdmadapter.so
|
||||
#install -m0755 out/Release/libwidevinecdm.so %{buildroot}%{_libdir}/chromium/libwidevinecdm.so
|
||||
#install -m0755 out/Release/libwidevinecdmadapter.so %{buildroot}%{_libdir}/chromium/libwidevinecdmadapter.so
|
||||
cp out/Release/*.bin %{buildroot}%{_libdir}/chromium/
|
||||
|
||||
install -m0755 chrome/tools/build/linux/chrome-wrapper %{buildroot}%{_libdir}/chromium/
|
||||
#install -m0755 third_party/xdg-utils/scripts/xdg-settings %{buildroot}/opt/chromium/xdg-settings
|
||||
|
||||
#%ifnarch arm
|
||||
#install -m0755 out/Release/gen* %{buildroot}/opt/chromium/
|
||||
#install -m0755 out/Release/re2c %{buildroot}/opt/chromium/
|
||||
#install -m0755 out/Release/yasm %{buildroot}/opt/chromium/
|
||||
##install -m0755 out/Release/ncdecode* %{buildroot}/opt/chromium/
|
||||
#%endif
|
||||
%if "%cross_target_cpu" != "i586"
|
||||
install -m0755 out/Release/protoc %{buildroot}%{_libdir}/chromium/
|
||||
%endif
|
||||
cp -a out/Release/*.pak %{buildroot}%{_libdir}/chromium/
|
||||
install -D -m0644 out/Release/icudtl.dat %{buildroot}%{_libdir}/chromium
|
||||
install -D -m0644 out/Release/chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
|
||||
#install -D -m0644 out/Release/icudtl.dat %{buildroot}%{_libdir}/chromium
|
||||
#install -D -m0644 out/Release/chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
|
||||
install -D -m0644 chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium.png
|
||||
cp -a out/Release/locales %{buildroot}%{_libdir}/chromium/
|
||||
|
||||
@ -469,6 +402,8 @@ fi
|
||||
_EOF
|
||||
chmod 755 %{buildroot}%{_bindir}/chromium
|
||||
|
||||
ln -s %{_libdir}/chromium/chromedriver %{buildroot}%{_bindir}/chromedriver
|
||||
|
||||
# legacy favorites symlink
|
||||
ln -s chromium.desktop %{buildroot}%{_datadir}/applications/chromium-devel.desktop
|
||||
|
||||
@ -498,6 +433,7 @@ fi
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/chromium
|
||||
%{_bindir}/chromedriver
|
||||
%{_datadir}/applications/chromium.desktop
|
||||
%{_datadir}/applications/chromium-devel.desktop
|
||||
%{_datadir}/pixmaps/chromium.png
|
||||
@ -508,32 +444,25 @@ fi
|
||||
%{_libdir}/chromium/*.pak
|
||||
%{_libdir}/chromium/chrome-wrapper
|
||||
%attr(4755,root,root) %{_libdir}/chromium/chrome-sandbox
|
||||
%{_libdir}/chromium/icudtl.dat
|
||||
%{_libdir}/chromium/libwidevinecdm.so
|
||||
%{_libdir}/chromium/libwidevinecdmadapter.so
|
||||
#/opt/chromium/libpdf.so
|
||||
#/opt/chromium/nacl_helper
|
||||
#/opt/chromium/nacl_helper-bootstrap
|
||||
#/opt/chromium/libppGoogleNaClPluginChrome.so
|
||||
#/opt/chromium/nacl_irt_*.nexe
|
||||
#%{_libdir}/chromium/icudtl.dat
|
||||
#%{_libdir}/chromium/libwidevinecdm.so
|
||||
#%{_libdir}/chromium/libwidevinecdmadapter.so
|
||||
%{_libdir}/chromium/master_preferences
|
||||
#/opt/chromium/xdg-settings
|
||||
#%ifnarch arm
|
||||
#/opt/chromium/ncdecode*
|
||||
#%endif
|
||||
%if "%cross_target_cpu" != "i586"
|
||||
%{_libdir}/chromium/protoc
|
||||
%endif
|
||||
#%ifnarch arm
|
||||
#/opt/chromium/gen*
|
||||
#/opt/chromium/re2c
|
||||
#/opt/chromium/yasm
|
||||
#%endif
|
||||
%dir %{_libdir}/chromium/locales
|
||||
%{_libdir}/chromium/locales/*.pak
|
||||
%{_mandir}/man1/chromium.1*
|
||||
%{_libdir}/chromium/locales/*.pak.info
|
||||
#%{_mandir}/man1/chromium.1*
|
||||
|
||||
%changelog
|
||||
* Fri Mar 01 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 72.0.3626.119-1mamba
|
||||
- update to 72.0.3626.119
|
||||
|
||||
* Tue Jul 17 2018 Automatic Build System <autodist@mambasoft.it> 67.0.3396.99-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jun 22 2017 Automatic Build System <autodist@mambasoft.it> 59.0.3071.109-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user